Autor Tópico: [Resolvido] Ubuntu não está captando o som do Microfone  (Lida 14061 vezes)

Offline Mundus

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
[Resolvido] Ubuntu não está captando o som do Microfone
« Online: 09 de Setembro de 2010, 21:38 »
instalei faz pouco tempo o Ubuntu neste meu HD (10.04, Lucid Lynx), e eu não estou conseguindo captar o som do microfone (o microfone está funcionando, já testei no Windows do meu pai) eu ja tinha esse problema no meu outro HD e não consegui resolve-lo, já procurei por toda a internet e não achei uma resposta q resolvesse o problema. alguem aqui sabe como resolver o problema?
« Última modificação: 13 de Setembro de 2010, 14:53 por Mundus »

libonati

  • Visitante
Re: Ubuntu não está captando o som do Microfone
« Resposta #1 Online: 09 de Setembro de 2010, 23:16 »
Tente as seguintes configurações:
Aplicativos/Multimidia/Gravador de som/
Arquivo/Abrir controle de volume/Preferências de som/Tema sonoro ubuntu
Almente volume de saída e volume de alerta
Habilitar som das janelas e botões
Hardware/Escolha um dispositivo para configurar/Audio interno ou 2620...
Configurações para o dispositivo selecionado/Analog stereo autput (caso tenha escolhido audio interno).
Verifique se os cabos do microfone estão conectados no lugar correto.
Poste se conseguiu resolver.

Offline Mundus

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
Re: Ubuntu não está captando o som do Microfone
« Resposta #2 Online: 09 de Setembro de 2010, 23:25 »
ok, agora está captando o som, só que de dentro do pc =P
testei gravar comigo falando no microfone e com nenhum som no pc, silencio total.

libonati

  • Visitante
Re: Ubuntu não está captando o som do Microfone
« Resposta #3 Online: 09 de Setembro de 2010, 23:38 »
Verifica todas as possibilidades em Configurações para o dispositivo selecionado
Meu áudio é "00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)" e pode ter pequenas diferenças do seu.

Offline Mundus

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
Re: Ubuntu não está captando o som do Microfone
« Resposta #4 Online: 10 de Setembro de 2010, 00:06 »
tentei selecionar todas, e, as vezes captava o som do pc, as vezes não captava som algum, outras até o pc perdia todos os sons =P

no, Configurações para o dispositivo selecionado:

tem as opções...


Desligado
Analog Stereo Input
Digital Stereo Duplex (IEC958)
Digital Stereo (IEC958) Output + Analog Stereo Input
Analog Stereo Output
Analog Stereo Duplex

só esses dois não tiram o som do pc
Analog Stereo Output
Analog Stereo Duplex


libonati

  • Visitante
Re: Ubuntu não está captando o som do Microfone
« Resposta #5 Online: 10 de Setembro de 2010, 09:43 »
Verifique em Efeitos de som e Entrada se estão marcados. Se estiver desmarque.
Qual sua placa de som?

Offline Mundus

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
Re: Ubuntu não está captando o som do Microfone
« Resposta #6 Online: 10 de Setembro de 2010, 13:03 »
nem sei qual é a minha placa de som, ela é daquelas placas embutidas na placa mãe =P
tem algum comando ai que eu possa dar aqui pra descobrir?

Fui no "Efeitos de som", em ambos os casos o que aparece é isto:
http://i56.tinypic.com/1yalgw.png

Com o "Analog Stereo Output" selecionado no "Hardware", o que aparece em Entrada é isso:
http://i55.tinypic.com/30m2ypz.png

Com o "Analog Stereo Duplex" selecionado no "Hardware", o que aparece em Entrada é isso:
http://i54.tinypic.com/2yn0wzo.png
Testei com o "Audio interno Analog Stereo" não selecionado, testar o microfone, e ainda assim o único som captado foi o de dentro do Computador.

E depois de clicar no "Audio Interno Analog Stereo, o que aparece é isto:
http://i54.tinypic.com/33cx6cx.png

Na opção Conector aparecem as seguintes opções:
Analog Input
Analog Line-in
Analog Microphone

testei todas e, em todas o unico som captado é o de dentro do computador.

Edit: esqueci de dizer, o volume de saida esta baixo assim por que estou usando fone de ouvido, se eu colocar mais alto que isto fico surdo  :P

libonati

  • Visitante
Re: Ubuntu não está captando o som do Microfone
« Resposta #7 Online: 10 de Setembro de 2010, 14:32 »
Com lspci você consegue ver o áudio.
Instale o Alsamixer e controle os volumes. Talvez solucione.
« Última modificação: 10 de Setembro de 2010, 14:46 por libonati »

Offline Mundus

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
Re: Ubuntu não está captando o som do Microfone
« Resposta #8 Online: 10 de Setembro de 2010, 15:51 »
Abri o Alsamixer, coloquei todos os volumes (menos o Master, já que estou com fone de ouvido...) no máximo, tentei gravar em todas as combinações de Perfil de Hardware e Conector de Entrada, possíveis, e ainda assim não captou o som do microfone.

O meu Alsamixer:
http://i52.tinypic.com/14v36vl.png

e eu digitei lspci, aqui está o resultado:

00:00.0 Host bridge: nVidia Corporation Device 0071 (rev a3)
00:00.1 RAM memory: nVidia Corporation Device 007f (rev a1)
00:00.2 RAM memory: nVidia Corporation Device 0075 (rev a1)
00:00.3 RAM memory: nVidia Corporation Device 006f (rev a1)
00:00.4 RAM memory: nVidia Corporation Device 00b4 (rev a1)
00:01.0 RAM memory: nVidia Corporation Device 0076 (rev a1)
00:01.1 RAM memory: nVidia Corporation Device 0078 (rev a1)
00:01.2 RAM memory: nVidia Corporation Device 0079 (rev a1)
00:01.3 RAM memory: nVidia Corporation Device 007a (rev a1)
00:01.4 RAM memory: nVidia Corporation Device 007b (rev a1)
00:01.5 RAM memory: nVidia Corporation Device 007c (rev a1)
00:01.6 RAM memory: nVidia Corporation Device 007d (rev a1)
00:02.0 PCI bridge: nVidia Corporation Device 007e (rev a2)
00:04.0 PCI bridge: nVidia Corporation Device 007e (rev a2)
00:05.0 PCI bridge: nVidia Corporation Device 007e (rev a2)
00:06.0 PCI bridge: nVidia Corporation Device 007e (rev a2)
00:07.0 PCI bridge: nVidia Corporation Device 007e (rev a2)
00:09.0 RAM memory: nVidia Corporation MCP51 Host Bridge (rev a2)
00:0a.0 ISA bridge: nVidia Corporation MCP51 LPC Bridge (rev a2)
00:0a.1 SMBus: nVidia Corporation MCP51 SMBus (rev a2)
00:0a.2 RAM memory: nVidia Corporation MCP51 Memory Controller 0 (rev a2)
00:0b.0 USB Controller: nVidia Corporation MCP51 USB Controller (rev a2)
00:0b.1 USB Controller: nVidia Corporation MCP51 USB Controller (rev a2)
00:0d.0 IDE interface: nVidia Corporation MCP51 IDE (rev a1)
00:0e.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev a1)
00:0f.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev a1)
00:10.0 PCI bridge: nVidia Corporation MCP51 PCI Bridge (rev a2)
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
01:00.0 VGA compatible controller: nVidia Corporation G72 [GeForce 7300 SE/7200 GS] (rev a1)
06:0c.0 Ethernet controller: Marvell Technology Group Ltd. 88E8001 Gigabit Ethernet Controller (rev 13)

libonati

  • Visitante
Re: Ubuntu não está captando o som do Microfone
« Resposta #9 Online: 10 de Setembro de 2010, 21:02 »
Mas se você não aumentar o master não terá som. O master não atrapalha em nada, muito pelo contrario.
O master é o próprio volume do computador.
« Última modificação: 10 de Setembro de 2010, 21:04 por libonati »

Offline Mundus

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
Re: Ubuntu não está captando o som do Microfone
« Resposta #10 Online: 10 de Setembro de 2010, 21:16 »
sim,mas com o fone de ouvido o som fica -muito- mais alto, por isso o master estava naquele nivel (que é o equivalente em volume ao master estando no maximo na caixa de som).

ainda assim eu coloquei absolutamente tudo no maximo e tirei o fone de ouvido, testei outra vez e nada de captar som do microfone

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: Ubuntu não está captando o som do Microfone
« Resposta #11 Online: 10 de Setembro de 2010, 21:47 »
Você está usando um PC ou notebook?

Já  tentou no terminal isso:

sudo gedit /etc/modprobe.d/alsa-base.conf

e no arquivo que abrir, colocar no seu final isso aqui:

options snd-hda-intel model=auto

salvar e reiniciar o seu PC.

Se não alterar em nada, leia este link:

https://help.ubuntu.com/community/HdaIntelSoundHowto
« Última modificação: 10 de Setembro de 2010, 21:54 por linuser104 »
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

libonati

  • Visitante
Re: Ubuntu não está captando o som do Microfone
« Resposta #12 Online: 10 de Setembro de 2010, 23:03 »
Poste
ls -l /dev | grep dsp
ls -l /dev | grep mixer

Offline Mundus

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
Re: Ubuntu não está captando o som do Microfone
« Resposta #13 Online: 11 de Setembro de 2010, 18:17 »
ls -l /dev | grep dsp:
crw-rw----+ 1 root audio    14,  12 2010-09-11 18:08 adsp
crw-rw----+ 1 root audio    14,   3 2010-09-11 18:08 dsp

ls -l /dev | grep mixer:
crw-rw----+ 1 root audio    14,   0 2010-09-11 18:08 mixer



reiniciando o pc pra ver se da alguma diferença


Offline Mundus

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
Re: Ubuntu não está captando o som do Microfone
« Resposta #14 Online: 11 de Setembro de 2010, 20:54 »
depois de eu colocar o comando
options snd-hda-intel model=auto
no alsa-base.conf
o som simplesmente parou de funcionar O___O"
tentei deletar esta linha, e fazer voltar a ser como era antes mas agora simplesmente não tem mais som o pc.


agora em Hardware aparecem:
Analog Stereo Duplex
Analog Stereo Output
Analog Stereo Input
Desligado

abri o alsamixer e eis o que apareceu:
http://i56.tinypic.com/2e1f95x.png
O Master Sumiu  :'(

porem eu digitei de novo aqueles dois comandos e eles estavam diferentes:

ls -l /dev | grep dsp:
crw-rw----+ 1 root audio    14,   3 2010-09-11 20:49 dsp

ls -l /dev | grep mixer:
crw-rw----+ 1 root audio    14,   0 2010-09-11 20:49 mixer