Autor Tópico: Ubuntu 10.04 não reconhece a placa de rede Via VT6102  (Lida 8499 vezes)

Offline ynamros

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Ubuntu 10.04 não reconhece a placa de rede Via VT6102
« Online: 16 de Agosto de 2010, 18:43 »
Olá amigos,
Estou com o seguinte problema: instalei o Ubuntu 10.04 em meu desktop, porém, este não está reconhecendo a placa de rede Via VT6102. Com isso, estou impossibilitado de conectar à internet.
O acesso da internet é feito através de um modem roteado. Instalei o Windows na mesma máquina e consegui conectar. Porém, quando entro pelo ubuntu, é como se a placa não existisse.

Seguem alguns dados:

lspci:
cliente01@cliente01-desktop:~$ lspci
00:00.0 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. PT890 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.7 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237/VX700 PCI Bridge
00:0f.0 RAID bus controller: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
00:11.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller (rev 80)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
01:00.0 VGA compatible controller: VIA Technologies, Inc. CN700/P4M800 Pro/P4M800 CE/VN800 [S3 UniChrome Pro] (rev 01)


ifconfig:
cliente01@cliente01-desktop:~$ ifconfig
lo        Link encap:Loopback Local 
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:16436  Métrica:1
          pacotes RX:8 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:8 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:0
          RX bytes:480 (480.0 B) TX bytes:480 (480.0 B)


iwconfig:
cliente01@cliente01-desktop:~$ iwconfig
lo        no wireless extensions.


lsmod:
cliente01@cliente01-desktop:~$ lsmod
Module                  Size  Used by
via                    37920  3
drm                   162471  4 via
binfmt_misc             6587  1
snd_via82xx            20058  2
gameport                9089  1 snd_via82xx
snd_mpu401_uart         5617  1 snd_via82xx
snd_via82xx_modem       8486  0
snd_seq_dummy           1338  0
snd_ac97_codec        100646  2 snd_via82xx,snd_via82xx_modem
ac97_bus                1002  1 snd_ac97_codec
snd_pcm_oss            35308  0
snd_seq_oss            26726  0
snd_mixer_oss          13746  1 snd_pcm_oss
snd_seq_midi            4557  0
snd_pcm                70662  4 snd_via82xx,snd_via82xx_modem,snd_ac97_codec,snd_pcm_oss
snd_rawmidi            19056  2 snd_mpu401_uart,snd_seq_midi
snd_seq_midi_event      6003  2 snd_seq_oss,snd_seq_midi
snd_seq                47263  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              19098  2 snd_pcm,snd_seq
snd_seq_device          5700  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
fbcon                  35102  71
tileblit                2031  1 fbcon
font                    7557  1 fbcon
bitblit                 4707  1 fbcon
softcursor              1189  1 bitblit
ppdev                   5259  0
snd                    54148  16 snd_via82xx,snd_mpu401_uart,snd_via82xx_modem,snd_ac97_codec,snd_pcm_oss,snd_seq_oss,snd_mixer_oss,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
vga16fb                11385  1
vgastate                8961  1 vga16fb
psmouse                63245  0
snd_page_alloc          7076  3 snd_via82xx,snd_via82xx_modem,snd_pcm
serio_raw               3978  0
i2c_viapro              5573  0
soundcore               6620  1 snd
via_agp                 5310  1
agpgart                31724  2 drm,via_agp
shpchp                 28820  0
parport_pc             25962  1
lp                      7028  0
parport                32635  3 ppdev,parport_pc,lp
via_rhine              19154  0
mii                     4381  1 via_rhine
sata_via                6945  0
pata_via                7272  2
floppy                 53016  1


sudo lshw -C network:
cliente01@cliente01-desktop:~$ sudo lshw -C network
[sudo] password for cliente01:
  *-network UNCLAIMED     
       description: Ethernet controller
       product: VT6102 [Rhine-II]
       vendor: VIA Technologies, Inc.
       physical id: 12
       bus info: pci@0000:00:12.0
       version: 78
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: latency=32
       resources: ioport:d800(size=256) memory:febffc00-febffcff


iwlist scan:
cliente01@cliente01-desktop:~$ iwlist scan
lo        Interface doesn't support scanning.


Na interface:
http://twitpic.com/2fey3r
http://twitpic.com/2feygf

Essas da intarface você pode abrir se quiser, elas estão mostrando apenas as telas, só pra ter ideia.
Mais uma vez, obrigado pela atenção!
« Última modificação: 17 de Agosto de 2010, 15:07 por ynamros »

libonati

  • Visitante
Re: Ubuntu 10.04 não reconhece a placa de rede Via VT6102
« Resposta #1 Online: 16 de Agosto de 2010, 21:44 »
Posta também:
Código: [Selecionar]
lspci -v -s 12.0
Não interessa tuas fotos. Quero por escrito a base de corta e cola.

Offline ynamros

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: Ubuntu 10.04 não reconhece a placa de rede Via VT6102
« Resposta #2 Online: 17 de Agosto de 2010, 18:06 »
Posta também:
Código: [Selecionar]
lspci -v -s 12.0
Não interessa tuas fotos. Quero por escrito a base de corta e cola.

Ok... o post foi corrigido conforme vc pediu... "corta e cola"... :)

e tá ai o q vc pediu pra acrescentar...

cliente01@cliente01-desktop:~$ lspci -v -s 12.0
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
   Flags: bus master, medium devsel, latency 32, IRQ 23
   I/O ports at d800 [size=256]
   Memory at febffc00 (32-bit, non-prefetchable) [size=256]
   Capabilities: <access denied>
   Kernel modules: via-rhine

libonati

  • Visitante
Re: Ubuntu 10.04 não reconhece a placa de rede Via VT6102
« Resposta #3 Online: 17 de Agosto de 2010, 19:12 »
Obrigado amigo. Vamos em frente...com muita atenção.
Execute os comandos:

Código: [Selecionar]
locate via-rhine        
Código: [Selecionar]
lsmod I grep "rhine"                      


#O primeiro comando Verifica onde está seu módulo
#O segundo comando Verifica se ele está carregado

Você pode cortar e colar os códigos em seu computador...
Estou aguardando...
« Última modificação: 17 de Agosto de 2010, 19:18 por libonati »

Offline ynamros

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: Ubuntu 10.04 não reconhece a placa de rede Via VT6102
« Resposta #4 Online: 17 de Agosto de 2010, 19:40 »
seguem os dados...


cliente01@cliente01-desktop:~$ locate via-rhine
/lib/modules/2.6.32-21-generic/kernel/drivers/net/via-rhine.ko

cliente01@cliente01-desktop:~$ lsmod I grep "rhine"
Usage: lsmod
« Última modificação: 17 de Agosto de 2010, 19:47 por ynamros »

libonati

  • Visitante
Re: Ubuntu 10.04 não reconhece a placa de rede Via VT6102
« Resposta #5 Online: 17 de Agosto de 2010, 20:09 »

use o comando abaixo.

Código: [Selecionar]
insmod  /lib/modules/2.6.32-21-generic/kernel/drivers/net/via-rhine.ko

libonati

  • Visitante
Re: Ubuntu 10.04 não reconhece a placa de rede Via VT6102
« Resposta #6 Online: 17 de Agosto de 2010, 20:16 »
Olá amigos.....

cliente01@cliente01-desktop:~$ lsmod
Module                  Size  Used by
via_rhine              19154  0
mii                     4381  1 via_rhine

Eu so não compreendo por que você está fazendo isso..... seu módulo está aí....mas siga em frente.

Offline ynamros

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: Ubuntu 10.04 não reconhece a placa de rede Via VT6102
« Resposta #7 Online: 17 de Agosto de 2010, 21:20 »
Também não entendo. Ele tá em dual boot e no xp pega normalmente... se fosse um problema com o hardware não dava nada. Mas ele funciona perfeitamente no xp, já no linux, não. E peguei o hd e coloquei em outra maquina pra ver se era alguma falha na instalação mas... na outra deu tudo certo. O ubuntu reconheceu a placa de rede perfeitamente.



essa linha de comando ta retornando esse erro:
insmod: error inserting '/lib/modules/2.6.32-21-generic/kernel/drivers/net/via-rhine.ko' : -1 Operation not permitted
« Última modificação: 17 de Agosto de 2010, 21:24 por ynamros »

libonati

  • Visitante
Re: Ubuntu 10.04 não reconhece a placa de rede Via VT6102
« Resposta #8 Online: 18 de Agosto de 2010, 08:25 »
Haaa...uma falha minha. Você tem de usar o root. Pode usar também no lugar do comando insmod o modprobe assim:
Código: [Selecionar]
modprobe via-rhineOperações críticas tem de usar sempre o root ou sudo.

A propósito, qual o modelo "completo" de seu modem?
Qual o modelo "completo" de seu roteador?
Qual o seu provedor de internet?


Offline ynamros

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: Ubuntu 10.04 não reconhece a placa de rede Via VT6102
« Resposta #9 Online: 18 de Agosto de 2010, 14:41 »
Haaa...uma falha minha. Você tem de usar o root. Pode usar também no lugar do comando insmod o modprobe assim:
Código: [Selecionar]
modprobe via-rhineOperações críticas tem de usar sempre o root ou sudo.

A propósito, qual o modelo "completo" de seu modem?
Qual o modelo "completo" de seu roteador?
Qual o seu provedor de internet?



Código: [Selecionar]
cliente01@cliente01-desktop:~$ modprobe via-rhine
cliente01@cliente01-desktop:~$ sudo insmod /lib/modules/2.6.32-21-generic/kernel/drivers/net/via-rhine.ko
insmod: error inserting '/lib/modules/2.6.32-21-generic/kernel/drivers/net/via-rhine.ko': -1 File exists
cliente01@cliente01-desktop:~$

Quanto as informações que vc me pediu:
Meu modem é um speedstream 4200 roteado e meu provedor é Oi.

libonati

  • Visitante
Re: Ubuntu 10.04 não reconhece a placa de rede Via VT6102
« Resposta #10 Online: 18 de Agosto de 2010, 14:59 »
Citar
insmod: error inserting '/lib/modules/2.6.32-21-generic/kernel/drivers/net/via-rhine.ko': -1 File exists

Na realidade não houve erro, apenas o arquivo já existe. O comando anterior modprobe deve ter cumprido sua missão.
Vamos em frente...
Código: [Selecionar]
lsmodVerifique se encontra seu módulo via-rhine carregado.
Estou aguardando...

Offline ynamros

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: Ubuntu 10.04 não reconhece a placa de rede Via VT6102
« Resposta #11 Online: 18 de Agosto de 2010, 15:06 »
Código: [Selecionar]
cliente01@cliente01-desktop:~$ lsmod
Module                  Size  Used by
nls_iso8859_1           3249  0
nls_cp437               4919  0
vfat                    8901  0
fat                    47767  1 vfat
usb_storage            39425  0
via                    37920  3
drm                   162471  4 via
binfmt_misc             6587  1
snd_via82xx_modem       8486  0
snd_via82xx            20058  2
gameport                9089  1 snd_via82xx
snd_ac97_codec        100646  2 snd_via82xx_modem,snd_via82xx
ac97_bus                1002  1 snd_ac97_codec
snd_pcm_oss            35308  0
snd_mixer_oss          13746  1 snd_pcm_oss
snd_pcm                70662  4 snd_via82xx_modem,snd_via82xx,snd_ac97_codec,snd_pcm_oss
snd_mpu401_uart         5617  1 snd_via82xx
snd_seq_dummy           1338  0
snd_seq_oss            26726  0
snd_seq_midi            4557  0
snd_rawmidi            19056  2 snd_mpu401_uart,snd_seq_midi
snd_seq_midi_event      6003  2 snd_seq_oss,snd_seq_midi
snd_seq                47263  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
fbcon                  35102  71
tileblit                2031  1 fbcon
font                    7557  1 fbcon
bitblit                 4707  1 fbcon
softcursor              1189  1 bitblit
snd_timer              19098  2 snd_pcm,snd_seq
snd_seq_device          5700  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
vga16fb                11385  1
vgastate                8961  1 vga16fb
ppdev                   5259  0
snd                    54148  16 snd_via82xx_modem,snd_via82xx,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_mpu401_uart,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
psmouse                63245  0
serio_raw               3978  0
i2c_viapro              5573  0
soundcore               6620  1 snd
snd_page_alloc          7076  3 snd_via82xx_modem,snd_via82xx,snd_pcm
parport_pc             25962  1
shpchp                 28820  0
via_agp                 5310  1
agpgart                31724  2 drm,via_agp
lp                      7028  0
parport                32635  3 ppdev,parport_pc,lp
via_rhine              19154  0
mii                     4381  1 via_rhine
pata_via                7272  2
sata_via                6945  0
floppy                 53016  0

libonati

  • Visitante
Re: Ubuntu 10.04 não reconhece a placa de rede Via VT6102
« Resposta #12 Online: 18 de Agosto de 2010, 17:20 »
Citar
via_rhine              19154  0
mii                     4381  1 via_rhine

Estamos quase no objetivo....

Código: [Selecionar]
ifconfig
Código: [Selecionar]
route -n
Código: [Selecionar]
ping -c 3 127.0.0.1
Código: [Selecionar]
ping -c 3 64.233.163.104
Código: [Selecionar]
ping -c 3 ns2.google.com
poste os resultados



Offline ynamros

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: Ubuntu 10.04 não reconhece a placa de rede Via VT6102
« Resposta #13 Online: 18 de Agosto de 2010, 17:48 »
Vamos lá...
Código: [Selecionar]
ifconfig
lo        Link encap:Loopback Local 
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:16436  Métrica:1
          pacotes RX:8 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:8 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:0
          RX bytes:480 (480.0 B) TX bytes:480 (480.0 B)

Código: [Selecionar]
route -n
Tabela de Roteamento IP do Kernel
Destino         Roteador        MáscaraGen.    Opções Métrica Ref   Uso Iface

Código: [Selecionar]
ping -c 3 127.0.0.1
PING 127.0.0.1 (127.0.0.1) 56(84) bytes of data.
64 bytes from 127.0.0.1: icmp_seq=1 ttl=64 time=0.063 ms
64 bytes from 127.0.0.1: icmp_seq=2 ttl=64 time=0.059 ms
64 bytes from 127.0.0.1: icmp_seq=3 ttl=64 time=0.055 ms

--- 127.0.0.1 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2000ms
rtt min/avg/max/mdev = 0.055/0.059/0.063/0.003 ms

Código: [Selecionar]
ping -c 3 64.233.163.104
connect: Network is unreachable

Código: [Selecionar]
ping -c 3 ns2.google.com
ping: unknown host ns2.google.com

libonati

  • Visitante
Re: Ubuntu 10.04 não reconhece a placa de rede Via VT6102
« Resposta #14 Online: 18 de Agosto de 2010, 18:06 »
Citar
route -n
Tabela de Roteamento IP do Kernel
Destino         Roteador        MáscaraGen.    Opções Métrica Ref   Uso Iface

Você não quer me mostrar a rota? Se o seu modem está roteado ele é 192.168.252.252. Vamos então fazer a rota, mas antes vamos verificar como está a configuração. Siga as instruções do link com muita atenção.
http://www.youtube.com/watch?v=EtO1jYTCtQA
« Última modificação: 18 de Agosto de 2010, 18:17 por libonati »