Autor Tópico: Guia geral NVIDIA para Ubuntu 10.04~12.10 - 1.0  (Lida 318167 vezes)

Offline sot-legend

  • Usuário Ubuntu
  • *
  • Mensagens: 237
    • Ver perfil
Re: Instalando driver recente nVidia no Ubuntu 10.04
« Resposta #30 Online: 27 de Julho de 2010, 13:05 »
eu respondi uma pergunta parecida com essa aqui:

http://ubuntuforum-br.org/index.php/topic,58761.0.html
][_, {[]} ][_,

»|.¶åŭĽĭŋĥØ.|«

Offline merorafael

  • Usuário Ubuntu
  • *
  • Mensagens: 236
  • Ubuntu 12.04 / Fedora 17
    • Ver perfil
    • Mero Projects
Re: Instalando driver recente nVidia no Ubuntu 10.04
« Resposta #31 Online: 30 de Julho de 2010, 11:00 »
Adicionado:
* Link de download do driver
* Lista de placas suportadas pelo driver
* Carregador de configurações quando inicia o sistema
* Corrigido etapa de instalação da biblioteca OpenGL
* Alterações do Blacklist(feito por py8elo)
* Recomendações
* Capitulo 03 - Alterando velocidade do Fan
« Última modificação: 30 de Julho de 2010, 11:38 por Mausai »
Projetos: Mero Projects - http://www.meroprojects.com/

Offline platao

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 5.013
    • Ver perfil
Re: Instalando driver recente nVidia no Ubuntu 10.04
« Resposta #32 Online: 30 de Julho de 2010, 12:08 »
Maravilha Mausai, ja foi para os favoritos.
\\\\\\\\Apostilas Dicas e Guias do Ubuntu\\\\\\\\\> http://ubuntuforum-br.org/index.php/topic,79368.msg440997.html#msg440997

Offline py8elo

  • Usuário Ubuntu
  • *
  • Mensagens: 105
  • Acorda Brasil!
    • Ver perfil
Re: Instalando driver recente nVidia no Ubuntu 10.04
« Resposta #33 Online: 30 de Julho de 2010, 22:36 »
Olá meu caro Mausai,
aproveitando o seu pique com essa questão do driver Nvidia, eu gostaria de saber se alguem mais está tendo um problema que eu descobri ontem...
Após testar a resolução máxima (1920x1080) suportada pelo meu monitor AOC2236, observei que ao reiniciar ele retorna com 1024x768...
Antes que algum outro colega dê a sugestão de editar o xorg.conf e adicionar a resolução máxima  na Subsection "Display" após o comando DefaultDepth 24, eu gostaria de dizer que já tentei essa tática e funcionou... Só que ele deixa de usar o driver Nvidia que instalei recentemente e me dá uma mensagem de erro durante a inicialização referente a um programa que não lembro ao certo (creio eu ser power manager) e me pergunta se tenho certeza que desejo continuar... Logo após, ele cai na tela de correção de problemas do GDM...
Exceto por essa mensagem e por deixar de usar o driver proprietário, isso aparentemente resolve o problema...
Eu já pesquisei muito em vários sites e foruns, seguindo as instruções e dicas encontradas sem sucesso...
Se mais alguém estiver enfrentando esse tipo de problema, por favor informe... Informe também o que tem feito para tentar resolver...

[]'s,

Silva.

Adicionado:
* Link de download do driver
* Lista de placas suportadas pelo driver
* Carregador de configurações quando inicia o sistema
* Corrigido etapa de instalação da biblioteca OpenGL
* Alterações do Blacklist(feito por py8elo)
* Recomendações
* Capitulo 03 - Alterando velocidade do Fan
Ubuntu 16.04 LTS
G41M-S01 + E7500 + 4Gb Ram + Gforce GT610 2Tb SATA + 3x500Gb SATA
Linux registered user #521164

Offline merorafael

  • Usuário Ubuntu
  • *
  • Mensagens: 236
  • Ubuntu 12.04 / Fedora 17
    • Ver perfil
    • Mero Projects
Re: Instalando driver recente nVidia no Ubuntu 10.04
« Resposta #34 Online: 31 de Julho de 2010, 00:37 »
No xorg.conf não pode os valores para "DefaultDepth" poderão serem apenas: 8, 16 e 24.
Então nunca coloque um valor diferente disso, e lembrando, existe dois tipos de suporte
a resolução, o do monitor e a da placa de vídeo. O do monitor você poderá ver qual é a
resolução máxima suportada na caixa ou no site do fabricante, já a placa de vídeo, você
poderá executar o comando que eu coloquei no guia do Plymouth ou verificar no site do fabricante
também.
Enquanto a utilizar outro driver, esse é um dos motivos que recomendo essa instalação "manual".
Para o driver da nvidia ser instalado dessa forma, é necessário remover todos os driver's de vídeo,
assim evitará com que o X.Org Server tenha conflito com outro driver.
Lembrando novamente, no Ubuntu 10.04 o usuário não usará o driver da nvidia mesmo que esteja
instalado(usando a instalação automática). O painel vai afirmar que está ativo mas o X.Org continuará
usando a porcaria do Noveau.
E por ultimo, tendo somente o driver da nvidia instalado e em xorg.conf usando o driver "nvidia", ele nunca
usará outro driver independente da resolução, a menos que você coloque alguma configuração errada,
ai o ubuntu iniciará com o vesa para que você endireite o xorg.conf
« Última modificação: 31 de Julho de 2010, 00:48 por Mausai »
Projetos: Mero Projects - http://www.meroprojects.com/

Offline py8elo

  • Usuário Ubuntu
  • *
  • Mensagens: 105
  • Acorda Brasil!
    • Ver perfil
Re: Instalando driver recente nVidia no Ubuntu 10.04
« Resposta #35 Online: 31 de Julho de 2010, 10:07 »
Olá meu caro Mausai,
eu acho que não me fiz entender...
Segue abaixo o meu xorg.conf:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 256.35  (buildd@lychee)  Tue Jul  6 21:09:58 UTC 2010

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 256.35  (buildmeister@builder101)  Wed Jun 16 19:25:59 PDT 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "AOC 2236"
    HorizSync       30.0 - 80.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8400 GS"
EndSection

Section "Screen"

# Removed Option "metamodes" "1920x1080 +0+0"
# Removed Option "metamodes" "nvidia-auto-select +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Coolbits" "1"
    Option         "TwinView" "0"
    Option         "metamodes" "nvidia-auto-select +0+0; 1920x1080 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Como pode ver, ele faz referencia ao modo que eu selecionei pelo Nvidia X server settings... Mas quando reinicio, a configuração está 1024x768 sempre... Exceto qdo eu adiciono:
 SubSection     "Display"
        Depth       24
mode 1920x1080
    EndSubSection
EndSection

Mas aí, já vem aquele problema da mensagem de erro e ele me diz que não está usando o driver do fabricante da placa de video...
Um outro detalhe é que a cada vez que reinicio pc, o painel do gnome altera sozinho... Os ícones mudam de posição e estilo...
Perdoe a falta de didática!!!
Espero ter sido mais claro agora...

[]'s,

Silva.

No xorg.conf não pode os valores para "DefaultDepth" poderão serem apenas: 8, 16 e 24.
Então nunca coloque um valor diferente disso, e lembrando, existe dois tipos de suporte
a resolução, o do monitor e a da placa de vídeo. O do monitor você poderá ver qual é a
resolução máxima suportada na caixa ou no site do fabricante, já a placa de vídeo, você
poderá executar o comando que eu coloquei no guia do Plymouth ou verificar no site do fabricante
também.
Enquanto a utilizar outro driver, esse é um dos motivos que recomendo essa instalação "manual".
Para o driver da nvidia ser instalado dessa forma, é necessário remover todos os driver's de vídeo,
assim evitará com que o X.Org Server tenha conflito com outro driver.
Lembrando novamente, no Ubuntu 10.04 o usuário não usará o driver da nvidia mesmo que esteja
instalado(usando a instalação automática). O painel vai afirmar que está ativo mas o X.Org continuará
usando a porcaria do Noveau.
E por ultimo, tendo somente o driver da nvidia instalado e em xorg.conf usando o driver "nvidia", ele nunca
usará outro driver independente da resolução, a menos que você coloque alguma configuração errada,
ai o ubuntu iniciará com o vesa para que você endireite o xorg.conf

« Última modificação: 31 de Julho de 2010, 11:59 por py8elo »
Ubuntu 16.04 LTS
G41M-S01 + E7500 + 4Gb Ram + Gforce GT610 2Tb SATA + 3x500Gb SATA
Linux registered user #521164

Offline merorafael

  • Usuário Ubuntu
  • *
  • Mensagens: 236
  • Ubuntu 12.04 / Fedora 17
    • Ver perfil
    • Mero Projects
Re: Instalando driver recente nVidia no Ubuntu 10.04
« Resposta #36 Online: 31 de Julho de 2010, 12:32 »
@py8elo Não precisa ser tão formal assim não, todos nós somos amigos aqui no fórum  ;D
Enquanto aos ícones no gnome painel, tenta desbloquear-los, reposiciona-los para sua preferência
e em seguida bloquear-los novamente, assim resolverá seu problema dos ícones ficarem passeando
pelo painel. Isso geralmente ocorre depois de instalar o Ubuntu e não pelo menos desbloquear e
bloquear de novo todos os ícones. ::)
Enquanto ao X Config, tudo está aparentemente corrento, você conseguiria tirar uma screenshot para
nós vermos direitinho como é esse erro? Você também pode tentar da um Ctrl+Alt+F1 e em seguida:
Código: [Selecionar]
$ sudo service gdm stop
$ sudo nvidia-xconfig
$ sudo service gdm start
Verifique também se seu monitor suporta a resolução que você colocou no X Config "1920x1080".
Tente reduzi-la para uma resolução menos, caso seu monitor seja de 22" o máximo sugerido por mim
é de "1680x1050". Então altere:
Código: [Selecionar]
    Option         "metamodes" "nvidia-auto-select +0+0; 1920x1080 +0+0"Para:
Código: [Selecionar]
    Option         "metamodes" "nvidia-auto-select +0+0; <resolução_de_sua_preferência> +0+0"
Projetos: Mero Projects - http://www.meroprojects.com/

Offline py8elo

  • Usuário Ubuntu
  • *
  • Mensagens: 105
  • Acorda Brasil!
    • Ver perfil
Re: Instalando driver recente nVidia no Ubuntu 10.04
« Resposta #37 Online: 31 de Julho de 2010, 12:50 »
OK meu caro Mausai...
Não é questão de formalidade não!!! hehehe... É que eu sou mesmo meio tosco pra explicar as coisas... Perdoe o mau jeito!!!! hehehe...
@py8elo Não precisa ser tão formal assim não, todos nós somos amigos aqui no fórum  ;D
Enquanto aos ícones no gnome painel, tenta desbloquear-los, reposiciona-los para sua preferência
e em seguida bloquear-los novamente, assim resolverá seu problema dos ícones ficarem passeando
pelo painel. Isso geralmente ocorre depois de instalar o Ubuntu e não pelo menos desbloquear e
bloquear de novo todos os ícones. ::)
Enquanto ao X Config, tudo está aparentemente corrento, você conseguiria tirar uma screenshot para
nós vermos direitinho como é esse erro? Você também pode tentar da um Ctrl+Alt+F1 e em seguida:
Código: [Selecionar]
$ sudo service gdm stop
$ sudo nvidia-xconfig
$ sudo service gdm start
Verifique também se seu monitor suporta a resolução que você colocou no X Config "1920x1080".
A resolução máxima suportada pelo  monitor AOC2236 é 1920x1080...
Tente reduzi-la para uma resolução menos, caso seu monitor seja de 22" o máximo sugerido por mim
é de "1680x1050". Então altere:
Código: [Selecionar]
   Option         "metamodes" "nvidia-auto-select +0+0; 1920x1080 +0+0"Para:
Código: [Selecionar]
   Option         "metamodes" "nvidia-auto-select +0+0; <resolução_de_sua_preferência> +0+0"
Tentarei agora mesmo a sua nova sugestão e postarei em seguida o resultado...

EDIT:
Infelizmente não deu certo a sua nova dica...
apenas 1024x786 aparece após reiniciar...
Mas, eu contunuo tentando...

[]'s,

Silva.
« Última modificação: 31 de Julho de 2010, 16:21 por py8elo »
Ubuntu 16.04 LTS
G41M-S01 + E7500 + 4Gb Ram + Gforce GT610 2Tb SATA + 3x500Gb SATA
Linux registered user #521164

Offline vinicius_aleao

  • Usuário Ubuntu
  • *
  • Mensagens: 1.275
    • Ver perfil
Re: Instalando driver recente nVidia no Ubuntu 10.04
« Resposta #38 Online: 31 de Julho de 2010, 18:04 »
Para os ícones não se moverem, bloqueia o painel do gnome com o Ubuntu Tweak.

Offline merorafael

  • Usuário Ubuntu
  • *
  • Mensagens: 236
  • Ubuntu 12.04 / Fedora 17
    • Ver perfil
    • Mero Projects
Re: Instalando driver recente nVidia no Ubuntu 10.04
« Resposta #39 Online: 31 de Julho de 2010, 21:39 »
@py8elo Alterou o XConfig como eu falei?
Caso tenha alterado tente alterar para essa forma:
Código: [Selecionar]
   Option         "metamodes" "1680x1050_60 +0+0; nvidia-auto-select +0+0; 1680x1050 +0+0"Verifique também se você não está iniciando o sistema no modo de segurança. Caso não funcione, não deixe de postar ::)
« Última modificação: 31 de Julho de 2010, 21:42 por Mausai »
Projetos: Mero Projects - http://www.meroprojects.com/

Offline py8elo

  • Usuário Ubuntu
  • *
  • Mensagens: 105
  • Acorda Brasil!
    • Ver perfil
Re: Instalando driver recente nVidia no Ubuntu 10.04
« Resposta #40 Online: 31 de Julho de 2010, 21:56 »
Olá meu caro Mausai...
eu modifiquei exatamente dojeito que vc sugere...
Mas, veja o que ele fez aoreiniciar:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 256.35  (buildd@lychee)  Tue Jul  6 21:09:58 UTC 2010

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 256.35  (buildmeister@builder101)  Wed Jun 16 19:25:59 PDT 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "AOC 2236"
    HorizSync       30.0 - 80.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8400 GS"
EndSection

Section "Screen"

# Removed Option "metamodes" "1920x1080 +0+0"
# Removed Option "metamodes" "nvidia-auto-select +0+0"
# Removed Option "metamodes" "nvidia-auto-select +0+0; 1920x10800 +0+0"
# Removed Option "metamodes" "nvidia-auto-select1680x1050 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Coolbits" "1"
    Option         "TwinView" "0"
    Option         "metamodes" "nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

@py8elo Alterou o XConfig como eu falei?
Caso tenha alterado tente alterar para essa forma:
Código: [Selecionar]
   Option         "metamodes" "1680x1050_60 +0+0; nvidia-auto-select +0+0; 1680x1050 +0+0"Eu tenho cerrteza de que não estou em modo de segurança...
Verifique também se você não está iniciando o sistema no modo de segurança. Caso não funcione, não deixe de postar ::)
Eu já tentei tambem outras configurações mas, a única que sempre permanece é quando coloco 1024x768... Essa ele não altera mas, tudo fica muito grande como se estivesse em 640x480 num monitor normal de 14",,,
Nós ainda encontraremos uma solução... Disso eu tenho certeza...

[]'s,

Silva.
Ubuntu 16.04 LTS
G41M-S01 + E7500 + 4Gb Ram + Gforce GT610 2Tb SATA + 3x500Gb SATA
Linux registered user #521164

Offline merorafael

  • Usuário Ubuntu
  • *
  • Mensagens: 236
  • Ubuntu 12.04 / Fedora 17
    • Ver perfil
    • Mero Projects
Re: Instalando driver recente nVidia no Ubuntu 10.04
« Resposta #41 Online: 01 de Agosto de 2010, 00:41 »
Código: [Selecionar]
Section "Screen"

# Removed Option "metamodes" "1920x1080 +0+0"
# Removed Option "metamodes" "nvidia-auto-select +0+0"
# Removed Option "metamodes" "nvidia-auto-select +0+0; 1920x10800 +0+0"
# Removed Option "metamodes" "nvidia-auto-select1680x1050 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Coolbits" "1"
    Option         "TwinView" "0"
    Option         "metamodes" "nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Para:
Código: [Selecionar]
Section "Screen"

# Removed Option "metamodes" "1920x1080 +0+0"
# Removed Option "metamodes" "nvidia-auto-select +0+0"
# Removed Option "metamodes" "nvidia-auto-select +0+0; 1920x10800 +0+0"
# Removed Option "metamodes" "nvidia-auto-select1680x1050 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "1680x1050_60 +0+0; nvidia-auto-select +0+0; 1680x1050 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Você pode tentar também:
Código: [Selecionar]
$ sudo nvidia-settingsX Server Display Configuration
Mude Resolution para resolução desejada.
Apply e Save to X Configuration File
Faça também o que coloquei no tópico do plymouth(o link está no guia desse tópico), de repente
o Grub seja o responsável pela baixa resolução ao iniciar o sistema(embora isso seja difícil, não
custa tentar).

Por fim...Option         "Coolbits" "1" deverá ser colocado na seção Device, não na seção Screen.
« Última modificação: 01 de Agosto de 2010, 00:43 por Mausai »
Projetos: Mero Projects - http://www.meroprojects.com/

Offline platao

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 5.013
    • Ver perfil
Re: Instalando driver recente nVidia no Ubuntu 10.04
« Resposta #42 Online: 01 de Agosto de 2010, 12:34 »
Ola companheiros, gostaria se possivel que fosse incluso no seu tutorial Mausai esses 2 artigos, o que vc acha? Ele vai ficar mais completo ainda.

http://www.ubuntu-ac.org/archives/753

E tbm se vale a pena ou nao instalar o driver CUDA Nvidia e se ha algum aumento de performance ou qualquer coisa do genero;

http://ubuntuforum-br.org/index.php/topic,61169.0.html

EDITADO
« Última modificação: 01 de Agosto de 2010, 13:06 por platao »
\\\\\\\\Apostilas Dicas e Guias do Ubuntu\\\\\\\\\> http://ubuntuforum-br.org/index.php/topic,79368.msg440997.html#msg440997

Offline merorafael

  • Usuário Ubuntu
  • *
  • Mensagens: 236
  • Ubuntu 12.04 / Fedora 17
    • Ver perfil
    • Mero Projects
Re: Instalando driver recente nVidia no Ubuntu 10.04
« Resposta #43 Online: 01 de Agosto de 2010, 15:51 »
@platao Estarei incluindo sim ;D depois(talvez amanhã ou hoje a noite) estarei colocando outro capitulo
referente a controle do PowerMizer que fiquei devendo, ai adiciono esses artigos também ;)

@offtopic O que acho engraçado na NVIDIA é que para sistemas "Ruindows" ela é considerada uma porcaria,
mas para Linux ela funciona muito bem, até melhor que no "Ruindows". Eu tava pensando em migrar para as placas
ATi, mas parece que agora já estou mudando de ideia, quando fizer upgrade acho que vou comprar NVIDIA de novo. ::)
Projetos: Mero Projects - http://www.meroprojects.com/

Offline py8elo

  • Usuário Ubuntu
  • *
  • Mensagens: 105
  • Acorda Brasil!
    • Ver perfil
Re: Instalando driver recente nVidia no Ubuntu 10.04
« Resposta #44 Online: 01 de Agosto de 2010, 17:41 »
caro Mausai,
eu já tentei tudo isso sem êxito...
Sinceramente, eu já nem sei mais o que fazer...
Mas, continuo pesquisando em busca de uma solução...
O "balé" do painel do Gnome é a menor de minhas preocupações...
Mas, esse lance de alterar  resolução está me tirando do sério...
Espero encontrar logo uma solução...

[]'s,

Silva.

Código: [Selecionar]
Section "Screen"

# Removed Option "metamodes" "1920x1080 +0+0"
# Removed Option "metamodes" "nvidia-auto-select +0+0"
# Removed Option "metamodes" "nvidia-auto-select +0+0; 1920x10800 +0+0"
# Removed Option "metamodes" "nvidia-auto-select1680x1050 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Coolbits" "1"
    Option         "TwinView" "0"
    Option         "metamodes" "nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Para:
Código: [Selecionar]
Section "Screen"

# Removed Option "metamodes" "1920x1080 +0+0"
# Removed Option "metamodes" "nvidia-auto-select +0+0"
# Removed Option "metamodes" "nvidia-auto-select +0+0; 1920x10800 +0+0"
# Removed Option "metamodes" "nvidia-auto-select1680x1050 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "1680x1050_60 +0+0; nvidia-auto-select +0+0; 1680x1050 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Você pode tentar também:
Código: [Selecionar]
$ sudo nvidia-settingsX Server Display Configuration
Mude Resolution para resolução desejada.
Apply e Save to X Configuration File
Faça também o que coloquei no tópico do plymouth(o link está no guia desse tópico), de repente
o Grub seja o responsável pela baixa resolução ao iniciar o sistema(embora isso seja difícil, não
custa tentar).

Por fim...Option         "Coolbits" "1" deverá ser colocado na seção Device, não na seção Screen.
Ubuntu 16.04 LTS
G41M-S01 + E7500 + 4Gb Ram + Gforce GT610 2Tb SATA + 3x500Gb SATA
Linux registered user #521164