Autor Tópico: Squid não quer funcionar  (Lida 1117 vezes)

Offline Bruno Budag

  • Usuário Ubuntu
  • *
  • Mensagens: 22
    • Ver perfil
Squid não quer funcionar
« Online: 14 de Junho de 2010, 11:46 »
Galera da um Help ae, aonde está meu erro, não consigo mais descobrir

http_port 3128 transparent
#snmp_port 127.0.0.1:3401
snmp_incoming_address 192.168.1.10
snmp_outgoing_address 192.168.1.10

cache_mem 64 MB
cache_swap_low  90
cache_swap_high 95
maximum_object_size 10240 KB
cache_dir ufs /var/spool/squid/cache 2000 16 256
cache_access_log /var/log/squid/access.log
cache_log /var/log/squid/cache.log
cache_store_log /var/log/squid/store.log

mime_table /etc/squid/mime.conf

acl all         src 0.0.0.0/0.0.0.0
acl server      dst 192.168.1.10/255.255.255.255
acl redelocal   src 192.168.0.0/255.255.255.0

acl admins      src "/etc/squid/acl/admins"
acl usuarios    src "/etc/squid/acl/usuarios"
acl restritos   src "/etc/squid/acl/restritos"

#acl passwd     proxy_auth REQUIRED

acl time_almoco  time MTWHF 12:10-13:30
acl time_noite   time MTWHF 18:00-18:59

acl extensoes           url_regex -i "/etc/squid/acl/extensoes.txt"
acl palavras_proibidas  url_regex "/etc/squid/acl/palavrasproibidas.txt"
acl site_restrito       url_regex "/etc/squid/acl/site_restrito.txt"
acl site_bloqueado      url_regex "/etc/squid/acl/site.bloqueado.txt"
acl ip_liberado         dst       "/etc/squid/acl/ip"
acl spyware             url_regex "/etc/squid/acl/spyware.txt"

acl snmppublic snmp_community public
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl SSL_ports port 443 563
acl Safe_ports port 80 21 443 563 70 210 1025-65535
acl Safe_ports port 280         # http-mgmt
acl Safe_ports port 488         # gss-http
acl Safe_ports port 591         # filemaker
acl Safe_ports port 777         # multiling http
acl Safe_ports port 81          # publicfile local
acl Safe_ports port 121         # another
acl CONNECT method CONNECT

http_access allow manager localhost
http_access deny manager
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports

http_access allow server all
http_access deny spyware
http_access allow admins
http_access allow ip_liberado
http_access allow site_restrito
#http_access allow restritos site_restrito
#http_access allow restritos ip_liberado
http_access deny extensoes
http_access deny site_bloqueado
http_access allow usuarios
http_access deny all

miss_access allow all
miss_access allow redelocal

snmp_access allow snmppublic localhost
snmp_access deny all

error_directory /usr/share/squid/errors/Portuguese

forwarded_for on

extension_methods SEARCH BMOVE MOVE BDELETE DELETE BPROPFIND REPORT MERGE MKACTIVITY CHECKOUT SUBSCRIBE UNSUBSCRIBE MKCOL POLL BCOPY CHECKOUT GNUTELLA GET POST HEAD PUT


Não sei se é no IP que está errado, ja fiz de tudo.

Eu tenho o Linux na VM, isso é feito tanto no Ubuntu quanto no CentOS e ambos da a mesma falha

No meu explorer eu aponto no proxy o IP do meu linux e a porta 3128. Porem não autentica e da a mensagem que estou sem internet.

Obrigado a quem puder ajudar
« Última modificação: 14 de Junho de 2010, 11:53 por Bruno Budag »

Offline jeflui

  • Usuário Ubuntu
  • *
  • Mensagens: 745
    • Ver perfil
Re: Squid não quer funcionar
« Resposta #1 Online: 14 de Junho de 2010, 16:51 »
Veja o log:
/var/log/squid/cache.log
Se tiver dúvida do erro, coloca aqui.