Autor Tópico: [resolvido] java banco do brasil no ubuntu lucid/precise  (Lida 78149 vezes)

Offline Homembom

  • Usuário Ubuntu
  • *
  • Mensagens: 23
  • Tudo se liga
    • Ver perfil
Re: [resolvido] java banco do brasil no ubuntu 10.04 lucid
« Resposta #15 Online: 07 de Fevereiro de 2011, 15:33 »
boladegude,

Obrigado por tentar ajudar, mas o problema de instalação, mais uma vez, era com o proxy da empresa onde trabalho (usa-se um sources.list diferente). Foi só eu usar minha conexão particular que a instalação (via Central de Programas) ocorreu tudo bem. Mas, mesmo assim, ainda continuo sem conseguir acessar o Banco do Brasil, pois após o site pedir para aguardar a verificação de solução de segurança, a seguinte mensagem persiste em aparecer:

Citar
Problemas na instalação do Módulo de Segurança

Não foi possível instalar o Módulo de Segurança.

Para acessar o Autoatendimento BB pela Internet é necessário ter instalado neste computador o JAVA. Faça a instalação do JAVA (link para www.java.com).

Após a instalação, caso os problemas persistam, por favor, acione o Suporte Técnico através do telefone 0800-7290200".

Segundo minha pesquisa por "java" na Central de Programas, os pacotes instalados são: Plug-in Sun Java 6.0, javahelp2, java-common, sun-java6-bin, sun-java6-jre, sun-java6-plugin e sun-java6-jdk. Será que está faltando algum outro pacote?

Puxa,

Talvez o seu sistema esteja comprometido por alguma coisa que você tenha feito, só uma hipótese.
Mas tente baixar separado os pacotes que a instalação reclama que estão faltando.
Percebi que na instalação diz os pacotes que estão faltando unixodbc e java-common.
Talvez você encontre arquivos .deb na web que tenham essas dependências.
Se isso não der certo, sempre dá para...: 1) Fazer backup de TODOS os seus dados 2) Fazer uma instalação do zero 3) Recuperar seus dados 4) Fazer a instalação do java segundo consta no primeiro post desse tópico.

É só o que me ocorre no momento para ajudar.
Mas tem gente bastante especializada no fórum, espero que postem ajuda.
boladegude.



Offline boladegude

  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Re: [resolvido] java banco do brasil no ubuntu 10.04 lucid
« Resposta #16 Online: 07 de Fevereiro de 2011, 17:17 »
Olá,

Olha, o único pacote que tenho a mais aqui é o sun-java6-fonts

Become an Ubuntu user. Don't just use it as a virtual machine.
If you have some space in your HD then dual boot it with Windows or Mac.
It's a fine system. You shall be willing to study a little, but is worth your effort.

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: [resolvido] java banco do brasil no ubuntu 10.04 lucid
« Resposta #17 Online: 07 de Fevereiro de 2011, 17:31 »
Olá,

Olha, o único pacote que tenho a mais aqui é o sun-java6-fonts



coloca aqui o resultado dos comandos:

java -version

sudo update-alternatives --config java

Executados no terminal do Ubuntu e veja também no seu navegador firefox o seguinte:

na barra de endereços digite:

about:plugins


veja se lá é mostrado o plugin icedtea6-plugin

Se tiver, você deveria ter desinstalado ele antes de instalar o plugin do java da SUN para o seu navegador. Pode ser somente isso.
« Última modificação: 07 de Fevereiro de 2011, 17:33 por linuser104 »
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline Homembom

  • Usuário Ubuntu
  • *
  • Mensagens: 23
  • Tudo se liga
    • Ver perfil
Re: [resolvido] java banco do brasil no ubuntu 10.04 lucid
« Resposta #18 Online: 08 de Fevereiro de 2011, 07:53 »
boladegude,

Instalei o sun-java6-fonts, e o problema persiste.

Olá,

Olha, o único pacote que tenho a mais aqui é o sun-java6-fonts

linuser104,

Resultado de:

1 - $ java -version (terminal):

Código: [Selecionar]
java version "1.6.0_22"
Java(TM) SE Runtime Environment (build 1.6.0_22-b04)
Java HotSpot(TM) Client VM (build 17.1-b03, mixed mode, sharing)[java version "1.6.0_22"
Java(TM) SE Runtime Environment (build 1.6.0_22-b04)
Java HotSpot(TM) Client VM (build 17.1-b03, mixed mode, sharing)

2 - sudo update-alternatives --config java (terminal):

Código: [Selecionar]
Só há uma alternativa no grupo de links java: /usr/lib/jvm/java-6-sun/jre/bin/java
Nada para configurar.

3 - about:plugins (Firefox) [nada relacionado a icedtea6-plugin]:

Citar
Java(TM) Plug-in 1.6.0_22

    Arquivo: libnpjp2.so
    Versão:
    The next generation Java plug-in for Mozilla browsers.

Parece estar tudo ok... Mas a conta do BB continua com problema na instalação do Módulo de Segurança.

coloca aqui o resultado dos comandos:

java -version

sudo update-alternatives --config java

Executados no terminal do Ubuntu e veja também no seu navegador firefox o seguinte:

na barra de endereços digite:

about:plugins


veja se lá é mostrado o plugin icedtea6-plugin

Se tiver, você deveria ter desinstalado ele antes de instalar o plugin do java da SUN para o seu navegador. Pode ser somente isso.

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: [resolvido] java banco do brasil no ubuntu 10.04 lucid
« Resposta #19 Online: 08 de Fevereiro de 2011, 11:13 »
Realmente tudo está em ordem, então como essas respostas parecem sempre ser genéricas, ou seja, a algum sinal de problema sempre acusar o java, o melhor mesmo seria entrar em contato com o suporte técnico para averiguar qual seria o verdadeiro motivo para o problema.

Fui no link do java informado pelo sua mensagem de erro (link para www.java.com). Lá mandei fazer o teste se possuía o java e foi informado o seguinte:

Citar
Verificando a versão do Java
Opa! Você não tem o Java recomendado instalado.
Sua versão do Java é Version 6 Update 22. Clique no botão abaixo para obter o Java recomendado para o seu computador.

NOTA: Se você tiver concluído recentemente a instalação do software Java, reinicie seu navegador (feche todas as janelas dele e abra o navegador novamente) antes de verificar a instalação.

O que ele recomenda é atualizar para: Version 6 Update 23

portanto uma versão acima e não creio que seria somente por isso o problema, pois a versão 22 nem seria tão antiga assim.

« Última modificação: 08 de Fevereiro de 2011, 11:15 por linuser104 »
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline Homembom

  • Usuário Ubuntu
  • *
  • Mensagens: 23
  • Tudo se liga
    • Ver perfil
Re: [resolvido] java banco do brasil no ubuntu 10.04 lucid
« Resposta #20 Online: 09 de Fevereiro de 2011, 19:10 »
linuser104,

O detalhe que você observou foi fundamental para eu resolver o problema em questão: realmente, apesar de a atualização 22 da versão 6 não ser tão antiga assim, só consegui acessar minha conta do BB instalando a atualização mais recente (23). Então, foi o que fiz: acessei este link para instalação da versão recomendada, segui os passos de instalação, ativação e configuração do respectivo arquivo (no meu caso, "Linux (arquivo de extração automática)") e, com bastante satisfação, solucionei meu problema.

Agradeço muito a você e a todos que, de alguma forma, tentaram me ajudar.

(...)

O que ele recomenda é atualizar para: Version 6 Update 23

portanto uma versão acima e não creio que seria somente por isso o problema, pois a versão 22 nem seria tão antiga assim.

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: [resolvido] java banco do brasil no ubuntu 10.04 lucid
« Resposta #21 Online: 22 de Fevereiro de 2011, 10:10 »
linuser104,

O detalhe que você observou foi fundamental para eu resolver o problema em questão: realmente, apesar de a atualização 22 da versão 6 não ser tão antiga assim, só consegui acessar minha conta do BB instalando a atualização mais recente (23). Então, foi o que fiz: acessei este link para instalação da versão recomendada, segui os passos de instalação, ativação e configuração do respectivo arquivo (no meu caso, "Linux (arquivo de extração automática)") e, com bastante satisfação, solucionei meu problema.

Agradeço muito a você e a todos que, de alguma forma, tentaram me ajudar.

(...)

O que ele recomenda é atualizar para: Version 6 Update 23

portanto uma versão acima e não creio que seria somente por isso o problema, pois a versão 22 nem seria tão antiga assim.

Ok, mas não deixa de ser lamentável que uma simples atualização para uma versão imediatamente posterior deixe o sistema sem funcionar, acho isso grave. Só se essa atualização for para uma correção grave de segurança da anterior é que seria razoável entender que parasse de funcionar.

Se você instalou o java da SUN pelos comandos indicados, ou seja, ativando o repositório partner, mais cedo ou mais tarde o gerenciador de atualizações do Ubuntu iria indicar a atualização do java da SUN para uma versão mais nova. Por um acaso o Ubuntu indicou hoje a atualização do java para a versão:

java version "1.6.0_24"
Java(TM) SE Runtime Environment (build 1.6.0_24-b07)
Java HotSpot(TM) Server VM (build 19.1-b02, mixed mode)


portanto, Version 6 Update 24

Entretanto sei que sua necessidade de uso deveria ser urgente. Pena que as atualizações do Ubuntu nem sempre ocorrem com a velocidade de que gostaríamos.
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline rafaelnf

  • Usuário Ubuntu
  • *
  • Mensagens: 84
  • Ubuntu since 2011!
    • Ver perfil
    • rafaelnf - blog
Re: [resolvido] java banco do brasil no ubuntu 10.04 lucid
« Resposta #22 Online: 25 de Abril de 2011, 00:01 »
acabei de conseguir enviar minha declaração do IR e tava fuçando como faria pra atualizar o Java pro 6.24

removi tudo que tinha o openjdk e relacionados conforme post inicial...

mas a parte do terminal:
Código: [Selecionar]
sudo aptitude install sun-java6-bin sun-java6-fonts sun-java6-jre sun-java6-plugin
[sudo] password for rafael:
sudo: aptitude: command not found
não tinha surtido nenhum efeito pra mim...

já tinha instalado e mandado rodar conforme instruções no Java.com

1. baixei este aqui (uso o Ubuntu 10.10 faz 1 mês):
Linux (arquivo de extração automática) tamanho do arquivo: 20.2 MB

segui esse passo a passo:
http://www.java.com/pt_BR/download/help/linux_install.xml#selfextracting

depois testei aqui via link:
http://www.java.com/pt_BR/download/help/testvm.xml

e finalmente consegui ter meu Java atualizado (Java 6 Update 24) e funcionando 100% no Firefox 3.6.16
@rafaelnf --- nightfox-rafa.blogspot.com

Offline boladegude

  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Re: [resolvido] java banco do brasil no ubuntu 10.04 lucid
« Resposta #23 Online: 25 de Abril de 2011, 23:07 »
mas a parte do terminal:
Código: [Selecionar]
sudo aptitude install sun-java6-bin sun-java6-fonts sun-java6-jre sun-java6-plugin
[sudo] password for rafael:
sudo: aptitude: command not found
não tinha surtido nenhum efeito pra mim...

rafaelnf,
O problema é que aptitude não funciona no Ubuntu 10.10
Esse tutorial é para o Ubuntu 10.04!!!
Mas creio que as pessoas que utilizam Ubuntu 10.10 podem substituir o aptitude no comando mencionado por apt-get.

Abraço,
boladegude.
Become an Ubuntu user. Don't just use it as a virtual machine.
If you have some space in your HD then dual boot it with Windows or Mac.
It's a fine system. You shall be willing to study a little, but is worth your effort.

Offline jkmsjq

  • Usuário Ubuntu
  • *
  • Mensagens: 3.345
  • Ubuntu Member
    • Ver perfil
Re: [resolvido] java banco do brasil no ubuntu 10.04 lucid
« Resposta #24 Online: 26 de Abril de 2011, 09:03 »

mas a parte do terminal:
Código: [Selecionar]
sudo aptitude install sun-java6-bin sun-java6-fonts sun-java6-jre sun-java6-plugin
[sudo] password for rafael:
sudo: aptitude: command not found



Para se utilizar o aptitude é preciso instalar antes ele via sudo apt-get install aptitude só depois que se consegue utilizar normal e corretamente!


Valeu...

Fui...

Até mais...!!!
LinuxUser: 548942 / Dando um tópico como resolvido
"A verdade só é agressiva a quem vive de mentiras". Autor desconhecido.
Twitter: @jeisonkertesz

Offline jkmsjq

  • Usuário Ubuntu
  • *
  • Mensagens: 3.345
  • Ubuntu Member
    • Ver perfil
Re: [resolvido] java banco do brasil no ubuntu 10.04 lucid
« Resposta #25 Online: 26 de Abril de 2011, 09:10 »
mas a parte do terminal:
Código: [Selecionar]
sudo aptitude install sun-java6-bin sun-java6-fonts sun-java6-jre sun-java6-plugin
[sudo] password for rafael:
sudo: aptitude: command not found
não tinha surtido nenhum efeito pra mim...

rafaelnf,
O problema é que aptitude não funciona no Ubuntu 10.10
Esse tutorial é para o Ubuntu 10.04!!!
Mas creio que as pessoas que utilizam Ubuntu 10.10 podem substituir o aptitude no comando mencionado por apt-get.

Abraço,
boladegude.



Já questionei em relação a prática de se sugerir o apt-get no lugar do aptitude ou mesmo do apt-build... da uma conferida nesse link que tem algumas respostas interessantes tanto do clcampos quanto do rjbgbo... http://ubuntuforum-br.org/index.php/topic,81603.0.html

Fazendo uma pesquisa aqui mesmo no fórum, você vai encontrar muito material sobre esse tema...!!!


Valeu...

Fui...

Até mais...!!!
LinuxUser: 548942 / Dando um tópico como resolvido
"A verdade só é agressiva a quem vive de mentiras". Autor desconhecido.
Twitter: @jeisonkertesz

Offline rafaelnf

  • Usuário Ubuntu
  • *
  • Mensagens: 84
  • Ubuntu since 2011!
    • Ver perfil
    • rafaelnf - blog
Re: [resolvido] java banco do brasil no ubuntu 10.04 lucid
« Resposta #26 Online: 26 de Abril de 2011, 09:22 »
rafaelnf,
O problema é que aptitude não funciona no Ubuntu 10.10
Esse tutorial é para o Ubuntu 10.04!!!
Mas creio que as pessoas que utilizam Ubuntu 10.10 podem substituir o aptitude no comando mencionado por apt-get.

valeu a dica, sou novato no Ubuntu e não sabia...
mas consegui fazer o Java da Sun ser atualizado no procedimento que eu falei.. bastou remover o openjdk e o icedtea via Synaptic!

Para se utilizar o aptitude é preciso instalar antes ele via sudo apt-get install aptitude só depois que se consegue utilizar normal e corretamente!


valeu a dica.. cada dia eu aprendo um pouco por aqui!

abração e obrigado a disposição e paciência em ajudar...
@rafaelnf --- nightfox-rafa.blogspot.com

Offline polidori

  • Usuário Ubuntu
  • *
  • Mensagens: 183
    • Ver perfil
Re: [resolvido] java banco do brasil no ubuntu 10.04 lucid
« Resposta #27 Online: 29 de Setembro de 2011, 23:19 »
matou a pau no EDITADO boladegude!!!
VAleu!!
ASUS Intel I7
Mint 19.3 MATE 64-bit

Offline boladegude

  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Re: [resolvido] java banco do brasil no ubuntu 10.04 lucid
« Resposta #28 Online: 13 de Janeiro de 2012, 18:03 »
Firefox 3.6 não reconhece java no ubuntu
 
Aqui resolvi assim:
(após estar instalado o java plugin...)

Para usuários 32 bits
sudo update-alternatives --install /usr/lib/mozilla/plugins/libjavaplugin.so mozilla-javaplugin.so /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so 50

Para usuários 64 bits
sudo update-alternatives --install /usr/lib/mozilla/plugins/libjavaplugin.so mozilla-javaplugin.so /usr/lib/jvm/java-6-sun/jre/lib/amd64/libnpjp2.so 50

(Referências:
http://ubuntuforum-pt.org/index.php/topic,61990.msg348811.html#msg348811
http://ubuntuforums.org/showthread.php?t=1389682
)
Become an Ubuntu user. Don't just use it as a virtual machine.
If you have some space in your HD then dual boot it with Windows or Mac.
It's a fine system. You shall be willing to study a little, but is worth your effort.

Offline rafaelnf

  • Usuário Ubuntu
  • *
  • Mensagens: 84
  • Ubuntu since 2011!
    • Ver perfil
    • rafaelnf - blog
Re: [resolvido] java banco do brasil no ubuntu 10.04 lucid
« Resposta #29 Online: 13 de Janeiro de 2012, 21:16 »
eu to usando o 11.04 e não tava abrindo o BB

instalei o pacote sugerido pelo firefox direto do Ubuntu e abriu normal!
@rafaelnf --- nightfox-rafa.blogspot.com