Autor Tópico: Internet 3G não conecta  (Lida 17931 vezes)

Offline Andreson Goveia

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.985
  • Kubuntu 14.10
    • Ver perfil
Re: Internet 3G não conecta
« Resposta #30 Online: 01 de Maio de 2010, 21:16 »
Acho que não tem como. Bom, como vc sabe eu segui seus passos e o vivo internet foi instalado no computador. Apartir daí eu conecto e tal. Aparece o icone desconetar,ou seja, a tela do vivo internet. Agora o problema é com o firefox. E agora?
Pelo que vi não é só com o firefox e sim com outros programas que usam a internet, como eu disse eu só consigo conectar clicando no icone da internet que abre automaticamente o firefox, mas uma solução mais rapida seria instalar o ubuntu 9.10 no qual eu tinha instalado e funcionava normal, estou pensando seriamente em fazer isso e depois, fazer um upgrade.

Como eu estou tendo o mesmo problema que você eu fui até onde deu, depois disso não sei mais o que fazer, me desculpe se não pude ajudar como você queria.

Offline lucivando

  • Usuário Ubuntu
  • *
  • Mensagens: 62
    • Ver perfil
Re: Internet 3G não conecta
« Resposta #31 Online: 01 de Maio de 2010, 21:23 »
Tudo bem, fica tranquilo!!!

Alguem do fórum sabe a solução desse problema do firefox que não conecta através da net 3g?

Offline dtomadon

  • Usuário Ubuntu
  • *
  • Mensagens: 591
  • Fatec SCS,Segurança da Informação, BackTrack5
    • Ver perfil
    • Computação Forense e suas Leis
Re: Internet 3G não conecta
« Resposta #32 Online: 01 de Maio de 2010, 22:02 »
O problema não é com o firefox, esses pacotes que a vivo faz traz algumas incompatibilidades, entre elas a versão do ubuntu se não estiver errado os pacotes servem até a versão 9.04, depois dá pau, minha sugestão e que vc baixe na sua pasta home deste link:

http://www.draisberghof.de/usb_modeswitch/usb-modeswitch-1.1.2.tar.bz2

na sua pasta home descompacte o arquivo , entre na pasta criada , e dê o comando sudo make install , depois como sudo ainda abra seu gerenciador de arquivos , na pasta criada existe um arquivo chamado  40-usb_modeswitch.rules copie este arquivo para o endereço abaixo :

/etc/udev/40-usb_modeswitch.rules.

Acredito que resolverá seu problema,após este procedimento irá abrir o gerenciador de conexões do ubuntu, o network manage aí e só configurar e navegar. se não resolver posta aí, abraços.
BacKTrack5 64 bits com Vídeo SIS

kernel omnislash 1.4.4 64 bits , Que venha o 5º Semestre !!!

Offline Andreson Goveia

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.985
  • Kubuntu 14.10
    • Ver perfil
Re: Internet 3G não conecta
« Resposta #33 Online: 01 de Maio de 2010, 22:10 »
O problema não é com o firefox, esses pacotes que a vivo faz traz algumas incompatibilidades, entre elas a versão do ubuntu se não estiver errado os pacotes servem até a versão 9.04, depois dá pau, minha sugestão e que vc baixe na sua pasta home deste link:

http://www.draisberghof.de/usb_modeswitch/usb-modeswitch-1.1.2.tar.bz2

na sua pasta home descompacte o arquivo , entre na pasta criada , e dê o comando sudo make install , depois como sudo ainda abra seu gerenciador de arquivos , na pasta criada existe um arquivo chamado  40-usb_modeswitch.rules copie este arquivo para o endereço abaixo :

/etc/udev/40-usb_modeswitch.rules.

Acredito que resolverá seu problema,após este procedimento irá abrir o gerenciador de conexões do ubuntu, o network manage aí e só configurar e navegar. se não resolver posta aí, abraços.
Traduzindo
entre na pasta criada , e dê o comando sudo make install

$cd usb-modeswitch(aperte tab)   depois

$sudo make install   

depois

$sudo nautilus

depois é só seguir o restante
Citar
na pasta criada existe um arquivo chamado  40-usb_modeswitch.rules copie este arquivo para o endereço abaixo :

/etc/udev/40-usb_modeswitch.rules.


Quando eu chegar em casa vou testar esta dica, mas se você puder testar e postar se deu certo ou não será ótimo.





Offline dtomadon

  • Usuário Ubuntu
  • *
  • Mensagens: 591
  • Fatec SCS,Segurança da Informação, BackTrack5
    • Ver perfil
    • Computação Forense e suas Leis
Re: Internet 3G não conecta
« Resposta #34 Online: 01 de Maio de 2010, 22:15 »
O problema não é com o firefox, esses pacotes que a vivo faz traz algumas incompatibilidades, entre elas a versão do ubuntu se não estiver errado os pacotes servem até a versão 9.04, depois dá pau, minha sugestão e que vc baixe na sua pasta home deste link:

http://www.draisberghof.de/usb_modeswitch/usb-modeswitch-1.1.2.tar.bz2

na sua pasta home descompacte o arquivo , entre na pasta criada , e dê o comando sudo make install , depois como sudo ainda abra seu gerenciador de arquivos , na pasta criada existe um arquivo chamado  40-usb_modeswitch.rules copie este arquivo para o endereço abaixo :

/etc/udev/40-usb_modeswitch.rules.

Acredito que resolverá seu problema,após este procedimento irá abrir o gerenciador de conexões do ubuntu, o network manage aí e só configurar e navegar. se não resolver posta aí, abraços.
Traduzindo
entre na pasta criada , e dê o comando sudo make install

$cd usb-modeswitch(aperte tab)   depois

$sudo make install   

depois

$sudo nautilus

depois é só seguir o restante
Citar
na pasta criada existe um arquivo chamado  40-usb_modeswitch.rules copie este arquivo para o endereço abaixo :

/etc/udev/40-usb_modeswitch.rules.


Quando eu chegar em casa vou testar esta dica, mas se você puder testar e postar se deu certo ou não será ótimo.





Valeu pela tradução,rsrs.
BacKTrack5 64 bits com Vídeo SIS

kernel omnislash 1.4.4 64 bits , Que venha o 5º Semestre !!!

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Internet 3G não conecta
« Resposta #35 Online: 01 de Maio de 2010, 22:40 »
Pra confirmar se o problema é de DNS ou ainda da conexão, conecte o 3g e execute os comandos abaixo:

ifconfig

Deve aparecer uma interface ativa, que pode ser "ppp0" ou "usb0". Anote o endereço dessa interface.

ping <endereço anotado>

ping 8.8.8.8

ping www.google.com
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Andreson Goveia

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.985
  • Kubuntu 14.10
    • Ver perfil
Re: Internet 3G não conecta
« Resposta #36 Online: 02 de Maio de 2010, 05:57 »
Tudo bem, fica tranquilo!!!

Alguem do fórum sabe a solução desse problema do firefox que não conecta através da net 3g?

Depois de conectado vá até o terminal e digite
$sudo firefox

Vai abrir o navegador e conseguirá navegar.

Só não entendo porque tem que ser root para poder navegar (Dai explica-se porque o synaptic funciona).
Estou tentando encontrar uma solução, mas a provisória é abrir o navegador como root mesmo (Estou escrevendo pelo chromium aberto pelo terminal ($sudo chromium-browser) e está funcionando normal testei o firefox e tambem funciona normal mas só assim.

Offline lucivando

  • Usuário Ubuntu
  • *
  • Mensagens: 62
    • Ver perfil
Re: Internet 3G não conecta
« Resposta #37 Online: 02 de Maio de 2010, 10:05 »
Bom, vejam o que ficou. copiei o arquivo para home/lucivando e descompactei, entrei na pasta criada e digitei sudo make install, a resposta foi a seguinte:

gcc -o usb_modeswitch usb_modeswitch.c -Wall -l usb
usb_modeswitch.c:66:17: error: usb.h: Arquivo ou diretório não encontrado
usb_modeswitch.c: In function ‘main’:
usb_modeswitch.c:359: warning: implicit declaration of function ‘usb_init’
usb_modeswitch.c:362: warning: implicit declaration of function ‘usb_set_debug’
usb_modeswitch.c:364: warning: implicit declaration of function ‘usb_find_busses’
usb_modeswitch.c:365: warning: implicit declaration of function ‘usb_find_devices’
usb_modeswitch.c:408: error: dereferencing pointer to incomplete type
usb_modeswitch.c:409: error: dereferencing pointer to incomplete type
usb_modeswitch.c:411: warning: implicit declaration of function ‘usb_open’
usb_modeswitch.c:411: warning: assignment makes pointer from integer without a cast
usb_modeswitch.c:418: error: dereferencing pointer to incomplete type
usb_modeswitch.c:420: error: dereferencing pointer to incomplete type
usb_modeswitch.c:422: error: dereferencing pointer to incomplete type
usb_modeswitch.c:570: warning: implicit declaration of function ‘usb_close’
usb_modeswitch.c: In function ‘deviceDescription’:
usb_modeswitch.c:584: error: dereferencing pointer to incomplete type
usb_modeswitch.c:585: warning: implicit declaration of function ‘usb_get_string_simple’
usb_modeswitch.c:585: error: dereferencing pointer to incomplete type
usb_modeswitch.c:594: error: dereferencing pointer to incomplete type
usb_modeswitch.c:595: error: dereferencing pointer to incomplete type
usb_modeswitch.c:604: error: dereferencing pointer to incomplete type
usb_modeswitch.c:605: error: dereferencing pointer to incomplete type
usb_modeswitch.c: In function ‘deviceInquire’:
usb_modeswitch.c:637: warning: implicit declaration of function ‘usb_claim_interface’
usb_modeswitch.c:642: warning: implicit declaration of function ‘usb_clear_halt’
usb_modeswitch.c:644: warning: implicit declaration of function ‘usb_bulk_write’
usb_modeswitch.c:650: warning: implicit declaration of function ‘usb_bulk_read’
usb_modeswitch.c:677: warning: implicit declaration of function ‘usb_release_interface’
usb_modeswitch.c: In function ‘resetUSB’:
usb_modeswitch.c:693: warning: implicit declaration of function ‘sleep’
usb_modeswitch.c:695: warning: implicit declaration of function ‘usb_reset’
usb_modeswitch.c: In function ‘switchConfiguration’:
usb_modeswitch.c:761: warning: implicit declaration of function ‘usb_set_configuration’
usb_modeswitch.c: In function ‘switchAltSetting’:
usb_modeswitch.c:777: warning: implicit declaration of function ‘usb_set_altinterface’
usb_modeswitch.c: In function ‘switchHuaweiMode’:
usb_modeswitch.c:794: warning: implicit declaration of function ‘usb_control_msg’
usb_modeswitch.c:794: error: ‘USB_TYPE_STANDARD’ undeclared (first use in this function)
usb_modeswitch.c:794: error: (Each undeclared identifier is reported only once
usb_modeswitch.c:794: error: for each function it appears in.)
usb_modeswitch.c:794: error: ‘USB_RECIP_DEVICE’ undeclared (first use in this function)
usb_modeswitch.c:794: error: ‘USB_REQ_SET_FEATURE’ undeclared (first use in this function)
usb_modeswitch.c: In function ‘switchSonyMode’:
usb_modeswitch.c:880: warning: assignment makes pointer from integer without a cast
usb_modeswitch.c: In function ‘detachDriver’:
usb_modeswitch.c:914: warning: implicit declaration of function ‘usb_get_driver_np’
usb_modeswitch.c:930: warning: implicit declaration of function ‘usb_detach_kernel_driver_np’
usb_modeswitch.c: In function ‘checkSuccess’:
usb_modeswitch.c:1020: warning: assignment makes pointer from integer without a cast
usb_modeswitch.c:1026: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1026: error: dereferencing pointer to incomplete type
usb_modeswitch.c: In function ‘search_devices’:
usb_modeswitch.c:1134: warning: implicit declaration of function ‘usb_get_busses’
usb_modeswitch.c:1134: warning: assignment makes pointer from integer without a cast
usb_modeswitch.c:1134: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1136: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1136: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1138: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1138: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1139: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1160: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1167: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1167: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1169: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1179: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1188: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1190: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1193: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1194: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1220: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1220: error: dereferencing pointer to incomplete type
usb_modeswitch.c: In function ‘find_first_bulk_output_endpoint’:
usb_modeswitch.c:1242: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1245: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1246: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1247: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1247: error: ‘USB_ENDPOINT_TYPE_MASK’ undeclared (first use in this function)
usb_modeswitch.c:1247: error: ‘USB_ENDPOINT_TYPE_BULK’ undeclared (first use in this function)
usb_modeswitch.c:1248: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1248: error: ‘USB_ENDPOINT_DIR_MASK’ undeclared (first use in this function)
usb_modeswitch.c:1249: error: dereferencing pointer to incomplete type
usb_modeswitch.c: In function ‘find_first_bulk_input_endpoint’:
usb_modeswitch.c:1260: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1263: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1264: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1265: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1265: error: ‘USB_ENDPOINT_TYPE_MASK’ undeclared (first use in this function)
usb_modeswitch.c:1265: error: ‘USB_ENDPOINT_TYPE_BULK’ undeclared (first use in this function)
usb_modeswitch.c:1266: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1266: error: ‘USB_ENDPOINT_DIR_MASK’ undeclared (first use in this function)
usb_modeswitch.c:1267: error: dereferencing pointer to incomplete type
make: ** [usb_modeswitch] Erro 1
lucivando@lucivando-desktop:~/usb-modeswitch-1.1.2$ 

Depois tentei com sudo nautilus e a resposta foi a seguinte:

Sudo nautilus

Initializing nautilus-gdu extension
Nautilus-Share-Message: Called "net usershare info" but it failed: "compartilhamento de rede de usuário" retornou erro 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error Arquivo ou diretório não encontrado
Please ask your system administrator to enable user sharing.


aí abriu o navegador de arquivos,mostrando a pasta desktop e outra pasta.

quanto ao ifconfig, anotei o endereço seguinte: 187.90.4.100
depois digitei ping 187.90.4.100 e uma das várias respostas foram:

64 bytes from 187.90.4.100 icmp_seq=145 ttl=64 0,043ms

E agora, o que faço?O que pode estar acontecendo?

Offline lucivando

  • Usuário Ubuntu
  • *
  • Mensagens: 62
    • Ver perfil
Re: Internet 3G não conecta
« Resposta #38 Online: 02 de Maio de 2010, 10:07 »
Ah, eu havia esquecendo. Na pasta criada não existe o arquivo 40-usbmodeswitch.rules. Existem outros arquivos usbmodeswitch.

Offline jannke

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re: Internet 3G não conecta
« Resposta #39 Online: 03 de Maio de 2010, 20:59 »
galera.... blz.... sou iniciante no mundo linux... mas ja me viroooo

me ferei bonito ate descobrir a soluçao para tal... mas apos conta-la a vcs... irao ficar se batendo, dizendo... por que nao pensei nisto antes!!!


é mole mole.... é so instalar o ubuntu com o modem 3g conectado... digo istalar o sistema com o modem plugado...

o mesmo sera reconhecido como modem e em seguida só sera necessario criar uma conexao de banda larga movel com seu perfil de operada...

e pronto... viva ao linux

abraços...

Offline RuiVelocci

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: Internet 3G não conecta
« Resposta #40 Online: 07 de Maio de 2010, 10:19 »
galera.... blz.... sou iniciante no mundo linux... mas ja me viroooo

me ferei bonito ate descobrir a soluçao para tal... mas apos conta-la a vcs... irao ficar se batendo, dizendo... por que nao pensei nisto antes!!!


é mole mole.... é so instalar o ubuntu com o modem 3g conectado... digo istalar o sistema com o modem plugado...

o mesmo sera reconhecido como modem e em seguida só sera necessario criar uma conexao de banda larga movel com seu perfil de operada...

e pronto... viva ao linux

abraços...

Olá.
sua dica funcionou comigo, porém depois que reinicei meu pc ele sumiu de novo.. ai formatei e instalei de novo, e funcionou, tirei o modem e coloquei de volta não apareceu mais.

O que podemos fazer?

abraços

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Internet 3G não conecta
« Resposta #41 Online: 07 de Maio de 2010, 10:45 »
Tem certeza de que não é só o ícone que não aparece?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline RuiVelocci

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: Internet 3G não conecta
« Resposta #42 Online: 07 de Maio de 2010, 11:00 »
Tem certeza de que não é só o ícone que não aparece?

Tenho sim. Acabei de formatar o pc de novo, e apareceu ai reinicei e sumiu de novo.
Estou tenttando outras dicas..mas parece que não vai.


Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Internet 3G não conecta
« Resposta #43 Online: 07 de Maio de 2010, 11:13 »
Não vai ser formatando o PC que vc vai resolver esse problema.

O Ubuntu tem registro (log) de quase tudo que acontece. Acompanhando os logs, eu quase sempre consigo resolver meus problemas.

Você também pode fazer isso; por exemplo, se você postar as 10 últimas linhas da saída do comando "dmesg", logo após plugar o modem, ajuda bastante.

Se puder também postar as 20 últimas linhas do arquivo "/var/log/syslog" após plugar o modem, ajuda mais ainda.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D