Autor Tópico: Microboard Ultimate Black, Ubuntu 9.10 e placa de som Realtek  (Lida 7424 vezes)

Offline ghspt

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Microboard Ultimate Black, Ubuntu 9.10 e placa de som Realtek
« Online: 10 de Fevereiro de 2010, 16:43 »
Estou tendo problemas com relação ao som no meu MUB no Ubuntu 9.10
O som sai nos speakers sem problema, mas quando coloco o heaphone eles continuam tocando.
Já procurei muita coisa na internet para tentar resolver, especialmente com relação a instalação de driver da Realtek, headphone jack sense, configuração do alsa, mas tudo sem resolver o problema.
O que eu consegui fazer foi desabilitar o som dos speakers, e ficar só com o do headphone, mas dá uma trabalheira medonha. Já mostrei para o pidgin, usuário deste forum e também possuidor de um MUB,  o procedimento, e também funcionou na máquina dele.
Configurando o alsa-base.conf (sudo gedit /etc/modprobe.d/alsa-base.conf), acrescentei as seguintes linhas no final

Código: [Selecionar]
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=3stack-6ch-dig
options snd-hda-intel enable_msi=1

Salvei e reiniciei a máquina. Para quem não usa speakers e prefere os headphones é uma maravilha. Acontece que não resolveu a questão do sensor do headphone, nem consegui alternar entre speakers e headphones sem reiniciar a máquina.

Todos estão com o mesmo problema? Alguém já resolveu?

Offline pigdin

  • Usuário Ubuntu
  • *
  • Mensagens: 723
  • Terra - Brasill - SP-Capital
    • Ver perfil
Re: Microboard Ultimate Black, Ubuntu 9.10 e placa de som Realtek
« Resposta #1 Online: 10 de MAR?O de 2010, 11:27 »
Estou tendo problemas com relação ao som no meu MUB no Ubuntu 9.10
O som sai nos speakers sem problema, mas quando coloco o heaphone eles continuam tocando.
Já procurei muita coisa na internet para tentar resolver, especialmente com relação a instalação de driver da Realtek, headphone jack sense, configuração do alsa, mas tudo sem resolver o problema.
O que eu consegui fazer foi desabilitar o som dos speakers, e ficar só com o do headphone, mas dá uma trabalheira medonha. Já mostrei para o pidgin, usuário deste forum e também possuidor de um MUB,  o procedimento, e também funcionou na máquina dele.
Configurando o alsa-base.conf (sudo gedit /etc/modprobe.d/alsa-base.conf), acrescentei as seguintes linhas no final

Código: [Selecionar]
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=3stack-6ch-dig
options snd-hda-intel enable_msi=1

Salvei e reiniciei a máquina. Para quem não usa speakers e prefere os headphones é uma maravilha. Acontece que não resolveu a questão do sensor do headphone, nem consegui alternar entre speakers e headphones sem reiniciar a máquina.

Todos estão com o mesmo problema? Alguém já resolveu?


Parece que a solução é essa ainda não testei:

" Re: Headphone jack não mudo falantes após atualizar para 9,10 Cármica

--------------------------------------------------------------------------------

i have a gateway laptop (m6809m) with a intel stac9205 and i solved it with this: Tenho um notebook gateway (m6809m) com um STAC9205 Intel e eu resolvi com este:

1.- read the instructions to get the the last version of the alsa project http://ubuntuforums.org/showthread.php?t=1046137 1 .- leia as instruções para obter a versão modificada do projeto alsa http://ubuntuforums.org/showthread.php?t=1046137

2.- download the script and run it to get the last alsa snapshot 2 .- baixar o script e executá-lo para obter o alsa último instantâneo

3.- edit the alsa.conf file with sudo properties like this on the terminal: 3 .- editar o arquivo alsa.conf com propriedades sudo como esta no terminal:
sudo gedit /etc/modprobe.d/alsa-base.conf sudo gedit / etc / modprobe.d / alsa-base.conf

4.- at the end of the file add this: 4 .- No final do arquivo de acrescentar o seguinte:

options snd-hda-intel model=eapd probe_mask=1 position_fix=1 options snd-hda-intel model = probe_mask EAPD position_fix = 1 = 1

5.- restart your laptop 5 .- reiniciar o seu computador portátil

the trick is "model= eapd" (e)xternal (a)udio (p)ower (d)own O truque é "model = EAPD" (e) EXTERNA (um udio) (p) ower (d) próprio
i hope it work for you all... Espero que funcione para todos vocês ...  "
 
http://translate.google.com.br/translate?hl=pt-BR&sl=en&u=http://joeb454.ubuntuforums.org/showthread.php%3Ft%3D1315138&ei=F6qXS9LLOI60tges6KHkAQ&sa=X&oi=translate&ct=result&resnum=9&ved=0CC4Q7gEwCDge&prev=/search%3Fq%3Dubuntu%2Balc662%2Bheadphone%26start%3D30%26hl%3Dpt-BR%26lr%3D%26sa%3DN

http://joeb454.ubuntuforums.org/showthread.php?t=1315138


EDItado

Para mim não funcionou

Fiquei com som somente nos fones de ouvido

meu alsamixer está assim

master com volume orientação LL
speaker com volume orientação mm
pcm com volume
front com volume orientação LL



« Última modificação: 10 de MAR?O de 2010, 12:07 por pigdin »
Desk: Phenom X3 2GB DDR II - Win 7 / Ubuntu 10.04 64 Bits
Note MUB: Core2Duo 4GB - Win7 / Ubuntu 10.04 / Bodhi Linux.
@alexpigdin

Offline ghspt

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Re: Microboard Ultimate Black, Ubuntu 9.10 e placa de som Realtek
« Resposta #2 Online: 17 de MAR?O de 2010, 10:31 »
pidgin... acho que consegui... foi uma treta grande...
entra no alsamixer e zera o volume apenas do speaker, vê se dá certo.
se não der certo, baixa o driver da realtek, para o ubuntu, e segue as instruções que tem lá...
depois tenta zerar o volume apenas do speaker.
Aí na verdade não resolve o problema do jack sense, mas pelo menos dá para você ficar alternando entre speaker e headphone sem choro.

Offline pigdin

  • Usuário Ubuntu
  • *
  • Mensagens: 723
  • Terra - Brasill - SP-Capital
    • Ver perfil
Re: Microboard Ultimate Black, Ubuntu 9.10 e placa de som Realtek
« Resposta #3 Online: 17 de MAR?O de 2010, 10:55 »
pidgin... acho que consegui... foi uma treta grande...
entra no alsamixer e zera o volume apenas do speaker, vê se dá certo.
se não der certo, baixa o driver da realtek, para o ubuntu, e segue as instruções que tem lá...
depois tenta zerar o volume apenas do speaker.
Aí na verdade não resolve o problema do jack sense, mas pelo menos dá para você ficar alternando entre speaker e headphone sem choro.


Beleza vou ver, apesar que agora estou só com o 10.04(lucid alfa).

Abraços
Desk: Phenom X3 2GB DDR II - Win 7 / Ubuntu 10.04 64 Bits
Note MUB: Core2Duo 4GB - Win7 / Ubuntu 10.04 / Bodhi Linux.
@alexpigdin

Offline ghspt

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Re: Microboard Ultimate Black, Ubuntu 9.10 e placa de som Realtek
« Resposta #4 Online: 17 de MAR?O de 2010, 17:28 »
poxa cara, nem soube que tinham lançado a versão nova
me conta aí a experiência, tá rodando tudo lisinho?
abs.

Offline pigdin

  • Usuário Ubuntu
  • *
  • Mensagens: 723
  • Terra - Brasill - SP-Capital
    • Ver perfil
Re: Microboard Ultimate Black, Ubuntu 9.10 e placa de som Realtek
« Resposta #5 Online: 18 de MAR?O de 2010, 22:37 »
poxa cara, nem soube que tinham lançado a versão nova
me conta aí a experiência, tá rodando tudo lisinho?
abs.

Não tem muitos bugs não, mas ainda existem.

Caso queira acompanhar, tem um tópico só para isso:

http://ubuntuforum-br.org/index.php/topic,60512.0/topicseen.html

abraços.
Desk: Phenom X3 2GB DDR II - Win 7 / Ubuntu 10.04 64 Bits
Note MUB: Core2Duo 4GB - Win7 / Ubuntu 10.04 / Bodhi Linux.
@alexpigdin