Autor Tópico: (RESOLVIDO) Ubuntu gutsy 7.10  (Lida 4453 vezes)

Offline laercio.camilo

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
(RESOLVIDO) Ubuntu gutsy 7.10
« Online: 10 de MAR?O de 2010, 09:56 »
Preciso instalar uma impressora hp1005 no ubuntu versao citada no assunto porem quando tenho fazer os procedimentos de instalacao mostra um erro:
Dependencies...
     ***
      *** Error: /usr/include/stdio.h is not installed!
      ***
      *** Install Software Development (gcc) package
      *** for Ubuntu: sudo apt-get install build-essential
      ***
make: *** [all-test] Error 1
 Quando tento instalar o que pede da erro :
apt-get install build-essential
Lendo lista de pacotes... Pronto
Construindo árvore de dependências
Reading state information... Pronto
E: Impossível achar pacote build-essential
Após tento fazer um update novamente erro nos arquivos da source.list

Falha ao buscar http://br.archive.ubuntu.com/ubuntu/dists/gutsy/main/binary-i386/Packages.gz  404 Not Found [IP: 200.17.202.1 80]
Falha ao buscar http://br.archive.ubuntu.com/ubuntu/dists/gutsy/restricted/binary-i386/Packages.gz  404 Not Found [IP: 200.17.202.1 80]
Falha ao buscar http://br.archive.ubuntu.com/ubuntu/dists/gutsy/main/source/Sources.gz  404 Not Found [IP: 200.17.202.1 80]
Falha ao buscar http://br.archive.ubuntu.com/ubuntu/dists/gutsy/restricted/source/Sources.gz  404 Not Found [IP: 200.17.202.1 80]
Falha ao buscar http://br.archive.ubuntu.com/ubuntu/dists/gutsy/universe/binary-i386/Packages.gz  404 Not Found [IP: 200.17.202.1 80]
 Esses sao alguns dos erros, entao gostaria de uma informacao de como devo proceder.

Obrigado.
« Última modificação: 11 de MAR?O de 2010, 17:35 por laercio.camilo »

Offline platao

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 5.021
    • Ver perfil
Re: Ubuntu gutsy 7.10
« Resposta #1 Online: 10 de MAR?O de 2010, 10:39 »
Ola companheiro laercio.camilo, o Ubuntu 7.10 nao tem mais suporte a atualizações de segurança e de programas vc pode instalar um programa recente mas pode haver problemas de dependencias nao resolvidas. Pode haver algum hardware que so funciona com versoes antigas entao aqui tem um tutorial para deixar o seu Gutsy em forma, mas primeiro vc vai ter que mudar a sua source-list o ubuntu instalado por padrao, nao vai conseguir fazer update dos pacotes pois os pacotes para distro sem suporte mudam para outro endereço os "old releases".

Primeiro entre com o comando;

sudo  gedit   /etc/apt/sources.list

Acrescente um # na frente de todas as linhas para essas nao serem mais usadas, e no final acrescente essas;

deb http://old-releases.ubuntu.com/ubuntu/  gutsy main restricted universe multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ gutsy main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ gutsy-updates main restricted universe multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ gutsy-updates main restricted universe multiverse

Depois de acrescentado os repositorios recarregue;

sudo apt-get update

Agora siga o tutorial;

http://hamacker.wordpress.com/ubuntu-perfeito-versao-710/

No caso da sua impressora se ela for nova provavelmente nao vai encontrar o driver correto para ela pois o pacote hplip do Gutsy se nao me enganar foi atualizado ate março de 2009 que e quando parou de ter suporte, vc pode fazer o download do pacote hplip no site da HP e somente acrescentar o arquivo ppd da impressora nova sem desinstalar o driver hplip do gutsy(que deve ser 2.7.7 se nao me engano e o recente deve ser 3.7) ou entao desistalar o hplip do gutsy e compilar com o .tar do site, ou entao forçar a instalação do pacote hplip do hardy 8.04.1 que tbm da certo.

Em resumo se puder fazer o download da versao mais nova do Ubuntu seria preferivel.
« Última modificação: 10 de MAR?O de 2010, 11:10 por platao »
\\\\\\\\Apostilas Dicas e Guias do Ubuntu\\\\\\\\\> http://ubuntuforum-br.org/index.php/topic,79368.msg440997.html#msg440997