Autor Tópico: Resolvido Firefox 3.6 não reconhece java no ubuntu 9.10  (Lida 27625 vezes)

Offline novogaroto

  • Usuário Ubuntu
  • *
  • Mensagens: 55
    • Ver perfil
Resolvido Firefox 3.6 não reconhece java no ubuntu 9.10
« Online: 23 de Janeiro de 2010, 23:28 »
 pessoal não tô conseguindo rodar o java no meu firefox 3.6 instalado no ubuntu 9.10, já instalei todos plugins do java que
está no sinaptics e no gerenciador de complemetos do firefox não aparece nada de java o que pode ser?
                O navegador está com uma performance excelente mais tá faltando o plugin do java pra ficar completo.  ah e na central
de programas do ubuntu consta que está instalado o java e o plugin java para navegador e o no firefox por enquanto nada de java. ;D
« Última modificação: 01 de Fevereiro de 2010, 15:45 por novogaroto »

Offline Bluray

  • Usuário Ubuntu
  • *
  • Mensagens: 75
    • Ver perfil
Re: Firefox 3.6 não reconhece java no ubuntu 9.10
« Resposta #1 Online: 24 de Janeiro de 2010, 08:14 »
boas eu tenho o mesmo problema

Já tinha criado tópico sobre o mesmo assunto , gostaria de pedir se alguns dos moderadores possam juntar este post a quele que inicialmente criei

http://ubuntuforum-pt.org/index.php/topic,61929.0.html

 
@CMatomic

Offline Alyscom

  • Usuário Ubuntu
  • *
  • Mensagens: 774
  • Apenas me dê o feijão!
    • Ver perfil
Re: Firefox 3.6 não reconhece java no ubuntu 9.10
« Resposta #2 Online: 24 de Janeiro de 2010, 08:49 »
Olá tente isso e vê se dá certo!! :)
Primeiro vamos baixar o sun-java6-plugin
No terminal digite:
Código: [Selecionar]
sudo apt-get install sun-java6-plugin
Execute o seguinte comando para criar o elo que faltava (copia e cola a linha inteira em um terminal e pressione enter):
Código: [Selecionar]
sudo update-alternatives --install /usr/lib/mozilla/plugins/libjavaplugin.so mozilla-javaplugin.so /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so 50Isto irá colocar o link apropriado para o plugin java em /usr/lib/mozilla/plugins.


[]'s


Alyscom
O álcool é o photoshop da vida real
 

Offline novogaroto

  • Usuário Ubuntu
  • *
  • Mensagens: 55
    • Ver perfil
Re: Firefox 3.6 não reconhece java no ubuntu 9.10
« Resposta #3 Online: 24 de Janeiro de 2010, 12:59 »
boas eu tenho o mesmo problema

Já tinha criado tópico sobre o mesmo assunto , gostaria de pedir se alguns dos moderadores possam juntar este post a quele que inicialmente criei

http://ubuntuforum-pt.org/index.php/topic,61929.0.html

 
pois  é bluray eu não tinha visto que vc tinha criado um post já sobre o assunto
    mas vamos tentar encontrar uma solução para esse problema pq o firefox é  o melhor navegador do mundo rsrsrsrs.

Offline novogaroto

  • Usuário Ubuntu
  • *
  • Mensagens: 55
    • Ver perfil
Re: Firefox 3.6 não reconhece java no ubuntu 9.10
« Resposta #4 Online: 24 de Janeiro de 2010, 13:06 »
Olá tente isso e vê se dá certo!! :)
Primeiro vamos baixar o sun-java6-plugin
No terminal digite:
Código: [Selecionar]
sudo apt-get install sun-java6-plugin
Execute o seguinte comando para criar o elo que faltava (copia e cola a linha inteira em um terminal e pressione enter):
Código: [Selecionar]
sudo update-alternatives --install /usr/lib/mozilla/plugins/libjavaplugin.so mozilla-javaplugin.so /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so 50Isto irá colocar o link apropriado para o plugin java em /usr/lib/mozilla/plugins.


[]'s


Alyscom
  Alyscom fiz o procedimento que vc descreveu mais continua a mesma coisa sem o java rodando no firefox.
   Dei uma tunada no firefox aqui que ficou uma bala,segui algumas dicas que vc passou nesse post aqui:http://ubuntuforum-pt.org/index.php?topic=58544.0
valeu!

Offline jcao

  • Usuário Ubuntu
  • *
  • Mensagens: 178
    • Ver perfil
Re: Firefox 3.6 não reconhece java no ubuntu 9.10
« Resposta #5 Online: 25 de Janeiro de 2010, 15:06 »
Olá pessoal, atualizei o firefox 3.5 para 3.6 pelo ubuntuzilla. Como faço para desinstalar o 3.5? Pelo synaptic só existe o 3.5.
Além disso o flash player não está funcionando no 3.6.
O Ubuntu é o 9.10.
Segui as instruções que estão no forum mas não estou conseguindo instalar o flash player.
Na aba aplicativos aparece o 3.5, como faço para tirá-lo de lá?
obrigado

Offline MarceloVilar

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Re: Firefox 3.6 não reconhece java no ubuntu 9.10
« Resposta #6 Online: 27 de Janeiro de 2010, 14:29 »
Descobri o problema :D

Tirado do meu blog: http://mistura.wordpress.com/2010/01/27/configurando-plugin-java-no-firefox-3-6-com-linux/

Após eu atualizar o meu firefox para a nova versão 3.6 notei que o plugin do java não estava funcionando, depois de várias tentativas para fazer o plugin funcionar e falharem, fui até meu amigo google buscar uma solução e chequem até esse link: http://support.mozilla.com/ta/forum/1/554389

Parece que existe uma "nova geração" de plugins do java, e a partir do Firefox 3.6 só funciona com esse plugin, antes o plugin ficava no caminho:
"Pasta_do_Java/plugin/i386/ns7/libjavaplugin_oji.so"
Agora o certo é:
"Pasta_do_Java/lib/i386/libnpjp2.so"

Para fazer o plugin funcionar, você deve ir até a pasta de plugins do firefox que normalmente é:
"/usr/lib/firefox/plugins"
e criar um link com o comando abaixo, substituindo o {Pasta_do_Java} pelo caminho da pasta do java:
ln -s "{Pasta_do_Java}/lib/i386/libnpjp2.so"
« Última modificação: 27 de Janeiro de 2010, 14:50 por MarceloVilar »

Offline novogaroto

  • Usuário Ubuntu
  • *
  • Mensagens: 55
    • Ver perfil
Re: Firefox 3.6 não reconhece java no ubuntu 9.10
« Resposta #7 Online: 30 de Janeiro de 2010, 21:27 »
não entendi como fazer para ir até a pasta e depois criar um link,como vc disse marcelo;  eu teria que ir até essa pasta de plugins
pelo terminal? é porque tem pouco tempo que começei a usar o ubuntu e tô aprendendo ainda e tô meio perdido
de como resolver esse problema como vc disse que conseguiu resolver e também queria muito resolver aqui.

eliseu_carvalho

  • Visitante
Re: Firefox 3.6 não reconhece java no ubuntu 9.10
« Resposta #8 Online: 30 de Janeiro de 2010, 21:37 »
Olá tente isso e vê se dá certo!! :)
Primeiro vamos baixar o sun-java6-plugin
No terminal digite:
Código: [Selecionar]
sudo apt-get install sun-java6-plugin
Execute o seguinte comando para criar o elo que faltava (copia e cola a linha inteira em um terminal e pressione enter):
Código: [Selecionar]
sudo update-alternatives --install /usr/lib/mozilla/plugins/libjavaplugin.so mozilla-javaplugin.so /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so 50Isto irá colocar o link apropriado para o plugin java em /usr/lib/mozilla/plugins.


[]'s


Alyscom
Eu também tive o mesmo problema de não ter Java no Firefox 3.6, mas graças a esse segundo comando aí tudo se resolveu  ;D

Offline novogaroto

  • Usuário Ubuntu
  • *
  • Mensagens: 55
    • Ver perfil
Re: Firefox 3.6 não reconhece java no ubuntu 9.10
« Resposta #9 Online: 30 de Janeiro de 2010, 21:44 »
Eliseu obrigado pela dica mas infelimente não deu certo,procurei nos complementos do firefox pelos plugins em uso
  e o java não aparece na lista. vc  poderia me explicar como faço para ir até uma pasta pelo terminal? aí eu iria tentar
a dica que o Marcelo passou logo acima.

Offline MarceloVilar

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Re: Firefox 3.6 não reconhece java no ubuntu 9.10
« Resposta #10 Online: 01 de Fevereiro de 2010, 08:25 »
Eliseu obrigado pela dica mas infelimente não deu certo,procurei nos complementos do firefox pelos plugins em uso
  e o java não aparece na lista. vc  poderia me explicar como faço para ir até uma pasta pelo terminal? aí eu iria tentar
a dica que o Marcelo passou logo acima.

Olá novogaroto, tente fazer os passos abaixo:

Vá em Aplicações depois acessórios e abra o o terminal, no terminal digite o comando abaixo:

Código: [Selecionar]
sudo apt-get install sun-java6-plugin
depois execute os dois comados abaixo:
Código: [Selecionar]
mkdir ~/.mozilla/plugins
ln -s /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so ~/.mozilla/plugins/libnpjp2.so

Depois disso, feche o Firefox e abra denovo, teste.

Se não der certo, execute o comando abaixo no terminal, depois copie o retorno do comando e cole aqui para eu ver:
Código: [Selecionar]
locate libnpjp2.so
« Última modificação: 01 de Fevereiro de 2010, 08:30 por MarceloVilar »

Offline novogaroto

  • Usuário Ubuntu
  • *
  • Mensagens: 55
    • Ver perfil
Re: Firefox 3.6 não reconhece java no ubuntu 9.10
« Resposta #11 Online: 01 de Fevereiro de 2010, 15:43 »
Marcelo valeu pela dica,o java agora tá funcionando beleza no firefox!
 graças a sua dica consegui resolver esse problema.obrigado amigo.  Agora vou editar o tópico e
colocar como resolvido.  Para as pessoas que estão com dificuldade em instalar o plugin do java
no novo firefox 3.6 no ubuntu 9.10,fica a dica aí do Marcelo que resolveu o problema aqui no meu computador.

Offline Mikael

  • Usuário Ubuntu
  • *
  • Mensagens: 370
    • Ver perfil
Re: Resolvido Firefox 3.6 não reconhece java no ubuntu 9.10
« Resposta #12 Online: 07 de Fevereiro de 2010, 20:20 »
Citar
Olá novogaroto, tente fazer os passos abaixo:

Vá em Aplicações depois acessórios e abra o o terminal, no terminal digite o comando abaixo:

Código:

sudo apt-get install sun-java6-plugin


depois execute os dois comados abaixo:
Código:

mkdir ~/.mozilla/plugins
ln -s /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so ~/.mozilla/plugins/libnpjp2.so


Depois disso, feche o Firefox e abra denovo, teste.

Se não der certo, execute o comando abaixo no terminal, depois copie o retorno do comando e cole aqui para eu ver:
Código:

locate libnpjp2.so
Essa dica me salvou vlw msmo!!!!!

Offline pietrfist

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re: Resolvido Firefox 3.6 não reconhece java no ubuntu 9.10
« Resposta #13 Online: 15 de MAR?O de 2010, 17:21 »
Olá,

Estou com o mesmo problema, o java não funciona no meu firefox 3.6. Já tentei os passos acima mas não consegui resolver. O erro que aparece no java é o seguinte:

Java Plug-in 1.6.0_15
Using JRE version 1.6.0_15-b03 Java HotSpot(TM) Server VM
User home directory = /home/policial

----------------------------------------------------
c:   clear console window
f:   finalize objects on finalization queue
g:   garbage collect
h:   display this help message
l:   dump classloader list
m:   print memory usage
o:   trigger logging
q:   hide console
r:   reload policy configuration
s:   dump system and deployment properties
t:   dump thread list
v:   dump thread stack
x:   clear classloader cache
0-5: set trace level to <n>
----------------------------------------------------

load: class Station not found.
java.lang.ClassNotFoundException: Station
   at sun.plugin2.applet.Applet2ClassLoader.findClass(Applet2ClassLoader.java:152)
   at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
   at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
   at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Plugin2ClassLoader.java:445)
   at sun.plugin2.applet.Plugin2Manager.createApplet(Plugin2Manager.java:2880)
   at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Plugin2Manager.java:1397)
   at java.lang.Thread.run(Thread.java:619)
Caused by: java.io.IOException: open HTTP connection failed:http://10.200.206.10/NXwebStation/Classes/Station.class
   at sun.plugin2.applet.Applet2ClassLoader.getBytes(Applet2ClassLoader.java:460)
   at sun.plugin2.applet.Applet2ClassLoader.access$000(Applet2ClassLoader.java:46)
   at sun.plugin2.applet.Applet2ClassLoader$1.run(Applet2ClassLoader.java:126)
   at java.security.AccessController.doPrivileged(Native Method)
   at sun.plugin2.applet.Applet2ClassLoader.findClass(Applet2ClassLoader.java:123)
   ... 6 more
Exception: java.lang.ClassNotFoundException: Station
load: class Station not found.
java.lang.ClassNotFoundException: Station
   at sun.plugin2.applet.Applet2ClassLoader.findClass(Applet2ClassLoader.java:152)
   at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
   at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
   at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Plugin2ClassLoader.java:445)
   at sun.plugin2.applet.Plugin2Manager.createApplet(Plugin2Manager.java:2880)
   at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Plugin2Manager.java:1397)
   at java.lang.Thread.run(Thread.java:619)
Caused by: java.io.IOException: open HTTP connection failed:http://10.200.206.10/NXwebStation/Classes/Station.class
   at sun.plugin2.applet.Applet2ClassLoader.getBytes(Applet2ClassLoader.java:460)
   at sun.plugin2.applet.Applet2ClassLoader.access$000(Applet2ClassLoader.java:46)
   at sun.plugin2.applet.Applet2ClassLoader$1.run(Applet2ClassLoader.java:126)
   at java.security.AccessController.doPrivileged(Native Method)
   at sun.plugin2.applet.Applet2ClassLoader.findClass(Applet2ClassLoader.java:123)
   ... 6 more
Exception: java.lang.ClassNotFoundException: Station
load: class Station not found.
java.lang.ClassNotFoundException: Station
   at sun.plugin2.applet.Applet2ClassLoader.findClass(Applet2ClassLoader.java:152)
   at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
   at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
   at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Plugin2ClassLoader.java:445)
   at sun.plugin2.applet.Plugin2Manager.createApplet(Plugin2Manager.java:2880)
   at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Plugin2Manager.java:1397)
   at java.lang.Thread.run(Thread.java:619)
Caused by: java.io.IOException: open HTTP connection failed:http://10.200.206.10/NXwebStation/Classes/Station.class
   at sun.plugin2.applet.Applet2ClassLoader.getBytes(Applet2ClassLoader.java:460)
   at sun.plugin2.applet.Applet2ClassLoader.access$000(Applet2ClassLoader.java:46)
   at sun.plugin2.applet.Applet2ClassLoader$1.run(Applet2ClassLoader.java:126)
   at java.security.AccessController.doPrivileged(Native Method)
   at sun.plugin2.applet.Applet2ClassLoader.findClass(Applet2ClassLoader.java:123)
   ... 6 more
Exception: java.lang.ClassNotFoundException: Station


Alguém sabe me ajudar?

Abraços

Offline groove

  • Usuário Ubuntu
  • *
  • Mensagens: 475
    • Ver perfil
Re: Firefox 3.6 não reconhece java no ubuntu 9.10
« Resposta #14 Online: 19 de MAR?O de 2010, 01:17 »
Eliseu obrigado pela dica mas infelimente não deu certo,procurei nos complementos do firefox pelos plugins em uso
  e o java não aparece na lista. vc  poderia me explicar como faço para ir até uma pasta pelo terminal? aí eu iria tentar
a dica que o Marcelo passou logo acima.

Olá novogaroto, tente fazer os passos abaixo:

Vá em Aplicações depois acessórios e abra o o terminal, no terminal digite o comando abaixo:

Código: [Selecionar]
sudo apt-get install sun-java6-plugin
depois execute os dois comados abaixo:
Código: [Selecionar]
mkdir ~/.mozilla/plugins
ln -s /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so ~/.mozilla/plugins/libnpjp2.so

Depois disso, feche o Firefox e abra denovo, teste.

Se não der certo, execute o comando abaixo no terminal, depois copie o retorno do comando e cole aqui para eu ver:
Código: [Selecionar]
locate libnpjp2.so
Marcelo, o problema de linkar desta forma é que todos os usuários deverão fazer...
Na versão 3.5 do FF a linkagem era feita no arquivo /usr/lib/xulrunner-addons/plugins/libnpjp2.so, agora deve ser feito linkando o arquivo /usr/lib/mozilla/plugins/libjavaplugin.so ?
Que confusão isso "/
Ubuntu 18.04