Autor Tópico: Driver Broadcom STA - Não carrega quando reinicia  (Lida 1944 vezes)

Offline Ubtuntero 2010

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Driver Broadcom STA - Não carrega quando reinicia
« Online: 02 de Julho de 2012, 12:46 »
Bom dia a todos!

Instalei o Ubuntu 12.04 no meu netbook HP DM1. Tudo reconhecido imediatamente, instalação perfeita!
Porém, a conexão wireless estava lenta: no cabo consigo entre 1.9 e 2.0 mega. No wireless estava conseguindo apenas 750k. Instalei o driver proprietário da Broadcom pelas Configurações do Sistema e a conexão foi para 1.8 mega. Mas quando reinicio a máquina a conexão volta a 750k, no máximo. Se reinstalo o Broadcom STA, consigo novamente os 1.8 mega. Mas sempre que reinicio a taxa diminui novamente.
Como posso resolver isso? procurei no forum e achei muita coisa sobre placas não reconhecidas, mas não é o caso, a placa funciona mas com conexão limitada.

Obrigado!

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.716
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Driver Broadcom STA - Não carrega quando reinicia
« Resposta #1 Online: 02 de Julho de 2012, 17:41 »
Bloqueie o driver nativo com o comando abaixo.

echo -e "#\nblacklist b43" | sudo tee /etc/modprobe.d/blacklist-b43.conf

Depois force a carga automática do módulo STA, com o comando abaixo [estou supondo que o nome do módulo STA é "wl"; corrija, se não for esse]:

echo "wl" | sudo tee -a /etc/modules

Esses comandos só devem ser executados uma vez.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Ubtuntero 2010

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: Driver Broadcom STA - Não carrega quando reinicia
« Resposta #2 Online: 02 de Julho de 2012, 22:46 »
oi, Zekkerj!

Obrigado por responder! Mas como faço para me certificar de que o módulo é o "wl"?

Obrigado!

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.716
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Driver Broadcom STA - Não carrega quando reinicia
« Resposta #3 Online: 03 de Julho de 2012, 00:03 »
A saída dos comandos abaixo pode confirmar.

sudo lshw -C network
nm-tool
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D