Autor Tópico: Script de Firewall não roda no boot.  (Lida 1760 vezes)

Offline NaotaKun

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Script de Firewall não roda no boot.
« Online: 30 de Novembro de 2009, 18:32 »
Olá pessoal!
Tenho um servidor que compartilha acesso internet já há uns 3 anos, rodando Ubuntu e funcionando muito bem.

Recentemente (ontem!) instalei do zero o Ubuntu Server 9.10 x86 e o meu script de firewall por algum motivo não mais roda no startup/shutdown da máquina. O script é o mesmo desde sempre e com as devidas melhorias e mudanças (mais melhorias).
Ele está devidamente mapeado nos runlevels mas não roda. Outros scripts de inicialização vão tranquilos (um que dá alerta sonoro no up/down dentre outros).

Se eu rodar o script manualmente, funciona tranquilamente.

Alguma idéia?
Grato!
Fabio

Offline jeflui

  • Usuário Ubuntu
  • *
  • Mensagens: 745
    • Ver perfil
Re: Script de Firewall não roda no boot.
« Resposta #1 Online: 30 de Novembro de 2009, 19:35 »
Colocou no /etc/init.d? Permissão de execução? rodou um update-rc.d nele?
Descreva o que foi feito que nos ajuda e você se ajuda :)

Offline NaotaKun

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re: Script de Firewall não roda no boot.
« Resposta #2 Online: 01 de Dezembro de 2009, 00:54 »
Então, exatamente tudo isso, nesta mesma ordem (/etc/init.d, permissão de execução e update-rc.d).
Tentei até não usar o update-rc.d, criando os links simbólicos "na mão" com fazia em outros linuxes, e não funciona.

Tem que ter alguma coisa em especial no script para ele rodar (agora, neste contexto do Ubuntu 9.10)?
É um script simples, com função de start/stop/restart que basicamente "pilota" o iptables e rotas - aprendi iptables do jeito difícil e agora não largo.

Obrigado!
Fabio ???