Autor Tópico: (Resolvido) Rede wireless não detectada após reinstalar o sistema  (Lida 7290 vezes)

Offline gritten2007

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
(Resolvido) Rede wireless não detectada após reinstalar o sistema
« Online: 26 de Novembro de 2010, 18:59 »
Olá,

Essa é a primeira vez que eu posto no forum, então desculpem se fizer algo digamos, errado.
Bem acabei de adquirir um netbook que já veio de fábrica com o Ubuntu 10.04. Mas como o HD estava mal particionado, resolvi fazer uma nova instalação e particionar do meu jeito. Mas infelizmente não funcionou a placa wireless (antes funcionava). Nem sequer a luz acende. Instalei o Wicd e diz que não há wireless. Baixei o ndiswrapper, bcmwl e nada. Procuro driver de terceiros, achando que talvez só esteja desabilitado e diz que não há driver no sistema. Alguém saberia dizer o que estaria faltando?

Obrigado.
« Última modificação: 10 de Dezembro de 2010, 23:42 por gritten2007 »

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Rede wireless não detectada após reinstalar o sistema
« Resposta #1 Online: 26 de Novembro de 2010, 19:19 »
Ola

Por favor informe ao forum qual sua placa de rede sem fio.

Para instalar o Ubuntu voce deve ter um cd do Sistema. Bootando pelo cd e escolhendo experimentar sem instalar, o wifi funciona?

[]'s

Offline gritten2007

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: Rede wireless não detectada após reinstalar o sistema
« Resposta #2 Online: 26 de Novembro de 2010, 20:27 »
Não tenho certeza da placa. Dando um lspdi aparece no fim "Realtek ... RTL8101E/RTL8102E PCI Express Fast Ethernet controller"
Não testei pelo CD, na verdade Pen Drive (o netbook não tem unidade ótica), vou tentar mais tarde. Depois eu posto aqui o que deu. Baixei tambem o pacote 3DSP mas ao tentar usar diz que deve ser atualizado e quando dá como retorno:

sudo wbdriverupdate.bin
3dspbus.ko 3dspbt.ko 3dspwlan.ko
download 3dspdriver.tar.gz, please wait ...
cd: Falha no acesso: %s 550 Failed to change directory. (/linux_wb_driver/2_6_35_22)
130: Download 3dspdriver.tar.gz fail

pode até não ser esse o problema, mas pelo menos é mais uma informação...

Offline gritten2007

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: Rede wireless não detectada após reinstalar o sistema
« Resposta #3 Online: 27 de Novembro de 2010, 01:44 »
É isso aí, gravei novamente a imagem no pendrive, carreguei o sistema e ainda assim não funcionou. O que irrita é que funcionava muito bem antes. Baixei inclusive um drive que deveria funcionar no site da Realtek e ainda não deu certo. vou tentar de novo.

Offline flavioml

  • Usuário Ubuntu
  • *
  • Mensagens: 121
    • Ver perfil
Re: Rede wireless não detectada após reinstalar o sistema
« Resposta #4 Online: 07 de Dezembro de 2010, 20:15 »
Por estes dias, um parente trouxe-me um notebook CCE, recém comprado, com o adaptador em questão, que funcionava de forma errática no satux do fabricante, sendo que na maior parte das vezes enxergando a rede e não conseguindo conectar. Para testar, rodei o live-cd do ubuntu 10.10 e conectou de prima, o que afastou a possibilidade de falha de hardware. Comparando os dois sistemas, o satux rodava (mal) através do ndiswrapper (kernel 2.6.33), enquanto o maverick trazia o módulo nativo do kernel (2.6.35).
Instalei então o ubuntu e oi sistema está rodando lindamente. Imagino que o 10.04 não traga ainda o suporte nativo no kernel, daí a sugestão para instalar a versão mais nova.
Flavio ML

Offline gritten2007

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
(Resolvido) Rede wireless não detectada após reinstalar o sistema
« Resposta #5 Online: 10 de Dezembro de 2010, 23:41 »
Acabei reinstalando o sistema, mas dessa vez tentei o Desktop Edition, e deixei baixar as atualizações durante a instalação (baixaram até os drivers da placa de vídeo). Depois segui a dica em
http://www.hugobarros.com.br/index.php/2010/11/instalando-drivers-3dsp-ubuntu-10-10-no-microboard/
e tudo funcionou, até o bluetooth. Estranho que eu acho que tinha tentado isso antes, mas tudo bem.
O único senão é que ao atualizar o Kernel, deixa de funcionar novamente, resolvi usando a versão antiga no login, mas acho que se executar o script novamente também funcione.
Fica aí a dica.

Offline rodrigo

  • Usuário Ubuntu
  • *
  • Mensagens: 57
    • Ver perfil
Re: (Resolvido) Rede wireless não detectada após reinstalar o sistema
« Resposta #6 Online: 03 de Janeiro de 2011, 16:42 »
oi pessoal já postei sobre esse assunto.

"desculpe o incomodo mas eu sou usuário novo do sistema Linux e tenho um problema se alguém puder me ajudar eu agradeceria, pois estou adorando o sistema me libertei do windows, graças a deus. não vou mais dar dinheiro para titio bill.

bem o meu problema e o seguinte:

instalei o Ubuntu 10.10 no meu notebook compaq presario v3015NR, infelizmente esta ocorrendo alguns problemas. o mais inconveniente e o drive wireless que não funciona. instalei o drive  broadcom sta e o sistema diz que o drive esta instalado, ativo e em uso só que a luz não fica azul, ou seja não funciona. outro problema e que quando o sistema pede a senha para autorizar alguma alteração no sistema fica pedindo autenticação, mas não autentica a janela não fecha vc tem que fechar a janela apertando o x encima da janela só que reconhece a autenticação e vc consegue instalar o programa.

ai irmão. formatei a maquina toda e instalei o Ubuntu novamente. deu um trabalho mas, com o tutorial que peguei na internet, consegui fazer o minimodem funcionar no Ubuntu e baixei todas as atualizações, instalei os drivers novamente tanto da placa de video, nvidia, quanto o wireless, broadcom sta, mas infelizmente continua com o mesmo problema, só que percebi que antes de ligar o notebook aparece uma mensagem de erro. a mensagem e esta:

"mod probe: fatal: could not load/lib/modules/2.6.35-24-generic/modules.dep: no such file or directory."

Eu estava pesquisando na internet e parece que esse 2.6.35 e justamente o que faz a placa wireless funcionar. como eu falei no começo sou novo com o Linux na internet o pessoal fala que tem como baixar e instalar esse 2.6.35 para o wireless funcionar, mas não encontrei nenhum tutorial que me ensine como fazer. e ai vc tem alguma sugestão parceiro.
alguém pode me ajudar.

Offline rodrigo

  • Usuário Ubuntu
  • *
  • Mensagens: 57
    • Ver perfil
Re: (Resolvido) Rede wireless não detectada após reinstalar o sistema
« Resposta #7 Online: 03 de Janeiro de 2011, 17:00 »
e ai parceiro resolvi o problema em um tópico do fórum. O andbecker ensina como resolver o problema.

Galera eu tenho que compartilhar a resposta para um problema incomodo, atualizei meu sistema para nova versão e minha rede wireless ficou off, mas funcionava perfeitamente na 10.04

então busquei em fóruns e achei os seguintes comandos:

Citar
sudo rfkill unblock all
rfkill list

Depois do segundo comando o terminal exibiu aqui:

Citar
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

dai eu dei o seguinte comando pra desbloquear a WAN:

Código:

sudo rfkill unblock 1


pronto, desbloqueou!!!

joguei 1 pq foi o que tava retornando como código de Wireless LAN, se na sua máquina retornar outro numero, basta substituir!


maluco eu fiz os comandos do cara e a wireless esta funcionando que e uma beleza.