Autor Tópico: Aceleração 3D  (Lida 6465 vezes)

flaviofifa

  • Visitante
Aceleração 3D
« Online: 11 de Abril de 2006, 07:26 »
Pessoal, instalei os drivers de video da minha placa Nvidia MX4000 64mb 8X, depois instalei o Cedega e quando faço o teste diz que eu não possuo aceleração 3D, alguem sabe como posso resolver isso?



Obrigado a todos pela atenção!!!

Flávio.   :arrow:

Offline Joseph

  • Usuário Ubuntu
  • *
  • Mensagens: 793
    • Ver perfil
Aceleração 3D
« Resposta #1 Online: 11 de Abril de 2006, 07:45 »
dê o comando num terminal:

cd /etc/X11

depois:

sudo gedit xorg.conf

vai abrir o editor de texto junto com o arquivo de configuraçao do X

depois procure a linha:

driver "nv" e troque por driver "nvidia"

reinicie o X ou o computador.

flaviofifa

  • Visitante
Aceleração 3D
« Resposta #2 Online: 11 de Abril de 2006, 10:30 »
Citação de: "Joseph"
dê o comando num terminal:

cd /etc/X11

depois:

sudo gedit xorg.conf

vai abrir o editor de texto junto com o arquivo de configuraçao do X

depois procure a linha:

driver "nv" e troque por driver "nvidia"

reinicie o X ou o computador.


Olá, eu instalei usando o tutorial que tem aqui e depois rodei este comando: sudo dpkg-reconfigure xserver-xorg

Ele refaz a configuração do vídeo, pedindo várias confirmações. Como tudo é autodetectado, você pode simplesmente ir pressionando <Enter> em todas. Preste atenção apenas para escolher "nvidia" na segunda pergunta, referente ao driver de vídeo que será usado.



Essa dica que você me deu é a mesma coisa dessa ou ela resolve isso?

Obrigado pela sua atenção!!!

Abraço.

Flávio.

 :wink:

Offline Joseph

  • Usuário Ubuntu
  • *
  • Mensagens: 793
    • Ver perfil
Aceleração 3D
« Resposta #3 Online: 11 de Abril de 2006, 12:46 »
basta apenas ver se o seu xorg.conf tah modificada a linha q falei.

flaviofifa

  • Visitante
Aceleração 3D
« Resposta #4 Online: 11 de Abril de 2006, 18:43 »
Citação de: "Joseph"
basta apenas ver se o seu xorg.conf tah modificada a linha q falei.


Esse aqui é o que tem no meu arquivo xorg.conf.

Citar
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
   FontPath   "/usr/share/X11/fonts/misc"
   FontPath   "/usr/share/X11/fonts/cyrillic"
   FontPath   "/usr/share/X11/fonts/100dpi/:unscaled"
   FontPath   "/usr/share/X11/fonts/75dpi/:unscaled"
   FontPath   "/usr/share/X11/fonts/Type1"
   FontPath   "/usr/share/X11/fonts/CID"
   FontPath   "/usr/share/X11/fonts/100dpi"
   FontPath   "/usr/share/X11/fonts/75dpi"
        # paths to defoma fonts
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
   Load   "GLcore"
   Load   "bitmap"
   Load   "ddc"
   Load   "dri"
   Load   "extmod"
   Load   "freetype"
   Load   "glx"
   Load   "int10"
   Load   "type1"
   Load   "vbe"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "abnt2"
   Option      "XkbLayout"   "br"
   Option      "XkbVariant"   "abnt2"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ImPS/2"
   Option      "Emulate3Buttons"   "true"
   Option      "ZAxisMapping"      "4 5"
EndSection

Section "Device"
   Identifier   "NVIDIA Corporation NV18 [GeForce4 MX 4000 AGP 8x]"
   Driver      "nvidia"
   BusID      "PCI:1:0:0"
EndSection

Section "Monitor"
   Identifier   "SyncMaster"
   Option      "DPMS"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "NVIDIA Corporation NV18 [GeForce4 MX 4000 AGP 8x]"
   Monitor      "SyncMaster"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1152x864" "1152x768" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1152x864" "1152x768" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1152x864" "1152x768" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1152x864" "1152x768" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1152x864" "1152x768" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1152x864" "1152x768" "1024x768" "800x600" "640x480"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
EndSection

Section "DRI"
   Mode   0666
EndSection


O que você acha que pode ser? Já que o que você falou ta certo...

Abraço.

Flávio.

Offline Agaporn

  • Usuário Ubuntu
  • *
  • Mensagens: 97
    • Ver perfil
Aceleração 3D
« Resposta #5 Online: 11 de Abril de 2006, 19:31 »
Aí chef blz?
Eu não recomendo muito vc se basear nos testes do Cedega, pois no meu caso, tenho uma Nvidia FX5200 com o driver instalado certinho, e também qdo faço este teste dá o mesmo resultado que o seu, só que pelo mesmo Cedega que acusou não ter aceleração 3D eu consigo emular sem nenhum problema NFSU2...

Mas de qualquer maneira para acabar com suas dúvidas, vc pode realizar o seguinte teste: no terminal digita

Código: [Selecionar]
glxinfo | grep rendering

Se vc tiver abilitado a aceleração 3D, a resposta será está

Código: [Selecionar]
direct rendering: Yes

Se quiser saber também a qtos anda a sua placa de vídeo pode fazer o seguinte teste: digite no terminal
Código: [Selecionar]
glxgears  isso vai mostrar o FPS da sua placa, viu pra efeito de comparação, posta seus resultados blz?

Ah, uma coisa interessante que também pode ser feita é, já que vc instalou o driver, a retirada da Linha  Load "dri" .

Não esqueça de reiniciar o Xserver

Grande Abraço

flaviofifa

  • Visitante
Aceleração 3D
« Resposta #6 Online: 11 de Abril de 2006, 20:28 »
Citação de: "Agaporn"
Aí chef blz?
Eu não recomendo muito vc se basear nos testes do Cedega, pois no meu caso, tenho uma Nvidia FX5200 com o driver instalado certinho, e também qdo faço este teste dá o mesmo resultado que o seu, só que pelo mesmo Cedega que acusou não ter aceleração 3D eu consigo emular sem nenhum problema NFSU2...

Mas de qualquer maneira para acabar com suas dúvidas, vc pode realizar o seguinte teste: no terminal digita

Código: [Selecionar]
glxinfo | grep rendering

Se vc tiver abilitado a aceleração 3D, a resposta será está

Código: [Selecionar]
direct rendering: Yes

Se quiser saber também a qtos anda a sua placa de vídeo pode fazer o seguinte teste: digite no terminal
Código: [Selecionar]
glxgears  isso vai mostrar o FPS da sua placa, viu pra efeito de comparação, posta seus resultados blz?

Ah, uma coisa interessante que também pode ser feita é, já que vc instalou o driver, a retirada da Linha  Load "dri" .

Não esqueça de reiniciar o Xserver

Grande Abraço


Blz cara!!!

Fiz o que você disse e deu tudo certo!!!!!!!!!!! Só não consegui ver os FPS, porque no glxgears as rodinhas ficam rodando e só saem se eu clicar em fechar... Mais valeu, agora estou mais tranquilo em relação a isso...

Abraço!!!

Flávio.    :)

Offline Joseph

  • Usuário Ubuntu
  • *
  • Mensagens: 793
    • Ver perfil
Aceleração 3D
« Resposta #7 Online: 11 de Abril de 2006, 22:17 »
comenta ou apaga as linhas glcore e dri, comenta com # antes da linha

flaviofifa

  • Visitante
Aceleração 3D
« Resposta #8 Online: 11 de Abril de 2006, 22:31 »
Citação de: "Joseph"
comenta ou apaga as linhas glcore e dri, comenta com # antes da linha


Mais tem um monte de linhas que tem esses nomes, é pra comentar todas?

Abraço.

Flávio.

 :roll:

Offline Joseph

  • Usuário Ubuntu
  • *
  • Mensagens: 793
    • Ver perfil
Aceleração 3D
« Resposta #9 Online: 11 de Abril de 2006, 23:35 »
Citação de: "flaviofifa"
Mais tem um monte de linhas que tem esses nomes, é pra comentar todas?

Abraço.

Flávio.

 :roll:


nao filho, soh na seçao module:

Citar

Section "Module"
#  Load    "GLcore"
    Load    "bitmap"
    Load    "ddc"
    Load    "dbe" (pode ateh incluir, mas se der erro, comenta com #)
#  Load    "dri"
    Load    "extmod"
    Load    "freetype"
    Load    "glx"
    Load    "int10"
    Load    "type1"
    Load    "vbe"
EndSection

Offline Joseph

  • Usuário Ubuntu
  • *
  • Mensagens: 793
    • Ver perfil
Aceleração 3D
« Resposta #10 Online: 14 de Abril de 2006, 11:14 »
pessoALL, pra quem nao sabe, o novo driver da nvidia, contido nos repositos do ubuntu (versao 1.0-8756), jah vem com o aplicativo "nvidia-settings".

ALT + F2 = nvidia-settings