Autor Tópico: Xubuntu perde resolução ao reiniciar  (Lida 9035 vezes)

Offline Denis Flosi

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
Xubuntu perde resolução ao reiniciar
« Online: 09 de Junho de 2009, 13:01 »
Boa tarde Pessoal,

Após a instalação meu Xubuntu ficou automaticamente com a resolução de 1024x768, porém preciso que ele fique com 800x600. Acessei o menu Aplicações -> Configurações -> Tela e alterei para a resolução que preciso, e ela foi alterada sem nenhum problema. Porém as reiniciar o computador e resolução volta para 1024x768.

Como faço para setar a resolução 800x600 como default?
Segue abaixo meu xorg.conf:

-----xorg.conf-----

Section "Device"
        Identifier      "Configured Video Device"
EndSection

Section "Monitor"
        Identifier      "Configured Monitor"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Monitor         "Configured Monitor"
        Device          "Configured Video Device"
EndSection

-------------------

Abraços.

Offline gatohumano

  • Usuário Ubuntu
  • *
  • Mensagens: 87
    • Ver perfil
Re: Xubuntu perde resolução ao reiniciar
« Resposta #1 Online: 11 de Junho de 2009, 21:46 »
Comigo acontece exactamente o mesmo,estou a usar o xubuntu 9.04 64bits,que grafica e drivers estas a usar?

Offline Gunfree

  • Usuário Ubuntu
  • *
  • Mensagens: 208
    • Ver perfil
Re: Xubuntu perde resolução ao reiniciar
« Resposta #2 Online: 11 de Junho de 2009, 22:31 »
Denis, faça assim:

Código: [Selecionar]
Section "Device"
        Identifier      "Configured Video Device"
EndSection

Section "Monitor"
        Identifier      "Configured Monitor"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Monitor         "Configured Monitor"
        Device          "Configured Video Device"
                SubSection "Display"
        Depth 16
        Modes "800x600"
        EndSubSection
EndSection

Caso ache que o depth ficou abaixo do esperado, aumente para 24.

[]'s
Linux Registered User: #491793

Offline gatohumano

  • Usuário Ubuntu
  • *
  • Mensagens: 87
    • Ver perfil
Re: Xubuntu perde resolução ao reiniciar
« Resposta #3 Online: 11 de Junho de 2009, 22:57 »
Aqui resulta mas só se essa resolução for uma das opções disponiveis para setar,se eu personalizar uma resolução setar e depois reeniciar não fica fixa,volta a 1024x768,sera que podiam dar uma ajudinha?aqui vai o meu xorg:

Section "Device"
   Identifier   "Configured Video Device"
EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
# 1200x900 @ 76.00 Hz (GTF) hsync: 71.44 kHz; pclk: 115.45 MHz
Modeline "1200x900_76.00" 115.45 1200 1280 1408 1616 900 901 904 940 -HSync +Vsync
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Configured Monitor"
   Device      "Configured Video Device"
                SubSection "Display"
              Depth      24
              Modes   "1200x900"
           EndSubSection
EndSection

Offline Gunfree

  • Usuário Ubuntu
  • *
  • Mensagens: 208
    • Ver perfil
Re: Xubuntu perde resolução ao reiniciar
« Resposta #4 Online: 11 de Junho de 2009, 23:05 »
Você precisa saber se seu monitor suporta antes. Rode:

Código: [Selecionar]
xrandr
Destas resoluções que apareceram, escolha uma e rode o gtf para pegar o modeline correto:

Código: [Selecionar]
gtf x y zonde X é o Horizontal, Y o vertical e Z o refresh.

Linux Registered User: #491793

Offline gatohumano

  • Usuário Ubuntu
  • *
  • Mensagens: 87
    • Ver perfil
Re: Xubuntu perde resolução ao reiniciar
« Resposta #5 Online: 11 de Junho de 2009, 23:19 »
Sim o monitor suporta esses valores e aplicando funcionam,o problema é apos fazer restart volta a 1024x768,para calcular o modeline usei este site:
http://www.arachnoid.com/modelines/

Offline Gunfree

  • Usuário Ubuntu
  • *
  • Mensagens: 208
    • Ver perfil
Re: Xubuntu perde resolução ao reiniciar
« Resposta #6 Online: 11 de Junho de 2009, 23:27 »
Em adição ao teu xorg, cole aqui a saída de:

Código: [Selecionar]
cat /var/log/Xorg.0.log
lspci -vvnn | grep -i VGA
sudo ddcprobe
xrandr
Linux Registered User: #491793

Offline gatohumano

  • Usuário Ubuntu
  • *
  • Mensagens: 87
    • Ver perfil
Re: Xubuntu perde resolução ao reiniciar
« Resposta #7 Online: 12 de Junho de 2009, 00:17 »
Acabei por conseguir resolver o problema,depois de andar as voltas no google fiz uns testes que deram resultado,eu alterei a resolução pq acho que fica melhor neste monitor,aqui fica a conf do xorg:
Código: [Selecionar]
Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
# 1152x864 @ 78.00 Hz (GTF) hsync: 70.51 kHz; pclk: 109.43 MHz
        Modeline "1152x864_78.00"  109.43  1152 1224 1352 1552  864 865 868 904  -HSync +Vsync
        Option          "PreferredMode" "1152x864_78.00"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection
« Última modificação: 12 de Junho de 2009, 07:00 por gatohumano »

Offline Gunfree

  • Usuário Ubuntu
  • *
  • Mensagens: 208
    • Ver perfil
Re: Xubuntu perde resolução ao reiniciar
« Resposta #8 Online: 12 de Junho de 2009, 10:14 »
Excelente :)
Provavelmente aquele modeline estava errado >:(

Marque como resolvido seu tópico.

[]'s
Linux Registered User: #491793

Offline gatohumano

  • Usuário Ubuntu
  • *
  • Mensagens: 87
    • Ver perfil
Re: Xubuntu perde resolução ao reiniciar
« Resposta #9 Online: 12 de Junho de 2009, 15:47 »
Excelente :)
Provavelmente aquele modeline estava errado >:(

Marque como resolvido seu tópico.

[]'s

Não tinha nada a ver com isso,o que faltava era a opção       Option          "PreferredMode"

Offline Jarraum

  • Usuário Ubuntu
  • *
  • Mensagens: 57
    • Ver perfil
Re: Xubuntu perde resolução ao reiniciar
« Resposta #10 Online: 16 de Agosto de 2009, 22:44 »
no meu eu resolvi rodando o configurador da placa de video como SU
ai a configuração não se perdeu mais

Offline Cálcio

  • Usuário Ubuntu
  • *
  • Mensagens: 213
  • Ubuntu 14.04
    • Ver perfil
Re: Xubuntu perde resolução ao reiniciar
« Resposta #11 Online: 31 de Outubro de 2009, 23:26 »
Galera boa noite...
Tentei fezer essas configurações e msm a ssim não conseigo deixar o Xubuntu fixo em 800x600. Segue a ultima atulização que eu fiz.

Código: [Selecionar]
Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
        Modeline "800x600_75.00"  109.43  1152 1224 1352 1552  864 865 868 904  -HSync +Vsync
        Option   "PreferredMode" "800x600_75.00"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Se alguém puder dar uma luz eu agradeço