Autor Tópico: Problemas Aiko 82D no 9.04  (Lida 4451 vezes)

Offline Carlos Leandro

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Problemas Aiko 82D no 9.04
« Online: 05 de Maio de 2009, 07:26 »
Esta é a primeira vez que posto algo aqui no Forum. Caso eu esteja colocando o meu pedido de socorro no lugar errado me desculpem.
Sou iniciante no Ubuntu, mas já possuo um bom conhecimento sobre ele, inclusive estou convertendo vários "ruwindowszeiros" em "ubuntuzeiros" rsrs. Tenho um note Gateway Core 2 Duo rodando o 9.04 de boa 99%, o pequeno problema é por que a minha internet é um parto para funcionar. Começei a usar o ubuntu na versão 7.alguma coisa em outro note, comprei este que veio com o Vista ingles original (o note é gringo) instalei o 8.10 (primeira versão)não precisei fazer nenhum malabarismo para instalar o ubuntu tudo foi reconhecido', só o vivozap que foi complicado fazer rodar. Tentei por wvdial, pppconfig e tudo mais, nada mudou, até então quando eu estava em um lugar com net wire eu atualizava do coitado, interessante que eu instalei o Virtual Box e configurei para compartilhar as portas USB e o modem AIKO 82D funciona com o Windows dentro dele normal, fui quebrando o galho.
Quando estava em um local sem internet que teria que impreterivelmente conectar a rede, abria o virtual box e conectava pelo windows dentro do ubuntu (que parto, rsrs, ruwindows ninguem merece).
Até que um dia atualizei o 8.10 e pimba reconheceu tudo e conectou de primeira com o Aiko, apareceu um icone de banda larga móvel e foi só alegria.
Ai como sou entusiasmado com o ubuntu saiu o 9.04 e eu atualizei. Agora o que acontece, que é o meu problema atual, reconhece o modem normalmente, tento conectar, conecta quando ele quer e onde ele quer. Agora mesmo estou no meu note agora conectado na net com o vivo zap dentro do windows no virtual box.
Alguem saberia como resolver o problema?
Eu até segui uma dica de usar o wvdial fiz as configurações corretas que fala no site http://www.vivaolinux.com.br/topico/Ubuntu-e-Kubuntu/Vivo-3G-+-modem-Aiko-82D-no-Ubuntu-9.04-Jaunty-Jackalope
mas aparece uma mensagem de erro, realmente eu não entendo o por que disto. Instalei também o 9.04 num computador pessoal aqui de casa e não consigo conectar. Caso alguém possa ajudar agradeço. Independente da conexão da internet eu vou usar o linux pelo resto da minha vida. Rsrsrss

alarcon

  • Visitante
Re: Problemas Aiko 82D no 9.04
« Resposta #1 Online: 05 de Maio de 2009, 16:59 »
Seguindo este link:

http://www.guiadohardware.net/tutoriais/3g-linux/

Na parte que fala em Solucionando problemas você deve fazer isso, abrir um terminal e digitar:

sudo gedit /etc/udev/rules.d/99_aiko82e.rules

e no arquivo vazio que se abrir colocar isso:

Citar
SUBSYSTEM=="block", ACTION=="add", \
SYSFS{idVendor}=="19d2", SYSFS{idProduct}=="2000", \
OPTIONS="ignore_device"

SUBSYSTEM=="usb", \
SYSFS{idVendor}=="19d2", SYSFS{idProduct}=="0001", \
RUN+="/sbin/modprobe usbserial vendor=0x19d2 product=0x0001"

Salve e  no terminal digite:

sudo udevcontrol reload_rules

para ativar a nova regra e desconecte/reconecte o modem para que ele seja detectado.

edite o arquivo wvdial.conf com o comando " sudo gedit /etc/wvdial.conf", seguindo este modelo:

Citar
[Dialer 3g]
Modem = /dev/ttyUSB0
Baud = 921600
DialCommand = ATDT
Check Def Route = on
FlowControl = Hardware(CRTSCTS)
Username = vivo
Password = vivo
Phone = *99#
Stupid mode = 1
Auto Reconnect = on
Auto DNS = on
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2
Init3 = AT+CGDCONT=1,"IP","zap.vivo.com.br"
ISDN = 0
Modem Type = Analog Modem

depois para se conectar via terminal seria:

sudo wvdial 3g

Isso se o aplicativo wvdial estiver instalado no seu sistema, pois aqui no meu Ubuntu 9.04 ele não está, mas como você atualizou o seu e como até as versões anteriores do Ubuntu o wvdial vinha instalado, pode ser que ele já esteja aí.

Chamo a atenção para mais isso:

Citar
Para a maioria dos modems essa configuração é suficiente, mas muitos modelos, como o Aiko 82D e o Huawei E156 precisam de um conjunto de opções adicionais. Originalmente o modem chega a discar e iniciar a conexão, mas desconecta sozinho logo depois. Para solucionar o problema, é necessário voltar ao "/etc/ppp/options" e adicionar também as linhas "asyncmap 0xa0000", "mru 1500" e "refuse-chap" no final do arquivo.

Caso o sistema não esteja obtendo automaticamente os endereços DNS da operadora ao ativar a conexão, edite o arquivo "/etc/ppp/options" e adicione a opção "ipcp-max-failure 30" no final do arquivo. Essa opção orienta o discador a esperar mais tempo pelas configurações da conexão antes de desistir, dando mais tempo ao servidor remoto.

Ele é um daqueles arquivos grandes e intimidadores, com mais de 350 linhas de opções, mas você não precisa se preocupar com elas. Basta adicionar as linhas no final do arquivo "/etc/ppp/options", logo depois do "# ---<End of File>---", como em:
# ---<End of File>---
asyncmap 0xa0000
mru 1500
refuse-chap
ipcp-max-failure 30

Depois de fazer as alterações, é só discar novamente, usando o comando " sudo wvdial 3g".

« Última modificação: 05 de Maio de 2009, 17:05 por alarcon »

Offline Carlos Leandro

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re: Problemas Aiko 82D no 9.04 (Resolvido)
« Resposta #2 Online: 04 de Julho de 2009, 18:50 »
Esta é a primeira vez que posto algo aqui no Forum. Caso eu esteja colocando o meu pedido de socorro no lugar errado me desculpem.
Sou iniciante no Ubuntu, mas já possuo um bom conhecimento sobre ele, inclusive estou convertendo vários "ruwindowszeiros" em "ubuntuzeiros" rsrs. Tenho um note Gateway Core 2 Duo rodando o 9.04 de boa 99%, o pequeno problema é por que a minha internet é um parto para funcionar. Começei a usar o ubuntu na versão 7.alguma coisa em outro note, comprei este que veio com o Vista ingles original (o note é gringo) instalei o 8.10 (primeira versão)não precisei fazer nenhum malabarismo para instalar o ubuntu tudo foi reconhecido', só o vivozap que foi complicado fazer rodar. Tentei por wvdial, pppconfig e tudo mais, nada mudou, até então quando eu estava em um lugar com net wire eu atualizava do coitado, interessante que eu instalei o Virtual Box e configurei para compartilhar as portas USB e o modem AIKO 82D funciona com o Windows dentro dele normal, fui quebrando o galho.
Quando estava em um local sem internet que teria que impreterivelmente conectar a rede, abria o virtual box e conectava pelo windows dentro do ubuntu (que parto, rsrs, ruwindows ninguem merece).
Até que um dia atualizei o 8.10 e pimba reconheceu tudo e conectou de primeira com o Aiko, apareceu um icone de banda larga móvel e foi só alegria.
Ai como sou entusiasmado com o ubuntu saiu o 9.04 e eu atualizei. Agora o que acontece, que é o meu problema atual, reconhece o modem normalmente, tento conectar, conecta quando ele quer e onde ele quer. Agora mesmo estou no meu note agora conectado na net com o vivo zap dentro do windows no virtual box.
Alguem saberia como resolver o problema?
Eu até segui uma dica de usar o wvdial fiz as configurações corretas que fala no site http://www.vivaolinux.com.br/topico/Ubuntu-e-Kubuntu/Vivo-3G-+-modem-Aiko-82D-no-Ubuntu-9.04-Jaunty-Jackalope
mas aparece uma mensagem de erro, realmente eu não entendo o por que disto. Instalei também o 9.04 num computador pessoal aqui de casa e não consigo conectar. Caso alguém possa ajudar agradeço. Independente da conexão da internet eu vou usar o linux pelo resto da minha vida. Rsrsrss


Offline tokarski

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: Problemas Aiko 82D no 9.04
« Resposta #3 Online: 11 de Agosto de 2009, 21:48 »
Bom, também sou novo no Linux, novo no Ubuntu. Instalei o 9.04 aqui em casa. Estou rodando num Core 2 Quad, 4 Gb de RAM, uma máquina bem bacaninha. Utilizo o modem Aiko 82D, da Vivo 3G. O Linux não reconheceu o modem. Não conectou. Tentei fazer o que foi indicado acima. O 1º problema foi: quando digitei "sudo udevcontrol reload_rules" a resposta foi: "sudo: udevcontrol: command not found". Assim mesmo continuei, tentei "sudo -u devcontrol reload_rules", e a resposta foi: "sudo: no passwd entry for devcontrol!". Alguém poderia me ajudar?
Obrigado!