Autor Tópico: Problemas com a configuração do arquivo xorg.conf  (Lida 2071 vezes)

Offline Fernando1979

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Problemas com a configuração do arquivo xorg.conf
« Online: 24 de MAR?O de 2009, 08:11 »
Fala aê pessoal, acontece que eu sou bem inexperiente ainda qunado se trata do Linux em geral e acabei de arrumar um pequeno abacaxi. Tenho instalado no meu pc uma placa de vídeo nVidia GeForce Mx/Mx400 (já consegui instalar o driver dela) e costumo usar a resolução máxima aqui, no caso 1440x900. O chato é que toda vez que eu reiniciava o pc, voltava com a resolução 1024x768. Resolvi adicionar algumas linhas no arquivo xorg.conf usando a própria janela de configuração da nVidia e até consegui chegar a metade do caminho mas agora arrumei outro inconveniente: a barra superior das janelas sumiram, como é possível ver na imagem abaixo.



Aqui está também o conteúdo do código que estou usando atualmente:

Código: [Selecionar]
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Module"
Load "glx"
Disable "dri2"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
EndSection

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd@palmer)  Mon Nov  3 08:46:46 UTC 2008

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Philips 107E6"
    HorizSync       30.0 - 72.0
    VertRefresh     50.0 - 160.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce2 MX/MX 400"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "1440x900_60 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Offline csilva

  • Usuário Ubuntu
  • *
  • Mensagens: 125
    • Ver perfil
Re: Problemas com a configuração do arquivo xorg.conf
« Resposta #1 Online: 24 de MAR?O de 2009, 09:09 »
Vc está usando o compiz? Experimente instalar o emerald, que costuma trabalhar melhor com o compiz.
Pode digitar num terminal: sudo apt-get install emerald
Ou pode tentar desativar o compiz em Aparência>efeitos visuais

Conhecendo o Linux...

Offline Fernando1979

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Re: Problemas com a configuração do arquivo xorg.conf
« Resposta #2 Online: 24 de MAR?O de 2009, 14:51 »
Não me lembro  de ter instalado o compiz e nem imagino se ele já vem na instalação do Ubutnu Intrepid mas vou tentar aqui com  o emerald pra ver o que acontece, só não estou muito afim de desativar os efeitos visuais.
Obrigado aí pela ajuda.
« Última modificação: 24 de MAR?O de 2009, 15:03 por Fernando1979 »