Autor Tópico: Ubuntu 8.10 intrepid não lê DVDs protegidos  (Lida 17758 vezes)

alarcon

  • Visitante
Re: Ubuntu 8.10 intrepid não lê DVDs protegidos
« Resposta #15 Online: 13 de Janeiro de 2009, 11:13 »
Ainda voltanto ao assunto sobre multimídia, codecs e etc. aqui no meu PC tudo funciona bem quanto a leitura de CDs/DVDs originais (músicas e vídeos) assim como CDs/DVDs de dados (R ou RW) e o que tenho instalado de pacotes (se não esqueci de mais algum) são estes:


totem-xine cpdvd regionset x264 gqmpeg mp3gain mjpegtools libdvdread3 mpeg2dec vorbis-tools id3v2 mpg321 mpg123 libflac++6 ffmpeg toolame libmp4v2-0 lame libmad0 libjpeg-progs libmpcdec3 libquicktime1 flac faac faad sox ffmpeg2theora libmpeg2-4 uudeview libmpeg3-1 mpeg3-utils mpegdemux liba52-0.7.4-dev gstreamer0.10-ffmpeg gstreamer0.10-fluendo-mp3 gstreamer0.10-fluendo-mpegdemux gstreamer0.10-gnonlin gstreamer0.10-pitfdll gstreamer0.10-plugins-bad gstreamer0.10-plugins-farsight gstreamer0.10-plugins-ugly gstreamer0.10-plugins-bad-multiverse gstreamer0.10-schroedinger gstreamer0.10-plugins-ugly-multiverse gstreamer-dbus-media-service gstreamer-tools w32codecs libdvdcss2 gsfonts gsfonts-x11 flashplugin-nonfree sun-java6-bin sun-java6-fonts sun-java6-jre sun-java6-plugin mplayer mplayer-fonts mplayer-skins mplayer-skin-blue mozilla-mplayer mencoder rar unrar unace p7zip p7zip-full p7zip-rar vlc vlc-plugin-esd vlc-plugin-pulse vlc-plugin-arts mozilla-plugin-vlc totem-mozilla libmjpegtools0c2a nautilus-script-audio-convert totem-gstreamer msttcorefonts



OBS: Alguns destes pacotes tem outros como dependência que são instalados automaticamente com ele. O que destaquei em vermelho é necessário adicionar repositórios de terceiros no seu Ubuntu para poder instalá-los, mas você já instalou pelos links que ofereci antes aqui no começo do seu tópico ok.

Nem tudo que tem nessa lista é específico de multimídia, mas é interessante ter instalado como o java, fonte do windows, compactadores/descompactadores e etc.

Se quiser ter o trabalho de ir no menu Sistema > Administração > Gerenciador de pacotes Synaptic e procurar por cada um destes pacotes aí para saber se já estão instalados no seu sistema e assim descartar definitivamente que seja problema por falta de codecs, fique a vontade.

Caso queria poupar trabalho e resolva instalar sem verificar é só colocar isso na frente do nome de todos os pacotes listados acima sudo apt-get -y install ou seja, sudo apt-get -y install nomes_dos_pacotes, isso pelo terminal. Atenção  que se for realmente fazer isso retire do comando o nome dos pacotes destacados em vermelho que já estão instalados e requerem repositórios extras.

Não há nada de errado com as permissões das subpastas em /media ok. Seu fstab quanto a entrada do driver óptico também está ok.

Se desejar você pode voltar seu fstab (presente em /etc) para o valor original:

Citar
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda1
UUID=5438f64a-2a51-4f9b-a221-ce92d225e9dc /               ext3    relatime,errors=remount-ro 0       1
# /dev/sda5
UUID=b61182f8-609b-4c13-976a-a56d3e2075f9 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0

ou seja retire a linha:

/dev/dvd       /media/dvd   udf,iso9660 user,noauto,exec,utf8 0       0

final dele.
« Última modificação: 13 de Janeiro de 2009, 11:21 por alarcon »

Offline Esther

  • Usuário Ubuntu
  • *
  • Mensagens: 16
    • Ver perfil
Re: Ubuntu 8.10 intrepid não lê DVDs protegidos
« Resposta #16 Online: 13 de Janeiro de 2009, 21:42 »
Alarcon,

Obrigada por sua sempre gentil atenção.

Verifiquei os pacotes um a um no Synaptic. A maioria já estava instalada. O resto, instalei.

Resultado: nada.

Minha palavra final a respeito disso é um grande e sonoro DESISTO.

Eu queria usar o Ubuntu porque achei para ele um programinha open-source que faz o que estou precisando:

http://www.getdeb.net/app/Dvd+Movie+Backup

Não há equivalente a isso para Mac OS X. As alternativas (muito boas, aliás) são pagas.

Então, se é para pagar, vou optar pela solução mais barata: comprar DVDs dual layer. Assim não preciso sair do ambiente Mac OS X nem fazer malabarismos com software.

Caso alguém ainda tenha alguma sugestão que ajude a explicar porque meu Ubuntu virtualizado não lê DVDs protegidos (e apenas eles, pois os desprotegidos são lidos normalmente), fique à vontade para expor. Não acho que seja problema envolvendo o fato de ser virtualizado, mas, enfim...

Obrigada pela atenção de todos.

Esther

alarcon

  • Visitante
Re: Ubuntu 8.10 intrepid não lê DVDs protegidos
« Resposta #17 Online: 13 de Janeiro de 2009, 22:05 »
Tudo bem Esther sei que deve ser muito frustrante ter algo não resolvido no linux, mas eu não desisto fácil e tento de tudo, não estou dizendo que você desista fácil ok, talvez por que já tenha passado muitos problemas com o linux e tendo obtido sucesso pela persistência.

Vi que você seguiu inicialmente este link aqui:

http://ubuntuforum-br.org/index.php/topic,36470.0.html

nos textos de lá informam como instalar o w32codecs e o libdvdread3, mas o comum dos sites que já vi sobre multimídia são o w32codecs e o libdvdcss2 cujos links para o Ubuntu 8.10 intrepid Ibex são esses aqui:


Citar
libdvdcss2:
http://packages.medibuntu.org/pool/free/libd/libdvdcss/libdvdcss2_1.2.10-0.2medibuntu1_i386.deb

O libdvdcss2 é responsável por permitir reprodução de DVDs encriptados

w32codecs:
http://packages.medibuntu.org/pool/non-free/w/w32codecs/w32codecs_20071007-0medibuntu3_i386.deb

O w32codecs são os codecs da Microsoft.

Estava pensando em te sugerir o seguinte, que reinstalasse o Ubuntu virtualizado, fizesse a atualização do sistema sem instalar nenhum pacote ainda e só então de fazer as atualizações sugeridas é que você deveria partir para a instalação dos pacotes acima e a execução deste comando aqui:

sudo apt-get -y install totem-xine cpdvd regionset x264 gqmpeg mp3gain mjpegtools libdvdread3 mpeg2dec vorbis-tools id3v2 mpg321 mpg123 libflac++6 ffmpeg toolame libmp4v2-0 lame libmad0 libjpeg-progs libmpcdec3 libquicktime1 flac faac faad sox ffmpeg2theora libmpeg2-4 uudeview libmpeg3-1 mpeg3-utils mpegdemux liba52-0.7.4-dev gstreamer0.10-ffmpeg gstreamer0.10-fluendo-mp3 gstreamer0.10-fluendo-mpegdemux gstreamer0.10-gnonlin gstreamer0.10-pitfdll gstreamer0.10-plugins-bad gstreamer0.10-plugins-farsight gstreamer0.10-plugins-ugly gstreamer0.10-plugins-bad-multiverse gstreamer0.10-schroedinger gstreamer0.10-plugins-ugly-multiverse gstreamer-dbus-media-service gstreamer-tools w32codecs libdvdcss2 gsfonts gsfonts-x11 flashplugin-nonfree sun-java6-bin sun-java6-fonts sun-java6-jre sun-java6-plugin mplayer mplayer-fonts mplayer-skins mplayer-skin-blue mozilla-mplayer mencoder rar unrar unace p7zip p7zip-full p7zip-rar vlc vlc-plugin-esd vlc-plugin-pulse vlc-plugin-arts mozilla-plugin-vlc totem-mozilla libmjpegtools0c2a nautilus-script-audio-convert totem-gstreamer msttcorefonts


pois quem sabe antes você usou um pacote inadequado para sua versão do Ubuntu que esteja causando algum conflito.

Como sei que já deve estar um pouco irritada com esse erro persistente, fica aqui só como uma idéia (trabalhosa eu sei ;D) para você pensar se vale mesmo a pena tentar.

Quem sabe também a instalação no HD do Ubuntu não apresente este problema, mas infelizmente isso só se pode saber instalando.
« Última modificação: 13 de Janeiro de 2009, 22:06 por alarcon »

alarcon

  • Visitante
Re: Ubuntu 8.10 intrepid não lê DVDs protegidos
« Resposta #18 Online: 13 de Janeiro de 2009, 22:12 »
para não escrever no mesmo texto, rsrsrs

Não sei se você conseguiria copiar o DVD para Backup em DVDs dual layer no seu MAC exatamente pelo que o agente100gelo falou:

Citar
Por acaso este problema não tem a ver com a proteção DRM (existente no Mac) de alguma forma está identificando duas mídias (no Mac e no Ubuntu) e proibindo sua reprodução?

Não podemos descartar esta possibilidade, já que em ambiente nativo este tipo de problema não ocorre depois da instação dos codecs.

O problema não é só de capacidade de DVDs, mas eles também tem uma trava para não permitir a cópia, sendo necessário usar programas de terceiros que fazem esta quebra e que no linux é exatamente o pacote libdvdcss2 ok.
« Última modificação: 13 de Janeiro de 2009, 22:18 por alarcon »

Offline Esther

  • Usuário Ubuntu
  • *
  • Mensagens: 16
    • Ver perfil
Re: Ubuntu 8.10 intrepid não lê DVDs protegidos
« Resposta #19 Online: 15 de Janeiro de 2009, 10:03 »
Oi, Alarcon.

Fiz o que você sugeriu: apaguei a instalação anterior e fiz uma nova, com todas as atualizações.

Quando fui emitir o comando que você sugeriu, recebi isto:

Código: [Selecionar]
O pacote w32codecs não está disponível, mas é referenciado por outro pacote.
Isto pode significar que o pacote está faltando, ficou obsoleto ou está disponível somente a partir de outra fonte
E: O pacote w32codecs não tem candidato para instalação.

Alguma sugestão?

A propósito, no Mac a quebra também se faz através de programas de terceiros. O que uso é o MacTheRipper. Todo o problema reside no fato de que a cópia é grande demais para caber num DVD-R comum. O único programa para Mac que descobri que comprime o conteúdo para caber num DVD-R é pago (custa 39 euros).

Eu poderia usar DVDs-R de camada dupla, mas esse produto simplesmente não existe no comércio de minha cidade. Procurando no Shopping UOL, encontrei-o em apenas duas lojas. Ambas só o vendem em bobinas com no mínimo 10 unidades. O preço delas mais o frete dá quase os 39 euros.

No Ubuntu temos esta opção open-source:

http://www.getdeb.net/app/Dvd+Movie+Backup

Eis porque estou insistindo no Ubuntu. Houvesse para Mac uma opção open-source como essa, eu não precisaria estar brigando com o Ubuntu.

-- Esther

alarcon

  • Visitante
Re: Ubuntu 8.10 intrepid não lê DVDs protegidos
« Resposta #20 Online: 15 de Janeiro de 2009, 10:16 »
quanto o isso aqui:

Citar
Quando fui emitir o comando que você sugeriu, recebi isto:


O pacote w32codecs não está disponível, mas é referenciado por outro pacote.
Isto pode significar que o pacote está faltando, ficou obsoleto ou está disponível somente a partir de outra fonte
E: O pacote w32codecs não tem candidato para instalação.

Já sei qual foi o erro, esqueci de tirar do comando:

sudo apt-get -y install totem-xine cpdvd regionset x264 gqmpeg mp3gain mjpegtools libdvdread3 mpeg2dec vorbis-tools id3v2 mpg321 mpg123 libflac++6 ffmpeg toolame libmp4v2-0 lame libmad0 libjpeg-progs libmpcdec3 libquicktime1 flac faac faad sox ffmpeg2theora libmpeg2-4 uudeview libmpeg3-1 mpeg3-utils mpegdemux liba52-0.7.4-dev gstreamer0.10-ffmpeg gstreamer0.10-fluendo-mp3 gstreamer0.10-fluendo-mpegdemux gstreamer0.10-gnonlin gstreamer0.10-pitfdll gstreamer0.10-plugins-bad gstreamer0.10-plugins-farsight gstreamer0.10-plugins-ugly gstreamer0.10-plugins-bad-multiverse gstreamer0.10-schroedinger gstreamer0.10-plugins-ugly-multiverse gstreamer-dbus-media-service gstreamer-tools w32codecs libdvdcss2 gsfonts gsfonts-x11 flashplugin-nonfree sun-java6-bin sun-java6-fonts sun-java6-jre sun-java6-plugin mplayer mplayer-fonts mplayer-skins mplayer-skin-blue mozilla-mplayer mencoder rar unrar unace p7zip p7zip-full p7zip-rar vlc vlc-plugin-esd vlc-plugin-pulse vlc-plugin-arts mozilla-plugin-vlc totem-mozilla libmjpegtools0c2a nautilus-script-audio-convert totem-gstreamer msttcorefonts


os pacotes que destaquei em vermelho por que como falei antes, eles não estão nos repositórios originais do Ubuntu, é preciso colocar no sources.list repositórios de terceiros ou baixá-los manualmente por esses links aqui:


Citar
libdvdcss2:
http://packages.medibuntu.org/pool/free/libd/libdvdcss/libdvdcss2_1.2.10-0.2medibuntu1_i386.deb

O libdvdcss2 é responsável por permitir reprodução de DVDs encriptados

w32codecs:
http://packages.medibuntu.org/pool/non-free/w/w32codecs/w32codecs_20071007-0medibuntu3_i386.deb

O w32codecs são os codecs da Microsoft.

Desculpe-me a falta de atenção, então o comando a ser executado seria:

sudo apt-get update

e

sudo apt-get -y install totem-xine cpdvd regionset x264 gqmpeg mp3gain mjpegtools libdvdread3 mpeg2dec vorbis-tools id3v2 mpg321 mpg123 libflac++6 ffmpeg toolame libmp4v2-0 lame libmad0 libjpeg-progs libmpcdec3 libquicktime1 flac faac faad sox ffmpeg2theora libmpeg2-4 uudeview libmpeg3-1 mpeg3-utils mpegdemux liba52-0.7.4-dev gstreamer0.10-ffmpeg gstreamer0.10-fluendo-mp3 gstreamer0.10-fluendo-mpegdemux gstreamer0.10-gnonlin gstreamer0.10-pitfdll gstreamer0.10-plugins-bad gstreamer0.10-plugins-farsight gstreamer0.10-plugins-ugly gstreamer0.10-plugins-bad-multiverse gstreamer0.10-schroedinger gstreamer0.10-plugins-ugly-multiverse gstreamer-dbus-media-service gstreamer-tools gsfonts gsfonts-x11 flashplugin-nonfree sun-java6-bin sun-java6-fonts sun-java6-jre sun-java6-plugin mplayer mplayer-fonts mplayer-skins mplayer-skin-blue mozilla-mplayer mencoder rar unrar unace p7zip p7zip-full p7zip-rar vlc vlc-plugin-esd vlc-plugin-pulse vlc-plugin-arts mozilla-plugin-vlc totem-mozilla libmjpegtools0c2a nautilus-script-audio-convert totem-gstreamer msttcorefonts

já retirado do comando os pacotes w32codecs e libdvdcss2 que não estão nos repositórios oficiais ok.

alarcon

  • Visitante
Re: Ubuntu 8.10 intrepid não lê DVDs protegidos
« Resposta #21 Online: 15 de Janeiro de 2009, 10:20 »
Uma pegunta, é possível você transferir dados do Ubuntu para o seu MAC por ele mesmo, ou seja, seu MAC enxerga a partição do Ubuntu e pode pegar dados de lá ou é somente o Ubuntu que vê o seu MAC e pode transferir dados para ele?

A utilização da forma virtualizada não permite isso do Ubuntu vê seu MAC?


alarcon

  • Visitante
Re: Ubuntu 8.10 intrepid não lê DVDs protegidos
« Resposta #22 Online: 15 de Janeiro de 2009, 10:33 »
Citar
No Ubuntu temos esta opção open-source:

http://www.getdeb.net/app/Dvd+Movie+Backup

Este programa eu não conheço, mas um que é muito usado no Ubuntu e que está nos seus repositórios e portanto pode ser instalado por apt-get ou Adicionar /Remover... ou Synaptic é o k9copy

Citar
k9copy is a tabbed tool that allows to copy of one or more titles from a DVD9 to a DVD5, in the same way than DVDShrink for Microsoft Windows (R).

Tem outro que não conheço chamado de Dvd95 Converter também nos repositórios do Ubuntu.

Citar
DVD95 is an GNOME application to convert DVD9 to DVD5 (4.7GB).
* DVD95 supports two copy modes:
* Without menus, one video title set, multiple audio tracks and subtitles.
* With menus, one video title set, multiple audio tracks and subtitles.


e se você conhece os programas DVD Decrypter e DVD Shrink do windows pode usá-los emulado via wine no Ubuntu.

Veja que opções tem muitas por aqui no mundo linux.
« Última modificação: 15 de Janeiro de 2009, 10:55 por alarcon »

Offline Esther

  • Usuário Ubuntu
  • *
  • Mensagens: 16
    • Ver perfil
Re: Ubuntu 8.10 intrepid não lê DVDs protegidos
« Resposta #23 Online: 15 de Janeiro de 2009, 12:56 »
É, sei disso, Alarcon. Por isso estou insistindo no Ubuntu.

O problema é, ainda, a leitura dos DVDs.

Depois que efetuei a instalação dos pacotes conforme você sugeriu, parece (note que eu disse parece) que meu Ubuntu está conseguindo abrir os DVDs protegidos.

Mas...

Quando tentei com o primeiro (Ratatouille), o Reprodutor de Filmes conseguiu exibir o menu de idiomas do DVD, mas não saiu disso. Não importa onde eu clicasse, nada acontecia. Tentei com o VLC, que simplesmente não abria o disco.

Tirei o Ratatouille e inseri o Madagascar. Ao tentar abri-lo, o Reprodutor de Filmes travava. O VLC fechava na minha cara.

Terceira tentativa, desta vez com o Monstros S.A. O Reprodutor fechava na minha cara. O VLC também.

Ainda não tentei ver se, apesar disso, o k9copy conseguiria copiar os filmes. Não estou tão interessada em reproduzir esses filmes no Ubuntu quanto estou em copiá-los.

Agora, respondendo sua pergunta: a transferência de arquivos entre o Mac OS X e o Ubuntu virtualizado via VirtualBox se faz através de uma pasta compartilhada entre ambos definida nas configurações do VirtualBox. Não há "partições". O Ubuntu roda dentro do Mac na forma de um único arquivo (chamado de máquina virtual) dentro da estrutura de pastas do Mac OS X como se fosse uma aplicação dele.
« Última modificação: 15 de Janeiro de 2009, 18:25 por Esther »

Offline pigdin

  • Usuário Ubuntu
  • *
  • Mensagens: 723
  • Terra - Brasill - SP-Capital
    • Ver perfil
Re: Ubuntu 8.10 intrepid não lê DVDs protegidos
« Resposta #24 Online: 15 de Janeiro de 2009, 13:15 »
Esther, o que me prende ao dual boot ainda é justamente não saber copiar DVD protegido pelo Ubuntu.

Se você encontrar um bom tutorial a respeito por favor divulgue no fórum.

Acho que o maior problema é remover a proteção contra cópia, no que até o Decrypter ás vezes falha.


Desejo-lhe boa sorte.

Desk: Phenom X3 2GB DDR II - Win 7 / Ubuntu 10.04 64 Bits
Note MUB: Core2Duo 4GB - Win7 / Ubuntu 10.04 / Bodhi Linux.
@alexpigdin

Offline Esther

  • Usuário Ubuntu
  • *
  • Mensagens: 16
    • Ver perfil
Re: Ubuntu 8.10 intrepid não lê DVDs protegidos
« Resposta #25 Online: 15 de Janeiro de 2009, 13:26 »
No meu caso, a remoção da proteção nem é o problema. No Mac tenho o MacTheRipper, que é bastante competente para isso.

Meu problema todo é gravar o conteúdo em um DVD-R comum de 4,7 GB, pois não cabe. As opções gratuitas de compressão de filmes para gravação nesses DVDs comuns são o que ainda me prendem ao Ubuntu.

Offline pigdin

  • Usuário Ubuntu
  • *
  • Mensagens: 723
  • Terra - Brasill - SP-Capital
    • Ver perfil
Re: Ubuntu 8.10 intrepid não lê DVDs protegidos
« Resposta #26 Online: 15 de Janeiro de 2009, 13:34 »
Entendi, seus propósitos são diferentes.

Eu gostaria de fazer tudo no Ubuntu e me livrar definitivamente do windows.

Obrigado pela resposta.
Desk: Phenom X3 2GB DDR II - Win 7 / Ubuntu 10.04 64 Bits
Note MUB: Core2Duo 4GB - Win7 / Ubuntu 10.04 / Bodhi Linux.
@alexpigdin

alarcon

  • Visitante
Re: Ubuntu 8.10 intrepid não lê DVDs protegidos
« Resposta #27 Online: 15 de Janeiro de 2009, 18:11 »
É, sei disso, Alarcon. Por isso estou insistindo no Ubuntu.

O problema é, ainda, a leitura dos DVDs.

Depois que efetuei a instalação dos pacotes conforme você sugeriu, parece (note que eu disse parece) que meu Ubuntu está conseguindo abrir os DVDs protegidos.

Mas...

Quando tentei com o primeiro (Ratatouille), o Reprodutor de Filmes conseguiu exibir o menu de idiomas do DVD, mas não saiu disso. Não importa onde eu clicasse, nada acontecia. Tentei com o VLC, que simplesmente não abria o disco.

Tirei o Ratatouille e inseri o Madagascar. Ao tentar abri-lo, o Reprodutor de Filmes travava. O VLC fechava na minha cara.

Terceira tentativa, desta vez com o Monstros S.A. O Reprodutor fechava na minha cara. O VLC também.

Ainda não tentei ver se, apesar disso, o k9copy conseguiria copiar os filmes. Não estou tão interessada em reproduzir esses filmes no Ubuntu quanto estou em copiá-los.

Agora, respondendo sua pergunta: a transferência de arquivos entre o Mac OS X e o Ubuntu virtualizado via VirtualBox se faz através de uma pasta compartilhada entre ambos. Não há "partições". O Ubuntu roda dentro do Mac na forma de um único arquivo (chamado de máquina virtual) dentro da estrutura de pastas do Mac OS X como se fosse uma aplicação dele.

Desta vez foi melhor que a anterior em termos de acesso de DVDs?

as opções que antes funcionavam no seu driver óptico continuam funcionando e as que não funcionavam, agora quase que funcionam?

Dê uma olhada para mim pelo Synaptic se os pacotes abaixo estão instalados também (além do libdvdcss2):

- libdvdread3
- libdvdnav4

caso algum não esteja instalado, faça a instalação.

Agora abra um terminal e digite:

sudo update-alternatives --config totem

deve aparece algo assim:

Citar
alarcon@Ubuntu-machine:~$ sudo update-alternatives --config totem

Existem 2 alternativas que fornecem 'totem'.

  Seleção      Alternativa
-----------------------------------------------
*+        1    /usr/bin/totem-gstreamer
          2    /usr/bin/totem-xine

Pressione enter para manter o padrão
  • ou digite o número da seleção:

Aí você tem de digitar 2 (caso esta opção já não esteja marcada) para usar o totem-xine ao invés do totem-gstreamer, pois é com o totem-xine que você conseguirá usar o Menu do DVD.

Em relação aqueles links em /dev continuam existindo só o cdrom e o dvd apontando para o scd0 no mesmo local ou desta vez apareceram os links cdrw e dvdrw apontando para o scd0 ?

Sei não, acho que o Ubuntu instalado no seu HD seria outra coisa, ou seja, grande possibilidade de tudo funcionar como deveria com relação ao driver óptico. Continuo achando que há algo na virtualização que pode não estar reconhecendo direito seu drive óptico ou algo relativo ao que o agente100gelo chamou a atenção.

O player VLC para mim é o melhor em ralação ao uso de DVDs, pois nele os menus e legendas sempre saíram corretamente aqui comigo, por isso coloquei ele aí no seu comando de instalação de programas multimídias. Já tentou abrir o DVD pelo Mplayer também, eu coloquei no comando também este player?

Offline Esther

  • Usuário Ubuntu
  • *
  • Mensagens: 16
    • Ver perfil
Re: Ubuntu 8.10 intrepid não lê DVDs protegidos
« Resposta #28 Online: 15 de Janeiro de 2009, 22:41 »
Desta vez foi melhor que a anterior em termos de acesso de DVDs?

as opções que antes funcionavam no seu driver óptico continuam funcionando e as que não funcionavam, agora quase que funcionam?

Receio que pouca coisa tenha mudado. CDs de áudio continuam não montando e, dos DVDs protegidos, só um consegue chegar até o ponto de abrir o menu, mas disso não sai.

Citar
Dê uma olhada para mim pelo Synaptic se os pacotes abaixo estão instalados também (além do libdvdcss2):

- libdvdread3
- libdvdnav4

caso algum não esteja instalado, faça a instalação.

libdvdcss2 e libdvdnav4 não estão instalados nem disponíveis para instalação. libdvdread3: já está instalado.

Citar
Agora abra um terminal e digite:

sudo update-alternatives --config totem

Aí você tem de digitar 2 (caso esta opção já não esteja marcada) para usar o totem-xine ao invés do totem-gstreamer, pois é com o totem-xine que você conseguirá usar o Menu do DVD.

Novidade: depois do "2", o Reprodutor de Filmes tentou ler a opção do menu sobre a qual cliquei (no único DVD que chega até o menu) e me deu o seguinte:

Código: [Selecionar]
[b]Ocorreu um erro[/b]

A fonte parece estar criptografada e não pode ser lida. Você está tentando reproduzir um DVD criptografado sem a libdvdcss?

Fui no Synaptic. O resultado da busca por libdvdcss resultou na exibição de um libdvdread3 instalado e mais nada.

Citar
Em relação aqueles links em /dev continuam existindo só o cdrom e o dvd apontando para o scd0 no mesmo local ou desta vez apareceram os links cdrw e dvdrw apontando para o scd0?

Continua havendo só cdrom e dvd apontando para scd0.

Citar
Sei não, acho que o Ubuntu instalado no seu HD seria outra coisa, ou seja, grande possibilidade de tudo funcionar como deveria com relação ao driver óptico. Continuo achando que há algo na virtualização que pode não estar reconhecendo direito seu drive óptico ou algo relativo ao que o agente100gelo chamou a atenção.

Eu bem que tentei instalar o Ubuntu direto em uma segunda partição, inclusive para seguir sua orientação de me desfazer da instalação antiga e criar uma nova. Mas a instalação não foi bem sucedida. Depois de escolher o idioma e o programa de instalação carregar aquela barra laranja na abertura, creio ter havido alguma incompatibilidade entre o Ubuntu e o chipset gráfico ATI Radeon HD 2600 Pro do meu iMac, pois, na hora de entrar com a interface gráfica, a tela ficou preta e nada foi exibido. Fiquei esperando algo acontecer até o CD parar de virar. Certamente o programa de instalação estava esperando uma resposta minha, mas, como nada era exibido na tela, eu não podia dar resposta alguma. Não tive alternativa senão abortar o processo pressionando o botão de força da máquina. O programa de instalação do Ubuntu foi então encerrado (com a barra laranja sendo apagada) e a máquina foi desligada. A instalação só é bem sucedida em meu iMac quando feita via VirtualBox.

Mas, ao contrário de você, continuo achando que se trata de problema de codecs ou pacotes faltando.

Citar
O player VLC para mim é o melhor em ralação ao uso de DVDs, pois nele os menus e legendas sempre saíram corretamente aqui comigo, por isso coloquei ele aí no seu comando de instalação de programas multimídias.

Sei disso, eu já conhecia o VLC. Ainda não contei, mas meu computador anterior ao iMac era um PC no qual eu rodava o Ubuntu 8.04. O sistema não é totalmente estranho para mim e foi por isso que eu quis mantê-lo no iMac. Só acho que episódios como este provam o quão complicadas as coisas podem ser no mundo Linux. No Mac tudo simplesmente funciona. Mas isso é outra história que foge ao tópico.

Citar
Já tentou abrir o DVD pelo Mplayer também, eu coloquei no comando também este player?

Já. Ele tenta ler o DVD e, depois de algum tempo aparentemente congelado, ele dá a seguinte mensagem:

Código: [Selecionar]
Error opening/initializing the selected video_out (-vo) device.
Aguardo as próximas sugestões.

Obrigada por toda sua solicitude.

Offline Esther

  • Usuário Ubuntu
  • *
  • Mensagens: 16
    • Ver perfil
Re: Ubuntu 8.10 intrepid não lê DVDs protegidos
« Resposta #29 Online: 15 de Janeiro de 2009, 22:42 »
Desta vez foi melhor que a anterior em termos de acesso de DVDs?

as opções que antes funcionavam no seu driver óptico continuam funcionando e as que não funcionavam, agora quase que funcionam?

Receio que pouca coisa tenha mudado. CDs de áudio continuam não montando e, dos DVDs protegidos, só um consegue chegar até o ponto de abrir o menu, mas disso não sai.

Citar
Dê uma olhada para mim pelo Synaptic se os pacotes abaixo estão instalados também (além do libdvdcss2):

- libdvdread3
- libdvdnav4

caso algum não esteja instalado, faça a instalação.

libdvdcss2 e libdvdnav4 não estão instalados nem disponíveis para instalação. libdvdread3 já está instalado.

Citar
Agora abra um terminal e digite:

sudo update-alternatives --config totem

Aí você tem de digitar 2 (caso esta opção já não esteja marcada) para usar o totem-xine ao invés do totem-gstreamer, pois é com o totem-xine que você conseguirá usar o Menu do DVD.

Novidade: depois do "2", o Reprodutor de Filmes tentou ler a opção do menu sobre a qual cliquei (no único DVD que chega até o menu) e me deu o seguinte:

Código: [Selecionar]
OCORREU UM ERRO

A fonte parece estar criptografada e não pode ser lida. Você está tentando reproduzir um DVD criptografado sem a libdvdcss?

Fui no Synaptic. O resultado da busca por libdvdcss resultou na exibição de um libdvdread3 instalado e mais nada.

Citar
Em relação aqueles links em /dev continuam existindo só o cdrom e o dvd apontando para o scd0 no mesmo local ou desta vez apareceram os links cdrw e dvdrw apontando para o scd0?

Continua havendo só cdrom e dvd apontando para scd0.

Citar
Sei não, acho que o Ubuntu instalado no seu HD seria outra coisa, ou seja, grande possibilidade de tudo funcionar como deveria com relação ao driver óptico. Continuo achando que há algo na virtualização que pode não estar reconhecendo direito seu drive óptico ou algo relativo ao que o agente100gelo chamou a atenção.

Eu bem que tentei instalar o Ubuntu direto em uma segunda partição, inclusive para seguir sua orientação de me desfazer da instalação antiga e criar uma nova. Mas a instalação não foi bem sucedida. Depois de escolher o idioma e o programa de instalação carregar aquela barra laranja na abertura, creio ter havido alguma incompatibilidade entre o Ubuntu e o chipset gráfico ATI Radeon HD 2600 Pro do meu iMac, pois, na hora de entrar com a interface gráfica, a tela ficou preta e nada foi exibido. Fiquei esperando algo acontecer até o CD parar de virar. Certamente o programa de instalação estava esperando uma resposta minha, mas, como nada era exibido na tela, eu não podia dar resposta alguma. Não tive alternativa senão abortar o processo pressionando o botão de força da máquina. O programa de instalação do Ubuntu foi então encerrado (com a barra laranja sendo apagada) e a máquina foi desligada. A instalação só é bem sucedida em meu iMac quando feita via VirtualBox.

Mas, ao contrário de você, continuo achando que se trata de problema de codecs ou pacotes faltando.

Citar
O player VLC para mim é o melhor em ralação ao uso de DVDs, pois nele os menus e legendas sempre saíram corretamente aqui comigo, por isso coloquei ele aí no seu comando de instalação de programas multimídias.

Sei disso, eu já conhecia o VLC. Ainda não contei, mas meu computador anterior ao iMac era um PC no qual eu rodava o Ubuntu 8.04. O sistema não é totalmente estranho para mim e foi por isso que eu quis mantê-lo no iMac. Só acho que episódios como este provam o quão complicadas as coisas podem ser no mundo Linux. No Mac tudo simplesmente funciona. Mas isso é outra história que foge ao tópico.

Citar
Já tentou abrir o DVD pelo Mplayer também, eu coloquei no comando também este player?

Já. Ele tenta ler o DVD e, depois de algum tempo aparentemente congelado, ele dá a seguinte mensagem:

Código: [Selecionar]
Error opening/initializing the selected video_out (-vo) device.
Aguardo as próximas sugestões.

Obrigada por toda sua solicitude.
« Última modificação: 15 de Janeiro de 2009, 22:48 por Esther »