Autor Tópico: Aceleração 3D  (Lida 6981 vezes)

Offline Luiz Portela

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
Aceleração 3D
« Online: 02 de Janeiro de 2009, 02:55 »
Bom, não sou muito experte em Sistema linux, uso uma versão Ubuntu 8.4 e sempre que tento abrir algum jogo o computador se recusa, ele para no meio do processo, ouvir falar que tenho que fazer uma "Aceleração 3D", mas antes de mais nada, gostaria de saber qual placa de vídeo estou usando, como isso é possivel? Existem outros meios?

Aguardo uma resposta atenciosamente, obrigado.

Offline 0tacon

  • Usuário Ubuntu
  • *
  • Mensagens: 439
    • Ver perfil
Re: Aceleração 3D
« Resposta #1 Online: 02 de Janeiro de 2009, 03:40 »
 Use o comando no terminal:
Citar
lspci
No meu caso, aparece na última linha:
Citar
01:00.0 VGA compatible controller: nVidia Corporation NV44A [GeForce 6200] (reva1)
É uma GeForce 6200 (dããã...).


Offline Luiz Portela

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
Re: Aceleração 3D
« Resposta #2 Online: 02 de Janeiro de 2009, 04:01 »
Hum...

Seria isso?

00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:05.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)



Qual se refere a minha placa de vídeo?

Obrigado.

« Última modificação: 02 de Janeiro de 2009, 04:03 por Luiz Portela »

Offline 0tacon

  • Usuário Ubuntu
  • *
  • Mensagens: 439
    • Ver perfil
Re: Aceleração 3D
« Resposta #3 Online: 02 de Janeiro de 2009, 04:36 »
Citar
Qual se refere a minha placa de vídeo?

 É sempre a linha que diz VGA. No seu caso, a segunda linha:
Citar
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)

 É um vídeo Intel Integrado. O comando para instalar o driver correto deve ser:
Citar
sudo apt-get install xserver-xorg-video-intel
Não se esqueça de que nesse tipo de instalação (driver de vídeo), é bom reiniciar o PC depois de instalar.
 Depois de reiniciar, tente o comando:
 
Citar
sudo glxinfo | grep direct
Se a resposta for direct rendering: yes está tudo certo com seu 3D agora.
 Tente este também:
 
Citar
glxgears
Se as engrenagens rodarem direito, o seu 3D deve estar certo agora.
« Última modificação: 02 de Janeiro de 2009, 04:42 por 0tacon »


Offline Luiz Portela

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
Re: Aceleração 3D
« Resposta #4 Online: 02 de Janeiro de 2009, 14:25 »
Pude executar todos os códigos que você me passou 0tacon, e as seguintes linhas aparecem...

Quando digito o primeiro código aparece:

Citar
sudo apt-get install xserver-xorg-video-intel
Lendo lista de pacotes... Pronto
Construindo árvore de dependências       
Lendo estado da informação... Pronto
xserver-xorg-video-intel já é a versão mais nova.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.

Quando digito o segundo código aparece:

Citar
sudo glxinfo | grep direct
/usr/lib/dri/i915_dri.so: undefined symbol: _glapi_Dispatch
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)

Quando digito o terceiro código aparece:

Citar
glxgears


Pelo que você disse, no caso o meu 3D não está abilitado, pelo fato do direct rendering está escrito "NO".

Oque pode ser feito além disso?

Obrigado.

Offline falecomcyber

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Re: Aceleração 3D
« Resposta #5 Online: 03 de Janeiro de 2009, 04:57 »
Tente o seguinte comando:

sudo dpkg-reconfigure xserver-xorg-video-intel




EDIT:

Depois utilizo o comando:

glxinfo | grep direct

para checar se tudo deu certo  (devera aperecer YES no direct rendering)
« Última modificação: 03 de Janeiro de 2009, 04:59 por falecomcyber »

Offline hco

  • Usuário Ubuntu
  • *
  • Mensagens: 91
    • Ver perfil
Re: Aceleração 3D
« Resposta #6 Online: 09 de Junho de 2009, 23:44 »
Citar
Qual se refere a minha placa de vídeo?

 É sempre a linha que diz VGA. No seu caso, a segunda linha:
Citar
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)

 É um vídeo Intel Integrado. O comando para instalar o driver correto deve ser:
Citar
sudo apt-get install xserver-xorg-video-intel
Não se esqueça de que nesse tipo de instalação (driver de vídeo), é bom reiniciar o PC depois de instalar.
 Depois de reiniciar, tente o comando:
 
Citar
sudo glxinfo | grep direct
Se a resposta for direct rendering: yes está tudo certo com seu 3D agora.
 Tente este também:
 
Citar
glxgears
Se as engrenagens rodarem direito, o seu 3D deve estar certo agora.

Também estou tendo o mesmo problema com essa placa de vídeo. Já segui essas dicas e não funcionou comigo. Você conseguiu resolver esse problema???

Abraços
* hCo *
Usuário Ubuntu

Offline Gunfree

  • Usuário Ubuntu
  • *
  • Mensagens: 208
    • Ver perfil
Re: Aceleração 3D
« Resposta #7 Online: 09 de Junho de 2009, 23:51 »
Linux Registered User: #491793

Offline hco

  • Usuário Ubuntu
  • *
  • Mensagens: 91
    • Ver perfil
Re: Aceleração 3D
« Resposta #8 Online: 10 de Junho de 2009, 09:05 »
Se você usam o Jaunty, tentem: http://br-linux.org/2009/atualizando-os-drivers-de-video-intel-no-ubuntu-jaunty/

Cara valeu pela dica, mas eu já tinha feito isso e não deu certo. Você tem outra idéia???

Abração
* hCo *
Usuário Ubuntu

Offline Gunfree

  • Usuário Ubuntu
  • *
  • Mensagens: 208
    • Ver perfil
Re: Aceleração 3D
« Resposta #9 Online: 10 de Junho de 2009, 10:28 »
Talvez este seu driver esteja blacklistado pelo Compiz... Dá uma olhada nisso, já vi algumas INTEL estarem no blacklist e bastou comentar a linha que o 3d funcionou.
Linux Registered User: #491793

Offline hco

  • Usuário Ubuntu
  • *
  • Mensagens: 91
    • Ver perfil
Re: Aceleração 3D
« Resposta #10 Online: 10 de Junho de 2009, 11:44 »
Talvez este seu driver esteja blacklistado pelo Compiz... Dá uma olhada nisso, já vi algumas INTEL estarem no blacklist e bastou comentar a linha que o 3d funcionou.

Mas então, o 3d está funcionando e até os efeitos do compiz, o problema é que estão muito lentos. Até abri um tópico para isso, mas até agora não houve solução... http://ubuntuforum-br.org/index.php/topic,51451.0.html

Mais alguma idéia???

Muito obrigado.
* hCo *
Usuário Ubuntu

Offline Gunfree

  • Usuário Ubuntu
  • *
  • Mensagens: 208
    • Ver perfil
Re: Aceleração 3D
« Resposta #11 Online: 10 de Junho de 2009, 16:25 »
Desculpe, desatenção minha na resposta anterior. Relendo o tópico inteiro, vi que você tem uma Intel onboard e está lento. Será que não é por falta de memória?

O sintoma é visto apenas no 3D ou tudo fica lento após a ativação dos efeitos/jogos? Dé um top e analise como está o uso de ram e cpu. Experimente olhar também se a placa mãe está esquentando muito prejudicando seu desempenho (us eo comando sensors para isso).

No mais, se tudo aparentemente estiver normal, sugiro que você providencie uma AGP offboard com drivers mais desenvolvidos.
Linux Registered User: #491793

Offline hco

  • Usuário Ubuntu
  • *
  • Mensagens: 91
    • Ver perfil
Re: Aceleração 3D
« Resposta #12 Online: 10 de Junho de 2009, 20:02 »
Desculpe, desatenção minha na resposta anterior. Relendo o tópico inteiro, vi que você tem uma Intel onboard e está lento. Será que não é por falta de memória?

O sintoma é visto apenas no 3D ou tudo fica lento após a ativação dos efeitos/jogos? Dé um top e analise como está o uso de ram e cpu. Experimente olhar também se a placa mãe está esquentando muito prejudicando seu desempenho (us eo comando sensors para isso).

No mais, se tudo aparentemente estiver normal, sugiro que você providencie uma AGP offboard com drivers mais desenvolvidos.

Falta de memória eu tenho certeza que não é, pois tenho 1gb de Ram e o processador é um Dual Core. Cara fiz o seguinte agora, fui na parte de efeitos visuais e tal, e coloquei no modo "Normal", e a lentidão deu uma bela melhorada. Será que o problema está nos efeitos do Compiz então???

Muito obrigado pela ajuda e paciência!!!
* hCo *
Usuário Ubuntu

Offline Gunfree

  • Usuário Ubuntu
  • *
  • Mensagens: 208
    • Ver perfil
Re: Aceleração 3D
« Resposta #13 Online: 11 de Junho de 2009, 01:00 »
Olhe, desculpe, mas ter 1 GB de RAM não quer dizer nada. Note que não estou querendo ser rude, apenas didático.

Perceba que existem várias possibilidades. E sua placa usa a RAM disponível para vídeo.
Um pente seu pode estar ruim, causando leituras erradas, experiemnte um dia que você puder deixar o computador ligado, sem precisar usálo e rode um memtest pelo maior prazo possível.
Outra possibilidade que eu não descartaria é seu o seu sistema maximiza o uso de ram. Faça o top, procure ver se sua máquina está fazendo uso de swap. Se estiver, batata. Está faltando ram ou você está pegando pesado no uso dela...

Mas de qualquer forma, boa sorte para ti.
Linux Registered User: #491793

Offline hco

  • Usuário Ubuntu
  • *
  • Mensagens: 91
    • Ver perfil
Re: Aceleração 3D
« Resposta #14 Online: 11 de Junho de 2009, 16:52 »
Olhe, desculpe, mas ter 1 GB de RAM não quer dizer nada. Note que não estou querendo ser rude, apenas didático.

Perceba que existem várias possibilidades. E sua placa usa a RAM disponível para vídeo.
Um pente seu pode estar ruim, causando leituras erradas, experiemnte um dia que você puder deixar o computador ligado, sem precisar usálo e rode um memtest pelo maior prazo possível.
Outra possibilidade que eu não descartaria é seu o seu sistema maximiza o uso de ram. Faça o top, procure ver se sua máquina está fazendo uso de swap. Se estiver, batata. Está faltando ram ou você está pegando pesado no uso dela...

Mas de qualquer forma, boa sorte para ti.

Eu entendi o que quis dizer, mas acredito que não seja o problema do pente de memória. Pois já usei o Ubuntu com 512 de Ram e não tive esse problema. Sem contar que também tenho o Windows instalado e não ocorre esse tipo de problema. Ah, tenho apenas 1 pente de 1gb.

Fiz o top e o uso da swap aparece zerado. Só não consegui entender o quanto está usando da minha memória.

Citar
top - 16:46:58 up 27 min,  2 users,  load average: 0.29, 0.45, 0.46
Tasks: 131 total,   1 running, 130 sleeping,   0 stopped,   0 zombie
Cpu(s):  4.7%us,  1.3%sy,  0.0%ni, 94.0%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:   1018172k total,   954372k used,    63800k free,    77992k buffers
Swap:   979924k total,        0k used,   979924k free,   578048k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND           
 3221 hco       20   0  230m  45m  22m S    6  4.6   1:18.18 rhythmbox         
 3027 hco       20   0  156m 5524 4176 S    3  0.5   0:33.94 pulseaudio         
 3298 hco       20   0  298m 113m  31m S    2 11.4   3:17.98 firefox           
 2559 root      20   0  285m  19m  11m S    1  2.0   1:02.44 Xorg               
 3125 hco       20   0 96248  22m 7804 S    1  2.2   0:10.24 compiz.real       
 4032 hco       20   0 39840  16m  10m S    1  1.6   0:03.62 gnome-terminal     
 3059 hco       20   0 30680 9.8m 7000 S    0  1.0   0:00.57 gnome-settings-   
 3148 hco       20   0 21408 8612 5896 S    0  0.8   0:02.08 parcellite         
 4077 hco       20   0  2448 1188  912 R    0  0.1   0:00.28 top               
    1 root      20   0  3084 1884  564 S    0  0.2   0:01.38 init               
    2 root      15  -5     0    0    0 S    0  0.0   0:00.00 kthreadd           
    3 root      RT  -5     0    0    0 S    0  0.0   0:00.00 migration/0       
    4 root      15  -5     0    0    0 S    0  0.0   0:00.09 ksoftirqd/0       
    5 root      RT  -5     0    0    0 S    0  0.0   0:00.00 watchdog/0         
    6 root      RT  -5     0    0    0 S    0  0.0   0:00.00 migration/1       
    7 root      15  -5     0    0    0 S    0  0.0   0:00.08 ksoftirqd/1       
    8 root      RT  -5     0    0    0 S    0  0.0   0:00.00 watchdog/1

No monitor do sistema, o uso de memória não passa de 350mb, isso quando tenho muitas abas abertas no firefox.

Mas agradeço muito sua ajuda Gunfree!!!
* hCo *
Usuário Ubuntu