Autor Tópico: Problemas com som no EnemyTerritory  (Lida 4016 vezes)

Offline peterson

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Problemas com som no EnemyTerritory
« Online: 11 de MAR?O de 2006, 23:43 »
olá a todos!

Tive um problema no jogo ET: não funcionava o som de jeito nenhum. Procurei várias soluções no Google e achei uma que dá certo mas não me agrada muito:

no console, digitar:
$ killall -9 esd

Notei que fazendo isso o SO fica sem som. Por isso não me agrada.

Alguém achou uma solução melhor?

Offline JeffersonX

  • Usuário Ubuntu
  • *
  • Mensagens: 442
  • Linux User: #364092
    • Ver perfil
Problemas com som no EnemyTerritory
« Resposta #1 Online: 12 de MAR?O de 2006, 08:03 »
Oh, eu achei uma solução melhor, mas talvez possa não ser a mais viável, pois envolve grana... hehe Eu peguei uma Creative Live 5.1. Ela suporte mixagem via hardware sem ter que configurar nada. Com isso não uso mais Arts, Dmix ou ESD. Hoje é muito difícil encontrar ela, mas tem a Audigy que é ainda melhor e também é capaz de fazer isso. Só digo que o som de uma Creative no Linux é simplesmente puro!!

As placas que vem com Nvidia Soundstorm onboard também tem suporte a hardware mixing, porém deve instalar o driver da Nforce que está disponível no site da Nvidia. Sem ele também não há como usar o hardware mixing.

Outra solução seria você pesquisar na net sobre configuração do Dmix. Ele é uma espécie de plugin do Alsa para fazer que o próprio servidor de som faça a mixagem dos sons sem usar outro servidor de som para esta tarefa. Com isso a mixagem não pesa nada e tem boa qualidade.
Um bom guia de Dmix que já usei é esse do Gentoo Wiki:
http://gentoo-wiki.com/HOWTO_ALSA_sound_mixer_aka_dmix
Linux Professional Institute Certified - Level 1, Novell CLA - Certified Linux Administrator, Microsoft Certified Professional - Windows Server 2003, ITIL Foundation Certified
Meu Blog: http://tibyjeffersonx.blogspot.com