Autor Tópico: notebook não desliga nem reinicia no ubuntu 8.10  (Lida 28267 vezes)

Offline superbr

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: notebook não desliga nem reinicia no ubuntu 8.10
« Resposta #15 Online: 03 de Novembro de 2008, 11:26 »
Uma dica que achei na net foi a seguinte.
Ainda não testei mas se tiver algo a ver com o alsa e a rede acho que vai funcionar.

Edite o arquivo /etc/init.d/alsa-utils

sudo gedit /etc/init.d/alsa-utils

Após o texto “stop)” no arquivo (aproximadamente na linha 353), adicione:

ifconfig wlan0 down
ifconfig eth0 down

Então o arquivo deve ficar assim:
stop)
ifconfig wlan0 down
ifconfig eth0 down
EXITSTATUS=0

Com isso o problema foi resolvido e agora o Ubuntu desliga e reinicia normalmente. :D

Essa dica foi de um cara chamado Rodrigo Lazoti

Offline JCS

  • Usuário Ubuntu
  • *
  • Mensagens: 52
    • Ver perfil
Re: notebook não desliga nem reinicia no ubuntu 8.10
« Resposta #16 Online: 03 de Novembro de 2008, 17:21 »
Tô com o mesmo problema aqui numa placa mãe ASUS P4V8X-X. Vou tentar a dica acima e ver se funciona.
Hack to learn, not learn to hack

Offline JCS

  • Usuário Ubuntu
  • *
  • Mensagens: 52
    • Ver perfil
Re: notebook não desliga nem reinicia no ubuntu 8.10
« Resposta #17 Online: 04 de Novembro de 2008, 01:19 »
Valeu! Funcionou aqui!  :D
Hack to learn, not learn to hack

Offline Becker

  • Usuário Ubuntu
  • *
  • Mensagens: 309
  • Por tanto tempo quanto dura a eternidade
    • Ver perfil
Re: notebook não desliga nem reinicia no ubuntu 8.10
« Resposta #18 Online: 04 de Novembro de 2008, 16:59 »
Não funcionou.
Continua o problema, e o jeito é apertar o botão para desligar e alguns casos usar o clássico alt +ctrl + del do bill.

Offline hedertone

  • Usuário Ubuntu
  • *
  • Mensagens: 72
    • Ver perfil
Re: notebook não desliga nem reinicia no ubuntu 8.10
« Resposta #19 Online: 04 de Novembro de 2008, 17:30 »
para desligar é só substituir o acpi=off por acpi=force

Offline adcoutinho

  • Usuário Ubuntu
  • *
  • Mensagens: 33
    • Ver perfil
Re: notebook não desliga nem reinicia no ubuntu 8.10
« Resposta #20 Online: 04 de Novembro de 2008, 18:46 »
;D ;D ;D ;D
Resolvido no meu:

No meu aqui a dica do Usuario superbr funcionou perfeitamente

stop)
ifconfig wlan0 down
ifconfig eth0 down
EXITSTATUS=0

, nem precisei de colocar no menu.lst o acpi=force.

Obrigado a todos que me ajudaram a resolver meu problema. ;D ;D ;D ;D

Offline rlazoti

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: notebook não desliga nem reinicia no ubuntu 8.10
« Resposta #21 Online: 05 de Novembro de 2008, 00:30 »
Uma dica que achei na net foi a seguinte.
Ainda não testei mas se tiver algo a ver com o alsa e a rede acho que vai funcionar.

Edite o arquivo /etc/init.d/alsa-utils

sudo gedit /etc/init.d/alsa-utils

Após o texto “stop)” no arquivo (aproximadamente na linha 353), adicione:

ifconfig wlan0 down
ifconfig eth0 down

Então o arquivo deve ficar assim:
stop)
ifconfig wlan0 down
ifconfig eth0 down
EXITSTATUS=0

Com isso o problema foi resolvido e agora o Ubuntu desliga e reinicia normalmente. :D

Essa dica foi de um cara chamado Rodrigo Lazoti


É isso ai galera...
eu encontrei essa dica e coloquei no meu blog para compartilhar...
comigo funcionou...

[]'s
Rodrigo Lazoti.
http://www.rodrigolazoti.com.br

Offline cholletao

  • Usuário Ubuntu
  • *
  • Mensagens: 117
    • Ver perfil
Re: notebook não desliga nem reinicia no ubuntu 8.10
« Resposta #22 Online: 05 de Novembro de 2008, 04:57 »
voltei pro 8.04 LTS...
Pelo menos com ele só tenho o problema para reiniciar.
Bom, se a 9.04 não resolver meu problema, vou atrás de outra distribuição.
Queria ir pro BigLinux, mas KDE não dá =/

e por que nao instala o gnome entao?
Ubuntu user # 17886

Linux Registered user # 455957

Offline Becker

  • Usuário Ubuntu
  • *
  • Mensagens: 309
  • Por tanto tempo quanto dura a eternidade
    • Ver perfil
Re: notebook não desliga nem reinicia no ubuntu 8.10
« Resposta #23 Online: 05 de Novembro de 2008, 20:18 »
Abri o arquivo e não tem nenhuma acpi=off para mudar, nem existe a palavra acpi.

E agora?
Continua sem solução.

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: notebook não desliga nem reinicia no ubuntu 8.10
« Resposta #24 Online: 05 de Novembro de 2008, 20:32 »
Abri o arquivo e não tem nenhuma acpi=off para mudar, nem existe a palavra acpi.

E agora?
Continua sem solução.

se não tem, coloque fazendo antes um back up do menu.lst

Exemplo:

DE
Citar
## ## End Default Options ##

title      Ubuntu 8.04.1, kernel 2.6.24-21-eeepc
root      (hd0,0)
kernel      /boot/vmlinuz-2.6.24-21-eeepc root=UUID=3a2e73ef-6e13-45aa-a259-d1f6a61797f7 ro locale=pt_BR
initrd      /boot/initrd.img-2.6.24-21-eeepc
quiet

PARA
Citar
## ## End Default Options ##

title      Ubuntu 8.04.1, kernel 2.6.24-21-eeepc
root      (hd0,0)
kernel      /boot/vmlinuz-2.6.24-21-eeepc root=UUID=3a2e73ef-6e13-45aa-a259-d1f6a61797f7 ro acpi=off locale=pt_BR
initrd      /boot/initrd.img-2.6.24-21-eeepc
quiet


Caso não funcione veja no meu tutorial eeepc aqui no forum que eu explico como desligar o acpi do alsa no desligamento/restart.

[],s

Offline Becker

  • Usuário Ubuntu
  • *
  • Mensagens: 309
  • Por tanto tempo quanto dura a eternidade
    • Ver perfil
Re: notebook não desliga nem reinicia no ubuntu 8.10
« Resposta #25 Online: 05 de Novembro de 2008, 21:36 »
Não  funcionou.
Voltei o backup do menu, mas agora nem o som funciona.
O meu menu esta assim:
# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not use 'savedefault' or your
# array will desync and will not let you boot your system.
default      0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout      10

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
#hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title      Windows 95/98/NT/2000
# root      (hd0,0)
# makeactive
# chainloader   +1
#
# title      Linux
# root      (hd0,1)
# kernel   /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=a14b1658-03a8-4fa0-88b4-5cf20083ba98 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,1)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## should update-grub lock old automagic boot options
## e.g. lockold=false
##      lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title      Ubuntu 8.10, kernel 2.6.27-3-rt
root      (hd0,1)
kernel      /boot/vmlinuz-2.6.27-3-rt root=UUID=a14b1658-03a8-4fa0-88b4-5cf20083ba98 ro quiet splash
initrd      /boot/initrd.img-2.6.27-3-rt
quiet

title      Ubuntu 8.10, kernel 2.6.27-3-rt (recovery mode)
root      (hd0,1)
kernel      /boot/vmlinuz-2.6.27-3-rt root=UUID=a14b1658-03a8-4fa0-88b4-5cf20083ba98 ro  single
initrd      /boot/initrd.img-2.6.27-3-rt

title      Ubuntu 8.10, kernel 2.6.24-21-rt
root      (hd0,1)
kernel      /boot/vmlinuz-2.6.24-21-rt root=UUID=a14b1658-03a8-4fa0-88b4-5cf20083ba98 ro quiet splash
initrd      /boot/initrd.img-2.6.24-21-rt
quiet

title      Ubuntu 8.10, kernel 2.6.24-21-rt (recovery mode)
root      (hd0,1)
kernel      /boot/vmlinuz-2.6.24-21-rt root=UUID=a14b1658-03a8-4fa0-88b4-5cf20083ba98 ro  single
initrd      /boot/initrd.img-2.6.24-21-rt

title      Ubuntu 8.10, memtest86+
root      (hd0,1)
kernel      /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title      Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title      Windows Vista/Longhorn (loader)
root      (hd0,0)
savedefault
makeactive
chainloader   +1


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda3
title      Windows Vista/Longhorn (loader)
root      (hd0,2)
savedefault
makeactive
chainloader   +1

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: notebook não desliga nem reinicia no ubuntu 8.10
« Resposta #26 Online: 05 de Novembro de 2008, 21:52 »
Bem, o som não tem absolutamente nada a ver com o menu.lst. Voce deve ter mudado algo antes de alterar o menu.lst para o som não funcionar mais.

porém, lendo o que os outros escreveram, experimente acpi=force da mesma maneira que voce acrescentou acpi=off.

voce pode também apagar os comandos => quiet splash ( o ultimo quiet não, só o que esta após o "ro".) isto vai retirar a tela de progresso do Ubuntu, deixando voce ver o que está sendo carregado/descarregado, onde travar, é o modulo com problema.

[],s

Offline Becker

  • Usuário Ubuntu
  • *
  • Mensagens: 309
  • Por tanto tempo quanto dura a eternidade
    • Ver perfil
Re: notebook não desliga nem reinicia no ubuntu 8.10
« Resposta #27 Online: 05 de Novembro de 2008, 22:13 »
Obrigado Tota.
Pela paciência.
Eu sou inexperiente no linux.
Usei o modo recovery e consegui fazer o som voltar.
Mas vou tentar acertar com mais calma.
Devo ter errado em alguma coisa na hora de inserir o comando.
Estou testando o ubuntu studio e experimentando, já fiz muitas loucuras e o sistema ainda esta funcionando, só não reinicia e nem desliga sózinho depois da atualização de 8.04 para 8.10.
Te tanto que já fuçei e experimentei o melhor mesmo daqui mais um tempo  é reinstalar tudo.
Quando peço para o computador desligar, o último comando que fica pendente é o do acpi.
Talvez eu tenha que esperar um pouco mais.

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: notebook não desliga nem reinicia no ubuntu 8.10
« Resposta #28 Online: 05 de Novembro de 2008, 22:28 »
Se for o acpi

1.Para contornar, edite o arquivo:

Código: [Selecionar]
sudo gedit /etc/default/halt


2.acrescente o comando:

Código: [Selecionar]
rmmod acpi

3.Salve e feche.


reboote e veja se resolve.( no proximo reboot )


se não resolver, desfaça.

[],s

Offline Becker

  • Usuário Ubuntu
  • *
  • Mensagens: 309
  • Por tanto tempo quanto dura a eternidade
    • Ver perfil
Re: notebook não desliga nem reinicia no ubuntu 8.10
« Resposta #29 Online: 05 de Novembro de 2008, 23:21 »
Tentei todas as opções e não adianta nada.
Pelo que vi na tela:
Quando tento desligar aparece a seguinte mensagem:
will now halt

Quando tento reiniciar aparece:
wil now restart

Mas só fica o cursor piscando.
Observei na tela que aparentemente todos os programas ou modulos vão se fechando normalmente, a única coisa que observei, mas penso que não é problema é que no relógio ele não dá ok, mas não mostra nenhuma linha indicando algum problema.
Li em algum lugar, que muitas bios de sistema foram feitas para funcionar somente no windows vista, e assim dão problemas no linux, pode ser?
De qualquer forma , como diz aquela música, a gente vai levando, vai levando...
Obrigado pela ajuda.