Autor Tópico: Teclado ABNT 2 no ubuntu 8.10  (Lida 28084 vezes)

Offline AFF

  • Usuário Ubuntu
  • *
  • Mensagens: 87
    • Ver perfil
Re: Teclado ABNT 2 no ubuntu 8.10
« Resposta #15 Online: 16 de Novembro de 2008, 00:17 »
Pessoal,
Também passei a ter o problema da tecla "." depois da última atualização. Resolvi o problema alterando o modelo do teclado para "ACPI Padrão", disposição "Brasil". Aparentemente não tenho tido mais problema algum.

Offline Felix

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 3.068
    • Ver perfil
    • Alexsandro Felix
Re: Teclado ABNT 2 no ubuntu 8.10
« Resposta #16 Online: 16 de Novembro de 2008, 10:53 »
Tive esse bendito problema hoje, no meu teclado ABNT2 consegui a solução, já coloquei até no blog. Se alguém precisar de ajuda, tamos aí!

Felix,

segui suas instruções. Funcionou quando eu executo o script manualmente assim...

Código: [Selecionar]
carlos@anakin:~$ sudo sh /etc/init.d/keymap_modifier-abnt_numpad_dot.sh
Mas quandu eu ligo o PC o problema volta. Tornei ele executável e também já tentei adicionar um "!/usr/bin" no início do arquivo. Tenho a impressão de que ele não é executado no boot ou algum outro script que é executado depois dele faz o problema voltar...

Tente colocar um #!/bin/bash no início do arquivo, isso deve resolver

Offline carloshiga

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
Re: Teclado ABNT 2 no ubuntu 8.10
« Resposta #17 Online: 16 de Novembro de 2008, 15:27 »
Também não adiantou. Meu script keymap_modifier-abnt_numpad_dot.sh está assim:

Código: [Selecionar]
#!/bin/bash

xmodmap -e "keycode 129 = period"
xmodmap -e "keycode 60 = period greater"
xmodmap -e "keycode 62 = Shift_R"
xmodmap -e "keycode 46 = l"

Offline Felix

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 3.068
    • Ver perfil
    • Alexsandro Felix
Re: Teclado ABNT 2 no ubuntu 8.10
« Resposta #18 Online: 16 de Novembro de 2008, 20:36 »
Também não adiantou. Meu script keymap_modifier-abnt_numpad_dot.sh está assim:

Código: [Selecionar]
#!/bin/bash

xmodmap -e "keycode 129 = period"
xmodmap -e "keycode 60 = period greater"
xmodmap -e "keycode 62 = Shift_R"
xmodmap -e "keycode 46 = l"

Estranho... aqui funcionou normalmente. Na verdade qdo iniciei o micro ele perdeu as configurações, mas quando rodei o script voltou ao normal

Offline carloshiga

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
Re: Teclado ABNT 2 no ubuntu 8.10
« Resposta #19 Online: 16 de Novembro de 2008, 20:42 »
Também não adiantou. Meu script keymap_modifier-abnt_numpad_dot.sh está assim:

Código: [Selecionar]
#!/bin/bash

xmodmap -e "keycode 129 = period"
xmodmap -e "keycode 60 = period greater"
xmodmap -e "keycode 62 = Shift_R"
xmodmap -e "keycode 46 = l"

Estranho... aqui funcionou normalmente. Na verdade qdo iniciei o micro ele perdeu as configurações, mas quando rodei o script voltou ao normal

Sim, é isso que acontece, quando eu reinicio o micro tenho que rodar o script novamente. Mas eu queria q ele fosse rodado durante o boot. Tentei usar o comando update-rc.d mas não funcionou:

Código: [Selecionar]
sudo update-rc.d keymap_modifier-abnt_numpad_dot.sh defaults

Offline danpos

  • Usuário Ubuntu
  • *
  • Mensagens: 386
    • Ver perfil
Re: Teclado ABNT 2 no ubuntu 8.10
« Resposta #20 Online: 17 de Novembro de 2008, 10:26 »
@all

Para tanto basta colocar as instruções no /etc/rc.local conforme instruções lá presentes. ;)

Danpos.

Offline Felix

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 3.068
    • Ver perfil
    • Alexsandro Felix
Re: Teclado ABNT 2 no ubuntu 8.10
« Resposta #21 Online: 17 de Novembro de 2008, 12:12 »
Tive um comentário no blog com outra sugestão:

Código: [Selecionar]
sudo setxkbmap -model pc104 -layout br -variant abnt2

Estou no trabalho agora sem Ubuntu, por isso não testei, a dica foi passada pelo Alan.

Offline carloshiga

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
Re: Teclado ABNT 2 no ubuntu 8.10
« Resposta #22 Online: 17 de Novembro de 2008, 19:37 »
@all

Para tanto basta colocar as instruções no /etc/rc.local conforme instruções lá presentes. ;)

Danpos.

O meu rc.local está assim:

Código: [Selecionar]
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

xmodmap -e "keycode 129 = period"
xmodmap -e "keycode 60 = period greater"
xmodmap -e "keycode 62 = Shift_R"
xmodmap -e "keycode 46 = l"

exit 0

E as permissões assim:

Código: [Selecionar]
-rwxr-xr-x 1 root root 444 2008-11-17 18:10 rc.local
E não funcinou... Alguma idéia do que possa ser?

Offline danpos

  • Usuário Ubuntu
  • *
  • Mensagens: 386
    • Ver perfil
Re: Teclado ABNT 2 no ubuntu 8.10
« Resposta #23 Online: 17 de Novembro de 2008, 22:26 »
@carloshiga

OK, não ficou tão claro: eu me referi ao script

Código: [Selecionar]
keymap_modifier-abnt_numpad_dot.sh
Agora pensando bem, seria mais simples salvar este script em uma de suas pastas de seu usuário (com permissão de execução) e então colocar para iniciar junto com a tua sessão Gnome (Sistema -> Preferências -> Sessões) ;)

Danpos.

Offline RC2006

  • Usuário Ubuntu
  • *
  • Mensagens: 822
  • Ubuntu 10.10
    • Ver perfil
Re: Teclado ABNT 2 no ubuntu 8.10
« Resposta #24 Online: 19 de Novembro de 2008, 08:41 »
No meu caso, resolvi da seguinte forma:
Sistema -> Preferências -> Teclado -> Troquei em Modelo de teclado para fabricante Generic e modelo Genérico 102 teclas (Intl) PC
HP All-in-one 4GB HD760 - windows7 home premium - Netbook Asus 1005PEB - Windows 7 - Ubuntu 11.04
Macbook branco 13.3" 2gb 160HD - Mac OS X 10.6 - Tablet Asus Eee Pad Transformer com dock - Android 3.2

Offline carloshiga

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
Re: Teclado ABNT 2 no ubuntu 8.10
« Resposta #25 Online: 19 de Novembro de 2008, 16:06 »
É... esta solução é mais fácil!  :)

Offline clovis

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re: Teclado ABNT 2 no ubuntu 8.10
« Resposta #26 Online: 19 de Novembro de 2008, 19:24 »
Estava com o mesmo problema, pesquisando aqui mesmo encontrei a solução.

Acesse o Link abaixo e tudo se resolve:

http://ubuntuforum-pt.org/index.php?topic=42941.0