Autor Tópico: Tutorial para HSP56 MR driver Smartlink  (Lida 1170138 vezes)

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1035 Online: 18 de Maio de 2009, 18:01 »
Novo pacote para ativação de modem no Ubuntu 9.04 Jaunty Jackalope 32bits - EXPERIMENTAL


O procedimento de instalação é igual ao outros pacotes que já fiz e para saber isso, para quem ainda não conhece basta fazer o download pelo outro sistema operacional, depois levar para o Ubuntu e colocar na sua pasta de usuário dentro da pasta home, depois basta descompactar o pacote clicando nele com o botão direito do mouse e escolhendo a opção extrair aqui, será criada uma pasta chamada de modem-arquivos-v30 dentro da sua pasta de usuário na pasta home, entre nela e leia os arquivos Leia-me.txt (resumido) e o guia_instalação.pdf (completo com ilustrações).

O link do pacote modem-arquivos-v30.tar.gz é esse:

http://www.4shared.com/file/102272939/5cc0c002/modem-arquivos-v30tar.html?dirPwdVerified=33e0a9ae


OBS: Qualquer erro por favor anotem e relatem aqui, pois este driver smartlink é o mais novo e portanto não garantido que funcione.

Atenção: Percebi que nesta nova versão do Ubuntu não há mais o aplicativo wvdial instalado por padrão, pelo menos aqui no meu sistema ele não instalou como nas versões anteriores. Então caso vocês instalem o meu pacote e que não tenha instalado ele do CD durante o processo de instalação do pacote como uma possível dependência do discador gnome-ppp, então antes de instalar o meu pacote, baixem o wvdial daqui:

http://packages.ubuntu.com/jaunty/wvdial

Notem que ele possui outros pacotes como dependência, portanto se não instalar somente baixando o wvdial, ou seja, se as dependências informadas não estiverem já instaladas no seu sistema, então vocês terão de baixar as que tiverem faltando ok.
             
car conseguyi instalar porem ele nao conecta da sinal da dicagem depois cai ele simplismente nao conecta mais o modem já foi detectado da uma ajuda

Afinal de contas você usa o Ubuntu 9.04 32bits ou o Ubuntu 8.10 32bits?

o v30 é somente para o Ubuntu 9.04 sendo o v29 para o Ubuntu 8.10.

Veja o que falei mais acima e verifique e cole aqui tudo que foi pedido por lá.

Offline dtomadon

  • Usuário Ubuntu
  • *
  • Mensagens: 591
  • Fatec SCS,Segurança da Informação, BackTrack5
    • Ver perfil
    • Computação Forense e suas Leis
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1036 Online: 18 de Maio de 2009, 23:47 »
Abra um terminal e digite o seguinte comando   sudo /etc/init.d/sl-modem-daemon status   e cole o resultado aqui.
Uma sugestão , quando vc usar o pacote do alarcon, toda a instalação gera um texto no terminal, copia esse texto e cola aqui, ficara muito mais fácil resolver seu problema.

essa resposta não foi pra mim né?

não foi para o nosso colega raimundo1
BacKTrack5 64 bits com Vídeo SIS

kernel omnislash 1.4.4 64 bits , Que venha o 5º Semestre !!!

Offline jaguarsouza

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1037 Online: 19 de Maio de 2009, 08:27 »
Novo pacote para ativação de modem no Ubuntu 9.04 Jaunty Jackalope 32bits - EXPERIMENTAL


O procedimento de instalação é igual ao outros pacotes que já fiz e para saber isso, para quem ainda não conhece basta fazer o download pelo outro sistema operacional, depois levar para o Ubuntu e colocar na sua pasta de usuário dentro da pasta home, depois basta descompactar o pacote clicando nele com o botão direito do mouse e escolhendo a opção extrair aqui, será criada uma pasta chamada de modem-arquivos-v30 dentro da sua pasta de usuário na pasta home, entre nela e leia os arquivos Leia-me.txt (resumido) e o guia_instalação.pdf (completo com ilustrações).

O link do pacote modem-arquivos-v30.tar.gz é esse:

http://www.4shared.com/file/102272939/5cc0c002/modem-arquivos-v30tar.html?dirPwdVerified=33e0a9ae


OBS: Qualquer erro por favor anotem e relatem aqui, pois este driver smartlink é o mais novo e portanto não garantido que funcione.

Atenção: Percebi que nesta nova versão do Ubuntu não há mais o aplicativo wvdial instalado por padrão, pelo menos aqui no meu sistema ele não instalou como nas versões anteriores. Então caso vocês instalem o meu pacote e que não tenha instalado ele do CD durante o processo de instalação do pacote como uma possível dependência do discador gnome-ppp, então antes de instalar o meu pacote, baixem o wvdial daqui:

http://packages.ubuntu.com/jaunty/wvdial

Notem que ele possui outros pacotes como dependência, portanto se não instalar somente baixando o wvdial, ou seja, se as dependências informadas não estiverem já instaladas no seu sistema, então vocês terão de baixar as que tiverem faltando ok.
             
car conseguyi instalar porem ele nao conecta da sinal da dicagem depois cai ele simplismente nao conecta mais o modem já foi detectado da uma ajuda

Afinal de contas você usa o Ubuntu 9.04 32bits ou o Ubuntu 8.10 32bits?

o v30 é somente para o Ubuntu 9.04 sendo o v29 para o Ubuntu 8.10.

Veja o que falei mais acima e verifique e cole aqui tudo que foi pedido por lá.
o arquivo  slmodemd nao existe  em /usr/sbin  e quando reinicia o pc  o modem nao é mais detectado porem se eu instalar novamente ele volta a funcionar  como faco para ele ser detectado apos  a intalacao  mesmo reiniciando ?Ubuntu 9.04 32bits    reultado do terminal =
jaguar@jaguar-desktop:~$ cd modem-arquivos-v30
jaguar@jaguar-desktop:~/modem-arquivos-v30$ sudo su
[sudo] password for jaguar:
root@jaguar-desktop:/home/jaguar/modem-arquivos-v30# chmod +x install-modem_Gnome
root@jaguar-desktop:/home/jaguar/modem-arquivos-v30# ./install-modem_Gnome
Usando ponto de montagem de CD-ROM /cdrom/
Desmontando CD-ROM
Aguardando por disco...
Por favor, insira um Disco na unidade e pressione enter
Montando CD-ROM...
Identificando.. [0ddc3e464ef646872b157b6ee0d2b473-2]
Procurando por arquivos de índice no disco..
Encontrado(s) 2 índice(s) de pacote(s), 0 índice(s) de fonte(s), 0 índice(s) de traduções e 1 assinatura(s)
Esse disco é chamado:
'Ubuntu 9.04 _Jaunty Jackalope_ - Release i386 (20090420.1)'
Copiando lista de pacotes...gpgv: Assinatura feita Seg 20 Abr 2009 11:30:13 BRT usando DSA chave ID FBB75451
gpgv: Assinatura correta de "Ubuntu CD Image Automatic Signing Key <cdimage@ubuntu.com>"
Reading Package Indexes... Pronto
Gravando nova lista de fontes
Entradas na lista de fontes para este disco são:
deb cdrom:[Ubuntu 9.04 _Jaunty Jackalope_ - Release i386 (20090420.1)]/ jaunty main restricted
Desmontando CD-ROM...
Repita este processo para o restante dos CDs em seu conjunto.
W: Skipping non-exisiting file /cdrom/dists/jaunty/main/binary-i386/Packages
W: Skipping non-exisiting file /cdrom/dists/jaunty/restricted/binary-i386/Packages

Make|Gcc|Build-Essential|Linux-Headers-2.6.28-11-generic|Libasound2|Gnome-PPP|Ungrab-Winmodem|Slmodem-2.9.11-20090222|Sl-Modem-Daemon|Dialup
Lendo listas de pacotes... Pronto
Construindo árvore de dependências      
Lendo informação de estado... Pronto
make já é a versão mais nova.
Você deve querer executar 'apt-get -f install' para corrigí-los:
Os pacotes a seguir têm dependências desencontradas:
  alsa-utils: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  bluez-alsa: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  gnome-ppp: Depende: libgnutls11 (>= 1.0.16) mas não é instalável
             Depende: libtasn1-2 (>= 0.2. 8 mas não é instalável
  gstreamer0.10-alsa: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  libasound2-plugins: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  libcanberra0: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  libesd-alsa0: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  libportaudio2: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  libpt2.6.1-plugins-alsa: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  libsdl1.2debian-alsa: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  libvisual-0.4-plugins: Depende: libasound2 (> 1.0.17) mas 1.0.10-2 está para ser instalado
  pulseaudio: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  rdesktop: Depende: libasound2 (> 1.0.16) mas 1.0.10-2 está para ser instalado
  sl-modem-daemon: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
E: Dependências desencontradas. Tente 'apt-get -f install' sem nenhum pacote (ou especifique uma solução).
Make|Gcc|Build-Essential|Linux-Headers-2.6.28-11-generic|Libasound2|Gnome-PPP|Ungrab-Winmodem|Slmodem-2.9.11-20090222|Sl-Modem-Daemon|Dialup
Lendo listas de pacotes... Pronto
Construindo árvore de dependências      
Lendo informação de estado... Pronto
gcc já é a versão mais nova.
Você deve querer executar 'apt-get -f install' para corrigí-los:
Os pacotes a seguir têm dependências desencontradas:
  alsa-utils: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  bluez-alsa: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  gnome-ppp: Depende: libgnutls11 (>= 1.0.16) mas não é instalável
             Depende: libtasn1-2 (>= 0.2. 8 mas não é instalável
  gstreamer0.10-alsa: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  libasound2-plugins: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  libcanberra0: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  libesd-alsa0: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  libportaudio2: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  libpt2.6.1-plugins-alsa: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  libsdl1.2debian-alsa: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  libvisual-0.4-plugins: Depende: libasound2 (> 1.0.17) mas 1.0.10-2 está para ser instalado
  pulseaudio: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  rdesktop: Depende: libasound2 (> 1.0.16) mas 1.0.10-2 está para ser instalado
  sl-modem-daemon: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
E: Dependências desencontradas. Tente 'apt-get -f install' sem nenhum pacote (ou especifique uma solução).
Make|Gcc|Build-Essential|Linux-Headers-2.6.28-11-generic|Libasound2|Gnome-PPP|Ungrab-Winmodem|Slmodem-2.9.11-20090222|Sl-Modem-Daemon|Dialup
Lendo listas de pacotes... Pronto
Construindo árvore de dependências      
Lendo informação de estado... Pronto
build-essential já é a versão mais nova.
Você deve querer executar 'apt-get -f install' para corrigí-los:
Os pacotes a seguir têm dependências desencontradas:
  alsa-utils: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  bluez-alsa: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  gnome-ppp: Depende: libgnutls11 (>= 1.0.16) mas não é instalável
             Depende: libtasn1-2 (>= 0.2. 8 mas não é instalável
  gstreamer0.10-alsa: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  libasound2-plugins: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  libcanberra0: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  libesd-alsa0: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  libportaudio2: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  libpt2.6.1-plugins-alsa: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  libsdl1.2debian-alsa: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  libvisual-0.4-plugins: Depende: libasound2 (> 1.0.17) mas 1.0.10-2 está para ser instalado
  pulseaudio: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  rdesktop: Depende: libasound2 (> 1.0.16) mas 1.0.10-2 está para ser instalado
  sl-modem-daemon: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
E: Dependências desencontradas. Tente 'apt-get -f install' sem nenhum pacote (ou especifique uma solução).
Make|Gcc|Build-Essential|Linux-Headers-2.6.28-11-generic|Libasound2|Gnome-PPP|Ungrab-Winmodem|Slmodem-2.9.11-20090222|Sl-Modem-Daemon|Dialup
Lendo listas de pacotes... Pronto
Construindo árvore de dependências      
Lendo informação de estado... Pronto
linux-headers-2.6.28-11-generic já é a versão mais nova.
Você deve querer executar 'apt-get -f install' para corrigí-los:
Os pacotes a seguir têm dependências desencontradas:
  alsa-utils: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  bluez-alsa: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  gnome-ppp: Depende: libgnutls11 (>= 1.0.16) mas não é instalável
             Depende: libtasn1-2 (>= 0.2. 8 mas não é instalável
  gstreamer0.10-alsa: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  libasound2-plugins: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  libcanberra0: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  libesd-alsa0: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  libportaudio2: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  libpt2.6.1-plugins-alsa: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  libsdl1.2debian-alsa: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  libvisual-0.4-plugins: Depende: libasound2 (> 1.0.17) mas 1.0.10-2 está para ser instalado
  pulseaudio: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
  rdesktop: Depende: libasound2 (> 1.0.16) mas 1.0.10-2 está para ser instalado
  sl-modem-daemon: Depende: libasound2 (> 1.0.18) mas 1.0.10-2 está para ser instalado
E: Dependências desencontradas. Tente 'apt-get -f install' sem nenhum pacote (ou especifique uma solução).
Make|Gcc|Build-Essential|Linux-Headers-2.6.28-11-generic|Libasound2|Gnome-PPP|Ungrab-Winmodem|Slmodem-2.9.11-20090222|Sl-Modem-Daemon|Dialup
(Lendo banco de dados ... 100119 arquivos e diretórios atualmente instalados).
Preparando para substituir libasound2-dev 1.0.10-2 (usando libasound2-dev_1.0.18-1ubuntu9_i386.deb) ...
Desempacotando substituto libasound2-dev ...
dpkg: problemas de dependência impedem a configuração de libasound2-dev:
 libasound2-dev depende de libasound2 (= 1.0.18-1ubuntu9); porém:
  Versão de libasound2 no sistema é 1.0.10-2.
dpkg: erro processando libasound2-dev (--install):
 problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
 libasound2-dev
Make|Gcc|Build-Essential|Linux-Headers-2.6.28-11-generic|Libasound2|Gnome-PPP|Ungrab-Winmodem|Slmodem-2.9.11-20090222|Sl-Modem-Daemon|Dialup
(Lendo banco de dados ... 100114 arquivos e diretórios atualmente instalados).
Preparando para substituir gnome-ppp 0.3.21-1 (usando gnome-ppp_0.3.23-1_i386.deb) ...
Desempacotando substituto gnome-ppp ...
Configurando gnome-ppp (0.3.23-1) ...

Processando gatilhos para man-db ...
Make|Gcc|Build-Essential|Linux-Headers-2.6.28-11-generic|Libasound2|Gnome-PPP|Ungrab-Winmodem|Slmodem-2.9.11-20090222|Sl-Modem-Daemon|Dialup
make modules -C /lib/modules/2.6.28-11-generic/build SUBDIRS=/home/jaguar/modem-arquivos-v30/ungrab-winmodem-20080126
make[1]: Entrando no diretório `/usr/src/linux-headers-2.6.28-11-generic'
  CC [M]  /home/jaguar/modem-arquivos-v30/ungrab-winmodem-20080126/ungrab-winmodem.o
  Building modules, stage 2.
  MODPOST 1 modules
  CC      /home/jaguar/modem-arquivos-v30/ungrab-winmodem-20080126/ungrab-winmodem.mod.o
  LD [M]  /home/jaguar/modem-arquivos-v30/ungrab-winmodem-20080126/ungrab-winmodem.ko
make[1]: Saindo do diretório `/usr/src/linux-headers-2.6.28-11-generic'
make modules -C /lib/modules/2.6.28-11-generic/build SUBDIRS=/home/jaguar/modem-arquivos-v30/ungrab-winmodem-20080126
make[1]: Entrando no diretório `/usr/src/linux-headers-2.6.28-11-generic'
  Building modules, stage 2.
  MODPOST 1 modules
make[1]: Saindo do diretório `/usr/src/linux-headers-2.6.28-11-generic'
install -D -m 644 ungrab-winmodem.ko /lib/modules/2.6.28-11-generic/extra/ungrab-winmodem.ko
/sbin/depmod -a
Make|Gcc|Build-Essential|Linux-Headers-2.6.28-11-generic|Libasound2|Gnome-PPP|Ungrab-Winmodem|Slmodem-2.9.11-20090222|Sl-Modem-Daemon|Dialup
make -C modem all
make[1]: Entrando no diretório `/home/jaguar/modem-arquivos-v30/slmodem-2.9.11-20090222/modem'
make[1]: Saindo do diretório `/home/jaguar/modem-arquivos-v30/slmodem-2.9.11-20090222/modem'
make -C drivers KERNEL_DIR=/lib/modules/2.6.28-11-generic/build
make[1]: Entrando no diretório `/home/jaguar/modem-arquivos-v30/slmodem-2.9.11-20090222/drivers'
doing kernel-ver::
cc -I/lib/modules/2.6.28-11-generic/build/include -o kernel-ver kernel-ver.c
make all KERNEL_VER=2.6.28-11-generic
make[2]: Entrando no diretório `/home/jaguar/modem-arquivos-v30/slmodem-2.9.11-20090222/drivers'
   obj-m=slamr.o
   slamr-objs=amrmo_init.o sysdep_amr.o amrlibs.o
make modules -C /lib/modules/2.6.28-11-generic/build SUBDIRS=/home/jaguar/modem-arquivos-v30/slmodem-2.9.11-20090222/drivers
make[3]: Entrando no diretório `/usr/src/linux-headers-2.6.28-11-generic'
  CC [M]  /home/jaguar/modem-arquivos-v30/slmodem-2.9.11-20090222/drivers/amrmo_init.o
  CC [M]  /home/jaguar/modem-arquivos-v30/slmodem-2.9.11-20090222/drivers/sysdep_amr.o
  LD [M]  /home/jaguar/modem-arquivos-v30/slmodem-2.9.11-20090222/drivers/slamr.o
  Building modules, stage 2.
  MODPOST 1 modules
WARNING: could not find /home/jaguar/modem-arquivos-v30/slmodem-2.9.11-20090222/drivers/.amrlibs.o.cmd for /home/jaguar/modem-arquivos-v30/slmodem-2.9.11-20090222/drivers/amrlibs.o
  CC      /home/jaguar/modem-arquivos-v30/slmodem-2.9.11-20090222/drivers/slamr.mod.o
  LD [M]  /home/jaguar/modem-arquivos-v30/slmodem-2.9.11-20090222/drivers/slamr.ko
make[3]: Saindo do diretório `/usr/src/linux-headers-2.6.28-11-generic'
   finished all:
make[2]: Saindo do diretório `/home/jaguar/modem-arquivos-v30/slmodem-2.9.11-20090222/drivers'
make[1]: Saindo do diretório `/home/jaguar/modem-arquivos-v30/slmodem-2.9.11-20090222/drivers'
make -C modem all
make[1]: Entrando no diretório `/home/jaguar/modem-arquivos-v30/slmodem-2.9.11-20090222/modem'
make[1]: Saindo do diretório `/home/jaguar/modem-arquivos-v30/slmodem-2.9.11-20090222/modem'
make -C drivers KERNEL_DIR=/lib/modules/2.6.28-11-generic/build
make[1]: Entrando no diretório `/home/jaguar/modem-arquivos-v30/slmodem-2.9.11-20090222/drivers'
doing kernel-ver::
cc -I/lib/modules/2.6.28-11-generic/build/include -o kernel-ver kernel-ver.c
make all KERNEL_VER=2.6.28-11-generic
make[2]: Entrando no diretório `/home/jaguar/modem-arquivos-v30/slmodem-2.9.11-20090222/drivers'
   obj-m=slamr.o
   slamr-objs=amrmo_init.o sysdep_amr.o amrlibs.o
make modules -C /lib/modules/2.6.28-11-generic/build SUBDIRS=/home/jaguar/modem-arquivos-v30/slmodem-2.9.11-20090222/drivers
make[3]: Entrando no diretório `/usr/src/linux-headers-2.6.28-11-generic'
  Building modules, stage 2.
  MODPOST 1 modules
WARNING: could not find /home/jaguar/modem-arquivos-v30/slmodem-2.9.11-20090222/drivers/.amrlibs.o.cmd for /home/jaguar/modem-arquivos-v30/slmodem-2.9.11-20090222/drivers/amrlibs.o
make[3]: Saindo do diretório `/usr/src/linux-headers-2.6.28-11-generic'
   finished all:
make[2]: Saindo do diretório `/home/jaguar/modem-arquivos-v30/slmodem-2.9.11-20090222/drivers'
make[1]: Saindo do diretório `/home/jaguar/modem-arquivos-v30/slmodem-2.9.11-20090222/drivers'
make install -C drivers KERNEL_DIR=/lib/modules/2.6.28-11-generic/build
make[1]: Entrando no diretório `/home/jaguar/modem-arquivos-v30/slmodem-2.9.11-20090222/drivers'
doing kernel-ver::
cc -I/lib/modules/2.6.28-11-generic/build/include -o kernel-ver kernel-ver.c
mkdir -p /dev
mknod -m 600 /dev/slamr0 c 242 0 ;   mknod -m 600 /dev/slamr1 c 242 1 ;   mknod -m 600 /dev/slamr2 c 242 2 ;   mknod -m 600 /dev/slamr3 c 242 3 ;  echo -n
make install KERNEL_VER=2.6.28-11-generic
make[2]: Entrando no diretório `/home/jaguar/modem-arquivos-v30/slmodem-2.9.11-20090222/drivers'
install -D -m 644 slamr.ko /lib/modules/2.6.28-11-generic/extra/slamr.ko
/sbin/depmod -a
make[2]: Saindo do diretório `/home/jaguar/modem-arquivos-v30/slmodem-2.9.11-20090222/drivers'
make[1]: Saindo do diretório `/home/jaguar/modem-arquivos-v30/slmodem-2.9.11-20090222/drivers'
install -D -m 755 modem/slmodemd /usr/sbin/slmodemd
rm -f -rf /var/lib/slmodem
install -d -D -m 755 /var/lib/slmodem
Make|Gcc|Build-Essential|Linux-Headers-2.6.28-11-generic|Libasound2|Gnome-PPP|Ungrab-Winmodem|Slmodem-2.9.11-20090222|Sl-Modem-Daemon|Dialup
(Lendo banco de dados ... 100113 arquivos e diretórios atualmente instalados).
Preparando para substituir sl-modem-daemon 2.9.11~20080817-3ubuntu2 (usando sl-modem-daemon_2.9.11~20080817-3ubuntu2_i386.deb) ...
Desempacotando substituto sl-modem-daemon ...
dpkg: sl-modem-daemon: problemas de dependência, mas configurando assim mesmo como pedido:
 sl-modem-daemon depende de libasound2 (>> 1.0.18); porém:
  Versão de libasound2 no sistema é 1.0.10-2.
Configurando sl-modem-daemon (2.9.11~20080817-3ubuntu2) ...
O usuário `Slmodemd' já existe. Saindo.
Starting SmartLink Modem driver for: slamr0.
Creating /dev/modem symlink, pointing to: /dev/ttySL0.

Processando gatilhos para man-db ...
Shutting down SmartLink Modem driver normally.
Unloading modem driver from kernel ... slamr.

Shutting down SmartLink Modem driver normally ... no slmodemd daemon running.
Unloading modem driver from kernel ... none found.
Starting SmartLink Modem driver for: slamr0.
Creating /dev/modem symlink, pointing to: /dev/ttySL0.
Make|Gcc|Build-Essential|Linux-Headers-2.6.28-11-generic|Libasound2|Gnome-PPP|Ungrab-Winmodem|Slmodem-2.9.11-20090222|Sl-Modem-Daemon|Dialup

Instalação concluída!
 
root@jaguar-desktop:/home/jaguar/modem-arquivos-v30#







« Última modificação: 19 de Maio de 2009, 12:32 por jaguarsouza »

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1038 Online: 19 de Maio de 2009, 16:46 »
jaguarsouza estou tentando te ajudar, mas para isso preciso que você me ajude a te ajudar ok.

Te pedi uma porção de comandos no terminal para vc colar aqui as respostas e você só respondeu uma falando que o executável slmodemd não estava na pasta /usr/sbin o que por si só já indica que o driver não foi instalado.

Se você não sabe todos os comandos que te pedi podem ser copiados do terminal e colados num editor de texto (menu Aplicativos > Acessórios > Editor de texto) e depois vc pode transferir para uma partição windows, caso use dual boot, ou pendriver e me enviar pelo Windows acessando o fórum, ou seja, colando os resultados aqui. Se esse foi o motivo de não ter postado os comando que pedi aqui.


esses aqui:

Citar
Para saber se o driver foi corretamente instalado aí, abra o terminal e digite cada um destes comandos:

dmesg | grep slamr

ps -aux | grep slmodemd

lsmod | grep slamr

lsmod | grep ungrab*


e por fim digite este comando:

sudo /etc/init.d/sl-modem-daemon restart

e veja o que é mostrado no terminal.

Veja também se em /usr/sbin existe o arquiuvo slmodemd.

Se em /etc/init.d/ existe o arquivo sl-modem-daemon.

Se em /etc/default existe o arquivo sl-modem-daemon

Se em /lib/modules/2.6.28-11-generic/extra existem os arquivos slamr.ko e ungrab-winmodem.ko

Se as configurações do gnome-ppp nas abas Modem e Opções estão como nas fotos deste link aqui:

http://ubuntuforum-br.org/index.php/topic,48619.msg283954.html#msg283954

Esses outros são apenas para vc verificar aí e não colocar aqui por que tem dados confidenciais:

Citar
se ao digitar:

sudo gedit /etc/ppp/pap-secrets

e

sudo gedit /etc/ppp/chap-secrets

no final de cada um destes dois arquivos há uma informação do tipo:

"usuario@provedor.com.br" * "senha1234"

obviamente que os valores entre duas aspas devem ser seu nodem de acesso do provedor de forma completa (com o @ e domínio) e sua senha de acesso do provedor, respectivamente e na formatação indicada acima.


por final ainda fiz estas observações:
Citar

Atenção também que o pacote que faço só funciona para as versões 32bits e não 64bits do Ubuntu.

Se tudo estiver correto, então no terminal digite mais isso:

sudo chmod a+x /usr/sbin/pppd

e depois isso:

sudo gpasswd -a seu_usuário dip

altere o que destaquei em vermelho para o seu nome de usuário (aquele que vc digita par entrar no Ubuntu) que não sei qual é ok.


Veja também se seu modem tem o mesmo problema do modem HSP56 MR (SiS) que antes de usar o discador gnome-ppp que fica em Aplicações > Internet, tem que abrir o terminal e digitar:

sudo /etc/init.d/sl-modem-daemon restart

para só então o modem ser detectado pelo discador gnome-ppp.

Preste atenção ao que já falei inúmeras vezes, pode ser que seu problema de não detectar o modem se resolva com um simples comando sudo /etc/init.d/sl-modem-daemon restart sem a necessidade de ter que instalar o meu pacote outra vez.

Preciso saber se o driver está corretamente instalado para só então pensar em outros possíveis problemas que vc está passando por aí.
« Última modificação: 19 de Maio de 2009, 16:53 por alarcon »

Offline jaguarsouza

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1039 Online: 19 de Maio de 2009, 18:36 »
resutalto  dos  comandos   nova msg  modem nao  detectado  minha  conexao e  ibest  sera  o  provedor?

jaguar@jaguar-desktop:~$ dmesg | grep slamr
[   22.388706] slamr: module license 'Smart Link Ltd.' taints kernel.
[   22.396785] slamr: SmartLink AMRMO modem.
[   22.397122] slamr: probe 2000:2800 SL2800 card...
[   22.397142] slamr 0000:00:0a.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[   22.398686] slamr: slamr0 is SL2800 card.
[  384.180763] slamr 0000:00:0a.0: PCI INT A disabled
[  421.433885] slamr: SmartLink AMRMO modem.
[  421.433961] slamr: probe 2000:2800 SL2800 card...
[  421.433982] slamr 0000:00:0a.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[  421.435582] slamr: slamr0 is SL2800 card.
[  423.738812] slamr 0000:00:0a.0: PCI INT A disabled
[  424.929723] slamr: SmartLink AMRMO modem.
[  424.929801] slamr: probe 2000:2800 SL2800 card...
[  424.929822] slamr 0000:00:0a.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[  424.931582] slamr: slamr0 is SL2800 card.
jaguar@jaguar-desktop:~$ ps -aux | grep slmodemd
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
root      4483  0.0  1.6   3012  3008 ?        SL   11:50   0:00 /usr/sbin/slmodemd --perm=0666 -c PORTUGAL /dev/slamr0
jaguar    4915  0.0  0.4   3352   808 pts/0    S+   11:57   0:00 grep slmodemd
jaguar@jaguar-desktop:~$ lsmod | grep slamr
slamr                 437544  2
jaguar@jaguar-desktop:~$ sudo /etc/init.d/sl-modem-daemon restart
Shutting down SmartLink Modem driver normally.
Unloading modem driver from kernel ... slamr.
Starting SmartLink Modem driver for: slamr0.
Creating /dev/modem symlink, pointing to: /dev/ttySL0.
jaguar@jaguar-desktop:~$ sudo gedit /etc/ppp/pap-secrets
jaguar@jaguar-desktop:~$ sudo chmod a+x /usr/sbin/pppd
jaguar@jaguar-desktop:~$ sudo gpasswd -a jaguar dip
Adicionando usuário jaguar ao grupo dip
jaguar@jaguar-desktop:~$



« Última modificação: 19 de Maio de 2009, 18:40 por jaguarsouza »

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1040 Online: 19 de Maio de 2009, 18:57 »
resutalto  dos  comandos   nova msg  modem nao  detectado  minha  conexao e  ibest  sera  o  provedor?

jaguar@jaguar-desktop:~$ dmesg | grep slamr
[   22.388706] slamr: module license 'Smart Link Ltd.' taints kernel.
[   22.396785] slamr: SmartLink AMRMO modem.
[   22.397122] slamr: probe 2000:2800 SL2800 card...
[   22.397142] slamr 0000:00:0a.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[   22.398686] slamr: slamr0 is SL2800 card.
[  384.180763] slamr 0000:00:0a.0: PCI INT A disabled
[  421.433885] slamr: SmartLink AMRMO modem.
[  421.433961] slamr: probe 2000:2800 SL2800 card...
[  421.433982] slamr 0000:00:0a.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[  421.435582] slamr: slamr0 is SL2800 card.
[  423.738812] slamr 0000:00:0a.0: PCI INT A disabled
[  424.929723] slamr: SmartLink AMRMO modem.
[  424.929801] slamr: probe 2000:2800 SL2800 card...
[  424.929822] slamr 0000:00:0a.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[  424.931582] slamr: slamr0 is SL2800 card.
jaguar@jaguar-desktop:~$ ps -aux | grep slmodemd
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
root      4483  0.0  1.6   3012  3008 ?        SL   11:50   0:00 /usr/sbin/slmodemd --perm=0666 -c PORTUGAL /dev/slamr0
jaguar    4915  0.0  0.4   3352   808 pts/0    S+   11:57   0:00 grep slmodemd
jaguar@jaguar-desktop:~$ lsmod | grep slamr
slamr                 437544  2
jaguar@jaguar-desktop:~$ sudo /etc/init.d/sl-modem-daemon restart
Shutting down SmartLink Modem driver normally.
Unloading modem driver from kernel ... slamr.
Starting SmartLink Modem driver for: slamr0.
Creating /dev/modem symlink, pointing to: /dev/ttySL0.
jaguar@jaguar-desktop:~$ sudo gedit /etc/ppp/pap-secrets
jaguar@jaguar-desktop:~$ sudo chmod a+x /usr/sbin/pppd
jaguar@jaguar-desktop:~$ sudo gpasswd -a jaguar dip
Adicionando usuário jaguar ao grupo dip
jaguar@jaguar-desktop:~$





Você esqueceu do comando:

lsmod | grep ungrab*

mas pelo que você postou está tudo ok, com um pequeno detalhe, parece-me que você é do Brasil e não entendi de no comando está assim:

/usr/sbin/slmodemd --perm=0666 -c PORTUGAL /dev/slamr0

pode ser que isso esteja influenciando, caso você seja realmente do Brasil.

Já usei conexão discada no linux e tinha um modem que usa o driver Smartlink e usava este provedor Ibest e funcionava perfeitamente, agora lembro que o nome de usuário tem de ser completo com @ e domínio, por exemplo, fulano@provedor.com.br e não apenas fulano ok.


Offline jaguarsouza

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1041 Online: 19 de Maio de 2009, 19:28 »
nao  sou  do  brasil  mesmo  porem esse  portugal  num  foi  comando   foi  a  resposta  do  comando
ps -aux | grep slmodemd

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1042 Online: 19 de Maio de 2009, 20:33 »
nao  sou  do  brasil  mesmo  porem esse  portugal  num  foi  comando   foi  a  resposta  do  comando
ps -aux | grep slmodemd

Mas você está no Brasil acessando a internet ou está em Portugal?

pergunto isso por que conforme sua região terá de editar o arquivo seguinte:

sudo gedit /etc/default/sl-modem-daemon

no arquivo que abrir, terá de mudar a linha:

SLMODEMD_COUNTRY=USA

para a sua localidade de acesso, por exemplo:

SLMODEMD_COUNTRY=BRAZIL

ou

SLMODEMD_COUNTRY=PORTUGAL


Uma pergunta, o erro de não econtrar modem após tentar discar e não conseguir se resolve apenas digitando no terminal:
 
sudo /etc/init.d/sl-modem-daemon restart

e ao usar o discador otra vez ele detecta o modem?

Ou você tem de reinstalar o pacote que fiz?

Se for esta ultima opção então acho que vc vai ter de fazer o que falei aqui:

http://ubuntuforum-br.org/index.php/topic,49609.msg289824.html#msg289824

e aqui:

http://ubuntuforum-br.org/index.php/topic,49609.msg290016.html#msg290016

ou seja:

sudo gedit /etc/init.d/ativar-modem

no arquivo vazio que abrir colocar exatamente isso:

Citar
#!/bin/sh
/etc/init.d/sl-modem-daemon stop
modprobe -r ungrab-winmodem
modprobe -r slamr
mknod -m 600 /dev/slamr0 c 242 0
sleep 2
modprobe ungrab-winmodem
modprobe slamr
/etc/init.d/sl-modem-daemon restart

salve e saia do arquivo e digite mais isso no terminal:


sudo chmod +x /etc/init.d/ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc2.d/S98ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc3.d/S98ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc4.d/S98ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc5.d/S98ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc6.d/S98ativar-modem


Reinicia o PC e veja se agora ele funciona a conexão usando o discador gnome-ppp.

Offline jaguarsouza

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1043 Online: 19 de Maio de 2009, 21:53 »
fiz conforme  a resposta ai em cima e  deu  certo  mudei   para  brazil e  execultei  os  comandos
sudo chmod +x /etc/init.d/ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc2.d/S98ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc3.d/S98ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc4.d/S98ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc5.d/S98ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc6.d/S98ativar-modem

e  reinicie  o  pc  simplismete  agora  estou  postando  pelo SO  do  ubuntum  eu  enchi  o  saco  num  foi  ??
valeu  mesmo  cara  vc  num  sabe  como0  eu  estou  feliz   muito  obrigado  agora  vou  pesquisa  como  por  MP3  para  tocar
thauuuu

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1044 Online: 20 de Maio de 2009, 09:49 »
fiz conforme  a resposta ai em cima e  deu  certo  mudei   para  brazil e  execultei  os  comandos
sudo chmod +x /etc/init.d/ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc2.d/S98ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc3.d/S98ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc4.d/S98ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc5.d/S98ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc6.d/S98ativar-modem

e  reinicie  o  pc  simplismete  agora  estou  postando  pelo SO  do  ubuntum  eu  enchi  o  saco  num  foi  ??
valeu  mesmo  cara  vc  num  sabe  como0  eu  estou  feliz   muito  obrigado  agora  vou  pesquisa  como  por  MP3  para  tocar
thauuuu

Que bom que tenha funcionado!

Fica aqui mais este alerta para quem usa o Ubuntu 9.04 32bits e que ativar seu modem que suporta o driver smartlink, além de instalar o wvdial antes de usar o meu pacote modem-arquivos-v30.tar.gz tem que também observar isso:

Se ao digitar:

ps -aux | grep slmodemd

o resultado for algo assim:

root      4483  0.0  1.6   3012  3008 ?        SL   11:50   0:00 /usr/sbin/slmodemd --perm=0666 -c BRAZIL /dev/slamr0

ou seja se está usando o driver smartlink na forma padrão, o Ubuntu 9.04 parece que está com um bug para esse caso tendo que sempre reinstalar o meu pacote para que o modem volte a funcionar, pois ele some com o /dev/slamr0 a cada reinicio do sistema. A solução é fazer  isso:


sudo gedit /etc/init.d/ativar-modem

no arquivo vazio que abrir colocar exatamente isso:


Citar
#!/bin/sh
/etc/init.d/sl-modem-daemon stop
modprobe -r ungrab-winmodem
modprobe -r slamr
mknod -m 600 /dev/slamr0 c 242 0
sleep 2
modprobe ungrab-winmodem
modprobe slamr
/etc/init.d/sl-modem-daemon restart

salve e saia do arquivo e digite mais isso no terminal:


sudo chmod +x /etc/init.d/ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc2.d/S98ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc3.d/S98ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc4.d/S98ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc5.d/S98ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc6.d/S98ativar-modem


Reinicia o PC e veja se agora ele funciona a conexão usando o discador gnome-ppp.

Quem usar a forma alsa, ou seja se o comando:

ps -aux | grep slmodemd

apresentar como resultado algo com a palavra --alsa, por exemplo:

root      4483  0.0  1.6   3012  3008 ?        SL   11:50   0:00 /usr/sbin/slmodemd --perm=0666 -c BRAZIL --alsa hw:0,6

não precisa fazer o que foi comentado por que ele não usa o /dev/slamr0 que está sumindo a cada reinicio.
« Última modificação: 20 de Maio de 2009, 09:56 por alarcon »

Offline Tobimax

  • Usuário Ubuntu
  • *
  • Mensagens: 25
    • Ver perfil
    • Naruto Arena Br
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1045 Online: 20 de Maio de 2009, 12:27 »
Aqui o certo:


Vou ter que fazer isso toda vez para que eu consiga conectar?
VLW

Offline raimundo1

  • Usuário Ubuntu
  • *
  • Mensagens: 111
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1046 Online: 20 de Maio de 2009, 13:32 »
Abra um terminal e digite o seguinte comando   sudo /etc/init.d/sl-modem-daemon status   e cole o resultado aqui.
Uma sugestão , quando vc usar o pacote do alarcon, toda a instalação gera um texto no terminal, copia esse texto e cola aqui, ficara muito mais fácil resolver seu problema.

Não instala o drive no ubuntu 8.10, no ubuntu 8.04 instalava, só dá problema quando muda o Kernel, aí eu instalo de novo. Mas a solução tem que ser fácil de usar e distribuir para os usuários que estão começando no Ubuntu: meus colegas e parentes.

Abaixo o texto do consola, após montar o CD do Ubuntu 8.10 ( bem grande). Instalei a V27 e depois a V29. Obrigado desde Já!!!

E ainda estou preocupado que me chamem de "mentiroso", pois sair falando que o Ubuntu 8.10 pega modem 3G. Está tão fácil mesmo?

Make|Gcc|Build-Essential|Linux-Headers-2.6.27-7-generic|Libasound2|Gnome-PPP|Ungrab-Winmodem|Slmodem-2.9.11-20080629|Sl-Modem-Daemon|Dialup
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
make já é a versão mais nova.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
Make|Gcc|Build-Essential|Linux-Headers-2.6.27-7-generic|Libasound2|Gnome-PPP|Ungrab-Winmodem|Slmodem-2.9.11-20080629|Sl-Modem-Daemon|Dialup
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
gcc já é a versão mais nova.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
Make|Gcc|Build-Essential|Linux-Headers-2.6.27-7-generic|Libasound2|Gnome-PPP|Ungrab-Winmodem|Slmodem-2.9.11-20080629|Sl-Modem-Daemon|Dialup
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
build-essential já é a versão mais nova.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
Make|Gcc|Build-Essential|Linux-Headers-2.6.27-7-generic|Libasound2|Gnome-PPP|Ungrab-Winmodem|Slmodem-2.9.11-20080629|Sl-Modem-Daemon|Dialup
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
linux-headers-2.6.27-7-generic já é a versão mais nova.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
Make|Gcc|Build-Essential|Linux-Headers-2.6.27-7-generic|Libasound2|Gnome-PPP|Ungrab-Winmodem|Slmodem-2.9.11-20080629|Sl-Modem-Daemon|Dialup
(Lendo banco de dados ... 98941 arquivos e diretórios atualmente instalados).
Preparando para substituir libasound2-dev 1.0.17a-0ubuntu4 (usando libasound2-dev_1.0.17a-0ubuntu4_i386.deb) ...
Desempacotando substituto libasound2-dev ...
Configurando libasound2-dev (1.0.17a-0ubuntu4) ...

Make|Gcc|Build-Essential|Linux-Headers-2.6.27-7-generic|Libasound2|Gnome-PPP|Ungrab-Winmodem|Slmodem-2.9.11-20080629|Sl-Modem-Daemon|Dialup
(Lendo banco de dados ... 98941 arquivos e diretórios atualmente instalados).
Preparando para substituir gnome-ppp 0.3.23-1 (usando gnome-ppp_0.3.23-1_i386.deb) ...
Desempacotando substituto gnome-ppp ...
Configurando gnome-ppp (0.3.23-1) ...

Processando gatilhos para man-db ...
Make|Gcc|Build-Essential|Linux-Headers-2.6.27-7-generic|Libasound2|Gnome-PPP|Ungrab-Winmodem|Slmodem-2.9.11-20080629|Sl-Modem-Daemon|Dialup
make modules -C /lib/modules/2.6.27-7-generic/build SUBDIRS=/home/usar/modem-arquivos-v29/ungrab-winmodem-20080126
make[1]: Entrando no diretório `/usr/src/linux-headers-2.6.27-7-generic'
  CC [M]  /home/usar/modem-arquivos-v29/ungrab-winmodem-20080126/ungrab-winmodem.o
  Building modules, stage 2.
  MODPOST 1 modules
  CC      /home/usar/modem-arquivos-v29/ungrab-winmodem-20080126/ungrab-winmodem.mod.o
  LD [M]  /home/usar/modem-arquivos-v29/ungrab-winmodem-20080126/ungrab-winmodem.ko
make[1]: Saindo do diretório `/usr/src/linux-headers-2.6.27-7-generic'
make modules -C /lib/modules/2.6.27-7-generic/build SUBDIRS=/home/usar/modem-arquivos-v29/ungrab-winmodem-20080126
make[1]: Entrando no diretório `/usr/src/linux-headers-2.6.27-7-generic'
  Building modules, stage 2.
  MODPOST 1 modules
make[1]: Saindo do diretório `/usr/src/linux-headers-2.6.27-7-generic'
install -D -m 644 ungrab-winmodem.ko /lib/modules/2.6.27-7-generic/extra/ungrab-winmodem.ko
install: acessando `/lib/modules/2.6.27-7-generic/extra/ungrab-winmodem.ko': Não é um diretório
make: ** [install] Erro 1
Make|Gcc|Build-Essential|Linux-Headers-2.6.27-7-generic|Libasound2|Gnome-PPP|Ungrab-Winmodem|Slmodem-2.9.11-20080629|Sl-Modem-Daemon|Dialup
Shutting down SmartLink Modem driver normally ... no slmodemd daemon running.
Unloading modem driver from kernel ... snd_atiixp_modem.
make -C modem all
make[1]: Entrando no diretório `/home/usar/modem-arquivos-v29/slmodem-2.9.11-20080629/modem'
rebuild profile...
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_main.o -c modem_main.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_cmdline.o -c modem_cmdline.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem.o -c modem.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_datafile.o -c modem_datafile.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_at.o -c modem_at.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_timer.o -c modem_timer.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_pack.o -c modem_pack.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_ec.o -c modem_ec.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_comp.o -c modem_comp.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_param.o -c modem_param.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_debug.o -c modem_debug.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o homolog_data.o -c homolog_data.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o dp_sinus.o -c dp_sinus.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o dp_dummy.o -c dp_dummy.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o sysdep_common.o -c sysdep_common.c
gcc -o slmodemd modem_main.o modem_cmdline.o modem.o modem_datafile.o modem_at.o modem_timer.o modem_pack.o modem_ec.o modem_comp.o modem_param.o modem_debug.o homolog_data.o dp_sinus.o dp_dummy.o dsplibs.o sysdep_common.o 
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_test.o -c modem_test.c
modem_test.c: In function ‘modem_test_start’:
modem_test.c:110: warning: ignoring return value of ‘write’, declared with attribute warn_unused_result
gcc -o modem_test modem_test.o modem_cmdline.o modem.o modem_datafile.o modem_at.o modem_timer.o modem_pack.o modem_ec.o modem_comp.o modem_param.o modem_debug.o homolog_data.o dp_sinus.o dp_dummy.o dsplibs.o sysdep_common.o 
make[1]: Saindo do diretório `/home/usar/modem-arquivos-v29/slmodem-2.9.11-20080629/modem'
make -C drivers KERNEL_DIR=/lib/modules/2.6.27-7-generic/build
make[1]: Entrando no diretório `/home/usar/modem-arquivos-v29/slmodem-2.9.11-20080629/drivers'
doing kernel-ver::
cc -I/lib/modules/2.6.27-7-generic/build/include -o kernel-ver kernel-ver.c
make all KERNEL_VER=2.6.27-7-generic
make[2]: Entrando no diretório `/home/usar/modem-arquivos-v29/slmodem-2.9.11-20080629/drivers'
   obj-m=slamr.o
   slamr-objs=amrmo_init.o sysdep_amr.o amrlibs.o
make modules -C /lib/modules/2.6.27-7-generic/build SUBDIRS=/home/usar/modem-arquivos-v29/slmodem-2.9.11-20080629/drivers
make[3]: Entrando no diretório `/usr/src/linux-headers-2.6.27-7-generic'
  CC [M]  /home/usar/modem-arquivos-v29/slmodem-2.9.11-20080629/drivers/amrmo_init.o
  CC [M]  /home/usar/modem-arquivos-v29/slmodem-2.9.11-20080629/drivers/sysdep_amr.o
  LD [M]  /home/usar/modem-arquivos-v29/slmodem-2.9.11-20080629/drivers/slamr.o
  Building modules, stage 2.
  MODPOST 1 modules
WARNING: could not find /home/usar/modem-arquivos-v29/slmodem-2.9.11-20080629/drivers/.amrlibs.o.cmd for /home/usar/modem-arquivos-v29/slmodem-2.9.11-20080629/drivers/amrlibs.o
  CC      /home/usar/modem-arquivos-v29/slmodem-2.9.11-20080629/drivers/slamr.mod.o
  LD [M]  /home/usar/modem-arquivos-v29/slmodem-2.9.11-20080629/drivers/slamr.ko
make[3]: Saindo do diretório `/usr/src/linux-headers-2.6.27-7-generic'
   finished all:
make[2]: Saindo do diretório `/home/usar/modem-arquivos-v29/slmodem-2.9.11-20080629/drivers'
make[1]: Saindo do diretório `/home/usar/modem-arquivos-v29/slmodem-2.9.11-20080629/drivers'
make -C modem all
make[1]: Entrando no diretório `/home/usar/modem-arquivos-v29/slmodem-2.9.11-20080629/modem'
make[1]: Saindo do diretório `/home/usar/modem-arquivos-v29/slmodem-2.9.11-20080629/modem'
make -C drivers KERNEL_DIR=/lib/modules/2.6.27-7-generic/build
make[1]: Entrando no diretório `/home/usar/modem-arquivos-v29/slmodem-2.9.11-20080629/drivers'
doing kernel-ver::
cc -I/lib/modules/2.6.27-7-generic/build/include -o kernel-ver kernel-ver.c
make all KERNEL_VER=2.6.27-7-generic
make[2]: Entrando no diretório `/home/usar/modem-arquivos-v29/slmodem-2.9.11-20080629/drivers'
   obj-m=slamr.o
   slamr-objs=amrmo_init.o sysdep_amr.o amrlibs.o
make modules -C /lib/modules/2.6.27-7-generic/build SUBDIRS=/home/usar/modem-arquivos-v29/slmodem-2.9.11-20080629/drivers
make[3]: Entrando no diretório `/usr/src/linux-headers-2.6.27-7-generic'
  Building modules, stage 2.
  MODPOST 1 modules
WARNING: could not find /home/usar/modem-arquivos-v29/slmodem-2.9.11-20080629/drivers/.amrlibs.o.cmd for /home/usar/modem-arquivos-v29/slmodem-2.9.11-20080629/drivers/amrlibs.o
make[3]: Saindo do diretório `/usr/src/linux-headers-2.6.27-7-generic'
   finished all:
make[2]: Saindo do diretório `/home/usar/modem-arquivos-v29/slmodem-2.9.11-20080629/drivers'
make[1]: Saindo do diretório `/home/usar/modem-arquivos-v29/slmodem-2.9.11-20080629/drivers'
make install -C drivers KERNEL_DIR=/lib/modules/2.6.27-7-generic/build
make[1]: Entrando no diretório `/home/usar/modem-arquivos-v29/slmodem-2.9.11-20080629/drivers'
doing kernel-ver::
cc -I/lib/modules/2.6.27-7-generic/build/include -o kernel-ver kernel-ver.c
mkdir -p /dev
mknod -m 600 /dev/slamr0 c 242 0 ;   mknod -m 600 /dev/slamr1 c 242 1 ;   mknod -m 600 /dev/slamr2 c 242 2 ;   mknod -m 600 /dev/slamr3 c 242 3 ;  echo -n
mknod: `/dev/slamr0': O arquivo já existe
make install KERNEL_VER=2.6.27-7-generic
make[2]: Entrando no diretório `/home/usar/modem-arquivos-v29/slmodem-2.9.11-20080629/drivers'
install -D -m 644 slamr.ko /lib/modules/2.6.27-7-generic/extra/slamr.ko
install: acessando `/lib/modules/2.6.27-7-generic/extra/slamr.ko': Não é um diretório
make[2]: ** [install] Erro 1
make[2]: Saindo do diretório `/home/usar/modem-arquivos-v29/slmodem-2.9.11-20080629/drivers'
make[1]: ** [install] Erro 2
make[1]: Saindo do diretório `/home/usar/modem-arquivos-v29/slmodem-2.9.11-20080629/drivers'
make: ** [install-drivers] Erro 2
Make|Gcc|Build-Essential|Linux-Headers-2.6.27-7-generic|Libasound2|Gnome-PPP|Ungrab-Winmodem|Slmodem-2.9.11-20080629|Sl-Modem-Daemon|Dialup
(Lendo banco de dados ... 98941 arquivos e diretórios atualmente instalados).
Preparando para substituir sl-modem-daemon 2.9.10+2.9.9d+e-pre2-5ubuntu4 (usando sl-modem-daemon_2.9.10+2.9.9d+e-pre2-5ubuntu4_i386.deb) ...
Desempacotando substituto sl-modem-daemon ...
Configurando sl-modem-daemon (2.9.10+2.9.9d+e-pre2-5ubuntu4) ...
O usuário `Slmodemd' já existe. Saindo.
update-rc.d: warning: /etc/init.d/sl-modem-daemon missing LSB style header
FATAL: Module ungrab_winmodem not found.
FATAL: Module slamr not found.
Starting SmartLink Modem driver for: auto.
Creating /dev/modem symlink, pointing to: /dev/ttySL0.

Shutting down SmartLink Modem driver normally ... no slmodemd daemon running.
Unloading modem driver from kernel ... snd_atiixp_modem.

Shutting down SmartLink Modem driver normally ... no slmodemd daemon running.
Unloading modem driver from kernel ... none found.
FATAL: Module ungrab_winmodem not found.
FATAL: Module slamr not found.
Starting SmartLink Modem driver for: auto.
Creating /dev/modem symlink, pointing to: /dev/ttySL0.
Make|Gcc|Build-Essential|Linux-Headers-2.6.27-7-generic|Libasound2|Gnome-PPP|Ungrab-Winmodem|Slmodem-2.9.11-20080629|Sl-Modem-Daemon|Dialup

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1047 Online: 20 de Maio de 2009, 16:38 »
Aqui o certo:


Vou ter que fazer isso toda vez para que eu consiga conectar?
VLW

Pela sua imagem está tudo certo, ou seja, o driver do modem foi instalado e está tudo carregado no boot do sistema, então se vc vai no menu Aplicativos > Internet > GNOME PPP e não consegue conexão  é porque ou vc tem problema de permissão ou é aquilo que já falei.

Não ficou claro para mim se você antes de usar o discador gnome-pppp executa o comando:

sudo /etc/init.d/sl-modem-daemon restart

e aí quando vai usar o discador gnome-ppp o modem funciona, portanto por favor seja mais explícito e diga se assim funciona ou não. Se funcionar há um modo de não ter que ficar digitando esse comando aí antes de usar o discador gnome-ppp, mas para isso preciso saber se o comando resolve o seu caso.

Se for problema de permissão tente isso:

sudo chmod a+x /usr/sbin/pppd

e depois isso:

sudo gpasswd -a seu_usuário dip

altere o que destaquei em vermelho para o seu nome de usuário (aquele que vc digita par entrar no Ubuntu) que não sei qual é ok.

Verifique também os arquivos pap-secrets e chap-secrets, assim:

sudo gedit /etc/ppp/pap-secrets

e

sudo gedit /etc/ppp/chap-secrets

no final de cada um destes dois arquivos há uma informação do tipo:

"usuario@provedor.com.br" * "senha1234"

obviamente que os valores entre duas aspas ( " ") devem ser seu nodem de acesso do provedor de forma completa (com o @ e domínio) e sua senha de acesso do provedor, respectivamente e na formatação indicada acima.

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1048 Online: 20 de Maio de 2009, 16:54 »

Não instala o drive no ubuntu 8.10, no ubuntu 8.04 instalava, só dá problema quando muda o Kernel, aí eu instalo de novo. Mas a solução tem que ser fácil de usar e distribuir para os usuários que estão começando no Ubuntu: meus colegas e parentes.


Algo você deve está fazendo de errado por aí para que não dê certo, pois veja que o usuário Tobimax já conseguiu pelo menos instalar o driver smartlink e ele está sendo carregado pelo que posso constatar da imagem que ele postou e o seu Ubuntu é o Ubuntu 8.10. Também já vi outros usuários aqui com esta mesma versão do Ubuntu e com sucesso com o pacote modem-arquivos-v29.tar.gz, então veja o que pode está sendo feito de errado que pode ser só um detalhe.

Veja se os arquivos necessários (make, gcc, build-essential, linux-headers e etc.) estão instalados, se você coloca o CD de instalação do Ubuntu no driver para que durante o processo de instalação instalae algo dele que ainda esteja faltando e etc.

Como vc já usou o v27, para facilitar mais as coisas vou pedir que vc faça isso (no terminal):

sudo /etc/init.d/sl-modem-daemon stop

sudo sudo apt-get --purge remove sl-modem-daemon

não se preocupe com qualquer mensagem de erro que isso é só para garantir.

Depois vá nas pastas:

/usr/sbin e remova o arquivo slmodemd (se ainda existir) de lá. Isso só pode ser feito como root ok.

/lib/modules/2.6.27-7-generic/extra e remova os arquivos slamr.ko e ungrab-winmodem.ko (se ainda existir) de lá. Isso só pode ser feito como root ok.

Reinicie o seu PC e só então tente instalar o pacote modem-arquivos-v29.tar.gz no Ubuntu 8.10 32bits seguindo exatamente as intruções que vc já deve conhecer bem.

Para saber se o driver foi corretamente instalado aí, abra o terminal e digite cada um destes comandos:

dmesg | grep slamr

ps -aux | grep slmodemd

lsmod | grep slamr

lsmod | grep ungrab*


e por fim digite este comando:

sudo /etc/init.d/sl-modem-daemon restart

e veja o que é mostrado no terminal.

Offline Tobimax

  • Usuário Ubuntu
  • *
  • Mensagens: 25
    • Ver perfil
    • Naruto Arena Br
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1049 Online: 23 de Maio de 2009, 13:22 »
Depois que eu executei o comando o gnome-ppp achou o modem sim
Quando eu chegar em casa eu tento as coisas que voce me explicou, mas aqui no meu pendrive já tem uma imagem que preciso te mostrar.



VLW

Edit 23:25: Conectou a internet, ai não ficou nem 1 minuto conectado já caiu e aparecia mensagem de Modem não encontrado e talz...

Edit 09:35 Domingo: Estou conectado no ubuntu agora, não caiu ainda (10 minutos), para conectar eu tive que executar o
sudo /etc/init.d/sl-modem-daemon restart

Porém depois que eu o executei o som sumiu, sabe o que posso fazer (depois de te encher de tantas perguntas)

Brigadão

Edit 10:12: Caiu a internet 1 vez, e consegui reconectar, caiu denovo ai quando fui conectar apareceu a mensagem dizendo que o modem não localizado, modem com problema
Ai eu reiniciei, executei o sudo /etc/init.d/sl-modem-daemon restart mas desta vez sem ouvir musica ao mesmo tempo, agora a internet e musica estão normais ^^

Obrigado
« Última modificação: 24 de Maio de 2009, 10:12 por Tobimax »