Autor Tópico: Soluções para 4 erros comuns na instalação/actualização de pacotes  (Lida 21154 vezes)

Offline sylvester

  • Usuário Ubuntu
  • *
  • Mensagens: 545
    • Ver perfil
Você teve erros na instalação ou actualização dos pacotes?
Aqui estão as soluções para os 4 erros mais comuns.

Em primeiro lugar certique-se de ter a sua Lista de Repositórios correcta.

Nota: Você terá que executar um “sudo apt-get update” duas vezes para se recuperar de um dos erros listados abaixo:


1 O Terminal disse a você para executar "dpkg --configure -a"?

Tudo o que você tem a fazer é acrescentar “sudo” no início do comando, assim:
Código: [Selecionar]
sudo dpkg --configure -a
ou se foi o comando install -f:

Código: [Selecionar]
sudo apt-get install -f
Aí certifique-se do seu sistema estar atualizado:

Código: [Selecionar]
sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade
2 Pacotes não existentes: Continua recebendo mensagens de que um determinado pacote não existe e não pode ser instalado? 

Se tem certeza de ter a Lista de Repositórios correcta, então você possui uma lista do apt corrompida devido a um “apt-get update” interrompido, isso faz o gerenciador de pacotes pensar que alguns pacotes não existem no servidor. Execute  ambos os comandos no Terminal/Consola:

Código: [Selecionar]
sudo rm /var/lib/apt/lists/partial/*
Código: [Selecionar]
sudo apt-get update
3 Newline Error/Package Error:
Um erro que pode evitar que QUALQUER sistema realize um update/upgrade ou instale um pacote é o problema chamado "final newline error", mas também existem outros erros e corrupções que podem evitar upgrades e instalações. Se você notar que algum pacote ou aplicação foi mencionada quando você tentou um upgrade ou instalar qualquer coisa não relacionada a isso, tome nota do nome do pacote que apresentou o erro, copie e cole o comando abaixo no terminal/consola,  no caso do exemplo dado substitua o "filename*” pelo nome do pacote que apresentou o erro e depois execute o comando editado para remover o(s) arquivo(s) corrompido(s):

Código: [Selecionar]
sudo rm /var/lib/dpkg/info/filename*
Código: [Selecionar]
sudo apt-get update
Isso não significa que o pacote foi removido, apenas os scripts pré/pós-instalação, md5sums e listas de arquivos relacionados a ele. Você deve reinstalar o pacote, mesmo que planeje retirá-lo, pois os arquivos deletados e corrompidos  relacionados a ele serão substituídos por arquivos não coorompidos.

4 Forbidden 403 Error:
Aqueles que receberem o erro "Forbidden 403" devem mudar a sua lista de repositório de "http" para "ftp". Você  pode fazer isso abrindo a sua lista de repositórios com o seu editor de arquivos padrão (substitua o  "gedit" pelo "kwrite" no Kubuntu e pelo "mousepad" no Xubuntu) no terminal/consola:

Código: [Selecionar]
gksudo gedit /etc/apt/sources.list
Altere todas as linhas de "http" para "ftp", depois salve e feche as mudanças realizadas. Agora você deve ser capaz de atualizar a sua lista de pacotes disponível:

Código: [Selecionar]
sudo apt-get update
Obrigado Galactus pela ajuda na preparação deste pequeno guia.


« Última modificação: 21 de Outubro de 2008, 05:55 por sylvester »

http://opensourceformac.blogspot.com/                                      http://easyubuntulinux.blogspot.com/

Offline brasilio

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Re: Soluções para 4 erros comuns na instalação/actualização de pacotes
« Resposta #1 Online: 04 de Fevereiro de 2009, 23:06 »
Fantástico este tópico de ajuda!!!

usei o dpkj configue a e deu a seguinte mensagem. pode me ajudar?

Download done.
md5sum mismatch install_flash_player_10_linux.tar.gz
The Flash plugin is NOT installed.

dpkg: problemas de dependência impedem a configuração de gnome-subtitles:
 gnome-subtitles depende de gtk-sharp2; porém:
  Pacote gtk-sharp2 não está configurado ainda.
dpkg: erro processando gnome-subtitles (--configure):
 problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
 monodoc-gtk2.0-manual
 gtk-sharp2
 monodoc-browser
 gnome-subtitles
brasilio@caldeira-desktop:~$

abraços

Offline rruella

  • Usuário Ubuntu
  • *
  • Mensagens: 1.095
    • Ver perfil
Re: Soluções para 4 erros comuns na instalação/actualização de pacotes
« Resposta #2 Online: 16 de Maio de 2009, 09:33 »
a gente quando não sabe? usei a dica e agora foi ao gestor de atualização para ver se havia feito alguma asneira e olhem:
Impossível inicializar a informação do pacote

Ocorreu um problema impossível de resolver ao inicializar a informação do pacote.

Por favor reporte este erro no pacote 'update-manager' e inclua a seguinte mensagem de erro:

'E:O tipo 'Sources.list' não é conhecido na linha 1 na lista de fontes /etc/apt/sources.list, E:A lista de fontes não pôde ser lida.'
Dar como resolvido, ou como solucionado um tópico seu:

http://www.youtube.com/watch?v=cW8isbYhR_M

alarcon

  • Visitante
Re: Soluções para 4 erros comuns na instalação/actualização de pacotes
« Resposta #3 Online: 16 de Maio de 2009, 10:28 »
Faltou esse erro bastante comum também ao se querer instalar algo no Ubuntu pelos repositórios:

Citar
E: Não foi possível obter acesso exclusivo a /var/lib/dpkg/lock - open (11 Recurso indisponível temporariamente)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

Que seria por que um outro processo que usa qualquer das formas de instalação de pacotes no Ubuntu (apt-get, Synaptic, Adicionar/Remover... e etc) está em execução.

alarcon

  • Visitante
Re: Soluções para 4 erros comuns na instalação/actualização de pacotes
« Resposta #4 Online: 16 de Maio de 2009, 10:31 »
a gente quando não sabe? usei a dica e agora foi ao gestor de atualização para ver se havia feito alguma asneira e olhem:
Impossível inicializar a informação do pacote

Ocorreu um problema impossível de resolver ao inicializar a informação do pacote.

Por favor reporte este erro no pacote 'update-manager' e inclua a seguinte mensagem de erro:

'E:O tipo 'Sources.list' não é conhecido na linha 1 na lista de fontes /etc/apt/sources.list, E:A lista de fontes não pôde ser lida.'

Há alguma inconsistência no arquivo sources.list que se encontra na pasta /etc/apt/ do sistema e na linha 1 deste arquivo.

Offline rruella

  • Usuário Ubuntu
  • *
  • Mensagens: 1.095
    • Ver perfil
Re: Soluções para 4 erros comuns na instalação/actualização de pacotes
« Resposta #5 Online: 17 de Maio de 2009, 08:36 »
apaguei o arquivo sources.list e agora? não consigo atualizar nem trabalhar com o synaptic e nem adcionar e remover.
Dar como resolvido, ou como solucionado um tópico seu:

http://www.youtube.com/watch?v=cW8isbYhR_M

alarcon

  • Visitante
Re: Soluções para 4 erros comuns na instalação/actualização de pacotes
« Resposta #6 Online: 17 de Maio de 2009, 13:42 »
apaguei o arquivo sources.list e agora? não consigo atualizar nem trabalhar com o synaptic e nem adcionar e remover.

Olha só, em momento algum foi falado aqui para vc remover o arquivo sources.list e sim para resolver/verificar algo de errado na linha 1 deste arquivo como informou o erro, pois ele é a lista de endereços de onde se baixar aplicativos do Ubuntu, ou seja, a lista de repositórios do Ubuntu.

Se você usa o Ubuntu 9.04 32bits o arquivo sources.list deve ser assim:

Citar
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://archive.ubuntu.com/ubuntu/ jaunty main restricted
deb-src http://archive.ubuntu.com/ubuntu/ jaunty main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://archive.ubuntu.com/ubuntu/ jaunty-updates main restricted
deb-src http://archive.ubuntu.com/ubuntu/ jaunty-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://archive.ubuntu.com/ubuntu/ jaunty universe
deb-src http://archive.ubuntu.com/ubuntu/ jaunty universe
deb http://archive.ubuntu.com/ubuntu/ jaunty-updates universe
deb-src http://archive.ubuntu.com/ubuntu/ jaunty-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://archive.ubuntu.com/ubuntu/ jaunty multiverse
deb-src http://archive.ubuntu.com/ubuntu/ jaunty multiverse
deb http://archive.ubuntu.com/ubuntu/ jaunty-updates multiverse
deb-src http://archive.ubuntu.com/ubuntu/ jaunty-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://br.archive.ubuntu.com/ubuntu/ jaunty-backports main restricted universe multiverse
# deb-src http://br.archive.ubuntu.com/ubuntu/ jaunty-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu jaunty partner
# deb-src http://archive.canonical.com/ubuntu jaunty partner

deb http://archive.ubuntu.com/ubuntu/ jaunty-security main restricted
deb-src http://archive.ubuntu.com/ubuntu/ jaunty-security main restricted
deb http://archive.ubuntu.com/ubuntu/ jaunty-security universe
deb-src http://archive.ubuntu.com/ubuntu/ jaunty-security universe
deb http://archive.ubuntu.com/ubuntu/ jaunty-security multiverse
deb-src http://archive.ubuntu.com/ubuntu/ jaunty-security multiverse

Offline rruella

  • Usuário Ubuntu
  • *
  • Mensagens: 1.095
    • Ver perfil
alarcon
como faço para saber se meu pc é 32 ou se 64 bits. depois o que faço com o arquivo sources.list que vc mandou?
« Última modificação: 17 de Maio de 2009, 16:36 por rruella »
Dar como resolvido, ou como solucionado um tópico seu:

http://www.youtube.com/watch?v=cW8isbYhR_M

Offline Ale_JP

  • Usuário Ubuntu
  • *
  • Mensagens: 55
    • Ver perfil
Re: Soluções para 4 erros comuns na instalação/actualização de pacotes
« Resposta #8 Online: 17 de Maio de 2009, 15:47 »
No terminal digite :

Código: [Selecionar]
sudo gedit /etc/apt/sources.list
copie o conteúdo acima e cole na janela q abrir salve e feche.

Offline platao

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.993
    • Ver perfil
Re: Soluções para 4 erros comuns na instalação/actualização de pacotes
« Resposta #9 Online: 18 de Maio de 2009, 01:14 »
Posteriormente amigo ruella ,vc pode ler alguns tutoriais e guias:

http://focalinux.cipsga.org.br/download.html

Apostila PDF do igor abreu para nós iniciantes:

http://ubunteiro.wordpress.com/apostila-ubuntu-ygor-abreu/

Script para ajudar na instalação de pacotes e programas etc:

http://hamacker.wordpress.com/script-ubuntu-perfeito/
\\\\\\\\Apostilas Dicas e Guias do Ubuntu\\\\\\\\\> http://ubuntuforum-br.org/index.php/topic,79368.msg440997.html#msg440997

Offline brasilio

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Re: Soluções para 4 erros comuns na instalação/actualização de pacotes
« Resposta #10 Online: 15 de Julho de 2009, 23:01 »
O pacote transcode esta quebrado e não consigo concertar nem remover. Tentei usar seus comando e consegui, no terminal as seguintes mensagens.

caldeira@caldeira-desktop:~$ sudo apt-get -f install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Corrigindo dependências... Pronto
Os seguintes pacotes foram automaticamente instalados e não são mais requeridos:
  diffstat postfix libapr1 devscripts dctrl-tools dput libpq5 bsd-mailx
  libaprutil1
Use 'apt-get autoremove' para removê-los.
Os pacotes extra a seguir serão instalados:
  transcode
Pacotes sugeridos:
  libdvdcss xvid4conf
Os pacotes a seguir serão atualizados:
  transcode
1 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 12 não atualizados.
1 pacotes não totalmente instalados ou removidos.
É preciso baixar 0B/2472kB de arquivos.
Depois desta operação, 0B adicionais de espaço em disco serão usados.
Você quer continuar [S/n]? y
dpkg: erro de análise, no arquivo '/var/lib/dpkg/status', próximo à linha 33218 pacote 'transcode':
 campo 'Depends', nome de pacote inválido '0Ql:@:': caractere '#' não permitido (apenas letras, dígitos e caracteres '-+._')
W: Duplicate sources.list entry http://archive.canonical.com jaunty/partner Packages (/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_jaunty_partner_binary-i386_Packages)
W: Duplicate sources.list entry http://archive.canonical.com jaunty/partner Packages (/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_jaunty_partner_binary-i386_Packages)
W: Você terá que executar apt-get update para corrigir estes problemas
E: Sub-process /usr/bin/dpkg returned an error code (2)
caldeira@caldeira-desktop:~$ sudo apt-get update
Atingido http://br.archive.ubuntu.com jaunty Release.gpg
Atingido http://br.archive.ubuntu.com jaunty/main Translation-pt_BR           
Atingido http://br.archive.ubuntu.com jaunty/restricted Translation-pt_BR     
Atingido http://br.archive.ubuntu.com jaunty/universe Translation-pt_BR       
Atingido http://br.archive.ubuntu.com jaunty/multiverse Translation-pt_BR     
Atingido http://br.archive.ubuntu.com jaunty-updates Release.gpg               
Ign http://br.archive.ubuntu.com jaunty-updates/main Translation-pt_BR         
Ign http://br.archive.ubuntu.com jaunty-updates/restricted Translation-pt_BR   
Ign http://br.archive.ubuntu.com jaunty-updates/universe Translation-pt_BR     
Ign http://br.archive.ubuntu.com jaunty-updates/multiverse Translation-pt_BR   
Atingido http://br.archive.ubuntu.com jaunty-backports Release.gpg             
Ign http://br.archive.ubuntu.com jaunty-backports/main Translation-pt_BR       
Ign http://br.archive.ubuntu.com jaunty-backports/restricted Translation-pt_BR
Ign http://br.archive.ubuntu.com jaunty-backports/universe Translation-pt_BR   
Ign http://br.archive.ubuntu.com jaunty-backports/multiverse Translation-pt_BR
Atingido http://br.archive.ubuntu.com jaunty Release                           
Atingido http://br.archive.ubuntu.com jaunty-updates Release                   
Obter:1 http://dl.google.com stable Release.gpg [191B]                         
Atingido http://br.archive.ubuntu.com jaunty-backports Release                 
Atingido http://br.archive.ubuntu.com jaunty/main Packages                     
Atingido http://br.archive.ubuntu.com jaunty/restricted Packages               
Atingido http://security.ubuntu.com jaunty-security Release.gpg               
Ign http://security.ubuntu.com jaunty-security/main Translation-pt_BR         
Ign http://security.ubuntu.com jaunty-security/restricted Translation-pt_BR   
Atingido http://br.archive.ubuntu.com jaunty/main Sources                     
Atingido http://br.archive.ubuntu.com jaunty/restricted Sources               
Atingido http://br.archive.ubuntu.com jaunty/universe Packages                 
Atingido http://br.archive.ubuntu.com jaunty/universe Sources                 
Atingido http://br.archive.ubuntu.com jaunty/multiverse Packages               
Atingido http://br.archive.ubuntu.com jaunty/multiverse Sources               
Atingido http://br.archive.ubuntu.com jaunty-updates/main Packages             
Atingido http://br.archive.ubuntu.com jaunty-updates/restricted Packages       
Atingido http://br.archive.ubuntu.com jaunty-updates/main Sources             
Atingido http://packages.medibuntu.org jaunty Release.gpg                     
Ign http://packages.medibuntu.org jaunty/free Translation-pt_BR               
Ign http://dl.google.com stable/main Translation-pt_BR                         
Atingido http://br.archive.ubuntu.com jaunty-updates/restricted Sources       
Atingido http://br.archive.ubuntu.com jaunty-updates/universe Packages         
Atingido http://br.archive.ubuntu.com jaunty-updates/universe Sources         
Atingido http://br.archive.ubuntu.com jaunty-updates/multiverse Packages       
Atingido http://br.archive.ubuntu.com jaunty-updates/multiverse Sources       
Atingido http://br.archive.ubuntu.com jaunty-backports/main Packages           
Atingido http://br.archive.ubuntu.com jaunty-backports/restricted Packages     
Ign http://security.ubuntu.com jaunty-security/universe Translation-pt_BR     
Ign http://security.ubuntu.com jaunty-security/multiverse Translation-pt_BR   
Atingido http://br.archive.ubuntu.com jaunty-backports/universe Packages       
Atingido http://br.archive.ubuntu.com jaunty-backports/multiverse Packages     
Atingido http://security.ubuntu.com jaunty-security Release                   
Obter:2 http://dl.google.com stable Release [1308B]                           
Ign http://packages.medibuntu.org jaunty/non-free Translation-pt_BR           
Atingido http://packages.medibuntu.org jaunty Release                         
Atingido http://security.ubuntu.com jaunty-security/main Packages             
Obter:3 http://dl.google.com stable/main Packages [615B]                       
Atingido http://ppa.launchpad.net jaunty Release.gpg                           
Ign http://ppa.launchpad.net jaunty/main Translation-pt_BR                     
Atingido http://archive.canonical.com jaunty Release.gpg                       
Ign http://archive.canonical.com jaunty/partner Translation-pt_BR             
Ign http://archive.canonical.com jaunty/multiverse Translation-pt_BR           
Atingido http://security.ubuntu.com jaunty-security/restricted Packages       
Atingido http://security.ubuntu.com jaunty-security/main Sources               
Atingido http://security.ubuntu.com jaunty-security/restricted Sources         
Atingido http://security.ubuntu.com jaunty-security/universe Packages         
Atingido http://packages.medibuntu.org jaunty/free Packages                   
Atingido http://security.ubuntu.com jaunty-security/universe Sources           
Atingido http://security.ubuntu.com jaunty-security/multiverse Packages       
Atingido http://security.ubuntu.com jaunty-security/multiverse Sources         
Atingido http://packages.medibuntu.org jaunty/non-free Packages               
Atingido http://ppa.launchpad.net jaunty Release.gpg                           
Ign http://ppa.launchpad.net jaunty/main Translation-pt_BR   
Atingido http://ppa.launchpad.net jaunty Release             
Ign http://archive.canonical.com jaunty/restricted Translation-pt_BR           
Ign http://archive.canonical.com jaunty/universe Translation-pt_BR
Atingido http://archive.canonical.com jaunty Release         
Atingido http://ppa.launchpad.net jaunty Release             
Atingido http://archive.canonical.com jaunty/partner Packages                 
Atingido http://ppa.launchpad.net jaunty/main Packages       
Atingido http://ppa.launchpad.net jaunty/main Packages
Baixados 2114B em 4s (521B/s)   
W: Falhou ao buscar http://archive.canonical.com/ubuntu/dists/jaunty/Release  Unable to find expected entry  multiverse/binary-i386/Packages in Meta-index file (malformed Release file?)

E: Alguns arquivos de índice falharam para baixar, eles foram ignorados ou os antigos foram usados no lugar.
caldeira@caldeira-desktop:~$ sudo aptitude -f install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Lendo informações estendidas de estado     
Inicializando estados de pacotes... Pronto
Os pacotes a seguir serão REMOVIDOS:
  bsd-mailx{u} dctrl-tools{u} devscripts{u} diffstat{u} dput{u} libapr1{u}
  libaprutil1{u} libpq5{u} postfix{u}
Os pacotes a seguir serão atualizados:
  libxcb-render0 libxcb-shape0 libxcb-shm0 libxcb-xv0 libxcb1 transcode
Os seguintes pacotes parcialmente instalados serão configurados:
  testdisk
6 pacotes atualizados, 0 novos instalados, 9 a serem removidos e 7 não atualizados.
É preciso obter 0B/2546kB de arquivos. Depois do desempacotamento, 7209kB serão liberados.
Você deseja continuar? [Y/n/?] y
dpkg: erro de análise, no arquivo '/var/lib/dpkg/status', próximo à linha 33218 pacote 'transcode':
 campo 'Depends', nome de pacote inválido '0Ql:@:': caractere '#' não permitido (apenas letras, dígitos e caracteres '-+._')
E: Sub-process /usr/bin/dpkg returned an error code (2)
A instalação de um pacote falhou. Tentando recuperar:
dpkg: erro de análise, no arquivo '/var/lib/dpkg/status', próximo à linha 33218 pacote 'transcode':
 campo 'Depends', nome de pacote inválido '0Ql:@:': caractere '#' não permitido (apenas letras, dígitos e caracteres '-+._')
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Lendo informações estendidas de estado     
Inicializando estados de pacotes... Pronto


Não sei o que fazer. pode me ajudar? obrigado

Offline Silvane

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re: Soluções para 4 erros comuns na instalação/actualização de pacotes
« Resposta #11 Online: 21 de Dezembro de 2009, 17:03 »
Mais um tópico perfeito para iniciantes poderem resolver os problemas que surgem.
Parabéns