Autor Tópico: Problemas com Kubuntu  (Lida 4601 vezes)

ricardo47

  • Visitante
Problemas com Kubuntu
« Online: 27 de Fevereiro de 2006, 19:51 »
Ae galera, sou novato em linux, enquando meu Ubuntu naum vem, resolvi instalar de curiosidade o Kubuntu... A instalação foi blz, soh o fuso horario q naum consegui ajeita... Entrando no sistema, fui direto pro terminal pra tenta instalar os drives...
Mas os comandos naum funcionam... Digito #make, #pppoe-config, #rpm e aparece "comand not found"...
E agora o q eu faço, naum posso fazer nda sem os principais comandos...
flw

Offline LaSSarD

  • Usuário Ubuntu
  • *
  • Mensagens: 1.147
    • Ver perfil
Problemas com Kubuntu
« Resposta #1 Online: 27 de Fevereiro de 2006, 20:04 »
Ricardo, os # não devem ser digitados, eles apenas indicam que esse é um comando que deve ser executado com poderes de superusuário. No caso, você teria que digitar "sudo make" (sem as aspas), por exemplo. Dá uma lida em https://wiki.ubuntu.com/RootSudoBr pra saber mais sobre o sudo.

Agora, outra coisa... Se você está tentando usar o make pra instalar programas, está indo pelo caminho mais difícil, já que no Ubuntu existem pacotes prontos que podem ser instalados com um único comando. Pra saber mais, leia https://wiki.ubuntu.com/InstalandoSoftware

Se você ler o link acima, verá também que o Ubuntu não usa pacotes .rpm mas sim pacotes .deb, portanto o comando "rpm" não existe ("deb" também não, lê que você entende hehe).
desculpem as mensagens não respondidas, mas eu tô afastado há mais de ano...
um dia eu volto ;)

ricardo47

  • Visitante
Problemas com Kubuntu
« Resposta #2 Online: 27 de Fevereiro de 2006, 20:16 »
ai cara, eu botei # soh pra indica q eu tava digitando os camandos, pq quando to no terminal eu to como root e digito os comando sem #, mas naum funfa do msm jeito... Como naum intendo muita coisa como instalo intaum esse driver por exemplo sem #make? olha o readme do meu modem... Jah to quase desistindo de usa linux, o q jah pesquisei na net eh brincadeira...

This document describes the steps of installing the E2 or Hasbani on the Linux.
Driver Version 062802_REL1.7

First, uncompressing the packaged: USBNET_E2_LINUX_062802_REL1.7.tar.gz
   #tar zxvpf USBNET_E2_LINUX_062802_REL1.7.tar.gz
A directory named e2 will be created under current directory.

Second, Changing directory to the "e2" directory.
   #cd e2

Third, compiling the source code.
   #make

At last, copy the firmware file "CnxE2Fw.bin" to directory "/etc".
   #cp CnxE2Fw.bin /etc/CnxE2Fw.bin


Now, you can install the driver by the command below under current directory:
   #insmod e2.o

If you would like to installing driver anywhere else, Please copy the e2.o to
the directory: /lib/modules/2.4.xx-xxx/kernel/drivers/usb first.

If the network doesn't up automatically, you must run the following commands to activate the net adapter.
   #ifconfig hsb0 up
   #dhcpcd -n hsb0

Offline LaSSarD

  • Usuário Ubuntu
  • *
  • Mensagens: 1.147
    • Ver perfil
Problemas com Kubuntu
« Resposta #3 Online: 27 de Fevereiro de 2006, 20:22 »
Ah, então, foi o que falei "se você está tentando instalar programas" porque pra drivers realmente tem que ser "na unha" :P
Desiste não, cara, quando você consegue a coisa começa a ficar boa... :D
Qual é o problema que você tem com o make? Já instalou o pacote build-essential?
desculpem as mensagens não respondidas, mas eu tô afastado há mais de ano...
um dia eu volto ;)

ricardo47

  • Visitante
Problemas com Kubuntu
« Resposta #4 Online: 27 de Fevereiro de 2006, 20:25 »
naum conheço nenhum pacote... e o make, simplesmente quando digito aparece "comando not found" e eu preciso do make pra instala drives... Preciso também do comando insmod e nda também...

Offline LaSSarD

  • Usuário Ubuntu
  • *
  • Mensagens: 1.147
    • Ver perfil
Problemas com Kubuntu
« Resposta #5 Online: 27 de Fevereiro de 2006, 20:32 »
Então, você precisa do build-essential ;)
Se não souber como instalar, leia o segundo link que passei :D
desculpem as mensagens não respondidas, mas eu tô afastado há mais de ano...
um dia eu volto ;)

ricardo47

  • Visitante
Problemas com Kubuntu
« Resposta #6 Online: 27 de Fevereiro de 2006, 20:50 »
instalei esse build-essential, mas também o comando insmod nuam funfa... naum precisa mais me ajudar, soh que como vou saber q pacote baixar no apt-get sempre q alguma coisa (comando, programa) naum funciona... Eh isso q naum intendo...

Offline LaSSarD

  • Usuário Ubuntu
  • *
  • Mensagens: 1.147
    • Ver perfil
Problemas com Kubuntu
« Resposta #7 Online: 27 de Fevereiro de 2006, 21:15 »
Tente usar "apt-cache search nome" substituindo nome por alguma referência do que está faltando. Por exemplo, apt-cache search insmod.
desculpem as mensagens não respondidas, mas eu tô afastado há mais de ano...
um dia eu volto ;)