Autor Tópico: UBUNTU 8.0.4 E ATI RADEON 9250  (Lida 14818 vezes)

Offline JeronimoBr

  • Usuário Ubuntu
  • *
  • Mensagens: 34
    • Ver perfil
    • Blog do Jerônimo
Re: UBUNTU 8.0.4 E ATI RADEON 9250
« Resposta #15 Online: 05 de Setembro de 2008, 14:54 »
Amigo jeronimoBr. qdo terminei a instalação aki pelo tuto que citei acima ficou td lento tbm...
Fiz o seguinte, reinstalei desde o começo ai voltou ao normal só que sem o openGl funcionando ou seja tah do msm jeito de antes sem o driver instalado ou não está funcionando direito..caraca será que vo ter que troca minha Placa de video.rsrsrsrsrs.. acho que não estaria tendo tanta dor de caeça se fosse uma nvidia..rsrsrsrsrsrsrs..

AT; ABRAÇOS...

DANIX

O driver que funcionou como era antes é o "ati"?

Offline danix

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: UBUNTU 8.0.4 E ATI RADEON 9250
« Resposta #16 Online: 05 de Setembro de 2008, 18:24 »
Caro jeronimo.. creio que era o que vem por default.. o vesa..eu acho..

Offline PRSC

  • Usuário Ubuntu
  • *
  • Mensagens: 668
    • Ver perfil
Re: UBUNTU 8.0.4 E ATI RADEON 9250
« Resposta #17 Online: 06 de Setembro de 2008, 02:16 »
Poxa, será que até a AMD vai deixar esse furo em drivers.

Minha GF7300GT pifou, eu vi umas da linha HD da ATI, tava quase pegando, mas resolvi pegar a GF8600GT, que tava em um bom preço.

Alias, troquei a placa, e simplesmente não precisei fazer nada, tive mais trabalho no windows, desinstala driver, reinicia, instala driver reinicia kkkkkkk

Minha unica dica era o envy mesmo pessoal, é uma pena não poder ajudar.


Abraço
Placa Gigabyte 970A-ud3p..16 GB Corsair Vegeance..FX8300..nVidia GTx750Ti.Gabinete Cougar Challenger
Linux user #511

Offline danix

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: UBUNTU 8.0.4 E ATI RADEON 9250
« Resposta #18 Online: 06 de Setembro de 2008, 13:27 »
Ok PRSC tro pensando em vender essa aki tbm cara.. pq eu só vou mexer com lnx agora por um bom tempo, entaum se um dia eu precisar reinstalar e ter esse trabalho td pra instalar vai tomar mto meu tempo.. alias de eu eu querer instalar ela msm pra rodar certo o compiz-fusion.....
Pelo drive default ela roda o compiz só que não aceita a maioria dos efeitos do tipo o desktop-cube por exemplo.. ela habilita só que nã aparece as janelas 3d e sim  um rotação de tela sem 3d algum...

mais por enquanto vo vendo o que pode ser feito assim ...




AT


 DANIX

Offline prct

  • Usuário Ubuntu
  • *
  • Mensagens: 84
  • Ubuntu 8.04 LTS
    • Ver perfil
Re: UBUNTU 8.0.4 E ATI RADEON 9250
« Resposta #19 Online: 06 de Setembro de 2008, 14:42 »
Tenho uma ati 9250, funcionou a primeira em todas as distribuições.

Agora coloca aqui o /etc/X11/xorg.conf

Asus T3 Intel 2Duo Core Quad 2.4, 2Gb Ram, 2x 160Gb HDD SataII, Asus EAH2600PRO 512Mb Ram

Offline danix

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: UBUNTU 8.0.4 E ATI RADEON 9250
« Resposta #20 Online: 06 de Setembro de 2008, 22:51 »
Olá caro prct. que bom pra vc carinha ter conseguido sem dor de cabeça.. bom aki está meu xorg por default,..

AT;

DANIX

Offline danix

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: UBUNTU 8.0.4 E ATI RADEON 9250
« Resposta #21 Online: 06 de Setembro de 2008, 22:51 »
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "abnt2"
   Option      "XkbLayout"   "br"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
EndSection

Section "Device"
   Identifier   "Configured Video Device"
EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Configured Monitor"
   Device      "Configured Video Device"
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
EndSection

Offline Phaster

  • Usuário Ubuntu
  • *
  • Mensagens: 50
    • Ver perfil
Re: UBUNTU 8.0.4 E ATI RADEON 9250
« Resposta #22 Online: 08 de Setembro de 2008, 09:24 »
Ok PRSC tro pensando em vender essa aki tbm cara.. pq eu só vou mexer com lnx agora por um bom tempo, entaum se um dia eu precisar reinstalar e ter esse trabalho td pra instalar vai tomar mto meu tempo.. alias de eu eu querer instalar ela msm pra rodar certo o compiz-fusion.....
Pelo drive default ela roda o compiz só que não aceita a maioria dos efeitos do tipo o desktop-cube por exemplo.. ela habilita só que nã aparece as janelas 3d e sim  um rotação de tela sem 3d algum...

mais por enquanto vo vendo o que pode ser feito assim ...




AT


 DANIX

Isso é muito esquisito, porque como eu falei tenho uma radeon 9100 on-board e roda a maioria dos efeitos, a única coisa q não roda q eu percebi são os efeitos de água, e o skydome do cubo o resto funciona normal as janelas 3d na rotação do cubo funciona mas fica um pouco lento, porém a placa só tem 64 de memória, e eu tbm acho q o vesa não ajuda muito na hora de habilitar estas janelas porque numa radeon x1050 tbm fica um pouco lenta.

Offline prct

  • Usuário Ubuntu
  • *
  • Mensagens: 84
  • Ubuntu 8.04 LTS
    • Ver perfil
Re: UBUNTU 8.0.4 E ATI RADEON 9250
« Resposta #23 Online: 14 de Setembro de 2008, 13:15 »
Citar
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "pt"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
EndSection

Section "Device"
   Identifier   "Configured Video Device"
   Driver      "fglrx"
EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Configured Monitor"
   Device      "Configured Video Device"
   Defaultdepth   24
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
  screen "Default Screen"
EndSection
Section "Module"
   Load      "glx"
EndSection

Este é o meu
Asus T3 Intel 2Duo Core Quad 2.4, 2Gb Ram, 2x 160Gb HDD SataII, Asus EAH2600PRO 512Mb Ram

Offline MalGaniz

  • Usuário Ubuntu
  • *
  • Mensagens: 133
  • What do you mean, I Ain't kind? Just not your kind
    • Ver perfil
    • Salada Do Kabeludo
Re: UBUNTU 8.0.4 E ATI RADEON 9250
« Resposta #24 Online: 19 de Setembro de 2008, 10:29 »
Olá amigos,
Acabei de migrar da Nvidia para ATI, minha placa é 9250, a mesmo do tópico, e também apanhei pra instalar......
Tentei o Envy, que aponta para o driver 8.7 e nada.
Tentei seguir vários tutoriais mas sem sucesso...
Se alguém tiver alguma idéia eu agradeço!

PS: Se eu conseguir obter algum sucesso eu posto aqui como fazer

Offline MalGaniz

  • Usuário Ubuntu
  • *
  • Mensagens: 133
  • What do you mean, I Ain't kind? Just not your kind
    • Ver perfil
    • Salada Do Kabeludo
Re: UBUNTU 8.0.4 E ATI RADEON 9250
« Resposta #25 Online: 21 de Setembro de 2008, 22:05 »
Olá galera,
Voltei com novidades, meu Direct Rendering está funcionando segundo os comandos glxinfo e glxgears, tudo normal exceto um baixíssimo desempenho nos jogos tais como WoW, mas nem tudo é perfeito né?

Bem, como não consegui instalar minha 9250 nem com reza brava, tentei pelo ENVY e nada, mas quando fui remover o driver pelo próprio ENVY, obtive uma surpresa na inicialização: minha resolução estava 1024 e com o Direct Rendering funcionando. O caso é que, de alguma forma, a desinstalação do driver pelo ENVY ativou a aceleração 3D ¬¬, talvez o ENVY tenha restaurado o xorg.conf como podem ver abaixo e, por conseqüência, ativado a aceleração:

Código: [Selecionar]
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "br"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Emulate3Buttons"       "true"
EndSection

Section "Device"
        Identifier      "Configured Video Device"
EndSection

Section "Monitor"
        Identifier      "Configured Monitor"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Monitor         "Configured Monitor"
        Device          "Configured Video Device"
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
EndSection


Como eu já disse, ao que parece o ENVY "renovou" o xorg, agora vai entender porque está funcionando.... entretanto, ainda estou atrás do driver certo para a Radeon 9250, pois, acredito que a baixa qualidade dos jogos estejam relacionadas ao driver (qualquer) que está rodando.
Tentei instalar o driver baixado do site da ATI que diz ser compatível apenas para alguns modelos incluindo o meu, baixei o pacote de instalação inteiro "ati-driver-installer-8.28.8.run" (este arquivo pesa 51,5MB) e um erro foi retornado:

Código: [Selecionar]

user@computer:~/Área de Trabalho$ sudo sh ati-driver-installer-8.28.8.run
Creating directory fglrx-install
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.28.8...
-e ==================================================
-e  [color=red]ATI Technologies Linux Driver Installer/Packager[/color]
-e ==================================================
Detected configuration:
Architecture: i686 (32-bit)
X Server: unable to detect
Removing temporary directory: fglrx-install


Já testei COM e SEM o XSERVER rodando, dêem sudo um "/etc/init.d/gdm stop" para sair do GNOME/KDE/XFCE e vejam vocês mesmos, o erro é igual ao citado acima.

Detalhe: Ainda não tentei o arquivo menor, mas agora não vou testar nada.

Up pro tópico, ainda espero uma "Luz" que seja :P

Abraço!

EDIT: Bem, eu já havia tentado o arquivo menor e não deu certo:

Código: [Selecionar]

Descompactando fglrx-6-8-0 (de fglrx-6-8-0_8.28.8-2_i386.deb) ...
dpkg: erro processando fglrx-6-8-0_8.28.8-2_i386.deb (--install):
 tentando sobrescrever `/usr/include/GL/glxATI.h', que também está no pacote xorg-driver-fglrx-dev-envy
dpkg-deb: subprocesso paste morto por sinal (Pipe quebrado)
Erros foram encontrados durante processamento de:
 fglrx-6-8-0_8.28.8-2_i386.deb

« Última modificação: 21 de Setembro de 2008, 22:15 por MalGaniz »

Offline MalGaniz

  • Usuário Ubuntu
  • *
  • Mensagens: 133
  • What do you mean, I Ain't kind? Just not your kind
    • Ver perfil
    • Salada Do Kabeludo
Re: UBUNTU 8.0.4 E ATI RADEON 9250
« Resposta #26 Online: 21 de Setembro de 2008, 22:25 »
Olá galera,
Voltei com novidades, meu Direct Rendering está funcionando segundo os comandos glxinfo e glxgears, tudo normal exceto um baixíssimo desempenho nos jogos tais como WoW, mas nem tudo é perfeito né?

Bem, como não consegui instalar minha 9250 nem com reza brava, tentei pelo ENVY e nada, mas quando fui remover o driver pelo próprio ENVY, obtive uma surpresa na inicialização: minha resolução estava 1024 e com o Direct Rendering funcionando. O caso é que, de alguma forma, a desinstalação do driver pelo ENVY ativou a aceleração 3D ¬¬, talvez o ENVY tenha restaurado o xorg.conf como podem ver abaixo e, por conseqüência, ativado a aceleração:

Código: [Selecionar]
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "br"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Emulate3Buttons"       "true"
EndSection

Section "Device"
        Identifier      "Configured Video Device"
EndSection

Section "Monitor"
        Identifier      "Configured Monitor"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Monitor         "Configured Monitor"
        Device          "Configured Video Device"
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
EndSection


Como eu já disse, ao que parece o ENVY "renovou" o xorg, agora vai entender porque está funcionando.... entretanto, ainda estou atrás do driver certo para a Radeon 9250, pois, acredito que a baixa qualidade dos jogos estejam relacionadas ao driver (qualquer) que está rodando.
Tentei instalar o driver baixado do site da ATI que diz ser compatível apenas para alguns modelos incluindo o meu, baixei o pacote de instalação inteiro "ati-driver-installer-8.28.8.run" (este arquivo pesa 51,5MB) e um erro foi retornado:

Código: [Selecionar]

user@computer:~/Área de Trabalho$ sudo sh ati-driver-installer-8.28.8.run
Creating directory fglrx-install
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.28.8...
-e ==================================================
-e  [color=red]ATI Technologies Linux Driver Installer/Packager[/color]
-e ==================================================
Detected configuration:
Architecture: i686 (32-bit)
X Server: unable to detect
Removing temporary directory: fglrx-install


Já testei COM e SEM o XSERVER rodando, dêem sudo um "/etc/init.d/gdm stop" para sair do GNOME/KDE/XFCE e vejam vocês mesmos, o erro é igual ao citado acima.

Detalhe: Ainda não tentei o arquivo menor, mas agora não vou testar nada.

Up pro tópico, ainda espero uma "Luz" que seja :P

Abraço!

EDIT: Bem, eu já havia tentado o arquivo menor e não deu certo:

Código: [Selecionar]

Descompactando fglrx-6-8-0 (de fglrx-6-8-0_8.28.8-2_i386.deb) ...
dpkg: erro processando fglrx-6-8-0_8.28.8-2_i386.deb (--install):
 tentando sobrescrever `/usr/include/GL/glxATI.h', que também está no pacote xorg-driver-fglrx-dev-envy
dpkg-deb: subprocesso paste morto por sinal (Pipe quebrado)
Erros foram encontrados durante processamento de:
 fglrx-6-8-0_8.28.8-2_i386.deb



FINAL EDIT: Galera, descobri qual foi o erro acima, eu ainda tinha os drivers xorg-driver-fglrx-envy instalados ¬¬, removi todos os drivers do envy e a instalação do pacote menor prosseguiu com sucesso!!!! O caso é que o driver nao podia ser instalado com todos os processos ativos como atievent, enfim, desinstalem os drivers e instalem o pacote menor!

Offline danix

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: UBUNTU 8.0.4 E ATI RADEON 9250
« Resposta #27 Online: 22 de Setembro de 2008, 22:23 »
Ola amigo MalGaniz.. td bem cara..
Vc pode até achar estranho mais o meu rendering está funfa tbm e começou do msm jeito que o seu.. tinha instalado esse driver ai da ATI tbm e naum obitve sucesso.. ai fui remover os pacotes instalados e funcionou.. agora rodo o compiz.. mais tbm com algumas falhas.. mais no final de seu post parece que vc conseguiu instalar o driver especifico pra suia aATI certo?? se conseguiu, posta um tuto ai pra gnt por como resolvido esse topico...as conf estão assim conforme o glxinfo...


OpenGL vendor string: Tungsten Graphics, Inc.
OpenGL renderer string: Mesa DRI R200 20060602 AGP 4x x86/MMX+/3DNow!+/SSE TCL
OpenGL version string: 1.3 Mesa 7.0.3-rc2
direct rendering: Yes



AT


danix

Offline dom diniz

  • Usuário Ubuntu
  • *
  • Mensagens: 152
    • Ver perfil
Re: UBUNTU 8.0.4 E ATI RADEON 9250
« Resposta #28 Online: 22 de Setembro de 2008, 23:02 »
Bem eu uso uma ATI radeon X300 e faz muito tempo que não tenho problema em instala-la e deixa-la funfando.

Sempre que eu vou usar o EnvyNG, antes eu instalo o hearders:

Citar
linux-headers-386
linux-headers-(versão do kernel)-386

então é só instalar pelo EnvyNG, que sabe não dá certo com vcs?


aqui minha peleja:

http://ubuntuforum-br.org/index.php/topic,31788.0.html
http://ubuntuforum-br.org/index.php/topic,30477.0.html
« Última modificação: 22 de Setembro de 2008, 23:29 por dom diniz »
Preocupem-se com a criação de mais programas e não de mais distros.
link
Ga-945GM-S2Dual|Core 2 Duo E4600|2GB DDR2 Kingston667|Radeon X300 128|XP+ubuntu 10.04 || DELL Vostro 1310 + ubuntu 10.04

Offline MalGaniz

  • Usuário Ubuntu
  • *
  • Mensagens: 133
  • What do you mean, I Ain't kind? Just not your kind
    • Ver perfil
    • Salada Do Kabeludo
Re: UBUNTU 8.0.4 E ATI RADEON 9250
« Resposta #29 Online: 24 de Setembro de 2008, 13:38 »
Acontece que já tentamos instalar pelo ENVY e esse é o problema, de alguma forma, ele diz que nosso driver suporta os drivers legacy e que não serão instalados. Encontrei uma maneira de instalar, contudo, meu painel de configurações da ATI não aparece nem ferrando. O modo que encontrei foi baixar o driver específico do site da ATI cuja versão só é suportada por algumas placas incluindo a minha. Como eu disse no quote acima, o arquivo pesa por volta de 11MB e não é o mais atual. Tudo o que precisamos fazer é dar um "/killall" nos processos da ATI, desinstalar o que já existe (pode ser pelo Synaptic/Adept) e instalar sossegadamente pelo terminal o driver baixado.

Este é o driver que usei: fglrx-6-8-0_8.28.8-2_i386.rpm (eu transformei em deb com o alien)

No momento, estou sem a barra do gnome por algum erro que estou tentando resolver, portanto, não posso dar maiores informações.

Abraço!