Autor Tópico: Ubuntu 8.04 não reconhece o meu HD  (Lida 3161 vezes)

Offline raphaz

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Ubuntu 8.04 não reconhece o meu HD
« Online: 05 de Julho de 2008, 18:06 »
Tenho uma peculiaridade aqui.
A alguns anos tive problemas de reconhecimento de meu HD sata, porém tudo se resolveu qhando saiu o kernel 2.6.18, tanto em relação ao Ubuntu quanto a outras distros.
Agora, tudo funcionava bem até o Ubuntu 8.04. Quando tentei instalar do CD, não reconheceu o HD. Na verdade nenhum deles. Desta forma só me restou atualizar pelo gerenciador de atualizações. Apesar de problemas com a minha placa de vídeo (o nvidia-glx-new deu pau, perdi os efeitos 3D, baichei o driver do site da nvidia e fiz na mão, desinstalando o restricted-modules e tudo o mais), tudo funcionou corretamente no kernel 2.6.22. Porém quando tento dar boot pelo 2.6.24, não reconhece o HD.
Alguém pode me ajudar ?

RaphaZ

Placa-mãe Asus A8V-MX
Processador Athlon 64 Bits 3200 +
1 GB memória DDR 400
HD master(sistema) Seagate Barracuda Sata 7200 RPM
HD slave (arquivos) Sansung Sata 7200 RPM
Placa de vídeo Nvidia Geforce 6200

Offline VB5

  • Usuário Ubuntu
  • *
  • Mensagens: 3.567
  • Liga dos Dinos
    • Ver perfil
Re: Ubuntu 8.04 não reconhece o meu HD
« Resposta #1 Online: 05 de Julho de 2008, 22:49 »
Por favor, pode postar aqui o seu fdisk -l e o fstab?

VB5
Ubuntu 10.04 - Semprom 2600+/Asus K8N/1.5 GB RAM DDR 400/GeForce 6200/HDs: 80MB + 320 GB

Offline raphaz

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: Ubuntu 8.04 não reconhece o meu HD
« Resposta #2 Online: 06 de Julho de 2008, 23:00 »
fdisk -l

Disco /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cilindros of 16065 * 512 = 8225280 bytes
Disk identifier: 0x5605541e

Dispositivo Boot Início Fim Blocos Id Sistema
/dev/sda1   *           1        5229    42001911   83  Linux
/dev/sda3            5230        9729    36146250   83  Linux

Disco /dev/sdb: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cilindros of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000c274f

Dispositivo Boot Início Fim Blocos Id Sistema
/dev/sdb1              90       19196   153476977+  83  Linux
/dev/sdb2           19197       19457     2096482+  82  Linux swap / Solaris

cat /etc/fstab

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda1
UUID=61c11085-3717-450b-bc68-9fbe9c7e8a1f /               reiserfs notail          0       1
# /dev/sda3
UUID=6dc82f79-d389-4492-9af4-5a23f2e7366a /home           reiserfs defaults        0       2
# /dev/sdb1
UUID=82f89907-3ed7-4bd7-8bbe-bd0121173ebe /home/arquivo   reiserfs defaults        0       2
# /dev/sdb2
UUID=2c958597-da43-4d5b-9fa6-54c5507d93ee none            swap    sw              0       0
/dev/hda        /media/cdrom0   udf,iso9660 user,noauto,exec 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec 0       0


Valeu, amigo !

Offline VB5

  • Usuário Ubuntu
  • *
  • Mensagens: 3.567
  • Liga dos Dinos
    • Ver perfil
Re: Ubuntu 8.04 não reconhece o meu HD
« Resposta #3 Online: 07 de Julho de 2008, 23:24 »
Não estou entendendo... seus dois discos SATA são reconhecidos:

Citar
fdisk -l

Disco /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cilindros of 16065 * 512 = 8225280 bytes
Disk identifier: 0x5605541e

Dispositivo Boot Início Fim Blocos Id Sistema
/dev/sda1   *           1        5229    42001911   83  Linux
/dev/sda3            5230        9729    36146250   83  Linux


Disco /dev/sdb: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cilindros of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000c274f

Dispositivo Boot Início Fim Blocos Id Sistema
/dev/sdb1              90       19196   153476977+  83  Linux
/dev/sdb2           19197       19457     2096482+  82  Linux swap / Solaris


e estão montados:

Citar
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda1
UUID=61c11085-3717-450b-bc68-9fbe9c7e8a1f /               reiserfs notail          0       1
# /dev/sda3
UUID=6dc82f79-d389-4492-9af4-5a23f2e7366a /home           reiserfs defaults        0       2
# /dev/sdb1
UUID=82f89907-3ed7-4bd7-8bbe-bd0121173ebe /home/arquivo   reiserfs defaults        0       2
# /dev/sdb2
UUID=2c958597-da43-4d5b-9fa6-54c5507d93ee none            swap    sw              0       0


Sua partição de boot é sda1, então devia funcionar...  a não ser que o Kernel 2.6.24 esteja instalado em sdb1. Pode nos esclarecer um pouco mais?...

VB5
Ubuntu 10.04 - Semprom 2600+/Asus K8N/1.5 GB RAM DDR 400/GeForce 6200/HDs: 80MB + 320 GB

Offline raphaz

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: Ubuntu 8.04 não reconhece o meu HD
« Resposta #4 Online: 09 de Julho de 2008, 19:49 »
Sim, realmente está tudo ok pois estou dando boot pelo kernel 2.6.22. mas quando tento subir pelo 2.6.24 dá erro no reconhecimento do HD. Este erro não acontece no kernel 2.6.22, apenas quando tento subir pelo kernel mais novo. o boot está instalado em /dev/sda1 o disco sdb1 é só para arquivos, mas pelo que eu pude compreender no boot, não reconhece nem um HD nem outro. Meu sistema atual é o 7.10 atualizado para o 8.04. Tive este problema, como comentei anteriormente a muito tempo, só resolvi com o ubuntu 7.04. Acho que o problema está  no meu chipset VIA, porém não sei como solucionar.

Offline VB5

  • Usuário Ubuntu
  • *
  • Mensagens: 3.567
  • Liga dos Dinos
    • Ver perfil
Re: Ubuntu 8.04 não reconhece o meu HD
« Resposta #5 Online: 10 de Julho de 2008, 20:25 »
Citar
Acho que o problema está  no meu chipset VIA, porém não sei como solucionar.

Talvez até seja... como ainda estou usando o 7.10 aqui em casa, não posso dizer. Entretanto, no trabalho tenho várias máquinas diferentes que foram atualizadas para o 8.04 sem problemas; amanhã vou verificar os kernels e os chipsets, se possível, e à noite posto aqui; pode ser que dê alguma pista...

VB5
Ubuntu 10.04 - Semprom 2600+/Asus K8N/1.5 GB RAM DDR 400/GeForce 6200/HDs: 80MB + 320 GB