Autor Tópico: Problema no Eclipse  (Lida 3256 vezes)

Offline Gilson Filho

  • Usuário Ubuntu
  • *
  • Mensagens: 45
    • Ver perfil
    • Open Tutoriais
Problema no Eclipse
« Online: 28 de Junho de 2008, 17:52 »
Ola galera,

Eu instalei o Eclipse pelo aplicativo de adicionar/remover programas. Instalou tudo beleza e instalei os plugins e inclusive
so visual editor. Mas quando faço a execução de um arquivo Swing da erro do tipo NullPointerException. Eu instalei o Eclipse e depois o JDK (sem querer), isso deve ser o motivo??

Como resolver isso?

Offline Lamego

  • Usuário Ubuntu
  • *
  • Mensagens: 1.943
    • Ver perfil
Re: Problema no Eclipse
« Resposta #1 Online: 06 de Julho de 2008, 19:54 »
O java que o eclipse utiliza está definido em:
/etc/eclipse/java_home
A entrada que aponta para o jdk da sun deve aparecer em primeiro lugar.

Pode verificar qual o JVM que está a ser utilizado em:
Help -> About Eclipse SDK -> Configuration details
João Luís Marques Pinto
Mais programs e jogos para o Ubuntu

Offline Gilson Filho

  • Usuário Ubuntu
  • *
  • Mensagens: 45
    • Ver perfil
    • Open Tutoriais
Re: Problema no Eclipse
« Resposta #2 Online: 08 de Julho de 2008, 15:39 »
Cara vlw pela ajuda. Mas sabe o que tive que fazer?

Tive que instalar o JDK pelo apt-get install, porque ele vai em um diretório padrão. O problema que tem turoriais que instalam em diretorios diferentes, ai complicou pra mim.

VLW!!!

Offline Lamego

  • Usuário Ubuntu
  • *
  • Mensagens: 1.943
    • Ver perfil
Re: Problema no Eclipse
« Resposta #3 Online: 09 de Julho de 2008, 11:07 »
Deve-se utilizar sempre os JDK/JRE dos repositórios :)
João Luís Marques Pinto
Mais programs e jogos para o Ubuntu