Autor Tópico: Webcam Dr. Hank VC-I130-CD1K (Microdia SN9C201 0c45:627b)  (Lida 6626 vezes)

Offline rseugling

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Webcam Dr. Hank VC-I130-CD1K (Microdia SN9C201 0c45:627b)
« Online: 23 de Maio de 2008, 13:37 »
?

« Última modificação: 25 de Maio de 2008, 16:04 por rseugling »

Offline rseugling

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Webcam Dr. Hank VC-I130-CD1K (Microdia SN9C201 0c45:627b)
« Resposta #1 Online: 25 de Maio de 2008, 16:02 »
Gente.... estou tentando fazer minha webcam funcionar, mas esta dificil.

Por enquanto,usei os seguinte comandos:

sudo apt-get install curl
sudo apt-get install exuberant-ctags
sudo apt-get install git-core gitk git-gui git-doc
git clone http://repo.or.cz/r/microdia.git
cd microdia
make
sudo modprobe videodev

Ela foi reconhecida, mas ainda não funcionou (tela preta). Alguem pode me ajudar a fazer ela funcionar?

Dei os seguintes comandos:
udevinfo -a -p $(udevinfo -q path -n /dev/video0)
udevinfo -a -p $(udevinfo -q path -n /dev/video1)

e obtive os seguintes resultados:
rseugling@rseugling-desktop:~$ udevinfo -a -p $(udevinfo -q path -n /dev/video0)
 
Udevinfo starts with the device specified by the devpath and then
walks up the chain of parent devices. It prints for every device
found, all possible attributes in the udev rules key format.
A rule to match, can be composed by the attributes of the device
and the attributes from one single parent device.

  looking at device '/devices/pci0000:00/0000:00:0b.0/video4linux/video0':
    KERNEL=="video0"
    SUBSYSTEM=="video4linux"
    DRIVER==""
    ATTR{dev}=="81:0"
    ATTR{name}=="BT878 video _Prolink PixelView "
    ATTR{card}=="37"

  looking at parent device '/devices/pci0000:00/0000:00:0b.0/video4linux':
    KERNELS=="video4linux"
    SUBSYSTEMS==""
    DRIVERS==""

  looking at parent device '/devices/pci0000:00/0000:00:0b.0':
    KERNELS=="0000:00:0b.0"
    SUBSYSTEMS=="pci"
    DRIVERS=="bttv"
    ATTRS{vendor}=="0x109e"
    ATTRS{device}=="0x036e"
    ATTRS{subsystem_vendor}=="0x0000"
    ATTRS{subsystem_device}=="0x0000"
    ATTRS{class}=="0x040000"
    ATTRS{irq}=="11"
    ATTRS{local_cpus}=="ff"
    ATTRS{modalias}=="pci:v0000109Ed0000036Esv00000000sd00000000bc04sc00i00"
    ATTRS{broken_parity_status}=="0"
    ATTRS{msi_bus}==""

  looking at parent device '/devices/pci0000:00':
    KERNELS=="pci0000:00"
    SUBSYSTEMS==""
    DRIVERS==""

rseugling@rseugling-desktop:~$


rseugling@rseugling-desktop:~$ udevinfo -a -p $(udevinfo -q path -n /dev/video1)
node name not found
udevinfo: option requires an argument -- p
rseugling@rseugling-desktop:~$


Ou seja, minha placa de TV foi reconhecida em /etc/video0.

Mas minha webcam que deveria estar em /etc/video1, necaasssss....

Como faço para subir minha webcam para video1?


Offline rseugling

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Re: Webcam Dr. Hank VC-I130-CD1K (Microdia SN9C201 0c45:627b)
« Resposta #2 Online: 27 de Maio de 2008, 14:46 »
up.........