Autor Tópico: Ubuntu não dá boot  (Lida 13255 vezes)

Offline Gui.beta

  • Usuário Ubuntu
  • *
  • Mensagens: 16
    • Ver perfil
Ubuntu não dá boot
« Online: 20 de Abril de 2008, 11:18 »
Eu uso o Ubuntu 7.10 e fui mudar a resolução de tela no usplash.con (coloquei 800x600). Ai fui no terminal e digitei "sudo update-usplash-theme usplash-theme-ubuntu" e reiniciei o computador. O grub iniciou, ai quando eu seleciono o Ubuntu pra iniciar, aparece uma tela preta com :
Citar
Starting Up...
Loading, Please Wait
Segmentation fault
FATAL:
(só consegui ve até aqui, pois os textos aparecem muito rapido)

Depois disso a tela fica toda preta com uma linha branca piscando no canto superior esquerdo. Depois de um tempo (+- 5 minutos), aparece um terminal:

Citar
BusyBox v1.1.3(Debian 1:1.1.3-Ubuntu7) Built-in Shell (Ash)
Enter 'Help' for a list of Built-in Comands

(initramfs)_

Eu queria saber como recupear o ubuntu para ele iniciar normalmente. Agradeço desde já.

Offline Hailtales

  • Usuário Ubuntu
  • *
  • Mensagens: 35
  • I am a man who walks alone
    • Ver perfil
    • Blog
Re: Ubuntu não dá boot
« Resposta #1 Online: 20 de Abril de 2008, 13:23 »
Veja se por acaso a opção recovery mode aparece disponível no menu do Grub.

Caso contrário você pode tentar utilizando o SuperGRUB:

http://supergrub.forjamari.linex.org/

Offline Gui.beta

  • Usuário Ubuntu
  • *
  • Mensagens: 16
    • Ver perfil
Re: Ubuntu não dá boot
« Resposta #2 Online: 20 de Abril de 2008, 13:47 »
Aparece. Eu iniciei essa opção e apareceu uns textos na tela, e no final vai pro mesmo terminal (
Citar
BusyBox v1.1.3Debian 1:1.1.3-Ubuntu7 Built-in Shell (Ash)
Enter 'Help' for a list of Built-in Comands

(initramfs)_
)
Mais antes aparece isso:
Citar
check root=bootarg cat /proc /cmdline or missing modules devices cat /proc /modules ls /dev
ALERT! /dev/disk /by-uvid/e61256fe-d368-4859-9f8c-d2f6b8534be5 does not exist. Dropping to a shell!

Offline Gui.beta

  • Usuário Ubuntu
  • *
  • Mensagens: 16
    • Ver perfil
Re: Ubuntu não dá boot
« Resposta #3 Online: 28 de Abril de 2008, 19:29 »
so pra da up

Offline ubuntufx

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
Re: Ubuntu não dá boot
« Resposta #4 Online: 01 de Maio de 2008, 23:02 »
Aparece. Eu iniciei essa opção e apareceu uns textos na tela, e no final vai pro mesmo terminal (
Citar
BusyBox v1.1.3Debian 1:1.1.3-Ubuntu7 Built-in Shell (Ash)
Enter 'Help' for a list of Built-in Comands

(initramfs)_
)
Mais antes aparece isso:
Citar
check root=bootarg cat /proc /cmdline or missing modules devices cat /proc /modules ls /dev
ALERT! /dev/disk /by-uvid/e61256fe-d368-4859-9f8c-d2f6b8534be5 does not exist. Dropping to a shell!

Comigo da o mesmo erro, em ambos os modos(recovery e normal), além de o ubuntu definir meus hds como scsi mas são IDE, em um hd vai normal(o que uso p/ testes de 15 GB) e no outro de 80GB da esse erro, estou achando que é alguma coisa no kernel, mas não tenho ideia do que fazer.

Offline xpaulinhox

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Re: Ubuntu não dá boot
« Resposta #5 Online: 11 de Junho de 2008, 09:28 »
Cara esse erro ta acontecendo comigo também, procurei, procurei e procurei, bom daí seguinte, a resolução pro meu problema eu não consegui encontrar mas tava lendo e encontrei o seguinte.

por exemplo.

se tiver em 2 hds um com win xp e outro com o linux tem que ir no BIOS e desabilitar o hd do xp e por o do linux como primário (se nescessário mudar o jumper).

e o meu problema é que eu tenho apenas 1 hd (SATA) com os dois S.Os, por isso que não consegui resolver o meu problema ainda.

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Ubuntu não dá boot
« Resposta #6 Online: 11 de Junho de 2008, 10:35 »
Citar
BusyBox v1.1.3Debian 1:1.1.3-Ubuntu7 Built-in Shell (Ash)
Enter 'Help' for a list of Built-in Comands

(initramfs)_

Se o erro é o descrito acima acho que o VB5 já deu a solução ontem:

Re: Falha na Atualização e Instalação
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline pintasart

  • Usuário Ubuntu
  • *
  • Mensagens: 50
    • Ver perfil
Re: Ubuntu não dá boot
« Resposta #7 Online: 11 de Julho de 2008, 20:16 »
Boas.

Tenho o XP e o Ubuntu 8.04 instalado no meu portátil. Entretanto ele teve uma avaria e foi para arranjar, mas quando voltou o dual boot não me aparece no ecrã. Eu ligo o portátil, aparece logo aquela imagem da memória etc... e depois devia aparecer o menu para seleccionar e este não aparece. Entretanto lembrei-me de ligar a um display externo e voltei a reiniciar e aí aparece no tal display mas não no portátil.
Voltei a reinstalar o ubuntu 8.04 e tudo igual.  Fiz a reparação com o cd no XP e voltei a reiniciar e tudo igual.
Apenas não aparece o tal menu, pq se deixar passar os tais 10 seg ele inicia logo o Ubuntu e funciona, se andar com as setas para baixo (no escuro) ele inicia o XP e ambos os casos tenho imagem.
Quanto à BIOS ela está como antes e funcionava.

O que posso fazer?

Offline sprit

  • Usuário Ubuntu
  • *
  • Mensagens: 65
    • Ver perfil
Re: Ubuntu não dá boot
« Resposta #8 Online: 16 de Julho de 2008, 15:32 »
Bom vocês estão fazendo uma bagunca e tanto!!! srsrs
A alternativa e o seguinte
Para tirar o grub da MBR:
Código: [Selecionar]
fdisk /MBR
Para inserir o grub na MBR.
Precisa dar boot em algum CD-Live, aquele que inicia algum Linux com grub
dentro do console:
Código: [Selecionar]
root@nomePC:/# grub
> root (hd0,[b]<TAB>[/b]1)   # particao onde fica o menu.list o que esta em negrito e para aperta tecla TAB, no meu esta no primeiro HD, na segunda particao esta o Ubuntu.
> find /boot/grub/stage1       # nao to lembrado pra que serve isso acho que e algumas configuracoes.
> setup (hd0)                     # instalar o grub na MBR do primeiro HD.
Resolver o problema do usplash do Gui.beta(bom voce teve sorte em da esse problema e muito raro acontece isso)
Precisa dar boot em algum CD-Live, aquele que inicia algum Linux.
dentro do console( se der boot atravez de um CD-Live do Ubuntu o mesmo que voce instalo acho que sua unidade vai ser montado automaticamente senao vai ter que montar manualmente):
Código: [Selecionar]
root@nomePC:/# chroot /media/particao_do_Ubuntu   # vai ter privilégios administrativos sobre o seu Ubuntu como se tive-se "logado" no Ubuntu, sua raiz que era em / agora e /media/particao_do_Ubuntu/
root@Ubuntu:/# update-grub                                  # atualizar o grub no Ubuntu, se ocorre um erro ou nao funciona, tente uma a resolucao de origem e o usplash de origem.

UFFAA... espero ter ajudado!!!
Se ainda não resolveu, e so tira as suas duvida!!!

Offline avidaqua

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Estou com problemas de arranque "Initramfs"
« Resposta #9 Online: 19 de Dezembro de 2008, 17:30 »
Pela primeira vez recorro a este fórum para tentar resolver o meu problema que passo explicar.

Eu uso sistema operativo Linux 8.04 e tenho o xp a rodar um vmware à pouco tempo fiz uma actualização com os comandos;

aptitude safe-upgrade
aptitude update

Após isto reiniciei o meu pc, e deparei-me que o meu pc fica parado numa tela preta aonde esta escrito "Initramfs", ja fiz diversas coisa.
Que passo a explicar o que fiz.
Já tentei entrar com outro Kernel e nada.
Já tentei em boot e executei o seguintes comandos;

noapic acpi=off

Mesmo assim nada.
Tentei entrar num terminal de root e executar os comandos;

sudo -s
fdisk -l
mount /dev/sda1 /mnt
mount --bind/dev /mnt/dev
mount --bind/proc /mnt/proc
chroot /mnt
update-initramfs -k all -u
umount /mnt/proc
umount /mnt/dev
umount /mnt
Mesmo assim nada.

Após estas tentativas frustradas fiz uma copia de um Cd para arrancar com o mesmo e ver se tinha perdido alguma coisa, e por sorte vi e revi o conteúdo e esta lá tudo e tenho acesso a tudo que esta no disco, penso que por aqui não posso fazer nada então entrei em modo de segurança através do CD e entrar num terminal e tentar repara as coisas, mas não tenho tido sucesso.
Têm-me aconselhado a fazer um backup as coisas mais importantes e instalar tudo de novo, mas as coisas não são assim tão simples estamos a falar de um PC de uma empresa com programas e com muitas outras coisas importantes.


Pergunto eu.
À alguma possibilidade de reparar o meu problema sem danificar os ficheiros e configurações.

Atentamente
Luís Castro

Rodrigo Henrique

  • Visitante
Re: Ubuntu não dá boot
« Resposta #10 Online: 21 de Dezembro de 2008, 20:24 »
tenta fdsk -f