Autor Tópico: libxxf86vm, ldconfig e gnome-settings-daemon  (Lida 6011 vezes)

Offline robertobech

  • Usuário Ubuntu
  • *
  • Mensagens: 139
    • Ver perfil
    • LINUX para o resgate
libxxf86vm, ldconfig e gnome-settings-daemon
« Online: 12 de Julho de 2005, 10:57 »
TÓPICO EDITADO COM A SOLUÇÃO DO PROBLEMA

Eu estava com dois problemas diferentes:

GNOME_SETTINGS_DAEMON
Subitamente comecei a ter problemas com o Gnome. Ao logar, aparecia uma mensagem dizendo que havia um problema com o Gnome-Settings-Daemon, e aí meus ícones e temas e algumas configurações (como a do teclado) não carregavam mais. Meu Gnome ficou horroroso, e eu desesperado.

Para resolver o problema, reinstalei pelo aptitude o capplets e o capplets-data. Acredito que também teria funcionado pelo Synaptic ou via apt-get, abrindo um terminal e digitando:

Código: [Selecionar]
sudo apt-get install capplets capplets-data

Isso geralmente já basta, mas eu estava com um probleminha com libs que parecia estar travando tudo no meu sistema, então tive que reinstalar o xlibs também, e o gnome-control-panel (ou seria gnome-control-center? Não lembro bem, vou verificar). Pronto, voltaram minhas configurações quando re-loguei.

Problemas com libXxf86vm.so.1

Essa ainda não resolvi completamente, mas estou quase lá. Meu MPlayer e meu xine pararam de abrir, eles diziam que o ld não conseguia acessar o libxxf86vm.so.1, ou algo do gênero (postarei depois o erro em detalhes). Sei que ao tentar instalar algumas oisas eu tomava com esse erro pela cara:

Código: [Selecionar]
unable to stat /usr/X11R6/lib/libXxf86vm.so.1.0 (which I was about to install). Permission denied

Resinstalar o xlibs ajudou bastante, mas continuo com alguns problemas nesse sentido. Então, pesquisando aprendi que o tal do ld que 'cannot stat libxxf86vm.so.1' é na verdade o ldconfig.

LDCONFIG?
Isso, ldconfig. Pelo que entendi, é um programinha responsável por ativar as libs do seu sistema. Estou certo? Tem um arquivo, o /etc/ld.so.conf que indica os diretórios em que o ldconfig vai ativar ou linkar as libs. Ainda não entendi ao certo como funciona, mas é bem interessante e aconselho todos a lerem a respeito neste link:
http://enterprise.linux.com/enterprise/05/05/15/1115252.shtml?tid=89

Que foi inclusive destacado pelo Linux Daily Log:
http://www.linuxdailylog.com/2005/05/usando-o-ldconfig-e-ldd.html

Parece que o ldconfig tem relação com o meu problema, e entendê-lo pode ajudar. Se alguém souber mais sobre o mesmo, que tal compartilhar seus conhecimentos aqui?

Obrigado a todos pela ajuda. Assim que souber mais sobre o ldconfig posto aqui para que todos possamos aprender.
Minha máquina velha de guerra:
ASUS A7S333, CPU Duron 1200Mhz
256MB RAM, HD 40GB
É velha, mas eu gosto :-)

Visitem meu site para técnicos de LINUX, o LINUX para o resgate

Offline robertobech

  • Usuário Ubuntu
  • *
  • Mensagens: 139
    • Ver perfil
    • LINUX para o resgate
libxxf86vm, ldconfig e gnome-settings-daemon
« Resposta #1 Online: 13 de Julho de 2005, 18:34 »
Alguém me salve, por favor, estou travado aqui...

Quando tento instalar pelo apt-get o libxxf86vm levo com essa:

unable to stat /usr/X11R6/lib/libXxf86vm.so.1.0 (which I was about to install). Permission denied

E agora? o que eu faço?
Minha máquina velha de guerra:
ASUS A7S333, CPU Duron 1200Mhz
256MB RAM, HD 40GB
É velha, mas eu gosto :-)

Visitem meu site para técnicos de LINUX, o LINUX para o resgate

Offline LaSSarD

  • Usuário Ubuntu
  • *
  • Mensagens: 1.144
    • Ver perfil
libxxf86vm, ldconfig e gnome-settings-daemon
« Resposta #2 Online: 13 de Julho de 2005, 18:51 »
Você executou o comando com o sudo?
desculpem as mensagens não respondidas, mas eu tô afastado há mais de ano...
um dia eu volto ;)

Offline robertobech

  • Usuário Ubuntu
  • *
  • Mensagens: 139
    • Ver perfil
    • LINUX para o resgate
libxxf86vm, ldconfig e gnome-settings-daemon
« Resposta #3 Online: 14 de Julho de 2005, 10:38 »
Já tentei como sudo, já tentei em modo texto, nada funciona.

Agora o tal arquivo sumiu, mas mesmo assim não consigo instalar nada. Vou postar hoje a noite o que a linha de comando retorna, mas já adianto que no meu /usr/X11R6/lib tem uns links para aquivos inexistentes - são uns dois, um link para libGL alguma coisa e outro para libxk alguma coisa - bem vao, né? :-)

Hoje vou postar mais detalhes, e vamos ver se alguém consegue dar uma luz na questão.
Minha máquina velha de guerra:
ASUS A7S333, CPU Duron 1200Mhz
256MB RAM, HD 40GB
É velha, mas eu gosto :-)

Visitem meu site para técnicos de LINUX, o LINUX para o resgate

Offline robertobech

  • Usuário Ubuntu
  • *
  • Mensagens: 139
    • Ver perfil
    • LINUX para o resgate
libxxf86vm, ldconfig e gnome-settings-daemon
« Resposta #4 Online: 15 de Julho de 2005, 00:51 »
Tentei reinstalar o libxxf86vm pelo aptitude:

Código: [Selecionar]
Preconfiguring packages ...

(Reading database ... 124347 files and directories currently installed.)
Preparing to replace libxxf86vm1 6.8.2-10 (using .../libxxf86vm1_6.8.2-10_i386.deb) ...
Unpacking replacement libxxf86vm1 ...
dpkg: error processing /var/cache/apt/archives/libxxf86vm1_6.8.2-10_i386.deb (--unpack):
 unable to stat `./usr/X11R6/lib/libXxf86vm.so.1.0' (which I was about to install): Permission denied
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libxxf86vm1_6.8.2-10_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Até aí eu já estava preparado, mas aí pintou isso:

[code]
Ack!  Something bad happened while installing packages.  Trying to recover:
Press return to continue.
[code]

EI! ISSO NÃO VALE!!! Que parada é essa, seu sem vergonha! Ack! Que raios de "ack" é esse, o que você fez com meu Ubuntu, seu sem-vergonha!!!!

...

Aham, perdão...  :roll: ME AJUDEM!!!! POR FAVOR!
Minha máquina velha de guerra:
ASUS A7S333, CPU Duron 1200Mhz
256MB RAM, HD 40GB
É velha, mas eu gosto :-)

Visitem meu site para técnicos de LINUX, o LINUX para o resgate

Offline saulodebaco

  • Usuário Ubuntu
  • *
  • Mensagens: 52
    • Ver perfil
libxxf86vm, ldconfig e gnome-settings-daemon
« Resposta #5 Online: 15 de Julho de 2005, 10:20 »
robertobech, sou meio novo no Ubuntu, portanto vou te dar uma dica de iniciante e você usa se achar conveniente. No teu lugar eu tentaria um apt-get -fu install; depois, se não funcionar, remover os dois programas e instalar novamente.

Boa sorte,

Saulo
Saulo C. De Baco,
Linux user #398458
Niterói/RJ