Autor Tópico: Problema com emesene. "No module named gtk" [Resolvido?]  (Lida 2722 vezes)

Offline BlackMoon

  • Usuário Ubuntu
  • *
  • Mensagens: 73
    • Ver perfil
Problema com emesene. "No module named gtk" [Resolvido?]
« Online: 26 de MAR?O de 2008, 21:27 »
Olá pessoal. Meu emesene não está mais funcionando.

A história é a seguinte:
Eu estou começando a programar em Python, mas sou muito iniciante, nunca havia programado antes, estou seguindo vários tutoriais e já aprendi várias coisas.

Até que tentei criar uma página dinâmica com o Apache e CGI.

Eu tinha que dizer o caminho para o interpretador do Python, mexi mexi e não achei. Fiquei muito tempo procurando e testando vários caminhos, então desisti. Baixei o Python 2.5.2 do site do Python na esperança de que algum arquivo me dissesse, ou que instalando eu descobrisse qual era o caminho certo para colocar no arquivo .py

Tentei instalar e finalmente descobri o caminho. Mas desde então o IDLE e o emesene pararam de funcionar. Procurei no fórum oficial do emesene, havia um tópico com o mesmo problema e de um cara que também havia instalado o Python pelo arquivo do site.

Infelizmente não há uma solução no tópico e ele se encontra trancado.

Os erros do IDLE e o emesene são os seguintes:
Código: [Selecionar]
vinicius@vinicius-desktop:~$ idle
Traceback (most recent call last):
  File "/usr/local/bin/idle", line 3, in <module>
    from idlelib.PyShell import main
  File "/usr/local/lib/python2.5/idlelib/PyShell.py", line 14, in <module>
    import macosxSupport
  File "/usr/local/lib/python2.5/idlelib/macosxSupport.py", line 6, in <module>
    import Tkinter
  File "/usr/local/lib/python2.5/lib-tk/Tkinter.py", line 38, in <module>
    import _tkinter # If this fails your Python may not be configured for Tk
ImportError: No module named _tkinter

Código: [Selecionar]
vinicius@vinicius-desktop:~$ emesene
Traceback (most recent call last):
  File "/usr/share/emesene/emesene_launcher", line 31, in <module>
    import Controller
  File "/usr/share/emesene/Controller.py", line 21, in <module>
    import gtk
ImportError: No module named gtk

Alguém poderia me ajudar?

PS: Já tentei reinstalar diversos arquivos do Python pelo synaptic, mas não houveram resultados.
« Última modificação: 28 de MAR?O de 2008, 17:42 por BlackMoon »

Offline BlackMoon

  • Usuário Ubuntu
  • *
  • Mensagens: 73
    • Ver perfil
Re: Problema com emesene. "No module named gtk"
« Resposta #1 Online: 27 de MAR?O de 2008, 13:30 »
Agora estou pensando em fazer uma instalação limpa do Hardy Beta, isso resolveria o problema e eu já estaria usando o 8.04.

Mas realmente gostaria de saber se não há uma solução para esse problema.

Offline kakita

  • Usuário Ubuntu
  • *
  • Mensagens: 285
    • Ver perfil
Re: Problema com emesene. "No module named gtk"
« Resposta #2 Online: 27 de MAR?O de 2008, 15:33 »
Agora estou pensando em fazer uma instalação limpa do Hardy Beta, isso resolveria o problema e eu já estaria usando o 8.04.

Mas realmente gostaria de saber se não há uma solução para esse problema.
Tambem tive um problema (diferente do seu) e instalei o hardy
Mais vale mudar agora que depois o unico problema e que vc fica sem saber a causa do problema, mas com o tempo vc vai descobrir, eu acabo sempre por descobrir (nem que seja fazendo borrada 2 vez ;D)

Offline samuelbh

  • Usuário Ubuntu
  • *
  • Mensagens: 582
    • Ver perfil
Re: Problema com emesene. "No module named gtk"
« Resposta #3 Online: 28 de MAR?O de 2008, 10:32 »
Aqui no meu também tá dando esse erro na hora de escolher a foto de exibição. Isso que eu saiba´não é problema no python, e sim no emesene. Na próxima versão do svn já deve ser corrigido.
Assinatura removida pela Equipe do Fórum

Offline BlackMoon

  • Usuário Ubuntu
  • *
  • Mensagens: 73
    • Ver perfil
Re: Problema com emesene. "No module named gtk"
« Resposta #4 Online: 28 de MAR?O de 2008, 17:41 »
Agora estou pensando em fazer uma instalação limpa do Hardy Beta, isso resolveria o problema e eu já estaria usando o 8.04.

Mas realmente gostaria de saber se não há uma solução para esse problema.
Tambem tive um problema (diferente do seu) e instalei o hardy
Mais vale mudar agora que depois o unico problema e que vc fica sem saber a causa do problema, mas com o tempo vc vai descobrir, eu acabo sempre por descobrir (nem que seja fazendo borrada 2 vez ;D)
Estou usando o Hardy aqui. Funcionando perfeitamente.

Única coisa que ainda não consegui fazer foi tornar o Foxmarks compatível com o Firefox 3 Beta 4.
Aqui no meu também tá dando esse erro na hora de escolher a foto de exibição. Isso que eu saiba´não é problema no python, e sim no emesene. Na próxima versão do svn já deve ser corrigido.
Olha, não sei sobre ser um erro do emsene. Mas depois que instalei a versão do Python do site, nenhum programa que usava Python funcionou.