Autor Tópico: GARNOME 2.22.x  (Lida 9504 vezes)

Offline Bluray

  • Usuário Ubuntu
  • *
  • Mensagens: 75
    • Ver perfil
GARNOME 2.22.x
« Online: 21 de MAR?O de 2008, 10:39 »
boas amigos, neste meu primeiro tópico trago-vos uma duvida que tenho, passo a explicar.

foi ao sayte do gonome  para ver as novidades, e reparei que havia uma nova versão do gnome,  tive vendo  um pouco como poderia instalar a nova versão do gnome,  e encontrei este programa  GARNOM http://www.gnome.org/projects/garnome/  este  progrma serve para instalar novas versões do gnome, mas  deu um erro na sua instalação
Citar
toni@toni-laptop:~$ cd garnome-2.22.0
toni@toni-laptop:~/garnome-2.22.0$ make paranoid-install
make[1]: Entering directory `/home/toni/garnome-2.22.0/admin'
make[2]: Entering directory `/home/toni/garnome-2.22.0/admin/pessulus'
[===== NOW BUILDING:    pessulus-2.16.4 =====]
        [fetch] complete for pessulus.
        [checksum] complete for pessulus.
        [extract] complete for pessulus.
        [patch] complete for pessulus.
        [fixup] complete for pessulus.
 ==> Building bindings/gnome-python as a dependency
make[3]: Entering directory `/home/toni/garnome-2.22.0/bindings/gnome-python'
[===== NOW BUILDING:    gnome-python-2.22.0     =====]
        [fetch] complete for gnome-python.
        [checksum] complete for gnome-python.
        [extract] complete for gnome-python.
        [patch] complete for gnome-python.
        [fixup] complete for gnome-python.
 ==> Building desktop/libgnomeprintui as a dependency
make[4]: Entering directory `/home/toni/garnome-2.22.0/desktop/libgnomeprintui'
[===== NOW BUILDING:    libgnomeprintui-2.18.2  =====]
        [fetch] complete for libgnomeprintui.
        [checksum] complete for libgnomeprintui.
        [extract] complete for libgnomeprintui.
        [patch] complete for libgnomeprintui.
        [fixup] complete for libgnomeprintui.
 ==> Building desktop/libgnomeprint as a dependency
make[5]: Entering directory `/home/toni/garnome-2.22.0/desktop/libgnomeprint'
[===== NOW BUILDING:    libgnomeprint-2.18.4    =====]
        [fetch] complete for libgnomeprint.
        [checksum] complete for libgnomeprint.
        [extract] complete for libgnomeprint.
        [patch] complete for libgnomeprint.
        [fixup] complete for libgnomeprint.
 ==> Building geektoys/libgnomecups as a dependency
make[6]: Entering directory `/home/toni/garnome-2.22.0/geektoys/libgnomecups'
[===== NOW BUILDING:    libgnomecups-0.2.3      =====]
        [fetch] complete for libgnomecups.
        [checksum] complete for libgnomecups.
        [extract] complete for libgnomecups.
        [patch] complete for libgnomecups.
        [fixup] complete for libgnomecups.
        [configure] complete for libgnomecups.
        [build] complete for libgnomecups.
 ==> Running make install in work/main.d/libgnomecups-0.2.3
make[7]: Entering directory `/home/toni/garnome-2.22.0/geektoys/libgnomecups/work/main.d/libgnomecups-0.2.3'
Making install in libgnomecups
make[8]: Entering directory `/home/toni/garnome-2.22.0/geektoys/libgnomecups/work/main.d/libgnomecups-0.2.3/libgnomecups'
make[9]: Entering directory `/home/toni/garnome-2.22.0/geektoys/libgnomecups/work/main.d/libgnomecups-0.2.3/libgnomecups'
test -z "/home/toni/garnome/lib" || /bin/mkdir -p "/home/toni/garnome/lib"
 /bin/bash ../libtool   --mode=install /usr/bin/install -c  'libgnomecups-1.0.la' '/home/toni/garnome/lib/libgnomecups-1.0.la'
/usr/bin/install -c .libs/libgnomecups-1.0.so.1.0.0 /home/toni/garnome/lib/libgnomecups-1.0.so.1.0.0
(cd /home/toni/garnome/lib && { ln -s -f libgnomecups-1.0.so.1.0.0 libgnomecups-1.0.so.1 || { rm -f libgnomecups-1.0.so.1 && ln -s libgnomecups-1.0.so.1.0.0 libgnomecups-1.0.so.1; }; })
(cd /home/toni/garnome/lib && { ln -s -f libgnomecups-1.0.so.1.0.0 libgnomecups-1.0.so || { rm -f libgnomecups-1.0.so && ln -s libgnomecups-1.0.so.1.0.0 libgnomecups-1.0.so; }; })
/usr/bin/install -c .libs/libgnomecups-1.0.lai /home/toni/garnome/lib/libgnomecups-1.0.la
/usr/bin/install: cannot stat `.libs/libgnomecups-1.0.lai': No such file or directory
make[9]: *** [install-libLTLIBRARIES] Error 1
make[9]: Leaving directory `/home/toni/garnome-2.22.0/geektoys/libgnomecups/work/main.d/libgnomecups-0.2.3/libgnomecups'
make[8]: *** [install-am] Error 2
make[8]: Leaving directory `/home/toni/garnome-2.22.0/geektoys/libgnomecups/work/main.d/libgnomecups-0.2.3/libgnomecups'
make[7]: *** [install-recursive] Error 1
make[7]: Leaving directory `/home/toni/garnome-2.22.0/geektoys/libgnomecups/work/main.d/libgnomecups-0.2.3'
make[6]: *** [install-work/main.d/libgnomecups-0.2.3/Makefile] Error 2
make[6]: Leaving directory `/home/toni/garnome-2.22.0/geektoys/libgnomecups'
make[5]: *** [../../geektoys/libgnomecups/cookies/main.d/install] Error 2
make[5]: Leaving directory `/home/toni/garnome-2.22.0/desktop/libgnomeprint'
make[4]: *** [../../desktop/libgnomeprint/cookies/main.d/install] Error 2
make[4]: Leaving directory `/home/toni/garnome-2.22.0/desktop/libgnomeprintui'
make[3]: *** [../../desktop/libgnomeprintui/cookies/main.d/install] Error 2
make[3]: Leaving directory `/home/toni/garnome-2.22.0/bindings/gnome-python'
make[2]: *** [../../bindings/gnome-python/cookies/main.d/install] Error 2
make[2]: Leaving directory `/home/toni/garnome-2.22.0/admin/pessulus'
make[1]: *** [paranoid-install] Error 2
make[1]: Leaving directory `/home/toni/garnome-2.22.0/admin'
make: *** [paranoid-install] Error 2
toni@toni-laptop:~/garnome-2.22.0$

alguém me poderia dizer como posso resolver este erro de instalação ?

« Última modificação: 21 de MAR?O de 2008, 20:05 por Bluray »
@CMatomic

Offline Bluray

  • Usuário Ubuntu
  • *
  • Mensagens: 75
    • Ver perfil
Re: GARNOME 2.24.x
« Resposta #1 Online: 10 de Novembro de 2008, 15:20 »
ajuda-me profavor gostaria de instalar uma nova versão do gnome 

Citar
toni@vaio-laptop:~/garnome-2.24.0$ auto-apt run make paranoid-install
Entering auto-apt mode: make paranoid-install
Exit the command to leave auto-apt mode.
make[1]: Entering directory `/home/toni/garnome-2.24.0/admin'
make[2]: Entering directory `/home/toni/garnome-2.24.0/admin/pessulus'
[===== NOW BUILDING:    pessulus-2.24.0 =====]
        [fetch] complete for pessulus.
        [checksum] complete for pessulus.
        [extract] complete for pessulus.
        [patch] complete for pessulus.
        [fixup] complete for pessulus.
 ==> Building bindings/gnome-python as a dependency
make[3]: Entering directory `/home/toni/garnome-2.24.0/bindings/gnome-python'
[===== NOW BUILDING:    gnome-python-2.22.3     =====]
        [fetch] complete for gnome-python.
        [checksum] complete for gnome-python.
        [extract] complete for gnome-python.
        [patch] complete for gnome-python.
        [fixup] complete for gnome-python.
 ==> Building desktop/libgnomeprintui as a dependency
make[4]: Entering directory `/home/toni/garnome-2.24.0/desktop/libgnomeprintui'
[===== NOW BUILDING:    libgnomeprintui-2.18.3  =====]
        [fetch] complete for libgnomeprintui.
        [checksum] complete for libgnomeprintui.
   [extract] complete for libgnomeprintui.
   [patch] complete for libgnomeprintui.
   [fixup] complete for libgnomeprintui.
 ==> Building desktop/libgnomeprint as a dependency
make[5]: Entering directory `/home/toni/garnome-2.24.0/desktop/libgnomeprint'
[===== NOW BUILDING:   libgnomeprint-2.18.5   =====]
   [fetch] complete for libgnomeprint.
   [checksum] complete for libgnomeprint.
   [extract] complete for libgnomeprint.
   [patch] complete for libgnomeprint.
   [fixup] complete for libgnomeprint.
 ==> Building geektoys/libgnomecups as a dependency
make[6]: Entering directory `/home/toni/garnome-2.24.0/geektoys/libgnomecups'
[===== NOW BUILDING:   libgnomecups-0.2.3   =====]
   [fetch] complete for libgnomecups.
   [checksum] complete for libgnomecups.
   [extract] complete for libgnomecups.
   [patch] complete for libgnomecups.
   [fixup] complete for libgnomecups.
   [configure] complete for libgnomecups.
   [build] complete for libgnomecups.
 ==> Running make install in work/main.d/libgnomecups-0.2.3
make[7]: Entering directory `/home/toni/garnome-2.24.0/geektoys/libgnomecups/work/main.d/libgnomecups-0.2.3'
Making install in libgnomecups
make[8]: Entering directory `/home/toni/garnome-2.24.0/geektoys/libgnomecups/work/main.d/libgnomecups-0.2.3/libgnomecups'
make[9]: Entering directory `/home/toni/garnome-2.24.0/geektoys/libgnomecups/work/main.d/libgnomecups-0.2.3/libgnomecups'
test -z "/home/toni/garnome/lib" || /bin/mkdir -p "/home/toni/garnome/lib"
 /bin/bash ../libtool   --mode=install /usr/bin/install -c  'libgnomecups-1.0.la' '/home/toni/garnome/lib/libgnomecups-1.0.la'
/usr/bin/install -c .libs/libgnomecups-1.0.so.1.0.0 /home/toni/garnome/lib/libgnomecups-1.0.so.1.0.0
(cd /home/toni/garnome/lib && { ln -s -f libgnomecups-1.0.so.1.0.0 libgnomecups-1.0.so.1 || { rm -f libgnomecups-1.0.so.1 && ln -s libgnomecups-1.0.so.1.0.0 libgnomecups-1.0.so.1; }; })
(cd /home/toni/garnome/lib && { ln -s -f libgnomecups-1.0.so.1.0.0 libgnomecups-1.0.so || { rm -f libgnomecups-1.0.so && ln -s libgnomecups-1.0.so.1.0.0 libgnomecups-1.0.so; }; })
/usr/bin/install -c .libs/libgnomecups-1.0.lai /home/toni/garnome/lib/libgnomecups-1.0.la
/usr/bin/install: cannot stat `.libs/libgnomecups-1.0.lai': No such file or directory
make[9]: *** [install-libLTLIBRARIES] Error 1
make[9]: Leaving directory `/home/toni/garnome-2.24.0/geektoys/libgnomecups/work/main.d/libgnomecups-0.2.3/libgnomecups'
make[8]: *** [install-am] Error 2
make[8]: Leaving directory `/home/toni/garnome-2.24.0/geektoys/libgnomecups/work/main.d/libgnomecups-0.2.3/libgnomecups'
make[7]: *** [install-recursive] Error 1
make[7]: Leaving directory `/home/toni/garnome-2.24.0/geektoys/libgnomecups/work/main.d/libgnomecups-0.2.3'
make[6]: *** [install-work/main.d/libgnomecups-0.2.3/Makefile] Error 2
make[6]: Leaving directory `/home/toni/garnome-2.24.0/geektoys/libgnomecups'
make[5]: *** [../../geektoys/libgnomecups/cookies/main.d/install] Error 2
make[5]: Leaving directory `/home/toni/garnome-2.24.0/desktop/libgnomeprint'
make[4]: *** [../../desktop/libgnomeprint/cookies/main.d/install] Error 2
make[4]: Leaving directory `/home/toni/garnome-2.24.0/desktop/libgnomeprintui'
make[3]: *** [../../desktop/libgnomeprintui/cookies/main.d/install] Error 2
make[3]: Leaving directory `/home/toni/garnome-2.24.0/bindings/gnome-python'
make[2]: *** [../../bindings/gnome-python/cookies/main.d/install] Error 2
make[2]: Leaving directory `/home/toni/garnome-2.24.0/admin/pessulus'
make[1]: *** [paranoid-install] Error 2
make[1]: Leaving directory `/home/toni/garnome-2.24.0/admin'
make: *** [paranoid-install] Error 2
toni@vaio-laptop:~/garnome-2.24.0$
« Última modificação: 10 de Novembro de 2008, 15:24 por Bluray »
@CMatomic

Offline Hqxriven

  • Usuário Ubuntu
  • *
  • Mensagens: 1.456
    • Ver perfil
Re: GARNOME 2.22.x
« Resposta #2 Online: 10 de Novembro de 2008, 15:30 »
Vc tem todas essas dependências instaladas...

http://www.gnome.org/projects/garnome/deps-list-ubuntu.html

Sinceramente... compilar gnome é coisa complicada demais até o cara criador do slackware desistiu...
Sem distro Linux fixa - Kernel Omnislash
Meu objetivo nesse fórum é ajudar. Sou um mero humano mas desejo sempre aprender e melhorar em tudo o que faço em minha vida. Então, por favor, quando eu postar me notifique depois

Offline agente100gelo

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.369
  • @Ceará
    • Ver perfil
Re: GARNOME 2.22.x
« Resposta #3 Online: 10 de Novembro de 2008, 15:50 »
Atualize o Ubuntu para a versão 8.10. É a melhor forma de atualizar o Gnome.
Advogado e analista de sistema cearense.
Twitter: @glaydson

Offline Bluray

  • Usuário Ubuntu
  • *
  • Mensagens: 75
    • Ver perfil
Re: GARNOME 2.22.x
« Resposta #4 Online: 10 de Novembro de 2008, 23:29 »
Atualize o Ubuntu para a versão 8.10. É a melhor forma de atualizar o Gnome.

o ubuntu 8.10 funciona mal no meu Portátil com placa grafica da intel i915GM, por enquanto vou ficar no ubuntu 8.04,
consegui resolver 99% das dependecias   neste momento tou compilar o gnome 2.24, obrigado pela dica Hqxriven não tinha pensado nisso na outra vez que tentei.
@CMatomic

Offline Bluray

  • Usuário Ubuntu
  • *
  • Mensagens: 75
    • Ver perfil
Re: GARNOME 2.24.x
« Resposta #5 Online: 11 de Novembro de 2008, 09:07 »
depois de mais de uma hora de compilar surgi-o um erro acesso a um servidor que o granome pede
vou tentar informar o pessoal do gnome sobre isto 
 
toni@vaio-laptop:~/garnome-2.24.0$ make paranoid-install
make[1]: Entering directory `/home/toni/garnome-2.24.0/admin'
make[2]: Entering directory `/home/toni/garnome-2.24.0/admin/pessulus'
[===== NOW BUILDING:    pessulus-2.24.0 =====]
        [fetch] complete for pessulus.
        [checksum] complete for pessulus.
        [extract] complete for pessulus.
        [patch] complete for pessulus.
        [fixup] complete for pessulus.
 ==> Building bindings/gnome-python as a dependency
make[3]: Entering directory `/home/toni/garnome-2.24.0/bindings/gnome-python'
[===== NOW BUILDING:    gnome-python-2.22.3     =====]
        [fetch] complete for gnome-python.
        [checksum] complete for gnome-python.
        [extract] complete for gnome-python.
        [patch] complete for gnome-python.
        [fixup] complete for gnome-python.
 ==> Building desktop/nautilus as a dependency
make[4]: Entering directory `/home/toni/garnome-2.24.0/desktop/nautilus'
[===== NOW BUILDING:    nautilus-2.24.0 =====]
        [fetch] complete for nautilus.
        [checksum] complete for nautilus.
        [extract] complete for nautilus.
        [patch] complete for nautilus.
        [fixup] complete for nautilus.
 ==> Building platform/libgnomeui as a dependency
make[5]: Entering directory `/home/toni/garnome-2.24.0/platform/libgnomeui'
[===== NOW BUILDING:    libgnomeui-2.24.0       =====]
        [fetch] complete for libgnomeui.
        [checksum] complete for libgnomeui.
        [extract] complete for libgnomeui.
        [patch] complete for libgnomeui.
        [fixup] complete for libgnomeui.
 ==> Building desktop/gnome-keyring as a dependency
make[6]: Entering directory `/home/toni/garnome-2.24.0/desktop/gnome-keyring'
[===== NOW BUILDING:    gnome-keyring-2.24.0    =====]
        [fetch] complete for gnome-keyring.
        [checksum] complete for gnome-keyring.
        [extract] complete for gnome-keyring.
        [patch] complete for gnome-keyring.
        [fixup] complete for gnome-keyring.
 ==> Building bootstrap/libtasn1 as a dependency
make[7]: Entering directory `/home/toni/garnome-2.24.0/bootstrap/libtasn1'
[===== NOW BUILDING:    libtasn1-1.4    =====]
 ==> Grabbing download/libtasn1-1.4.tar.gz
        ==> Trying file//files/libtasn1-1.4.tar.gz
make[8]: Entering directory `/home/toni/garnome-2.24.0/bootstrap/libtasn1'
make[8]: *** [file//files/libtasn1-1.4.tar.gz] Error 1
make[8]: Leaving directory `/home/toni/garnome-2.24.0/bootstrap/libtasn1'
        ==> Trying file///libtasn1-1.4.tar.gz
make[8]: Entering directory `/home/toni/garnome-2.24.0/bootstrap/libtasn1'
make[8]: *** [file///libtasn1-1.4.tar.gz] Error 1
make[8]: Leaving directory `/home/toni/garnome-2.24.0/bootstrap/libtasn1'
        ==> Trying http//www.gnu.org/software/gnutls/releases/libtasn1/libtasn1-1.4.tar.gz
make[8]: Entering directory `/home/toni/garnome-2.24.0/bootstrap/libtasn1'
--11:01:34--  http://www.gnu.org/software/gnutls/releases/libtasn1/libtasn1-1.4.tar.gz
           => `download/partial/libtasn1-1.4.tar.gz'
A resolver www.gnu.org... 199.232.41.10
A conectar www.gnu.org|199.232.41.10|:80... conectado.
Pedido HTTP enviado, a aguardar resposta... 404 Not Found
11:01:34 ERRO 404: Not Found.

make[8]: *** [http//www.gnu.org/software/gnutls/releases/libtasn1/libtasn1-1.4.tar.gz] Error 1
make[8]: Leaving directory `/home/toni/garnome-2.24.0/bootstrap/libtasn1'
        ==> Trying http//ftp.gnome.org/pub/GNOME/sources/libtasn1/1.4/libtasn1-1.4.tar.gz
make[8]: Entering directory `/home/toni/garnome-2.24.0/bootstrap/libtasn1'
--11:01:35--  http://ftp.gnome.org/pub/GNOME/sources/libtasn1/1.4/libtasn1-1.4.tar.gz
           => `download/partial/libtasn1-1.4.tar.gz'
A resolver ftp.gnome.org... 130.239.18.137, 130.239.18.173
A conectar ftp.gnome.org|130.239.18.137|:80... conectado.
Pedido HTTP enviado, a aguardar resposta... 302 Found
Localização: http://gemmei.acc.umu.se/pub/GNOME/sources/libtasn1/1.4/libtasn1-1.4.tar.gz [a seguir]
--11:01:35--  http://gemmei.acc.umu.se/pub/GNOME/sources/libtasn1/1.4/libtasn1-1.4.tar.gz
           => `download/partial/libtasn1-1.4.tar.gz'
A resolver gemmei.acc.umu.se... 130.239.18.163
A conectar gemmei.acc.umu.se|130.239.18.163|:80... conectado.
Pedido HTTP enviado, a aguardar resposta... 404 Not Found
11:01:36 ERRO 404: Not Found.

make[8]: *** [http//ftp.gnome.org/pub/GNOME/sources/libtasn1/1.4/libtasn1-1.4.tar.gz] Error 1
make[8]: Leaving directory `/home/toni/garnome-2.24.0/bootstrap/libtasn1'
*** GAR GAR GAR!  Failed to download download/libtasn1-1.4.tar.gz!  GAR GAR GAR! ***
make[7]: *** [download/libtasn1-1.4.tar.gz] Error 1
make[7]: Leaving directory `/home/toni/garnome-2.24.0/bootstrap/libtasn1'
make[6]: *** [../../bootstrap/libtasn1/cookies/main.d/install] Error 2
make[6]: Leaving directory `/home/toni/garnome-2.24.0/desktop/gnome-keyring'
make[5]: *** [../../desktop/gnome-keyring/cookies/main.d/install] Error 2
make[5]: Leaving directory `/home/toni/garnome-2.24.0/platform/libgnomeui'
make[4]: *** [../../platform/libgnomeui/cookies/main.d/install] Error 2
make[4]: Leaving directory `/home/toni/garnome-2.24.0/desktop/nautilus'
make[3]: *** [../../desktop/nautilus/cookies/main.d/install] Error 2
make[3]: Leaving directory `/home/toni/garnome-2.24.0/bindings/gnome-python'
make[2]: *** [../../bindings/gnome-python/cookies/main.d/install] Error 2
make[2]: Leaving directory `/home/toni/garnome-2.24.0/admin/pessulus'
make[1]: *** [paranoid-install] Error 2
make[1]: Leaving directory `/home/toni/garnome-2.24.0/admin'
make: *** [paranoid-install] Error 2
toni@vaio-laptop:~/garnome-2.24.0$       
@CMatomic

Offline Bluray

  • Usuário Ubuntu
  • *
  • Mensagens: 75
    • Ver perfil
Re: GARNOME 2.24.x
« Resposta #6 Online: 11 de Novembro de 2008, 10:21 »
depois de mais de uma hora de compilar surgi-o um erro acesso a um servidor que o granome pede
vou tentar informar o pessoal do gnome sobre isto 
 
toni@vaio-laptop:~/garnome-2.24.0$ make paranoid-install
make[1]: Entering directory `/home/toni/garnome-2.24.0/admin'
make[2]: Entering directory `/home/toni/garnome-2.24.0/admin/pessulus'
[===== NOW BUILDING:    pessulus-2.24.0 =====]
        [fetch] complete for pessulus.
        [checksum] complete for pessulus.
        [extract] complete for pessulus.
        [patch] complete for pessulus.
        [fixup] complete for pessulus.
 ==> Building bindings/gnome-python as a dependency
make[3]: Entering directory `/home/toni/garnome-2.24.0/bindings/gnome-python'
[===== NOW BUILDING:    gnome-python-2.22.3     =====]
        [fetch] complete for gnome-python.
        [checksum] complete for gnome-python.
        [extract] complete for gnome-python.
        [patch] complete for gnome-python.
        [fixup] complete for gnome-python.
 ==> Building desktop/nautilus as a dependency
make[4]: Entering directory `/home/toni/garnome-2.24.0/desktop/nautilus'
[===== NOW BUILDING:    nautilus-2.24.0 =====]
        [fetch] complete for nautilus.
        [checksum] complete for nautilus.
        [extract] complete for nautilus.
        [patch] complete for nautilus.
        [fixup] complete for nautilus.
 ==> Building platform/libgnomeui as a dependency
make[5]: Entering directory `/home/toni/garnome-2.24.0/platform/libgnomeui'
[===== NOW BUILDING:    libgnomeui-2.24.0       =====]
        [fetch] complete for libgnomeui.
        [checksum] complete for libgnomeui.
        [extract] complete for libgnomeui.
        [patch] complete for libgnomeui.
        [fixup] complete for libgnomeui.
 ==> Building desktop/gnome-keyring as a dependency
make[6]: Entering directory `/home/toni/garnome-2.24.0/desktop/gnome-keyring'
[===== NOW BUILDING:    gnome-keyring-2.24.0    =====]
        [fetch] complete for gnome-keyring.
        [checksum] complete for gnome-keyring.
        [extract] complete for gnome-keyring.
        [patch] complete for gnome-keyring.
        [fixup] complete for gnome-keyring.
 ==> Building bootstrap/libtasn1 as a dependency
make[7]: Entering directory `/home/toni/garnome-2.24.0/bootstrap/libtasn1'
[===== NOW BUILDING:    libtasn1-1.4    =====]
 ==> Grabbing download/libtasn1-1.4.tar.gz
        ==> Trying file//files/libtasn1-1.4.tar.gz
make[8]: Entering directory `/home/toni/garnome-2.24.0/bootstrap/libtasn1'
make[8]: *** [file//files/libtasn1-1.4.tar.gz] Error 1
make[8]: Leaving directory `/home/toni/garnome-2.24.0/bootstrap/libtasn1'
        ==> Trying file///libtasn1-1.4.tar.gz
make[8]: Entering directory `/home/toni/garnome-2.24.0/bootstrap/libtasn1'
make[8]: *** [file///libtasn1-1.4.tar.gz] Error 1
make[8]: Leaving directory `/home/toni/garnome-2.24.0/bootstrap/libtasn1'
        ==> Trying http//www.gnu.org/software/gnutls/releases/libtasn1/libtasn1-1.4.tar.gz
make[8]: Entering directory `/home/toni/garnome-2.24.0/bootstrap/libtasn1'
--11:01:34--  http://www.gnu.org/software/gnutls/releases/libtasn1/libtasn1-1.4.tar.gz
           => `download/partial/libtasn1-1.4.tar.gz'
A resolver www.gnu.org... 199.232.41.10
A conectar www.gnu.org|199.232.41.10|:80... conectado.
Pedido HTTP enviado, a aguardar resposta... 404 Not Found
11:01:34 ERRO 404: Not Found.

make[8]: *** [http//www.gnu.org/software/gnutls/releases/libtasn1/libtasn1-1.4.tar.gz] Error 1
make[8]: Leaving directory `/home/toni/garnome-2.24.0/bootstrap/libtasn1'
        ==> Trying http//ftp.gnome.org/pub/GNOME/sources/libtasn1/1.4/libtasn1-1.4.tar.gz
make[8]: Entering directory `/home/toni/garnome-2.24.0/bootstrap/libtasn1'
--11:01:35--  http://ftp.gnome.org/pub/GNOME/sources/libtasn1/1.4/libtasn1-1.4.tar.gz
           => `download/partial/libtasn1-1.4.tar.gz'
A resolver ftp.gnome.org... 130.239.18.137, 130.239.18.173
A conectar ftp.gnome.org|130.239.18.137|:80... conectado.
Pedido HTTP enviado, a aguardar resposta... 302 Found
Localização: http://gemmei.acc.umu.se/pub/GNOME/sources/libtasn1/1.4/libtasn1-1.4.tar.gz [a seguir]
--11:01:35--  http://gemmei.acc.umu.se/pub/GNOME/sources/libtasn1/1.4/libtasn1-1.4.tar.gz
           => `download/partial/libtasn1-1.4.tar.gz'
A resolver gemmei.acc.umu.se... 130.239.18.163
A conectar gemmei.acc.umu.se|130.239.18.163|:80... conectado.
Pedido HTTP enviado, a aguardar resposta... 404 Not Found
11:01:36 ERRO 404: Not Found.

make[8]: *** [http//ftp.gnome.org/pub/GNOME/sources/libtasn1/1.4/libtasn1-1.4.tar.gz] Error 1
make[8]: Leaving directory `/home/toni/garnome-2.24.0/bootstrap/libtasn1'
*** GAR GAR GAR!  Failed to download download/libtasn1-1.4.tar.gz!  GAR GAR GAR! ***
make[7]: *** [download/libtasn1-1.4.tar.gz] Error 1
make[7]: Leaving directory `/home/toni/garnome-2.24.0/bootstrap/libtasn1'
make[6]: *** [../../bootstrap/libtasn1/cookies/main.d/install] Error 2
make[6]: Leaving directory `/home/toni/garnome-2.24.0/desktop/gnome-keyring'
make[5]: *** [../../desktop/gnome-keyring/cookies/main.d/install] Error 2
make[5]: Leaving directory `/home/toni/garnome-2.24.0/platform/libgnomeui'
make[4]: *** [../../platform/libgnomeui/cookies/main.d/install] Error 2
make[4]: Leaving directory `/home/toni/garnome-2.24.0/desktop/nautilus'
make[3]: *** [../../desktop/nautilus/cookies/main.d/install] Error 2
make[3]: Leaving directory `/home/toni/garnome-2.24.0/bindings/gnome-python'
make[2]: *** [../../bindings/gnome-python/cookies/main.d/install] Error 2
make[2]: Leaving directory `/home/toni/garnome-2.24.0/admin/pessulus'
make[1]: *** [paranoid-install] Error 2
make[1]: Leaving directory `/home/toni/garnome-2.24.0/admin'
make: *** [paranoid-install] Error 2
toni@vaio-laptop:~/garnome-2.24.0$       

este problema  resolvido pesquisei no google a  source(fonte) em falta e copiei  para /garnome-2.24.0/bootstrap/libtasn1/download
para quem tiver os mesmo problema pode ir sacar oa  source aqui https://launchpad.net/libtasn1-2/main/1.4
depois de resolvido este problema o compilar continuou,
irei por aqui o resultado final  e um pequeno tutorial  como instalar novas versões do gnome
@CMatomic

Offline Bluray

  • Usuário Ubuntu
  • *
  • Mensagens: 75
    • Ver perfil
Re: GARNOME 2.24.x
« Resposta #7 Online: 11 de Novembro de 2008, 10:54 »
../../dist/lib/libgkconcvs_s.a(nsCanvasRenderingContext2D.o): In function `nsCanvasRenderingContext2D::SetDimensions(int, int)':
nsCanvasRenderingContext2D.cpp:(.text+0x5dbc): undefined reference to `XRenderFindStandardFormat'
collect2: ld returned 1 exit status
make[10]: *** [libgklayout.so] Error 1
make[10]: Leaving directory `/home/toni/garnome-2.24.0/bootstrap/firefox/work/main.d/mozilla/layout/build'
make[9]: *** [libs] Error 2
make[9]: Leaving directory `/home/toni/garnome-2.24.0/bootstrap/firefox/work/main.d/mozilla/layout'
make[8]: *** [tier_9] Error 2
make[8]: Leaving directory `/home/toni/garnome-2.24.0/bootstrap/firefox/work/main.d/mozilla'
make[7]: *** [default] Error 2
make[7]: Leaving directory `/home/toni/garnome-2.24.0/bootstrap/firefox/work/main.d/mozilla'
make[6]: *** [build-work/main.d/mozilla/Makefile] Error 2
make[6]: Leaving directory `/home/toni/garnome-2.24.0/bootstrap/firefox'
make[5]: *** [../../bootstrap/firefox/cookies/main.d/install] Error 2
make[5]: Leaving directory `/home/toni/garnome-2.24.0/desktop/librsvg'
make[4]: *** [../../desktop/librsvg/cookies/main.d/install] Error 2
make[4]: Leaving directory `/home/toni/garnome-2.24.0/desktop/nautilus'
make[3]: *** [../../desktop/nautilus/cookies/main.d/install] Error 2
make[3]: Leaving directory `/home/toni/garnome-2.24.0/bindings/gnome-python'
make[2]: *** [../../bindings/gnome-python/cookies/main.d/install] Error 2
make[2]: Leaving directory `/home/toni/garnome-2.24.0/admin/pessulus'
make[1]: *** [paranoid-install] Error 2
make[1]: Leaving directory `/home/toni/garnome-2.24.0/admin'
make: *** [paranoid-install] Error 2
toni@vaio-laptop:~/garnome-2.24.0$
 apareceu este  (undefined reference to `XRenderFindStandardFormat) erro no compilar vou fazer uma pesquisa como resolver
@CMatomic

Offline Bluray

  • Usuário Ubuntu
  • *
  • Mensagens: 75
    • Ver perfil
Re: GARNOME 2.24.x
« Resposta #8 Online: 11 de Novembro de 2008, 13:05 »
../../dist/lib/libgkconcvs_s.a(nsCanvasRenderingContext2D.o): In function `nsCanvasRenderingContext2D::SetDimensions(int, int)':
nsCanvasRenderingContext2D.cpp:(.text+0x5dbc): undefined reference to `XRenderFindStandardFormat'
collect2: ld returned 1 exit status
make[10]: *** [libgklayout.so] Error 1
make[10]: Leaving directory `/home/toni/garnome-2.24.0/bootstrap/firefox/work/main.d/mozilla/layout/build'
make[9]: *** [libs] Error 2
make[9]: Leaving directory `/home/toni/garnome-2.24.0/bootstrap/firefox/work/main.d/mozilla/layout'
make[8]: *** [tier_9] Error 2
make[8]: Leaving directory `/home/toni/garnome-2.24.0/bootstrap/firefox/work/main.d/mozilla'
make[7]: *** [default] Error 2
make[7]: Leaving directory `/home/toni/garnome-2.24.0/bootstrap/firefox/work/main.d/mozilla'
make[6]: *** [build-work/main.d/mozilla/Makefile] Error 2
make[6]: Leaving directory `/home/toni/garnome-2.24.0/bootstrap/firefox'
make[5]: *** [../../bootstrap/firefox/cookies/main.d/install] Error 2
make[5]: Leaving directory `/home/toni/garnome-2.24.0/desktop/librsvg'
make[4]: *** [../../desktop/librsvg/cookies/main.d/install] Error 2
make[4]: Leaving directory `/home/toni/garnome-2.24.0/desktop/nautilus'
make[3]: *** [../../desktop/nautilus/cookies/main.d/install] Error 2
make[3]: Leaving directory `/home/toni/garnome-2.24.0/bindings/gnome-python'
make[2]: *** [../../bindings/gnome-python/cookies/main.d/install] Error 2
make[2]: Leaving directory `/home/toni/garnome-2.24.0/admin/pessulus'
make[1]: *** [paranoid-install] Error 2
make[1]: Leaving directory `/home/toni/garnome-2.24.0/admin'
make: *** [paranoid-install] Error 2
toni@vaio-laptop:~/garnome-2.24.0$
 apareceu este  (undefined reference to `XRenderFindStandardFormat) erro no compilar vou fazer uma pesquisa como resolver

erro aqui referido a cima é um erro no compilar do Frirefox fiz uma pesquiza no google encontrei uma reposta a este problema mas não sei o que fazer porque o post ta em Chimes, tentei perceber mas  deu mesmo erro
Citar
修改文件 garnome-2.24.0/bootstrap/firefox/work/main.d/mozilla/layout/build/Makefile.in

将227行的内容由

ifdef MOZ_ENABLE_GTK2
EXTRA_DSO_LDOPTS += $(MOZ_GTK2_LIBS) \
$(NULL)
endif

改为

ifdef MOZ_ENABLE_GTK2
EXTRA_DSO_LDOPTS += $(MOZ_GTK2_LIBS) \
-lXrender \
-lX11 \

$(NULL)
endif
@CMatomic

Offline Bluray

  • Usuário Ubuntu
  • *
  • Mensagens: 75
    • Ver perfil
Re: GARNOME 2.24.x
« Resposta #9 Online: 11 de Novembro de 2008, 13:42 »
fiz mais uma tentativa, cheguei a uma conclusão que tava editar o ficheiro errado.
Citar
修改文件 garnome-2.24.0/bootstrap/firefox/work/main.d/mozilla/layout/build/Makefile.in

将227行的内容由

ifdef MOZ_ENABLE_GTK2
EXTRA_DSO_LDOPTS += $(MOZ_GTK2_LIBS) \
$(NULL)
endif

改为

ifdef MOZ_ENABLE_GTK2
EXTRA_DSO_LDOPTS += $(MOZ_GTK2_LIBS) \
-lXrender \
-lX11 \
$(NULL)
endif
 fonte http://forum.ubuntu.org.cn/viewtopic.php?f=56&t=157154&p=978019
é memos  desta maneira que se resolve o problema  vamos ao ficheiro garnome-2.24.0/bootstrap/firefox/work/main.d/mozilla/layout/build/Makefile.in
edita-se isto

ifdef MOZ_ENABLE_GTK2
EXTRA_DSO_LDOPTS += $(MOZ_GTK2_LIBS) \
$(NULL)
endif

para ficar assim

ifdef MOZ_ENABLE_GTK2
EXTRA_DSO_LDOPTS += $(MOZ_GTK2_LIBS) \
-lXrender \
-lX11 \

$(NULL)
endif

e continuo  a compilar


« Última modificação: 11 de Novembro de 2008, 13:44 por Bluray »
@CMatomic

Offline Bluray

  • Usuário Ubuntu
  • *
  • Mensagens: 75
    • Ver perfil
Re: GARNOME 2.24.x
« Resposta #10 Online: 11 de Novembro de 2008, 13:51 »
novo erro
checking for METACITY... configure: error: Package requirements (gtk+-2.0 >= 2.10.0 pango >= 1.2.0 gconf-2.0 >= 1.2.0 libstartup-notification-1.0 >= 0.7 xcomposite >= 0.2 xfixes xrender xdamage) were not met:

Package pthread-stubs was not found in the pkg-config search path.
Perhaps you should add the directory containing `pthread-stubs.pc'
to the PKG_CONFIG_PATH environment variable
Package 'pthread-stubs', required by 'XCB', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables METACITY_CFLAGS
and METACITY_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

make[7]: *** [configure-work/main.d/metacity-2.24.0/configure] Error 1
make[7]: Leaving directory `/home/toni/garnome-2.24.0/desktop/metacity'
make[6]: *** [../../desktop/metacity/cookies/main.d/install] Error 2
make[6]: Leaving directory `/home/toni/garnome-2.24.0/desktop/gnome-themes'
make[5]: *** [../../desktop/gnome-themes/cookies/main.d/install] Error 2
make[5]: Leaving directory `/home/toni/garnome-2.24.0/desktop/gnome-desktop'
make[4]: *** [../../desktop/gnome-desktop/cookies/main.d/install] Error 2
make[4]: Leaving directory `/home/toni/garnome-2.24.0/desktop/nautilus'
make[3]: *** [../../desktop/nautilus/cookies/main.d/install] Error 2
make[3]: Leaving directory `/home/toni/garnome-2.24.0/bindings/gnome-python'
make[2]: *** [../../bindings/gnome-python/cookies/main.d/install] Error 2
make[2]: Leaving directory `/home/toni/garnome-2.24.0/admin/pessulus'
make[1]: *** [paranoid-install] Error 2
make[1]: Leaving directory `/home/toni/garnome-2.24.0/admin'
make: *** [paranoid-install] Error 2
toni@vaio-laptop:~/garnome-2.24.0$
mais uma pesquisa no google
@CMatomic

Offline Bluray

  • Usuário Ubuntu
  • *
  • Mensagens: 75
    • Ver perfil
Re: GARNOME 2.24.x
« Resposta #11 Online: 11 de Novembro de 2008, 15:12 »
novo erro
checking for METACITY... configure: error: Package requirements (gtk+-2.0 >= 2.10.0 pango >= 1.2.0 gconf-2.0 >= 1.2.0 libstartup-notification-1.0 >= 0.7 xcomposite >= 0.2 xfixes xrender xdamage) were not met:

Package pthread-stubs was not found in the pkg-config search path.
Perhaps you should add the directory containing `pthread-stubs.pc'
to the PKG_CONFIG_PATH environment variable
Package 'pthread-stubs', required by 'XCB', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables METACITY_CFLAGS
and METACITY_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

make[7]: *** [configure-work/main.d/metacity-2.24.0/configure] Error 1
make[7]: Leaving directory `/home/toni/garnome-2.24.0/desktop/metacity'
make[6]: *** [../../desktop/metacity/cookies/main.d/install] Error 2
make[6]: Leaving directory `/home/toni/garnome-2.24.0/desktop/gnome-themes'
make[5]: *** [../../desktop/gnome-themes/cookies/main.d/install] Error 2
make[5]: Leaving directory `/home/toni/garnome-2.24.0/desktop/gnome-desktop'
make[4]: *** [../../desktop/gnome-desktop/cookies/main.d/install] Error 2
make[4]: Leaving directory `/home/toni/garnome-2.24.0/desktop/nautilus'
make[3]: *** [../../desktop/nautilus/cookies/main.d/install] Error 2
make[3]: Leaving directory `/home/toni/garnome-2.24.0/bindings/gnome-python'
make[2]: *** [../../bindings/gnome-python/cookies/main.d/install] Error 2
make[2]: Leaving directory `/home/toni/garnome-2.24.0/admin/pessulus'
make[1]: *** [paranoid-install] Error 2
make[1]: Leaving directory `/home/toni/garnome-2.24.0/admin'
make: *** [paranoid-install] Error 2
toni@vaio-laptop:~/garnome-2.24.0$
mais uma pesquisa no google
depois de mais umas pesquisas encontrei a solução em Russo
http://otvety.google.ru/otvety/thread?tid=351a3862ef479b0c

segundo o que vi basta fazer este comando "
 sudo mv /usr/share/pkgconfig/pthread-stubs.pc /usr/lib/pkgconfig/pthread-stubs.pc  "


e  o compilar continua 
@CMatomic

Offline Bluray

  • Usuário Ubuntu
  • *
  • Mensagens: 75
    • Ver perfil
Re: GARNOME 2.24.x
« Resposta #12 Online: 11 de Novembro de 2008, 15:19 »
mais um erro  ;D

configure: error: ImageMagick is required to build tango-icon-theme
make[7]: *** [configure-work/main.d/tango-icon-theme-0.8.1/configure] Error 1
make[7]: Leaving directory `/home/toni/garnome-2.24.0/freedesktop/tango-icon-theme'
make[6]: *** [post-install] Error 2
make[6]: Leaving directory `/home/toni/garnome-2.24.0/desktop/gnome-themes'
make[5]: *** [../../desktop/gnome-themes/cookies/main.d/install] Error 2
make[5]: Leaving directory `/home/toni/garnome-2.24.0/desktop/gnome-desktop'
make[4]: *** [../../desktop/gnome-desktop/cookies/main.d/install] Error 2
make[4]: Leaving directory `/home/toni/garnome-2.24.0/desktop/nautilus'
make[3]: *** [../../desktop/nautilus/cookies/main.d/install] Error 2
make[3]: Leaving directory `/home/toni/garnome-2.24.0/bindings/gnome-python'
make[2]: *** [../../bindings/gnome-python/cookies/main.d/install] Error 2
make[2]: Leaving directory `/home/toni/garnome-2.24.0/admin/pessulus'
make[1]: *** [paranoid-install] Error 2
make[1]: Leaving directory `/home/toni/garnome-2.24.0/admin'
make: *** [paranoid-install] Error 2
toni@vaio-laptop:~/garnome-2.24.0$
para instalar esta dependência ver aqui http://www.imagemagick.org/script/index.php
 a outra maneira mais facil   é ir ao synaptic procurar por imagemagick e seleccionar alguns pacotes de desenvolvimento como ex libgraphicsmagick++1-dev ,libmagick++9-dev,libgraphicsmagick1-dev
este problema fica resolvido
 e continua o compilar
« Última modificação: 11 de Novembro de 2008, 17:28 por Bluray »
@CMatomic

Offline Bluray

  • Usuário Ubuntu
  • *
  • Mensagens: 75
    • Ver perfil
Re: GARNOME 2.24.x
« Resposta #13 Online: 11 de Novembro de 2008, 15:48 »
checking for GNOME_PLATFORM... configure: error: Package requirements (glib-2.0 >= 2.16.1
         gtk+-2.0 >= 2.10.0
         ORBit-2.0 >= 2.9.8
         libbonobo-2.0 >= 2.20.3
         gconf-2.0 >= 2.0.0
         libglade-2.0 >= 2.0.0
         libgnome-2.0 >= 2.0.0
         libxml-2.0 >= 2.0.0
         libsoup-2.4 >= 2.3.0
       sqlite3 >= 3.5) were not met:

Requested 'sqlite3 >= 3.5' but version of SQLite is 3.4.2

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GNOME_PLATFORM_CFLAGS
and GNOME_PLATFORM_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
 aqui vai mais um para lista  ;D
make[5]: *** [configure-work/main.d/evolution-data-server-2.24.0/configure] Error 1
make[5]: Leaving directory `/home/toni/garnome-2.24.0/desktop/evolution-data-server'
make[4]: *** [../../desktop/evolution-data-server/cookies/main.d/install] Error 2
make[4]: Leaving directory `/home/toni/garnome-2.24.0/desktop/gnome-panel'
make[3]: *** [../../desktop/gnome-panel/cookies/main.d/install] Error 2
make[3]: Leaving directory `/home/toni/garnome-2.24.0/bindings/gnome-python'
make[2]: *** [../../bindings/gnome-python/cookies/main.d/install] Error 2
make[2]: Leaving directory `/home/toni/garnome-2.24.0/admin/pessulus'
make[1]: *** [paranoid-install] Error 2
make[1]: Leaving directory `/home/toni/garnome-2.24.0/admin'
make: *** [paranoid-install] Error 2
toni@vaio-laptop:~/garnome-2.24.0$
@CMatomic

Offline Bluray

  • Usuário Ubuntu
  • *
  • Mensagens: 75
    • Ver perfil
Re: GARNOME 2.24.x
« Resposta #14 Online: 11 de Novembro de 2008, 17:24 »
checking for GNOME_PLATFORM... configure: error: Package requirements (glib-2.0 >= 2.16.1
         gtk+-2.0 >= 2.10.0
         ORBit-2.0 >= 2.9.8
         libbonobo-2.0 >= 2.20.3
         gconf-2.0 >= 2.0.0
         libglade-2.0 >= 2.0.0
         libgnome-2.0 >= 2.0.0
         libxml-2.0 >= 2.0.0
         libsoup-2.4 >= 2.3.0
       sqlite3 >= 3.5) were not met:

Requested 'sqlite3 >= 3.5' but version of SQLite is 3.4.2

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GNOME_PLATFORM_CFLAGS
and GNOME_PLATFORM_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
 aqui vai mais um para lista  ;D
make[5]: *** [configure-work/main.d/evolution-data-server-2.24.0/configure] Error 1
make[5]: Leaving directory `/home/toni/garnome-2.24.0/desktop/evolution-data-server'
make[4]: *** [../../desktop/evolution-data-server/cookies/main.d/install] Error 2
make[4]: Leaving directory `/home/toni/garnome-2.24.0/desktop/gnome-panel'
make[3]: *** [../../desktop/gnome-panel/cookies/main.d/install] Error 2
make[3]: Leaving directory `/home/toni/garnome-2.24.0/bindings/gnome-python'
make[2]: *** [../../bindings/gnome-python/cookies/main.d/install] Error 2
make[2]: Leaving directory `/home/toni/garnome-2.24.0/admin/pessulus'
make[1]: *** [paranoid-install] Error 2
make[1]: Leaving directory `/home/toni/garnome-2.24.0/admin'
make: *** [paranoid-install] Error 2
toni@vaio-laptop:~/garnome-2.24.0$
para resolver este problema temos que instalar os seguintes pacotes " libsqlite3-0_3.5.9-1_i386.deb , libsqlite3-0-dbg_3.5.9-1_i386.deb , libsqlite3-dev_3.5.9-1_i386.deb , podem fazer o download dos pacotes necessários aqui http://rapidshare.com/files/162841057/sqlite3_3.5.9-1_.deb_.tar.gz.html
se o link ficar desatualizado ver aqui http://download.thaigrid.or.th/pub/ubuntu/archives/pool/main/s/sqlite3/?C=S;O=A
depois instalar isto voltou a compilar
quando acabar instalar o gnome 2.24.0 no ubuntu 8.04  digo-vos como correu se aparecer um erro qualquer vou postando aqui 
« Última modificação: 11 de Novembro de 2008, 17:36 por Bluray »
@CMatomic