Autor Tópico: Som hora funciona hora não: AC'97 onboard PCCHIPS- Resolvido  (Lida 2771 vezes)

Offline gidalte

  • Usuário Ubuntu
  • *
  • Mensagens: 22
    • Ver perfil
Som hora funciona hora não: AC'97 onboard PCCHIPS- Resolvido
« Online: 01 de MAR?O de 2008, 13:51 »
Ubuntu 7.04 - 2.6.20-16-generic
Placa-mãe: PCCHIPS K8 A31G (som on-board)
Segundo manual da placa: AC`97 Audio Codec:Compliant whit AC'97 2.3 specification

# lspci -nn
00:02.7 Multimedia audio controller [0401]: Silicon Integrated Systems [SiS] AC'97 Sound Controller [1039:7012] (rev a0)

# modprobe -c | egrep '1039.*7012'
alias pci:v00001039d00007012sv*sd*bc*sc*i* snd_intel8x0
alias pci:v00001039d00007012sv*sd*bc*sc*i* i810_audio

# dmesg | grep '00:02.7'
[   34.850309] ACPI: PCI Interrupt 0000:00:02.7[C] -> GSI 18 (level, low) -> IRQ 16
[   35.852702] ACPI: PCI interrupt for device 0000:00:02.7 disabled  <--- quando funciona não aparece
[   35.852715] Intel ICH: probe of 0000:00:02.7 failed with error -5 <--- idem

# find -iname *i810_audio*
./usr/src/linux-source-2.6.20/sound/oss/i810_audio.c
./root/.Trash/linux-2.6.20/sound/oss/i810_audio.c
./lib/modules/2.6.20-16-generic/kernel/sound/oss/i810_audio.ko

# find -iname *ac97*
./lib/modules/2.6.20-16-generic/kernel/sound/oss/ac97_codec.ko
./lib/modules/2.6.20-16-generic/kernel/sound/pci/ac97/snd-ac97-codec.ko
./lib/modules/2.6.20-16-generic/kernel/sound/ac97_bus.ko

# lsmod | egrep 'snd*'
snd_intel8x0           34332  0
snd_ac97_codec         98464  1 snd_intel8x0
ac97_bus                3200  1 snd_ac97_codec
snd_pcm_oss            44544  0
snd_mixer_oss          17408  1 snd_pcm_oss
snd_pcm                79876  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_seq_dummy           4740  0
snd_seq_oss            32896  0
snd_seq_midi            9600  0
snd_rawmidi            25472  1 snd_seq_midi
snd_seq_midi_event      8448  2 snd_seq_oss,snd_seq_midi
snd_seq                52592  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              23684  2 snd_pcm,snd_seq
snd_seq_device          9100  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd                    54020  8 snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device soundcore               8672  1 snd
snd_page_alloc         10888  1 snd_pcm

O que estrá acontecendo? Será o módulo incoreto?
------------------------------------------------------------------
No forum dos gringos porque aqui é "mei difice":

Tradução livre

Oĺá
Eu tenho um velho Laptop OEM com som onboard.
O problema é que no primeiro boot no Ubuntu 7.04 eu não pego o som, mas se eu reiniciar ou se der boot com windows XP,
eu consigo obter o som funcionando. Quando o som não está funcionando, ao usar "sudo asoundconf list" retorna: no sound card

O mesmo comando quando o som está funcionando, retorna: SI7012
(que usa o módulo snd_intel8x0 alsa).

Usando "aplay -l" retorna: device_list:222: no soundcards found...

Mas se entrar com "lspci -v" o sistema detecta o seguinte:

00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
Subsystem: Wistron Corp. Unknown device 2000
Flags: medium devsel, IRQ 18
I/O ports at 1c00 [size=256]
I/O ports at 1800 [size=128]
Capabilities: <access denied>

Adicionando "snd-intel8x0" para etc/modules não produz nenhuma mudança.

O acesso parece estar bloquedo(?) Alí pode ser um caminho para forçar o Feisty sempre acessar o son onboard.
(embora reiniciando ou inicializando no windows XP parece desbloqueado)

Alguém tem algua idéia que poderia resolver esta questão?
---------------------------------------------------------
ONBOARD SI7012 QUESTÃO DO SOM UBUNTU (RESOLVIDA)
SOLUÇÃO:
(Testado no Gutsy Gibbon 7.10 e no Feisty Fawn 7.04)

1st:(Primeiro) - Edite e modifique a seguinte linha do aqruivo:alsa-base
sudo gedit /etc/modprobe.d/alsa-base
procure por "options snd-intel8x0 index=-2" e mude para "options snd-intel8x0 index=0"

2nd:(Segundo) - Instale o modulo assistente:
sudo apt-get install module-assistant
sudo m-a update
sudo m-a prepare
sudo m-a a-i alsa

3rd:(Terceiro) - Reinicialize
Reboot

O som deveria estar funncionando agora.

NOTAS:
Tem fundamento que a atividade dos drievers do software modem possa conflitar com a placa de som.
o módulo "snd-intel8x0m" é para SI7013 modem
(nota do tradutor:se sua placa-mãe tem modem onboard e voce não usa é aconselhavel desativa-la no setup do BIOS)

Se ainda assim o áudio do seu sistema não vir a funcionar:
sudo apt-get install linux-backports-modules-generic

sudo chmod a+rwx /dev/dsp

sudo gedit /etc/groups
edite esta linha: audio:29:haldaemon,root,yourusername

sudo gedit /etc/modprobe.d/alsa-base
adicione a linha ao final: options snd-intel8x0 ac97_quirk=3
« Última modificação: 20 de MAR?O de 2008, 07:57 por gidalte »

Offline gidalte

  • Usuário Ubuntu
  • *
  • Mensagens: 22
    • Ver perfil
Re: Som hora funciona hora não: AC'97 onboard PCCHIPS- Resolvido
« Resposta #1 Online: 20 de MAR?O de 2008, 07:59 »
up

Offline alexmatos

  • Usuário Ubuntu
  • *
  • Mensagens: 792
  • Arch Linux / Ubuntu 7.04
    • Ver perfil
Re: Som hora funciona hora não: AC'97 onboard PCCHIPS- Resolvido
« Resposta #2 Online: 20 de MAR?O de 2008, 09:12 »
Eu tive o mesmo problema no computador da minha namorada e não tinha resolvido ainda. Vou testar essa solução!