Autor Tópico: Ubuntu 7.10 sem som - RESOLVIDO  (Lida 5829 vezes)

Offline HMF

  • Usuário Ubuntu
  • *
  • Mensagens: 33
    • Ver perfil
Ubuntu 7.10 sem som - RESOLVIDO
« Online: 03 de MAR?O de 2008, 02:06 »
Boa noite a todos,
Tem apenas um mês que estou usando o  Ubuntu 7.10, na minha 2ª instalação (pois caí na besteira de testar outras versões). O problema é que nunca tinha passado perto de um Linux na vida, mas com muito custo e com a ajuda de diversos fóruns consegui até instalar a placa wireless do meu Acer Aspire 4720z, mas a o som não to conseguindo fazer funcionar.
Aliás, nunca consegui fazer o som funcionar e não sei mais o que fazer, pensei até em desistir do operacional.
Me parece que a placa é uma intel HDA.
Já tentei algumas soluções postadas em outros fóruns mas sem sucesso. Alguém poderia me ajudar????? Só falta resolver isso para o abandono definitivo do windows, rsrsrsrs.
OBS.: eu realmente não sei nada sobre o Linux  (antes não sabia nem o que era um terminal), os comandos que executei peguei todos em fóruns e etc.

Alguns detalhes com o comando  "lspci":

administrador@administrador-laptop:~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Contoller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA IDE Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
04:00.0 Ethernet controller: Atheros Communications, Inc. AR5006EG 802.11 b/g Wireless PCI Express Adapter (rev 01)
05:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5787M Gigabit Ethernet PCI Express (rev 02)
0a:09.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
0a:09.1 Generic system peripheral [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
0a:09.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 12)
0a:09.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
0a:09.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 12)
administrador@administrador-laptop

Se alguém puder ajudar, especialmente no esquema passo a passo, pois tenho pouco ou quase nenhum conhecimento sobre o linux, eu agradeço. Valeu
« Última modificação: 11 de Maio de 2008, 01:49 por HMF »

Offline Oni-BR-

  • Usuário Ubuntu
  • *
  • Mensagens: 191
  • Ubuntu 8.10 Recém Instalado!!!! :D
    • Ver perfil
Re: Ubuntu 7.10 sem som
« Resposta #1 Online: 03 de MAR?O de 2008, 03:10 »
dá uma olhada nisso aqui vê se resolve o seu problema...

http://www.vivaolinux.com.br/comunidades/verTopico.php?codigo=65&codtopico=11638
Ubuntu 8.10 Recém Instalado!!!!

Offline HMF

  • Usuário Ubuntu
  • *
  • Mensagens: 33
    • Ver perfil
Re: Ubuntu 7.10 sem som
« Resposta #2 Online: 03 de MAR?O de 2008, 14:02 »
Oni-BR-
Valeu pela ajuda. Vou dar uma olhada e retorno com o resultado.
Eu achei essa indicação:

Crie o arquivo /etc/modprobe.d/alsa-base (como root) e coloque nele o seguinte conteúdo

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-intel8x0
options snd-intel8x0 index=0
options snd-intel8x0 buggy_semaphore=1
# module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

# OSS/Free portion - card #1
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

# OSS/Free portion - card #2 (cmipci)
alias sound-slot-1 snd-card-1
alias sound-service-1-0 snd-mixer-oss
alias sound-service-1-3 snd-pcm-oss
alias sound-service-1-12 snd-pcm-oss

---------------------------------------------------------
Pronto agora é so reiniciar o linux e a placa vai funcionar


Mas não consegui criar o diretório conforme foi orientado, aparece isso:
root@administrador-laptop:/home/administrador# /etc/modprobe.d/alsa-base
bash: /etc/modprobe.d/alsa-base: Permissão negada
root@administrador-laptop:/home/administrador#
 
E vi muita gente dizendo q resolveu o problema com esses passos. Mas, pedindo desculpas pela minha ignorância  no tema, não consigo seguir por completo a orientação escrita acima e não sei também porque dá permissão negada. Vc ou alguém sabe me dizer?

Obs: quando à solução que vc me indicou vou testar e coloco aqui os resultados. valeu

Offline Oni-BR-

  • Usuário Ubuntu
  • *
  • Mensagens: 191
  • Ubuntu 8.10 Recém Instalado!!!! :D
    • Ver perfil
Re: Ubuntu 7.10 sem som
« Resposta #3 Online: 03 de MAR?O de 2008, 15:19 »
Oni-BR-
Valeu pela ajuda. Vou dar uma olhada e retorno com o resultado.
Eu achei essa indicação:

Crie o arquivo /etc/modprobe.d/alsa-base (como root) e coloque nele o seguinte conteúdo

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-intel8x0
options snd-intel8x0 index=0
options snd-intel8x0 buggy_semaphore=1
# module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

# OSS/Free portion - card #1
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

# OSS/Free portion - card #2 (cmipci)
alias sound-slot-1 snd-card-1
alias sound-service-1-0 snd-mixer-oss
alias sound-service-1-3 snd-pcm-oss
alias sound-service-1-12 snd-pcm-oss

---------------------------------------------------------
Pronto agora é so reiniciar o linux e a placa vai funcionar


Mas não consegui criar o diretório conforme foi orientado, aparece isso:
root@administrador-laptop:/home/administrador# /etc/modprobe.d/alsa-base
bash: /etc/modprobe.d/alsa-base: Permissão negada
root@administrador-laptop:/home/administrador#
 
E vi muita gente dizendo q resolveu o problema com esses passos. Mas, pedindo desculpas pela minha ignorância  no tema, não consigo seguir por completo a orientação escrita acima e não sei também porque dá permissão negada. Vc ou alguém sabe me dizer?

Obs: quando à solução que vc me indicou vou testar e coloco aqui os resultados. valeu

para vc fazer isso tem que ser como root....
Ubuntu 8.10 Recém Instalado!!!!

Offline HMF

  • Usuário Ubuntu
  • *
  • Mensagens: 33
    • Ver perfil
Re: Ubuntu 7.10 sem som
« Resposta #4 Online: 03 de MAR?O de 2008, 21:25 »
Segui a dica que vc me enviou mas não deu certo, ficou tudo como estava.
Depois fui ao link https://wiki.ubuntu.com/Gutsy_Intel_HD_Audio_Controller e fiz os métodos A e C e quando plug o fone de ouvido o som sai bem baixo, quase imperceptível e com ruidos.
Quanto ao método que postei anteriormente eu tentei fazê-lo apos dar o comando sudo -s -H e digitar a senha. Aí aparecia o root no nome lá do terminal, mas não consegui criar a tal pasta e muito menos incluir o texto q a dica mandava.
Como faço p a dica anteriror dar certo????
OBS.: quanto à dica que vc me indicou deu tudo certo e os métodos A e C do link q coloquei aqui também deram. O som ao qual me refiro que está saindo no fone, muito mal, é de um arquivo de mp3 e no programa Rhythmbox e no Amarok.
Já estou começando a ficar desesperado pela falta do som. rsrsrs
Vc tem alguma idéia do que seja meu problema (além do fato de eu não saber nada de linux!!!!!) ???
Valeu

Offline HMF

  • Usuário Ubuntu
  • *
  • Mensagens: 33
    • Ver perfil
Re: Ubuntu 7.10 sem som
« Resposta #5 Online: 03 de MAR?O de 2008, 21:28 »
Havia me esquecido, depois dessas tentativas que falei as informações do lspci ficaram assim

administrador@administrador-laptop:~$ sudo -s -H
[sudo] password for administrador:
root@administrador-laptop:/home/administrador# lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Contoller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA IDE Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
04:00.0 Ethernet controller: Atheros Communications, Inc. AR5006EG 802.11 b/g Wireless PCI Express Adapter (rev 01)
05:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5787M Gigabit Ethernet PCI Express (rev 02)
0a:09.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
0a:09.1 Generic system peripheral [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
0a:09.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 12)
0a:09.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
0a:09.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 12)
root@administrador-laptop:/home/administrador#



Offline HMF

  • Usuário Ubuntu
  • *
  • Mensagens: 33
    • Ver perfil
Re: Ubuntu 7.10 sem som
« Resposta #6 Online: 03 de MAR?O de 2008, 21:30 »
Tentei dar o comando citado na minha primeira msg e dá o seguinte:

root@administrador-laptop:~# /etc/modprobe.d/alsa-base
bash: /etc/modprobe.d/alsa-base: Permissão negada
root@administrador-laptop:~#

Offline HMF

  • Usuário Ubuntu
  • *
  • Mensagens: 33
    • Ver perfil
Re: Ubuntu 7.10 sem som
« Resposta #7 Online: 04 de MAR?O de 2008, 22:04 »
Oni-BR-
É meu amigo, a coisa tá difícil mesmo, já devo ter tentado um milhão de coisas e nada, a única diferença que notei foi o fone com um som bem baixo e com muitos ruidos.
Se tiver alguma sugestão eu agradeço. Valeu pela ajuda.

Offline Oni-BR-

  • Usuário Ubuntu
  • *
  • Mensagens: 191
  • Ubuntu 8.10 Recém Instalado!!!! :D
    • Ver perfil
Re: Ubuntu 7.10 sem som
« Resposta #8 Online: 04 de MAR?O de 2008, 22:24 »
opa amigo desculpe não ter te respondido antes é as coisas ficaram um pouco corridas aqui!!! :P

bom eu vou te passar uma solução que um cara conseguiu no forum gringo...espero que te ajude...

Abra o terminal e digite seguindo a ordem:

Código: [Selecionar]
wget ftp://ftp.alsa-project.org/pub/drive....16rc1.tar.bz2

tar xvpjf alsa-driver-1.0.16rc1.tar.bz2

cd alsa-driver-1.0.16rc1

./configure --with-cards=hda-intel

make
 
sudo make install

Se funcionar e vc não receber nenhuma mensagem de erro, digite isso no terminal:
Código: [Selecionar]
sudo alsaconf
e siga as instruções que irá surgir na tela.

[]['s
Ubuntu 8.10 Recém Instalado!!!!

Offline HMF

  • Usuário Ubuntu
  • *
  • Mensagens: 33
    • Ver perfil
Re: Ubuntu 7.10 sem som
« Resposta #9 Online: 04 de MAR?O de 2008, 23:38 »
Oni-BR-
Blz? Olhe só, tentei a essa ultima indicação sua, mas parece que não deu certo, porque aparece em algum lugar que o arquivo ou driver não foi encontrado. No terminal ficou assim:

administrador@administrador-laptop:~$ sudo -s -H
[sudo] password for administrador:
root@administrador-laptop:/home/administrador# wget ftp://ftp.alsa-project.org/pub/drive....16rc1.tar.bz2
--23:33:35--  ftp://ftp.alsa-project.org/pub/drive....16rc1.tar.bz2
           => `drive....16rc1.tar.bz2'
Resolvendo ftp.alsa-project.org... 160.217.9.25
Conectando a ftp.alsa-project.org|160.217.9.25|:21... conectado.
Logando como anonymous ... Logado!
==> SYST ... pronto.    ==> PWD ... pronto.
==> TYPE I ... feito.  ==> CWD /pub ... pronto.
==> PASV ... pronto.    ==> RETR drive....16rc1.tar.bz2 ...
Arquivo `drive....16rc1.tar.bz2' não encontrado.

root@administrador-laptop:/home/administrador#


Quanto a vc não ter respondido antes, não tem problema algum. Quando vc estiver mais tranquilo e puder vc responde, e desde já lhe agradeço a ajuda. Valeu

Offline HMF

  • Usuário Ubuntu
  • *
  • Mensagens: 33
    • Ver perfil
Re: Ubuntu 7.10 sem som
« Resposta #10 Online: 04 de MAR?O de 2008, 23:49 »
Oni-BR-

Tive uma idéia, e se isso for algum absurdo desconsidere, pq como já disse não entendo nada de linux,  fui no endereço que está no comando que vc me passou por último e o driver me parece ter esse nome: alsa-driver-1.0.16rc1.tar.bz2 Será que se eu colocar o primeiro comando que vc me passou assim o driver não seria encontrado ???: wget ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.16rc1.tar.bz2

Offline Oni-BR-

  • Usuário Ubuntu
  • *
  • Mensagens: 191
  • Ubuntu 8.10 Recém Instalado!!!! :D
    • Ver perfil
Re: Ubuntu 7.10 sem som
« Resposta #11 Online: 05 de MAR?O de 2008, 01:39 »
Oni-BR-

Tive uma idéia, e se isso for algum absurdo desconsidere, pq como já disse não entendo nada de linux,  fui no endereço que está no comando que vc me passou por último e o driver me parece ter esse nome: alsa-driver-1.0.16rc1.tar.bz2 Será que se eu colocar o primeiro comando que vc me passou assim o driver não seria encontrado ???: wget ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.16rc1.tar.bz2

é uma alternativa....pq quando eu copiei e colei parece que abreviou o endereço que se encontra o driver....tenta ai e me fala o que aconteceu...
Ubuntu 8.10 Recém Instalado!!!!

Offline HMF

  • Usuário Ubuntu
  • *
  • Mensagens: 33
    • Ver perfil
Re: Ubuntu 7.10 sem som
« Resposta #12 Online: 05 de MAR?O de 2008, 16:18 »
Oni-BR-

corrigi o negócio do endereço e deu certo no que diz respeito ao download. porém, no último comando make ou make install, salvo engano , deram erros de arquivos ou diretórios inexistentes.

Offline Oni-BR-

  • Usuário Ubuntu
  • *
  • Mensagens: 191
  • Ubuntu 8.10 Recém Instalado!!!! :D
    • Ver perfil
Re: Ubuntu 7.10 sem som
« Resposta #13 Online: 05 de MAR?O de 2008, 21:21 »
Oni-BR-

corrigi o negócio do endereço e deu certo no que diz respeito ao download. porém, no último comando make ou make install, salvo engano , deram erros de arquivos ou diretórios inexistentes.

tente fazer o processo novamente e coloque a mensagem de erro que apareceu...

[]'s
Ubuntu 8.10 Recém Instalado!!!!

Offline HMF

  • Usuário Ubuntu
  • *
  • Mensagens: 33
    • Ver perfil
Re: Ubuntu 7.10 sem som
« Resposta #14 Online: 06 de MAR?O de 2008, 22:41 »
Oni-BR-
Blz, só fui até o comando "make", mas não tenho  certeza se houve erro nos processos anteriores. A única coisa q vi e pensei ser algum problema foi a msg:
*** NO PREDEFINED KERNEL COMPILER IS DETECTED
*** Assuming the same compiler is used with the current system compiler.

*** Please make sure that the same compiler version was used for building kernel

Se preferir posso mandar também o resultado dos comandos anteriores e tentar fazer o comando "make install".
Valeu.

O comando "make" deu nisso:

root@administrador-laptop:/home/administrador/alsa-driver-1.0.16rc1# make
make dep
make[1]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1'
make[2]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/acore'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/acore/ioctl32'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/acore/ioctl32'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/acore/oss'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/acore/oss'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/acore/seq'
make[4]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/acore/seq/oss'
make[4]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/acore/seq/oss'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/acore/seq'
make[2]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/acore'
make[2]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/i2c'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/i2c/l3'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/i2c/l3'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/i2c/other'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/i2c/other'
make[2]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/i2c'
make[2]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/drivers'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/drivers/mpu401'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/drivers/mpu401'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/drivers/opl3'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/drivers/opl3'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/drivers/opl4'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/drivers/opl4'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/drivers/pcsp'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/drivers/pcsp'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/drivers/vx'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/drivers/vx'
make[2]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/drivers'
make[2]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/isa'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/isa/ad1816a'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/isa/ad1816a'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/isa/ad1848'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/isa/ad1848'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/isa/cs423x'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/isa/cs423x'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/isa/es1688'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/isa/es1688'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/isa/gus'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/isa/gus'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/isa/msnd'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/isa/msnd'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/isa/opti9xx'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/isa/opti9xx'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/isa/sb'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/isa/sb'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/isa/wavefront'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/isa/wavefront'
make[2]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/isa'
make[2]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/synth'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/synth/emux'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/synth/emux'
make[2]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/synth'
make[2]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/pci'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/ac97'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/ac97'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/ali5451'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/ali5451'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/asihpi'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/asihpi'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/au88x0'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/au88x0'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/ca0106'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/ca0106'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/cs46xx'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/cs46xx'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/cs5535audio'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/cs5535audio'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/echoaudio'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/echoaudio'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/emu10k1'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/emu10k1'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/hda'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/hda'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/ice1712'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/ice1712'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/korg1212'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/korg1212'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/mixart'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/mixart'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/nm256'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/nm256'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/oxygen'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/oxygen'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/pcxhr'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/pcxhr'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/pdplus'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/pdplus'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/riptide'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/riptide'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/rme9652'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/rme9652'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/trident'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/trident'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/vx222'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/vx222'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/ymfpci'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/pci/ymfpci'
make[2]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/pci'
make[2]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/aoa'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/aoa/codecs'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/aoa/codecs'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/aoa/core'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/aoa/core'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/aoa/fabrics'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/aoa/fabrics'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/aoa/soundbus'
make[4]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/aoa/soundbus/i2sbus'
make[4]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/aoa/soundbus/i2sbus'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/aoa/soundbus'
make[2]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/aoa'
make[2]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/soc'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/soc/at91'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/soc/at91'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/soc/codecs'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/soc/codecs'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/soc/fsl'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/soc/fsl'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/soc/pxa'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/soc/pxa'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/soc/s3c24xx'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/soc/s3c24xx'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/soc/sh'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/soc/sh'
make[2]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/soc'
make[2]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/usb'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/usb/caiaq'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/usb/caiaq'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/usb/usx2y'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/usb/usx2y'
make[2]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/usb'
make[2]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/pcmcia'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/pcmcia/pdaudiocf'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/pcmcia/pdaudiocf'
make[3]: Entrando no diretório `/home/administrador/alsa-driver-1.0.16rc1/pcmcia/vx'
make[3]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/pcmcia/vx'
make[2]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1/pcmcia'
make[1]: Saindo do diretório `/home/administrador/alsa-driver-1.0.16rc1'
make -C /lib/modules/2.6.22-14-generic/build SUBDIRS=/home/administrador/alsa-driver-1.0.16rc1  CPP="gcc -E" CC="gcc" modules
make[1]: Entrando no diretório `/usr/src/linux-headers-2.6.22-14-generic'
  CC [M]  /home/administrador/alsa-driver-1.0.16rc1/acore/hwdep.o
  CC [M]  /home/administrador/alsa-driver-1.0.16rc1/acore/memory_wrapper.o
  CC [M]  /home/administrador/alsa-driver-1.0.16rc1/acore/memalloc.o
  CC [M]  /home/administrador/alsa-driver-1.0.16rc1/acore/sgbuf.o
  CC [M]  /home/administrador/alsa-driver-1.0.16rc1/acore/pcm.o
  CC [M]  /home/administrador/alsa-driver-1.0.16rc1/acore/pcm_native.o
  CC [M]  /home/administrador/alsa-driver-1.0.16rc1/acore/pcm_lib.o
  CC [M]  /home/administrador/alsa-driver-1.0.16rc1/acore/pcm_timer.o
  CC [M]  /home/administrador/alsa-driver-1.0.16rc1/acore/pcm_misc.o
  CC [M]  /home/administrador/alsa-driver-1.0.16rc1/acore/pcm_memory.o
  CC [M]  /home/administrador/alsa-driver-1.0.16rc1/acore/rtctimer.o
  CC [M]  /home/administrador/alsa-driver-1.0.16rc1/acore/timer.o
  CC [M]  /home/administrador/alsa-driver-1.0.16rc1/acore/wrappers.o
  CC [M]  /home/administrador/alsa-driver-1.0.16rc1/acore/misc_driver.o
  CC [M]  /home/administrador/alsa-driver-1.0.16rc1/acore/sound.o
  CC [M]  /home/administrador/alsa-driver-1.0.16rc1/acore/init.o
  CC [M]  /home/administrador/alsa-driver-1.0.16rc1/acore/memory.o
  CC [M]  /home/administrador/alsa-driver-1.0.16rc1/acore/info.o
  CC [M]  /home/administrador/alsa-driver-1.0.16rc1/acore/control.o
  CC [M]  /home/administrador/alsa-driver-1.0.16rc1/acore/misc.o
  CC [M]  /home/administrador/alsa-driver-1.0.16rc1/acore/device.o
  CC [M]  /home/administrador/alsa-driver-1.0.16rc1/acore/isadma.o
  CC [M]  /home/administrador/alsa-driver-1.0.16rc1/acore/sound_oss.o
  CC [M]  /home/administrador/alsa-driver-1.0.16rc1/acore/info_oss.o
Em arquivo incluído de /home/administrador/alsa-driver-1.0.16rc1/acore/../alsa-kernel/core/info_oss.c:29,
                 do /home/administrador/alsa-driver-1.0.16rc1/acore/info_oss.c:7:
include/linux/utsname.h:76:52: erro: a macro "init_utsname" passou 1 argumentos, mas recebe somente 0
In file included from /home/administrador/alsa-driver-1.0.16rc1/acore/../alsa-kernel/core/info_oss.c:29,
                 from /home/administrador/alsa-driver-1.0.16rc1/acore/info_oss.c:7:
include/linux/utsname.h:77: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token
In file included from /home/administrador/alsa-driver-1.0.16rc1/acore/info_oss.c:7:
/home/administrador/alsa-driver-1.0.16rc1/acore/../alsa-kernel/core/info_oss.c: In function ‘snd_sndstat_proc_read’:
/home/administrador/alsa-driver-1.0.16rc1/acore/../alsa-kernel/core/info_oss.c:96: error: ‘system_utsname’ undeclared (first use in this function)
/home/administrador/alsa-driver-1.0.16rc1/acore/../alsa-kernel/core/info_oss.c:96: error: (Each undeclared identifier is reported only once
/home/administrador/alsa-driver-1.0.16rc1/acore/../alsa-kernel/core/info_oss.c:96: error: for each function it appears in.)
make[3]: ** [/home/administrador/alsa-driver-1.0.16rc1/acore/info_oss.o] Erro 1
make[2]: ** [/home/administrador/alsa-driver-1.0.16rc1/acore] Erro 2
make[1]: ** [_module_/home/administrador/alsa-driver-1.0.16rc1] Erro 2
make[1]: Saindo do diretório `/usr/src/linux-headers-2.6.22-14-generic'
make: ** [compile] Erro 2
root@administrador-laptop:/home/administrador/alsa-driver-1.0.16rc1#