Autor Tópico: Compiz funciona mas sistema diz que não tenho aceleração 3D (ATI) (resolvido)  (Lida 2398 vezes)

Offline dom diniz

  • Usuário Ubuntu
  • *
  • Mensagens: 152
    • Ver perfil
Bem, tem algo estranho com minha ATI Radeon X-300.
eu instalei seguindo essa dica:
Citar
Well, let's try here and see if I can help you... If yes, I will create a Wiki page.

Before we begin -- supported hardware list

Taken from fglrx driver description for Gutsy.

This version of the ATI driver officially supports:

* FireGL: V7350, V7300, V7200, V7100, V5200, V5100, V5000, V3400,
V3300, V3200, V3100, X3-256, X3, X2-256, Z1-128, T2-128,
X1-128, X1-256p
* FireMV: 2200 (Single card PCI-e configuration)
* Mobility FireGL: V5000, T2
* Mobility Radeon: X1800, X1600, X1400, X1300, X800, X700, X600, X300,
9800, 9600, 9550, 9500
* Radeon Xpress: 200M series, 1250 IGP, 200 series
* Radeon: X1900, X1800, X1600, X1300, X850, X800, X700, X600, X550,
X300, 9800, 9700, 9600, 9550, 9500

ATI All-in-Wonder variants of the above cards/chips are also supported,
but video capture is not.

If you are doing fresh install of Gutsy

   1. Enable fgrlx driver.

      Install linux-restricted-modules and restricted-manager provied in the restricted repositories:
      Code:

      sudo apt-get update
      sudo apt-get install linux-restricted-modules-generic restricted-manager

      Open the restricted drivers manager in "System -> Administration -> Restricted Drivers Manager" and select "ATI accelerated graphics driver".
   2. Install xserver-xgl package
      Code:

      sudo apt-get install xserver-xgl

   3. Install compiz
      Code:

      sudo apt-get install compizconfig-settings-manager compiz compiz-core compiz-fusion-plugins-main compiz-fusion-plugins-extra compiz-gnome compiz-plugins libcompizconfig-backend-gconf libcompizconfig0

   4. Reboot
   5. Log in. 3D effects should be enabled!
   6. Customize Compiz Fusion.
      Select System → Preferences → Advanced Desktop Effects Settings
      In the new window, General Options → Desktop Size → Horizontal Virtual Size. Set it to 4.
      The other two options have to be left at 1.

      Continue customization per Forlong's guide at http://forlong.blogage.de/article/20...-Compiz-Fusion

Fonte:  http://ubuntuforums.org/showthread.php?t=569654&highlight=x300+gutsy

que eu achei aqui:http://ubuntuforum-pt.org/index.php?topic=27077.0

Bem, está tudo bem, Compiz Fuzion funcionando, mas quando fui instalar o Enemy Terrytorry e usa-lo ele carregava mas a paisagem ficava muito ruim, parecia um monte de triângulos quebrados, e a luz alterava o tempo todo, ficava cansativo para a vista joga-lo.
Quando fui usar o Google Earth ele não carrega e termina travando, então fui pesquisar sobre isso, parecia que não tinha feito nada errado então fiz o texte, digitei # glxinfo | grep "direct rendering" e deu nisso:

Citar
root@ubuntu-desktop:/home/josephdiniz# glxinfo | grep "direct rendering"
Xlib:  extension "XFree86-DRI" missing on display ":1.0".
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
root@ubuntu-desktop:/home/josephdiniz#

Notei, pelo synaptic, que não tenho instalado o fglrx-kernel-source, pode ser que isso tenha haver com o problema mas gostaria que alguém me confirmasse pois este pc é usado por várias pessoas e não posso ficar reinstalando o sistema quando algo da errado, pois tem material dos outros também.

Peço ajuda e colaboração

edit: não sei se tem haver mas o mplayer não funciona o fullscrem e quando eu paro algum filme aparece:
gnome_screensaver_control ()

edit: editei o título pq o anterior não explicava bem a situação.
« Última modificação: 23 de MAR?O de 2008, 23:23 por dom diniz »
Preocupem-se com a criação de mais programas e não de mais distros.
link
Ga-945GM-S2Dual|Core 2 Duo E4600|2GB DDR2 Kingston667|Radeon X300 128|XP+ubuntu 10.04 || DELL Vostro 1310 + ubuntu 10.04

Offline dom diniz

  • Usuário Ubuntu
  • *
  • Mensagens: 152
    • Ver perfil
Preocupem-se com a criação de mais programas e não de mais distros.
link
Ga-945GM-S2Dual|Core 2 Duo E4600|2GB DDR2 Kingston667|Radeon X300 128|XP+ubuntu 10.04 || DELL Vostro 1310 + ubuntu 10.04