Autor Tópico: Não consigo me conectar em "banda discada"  (Lida 3524 vezes)

Offline Gimar23br

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Não consigo me conectar em "banda discada"
« Online: 02 de Dezembro de 2007, 19:47 »
Caros,

Eu era usuário de banda larga do Speedy, mas tive que mudar para a conexão discada. Entretanto, o programinha do Ubuntu nao conseguia estabelecer uma conexão. Ele até discava e pelo fone do telefone eu ouvia o barulho caracteristico, mas não havia uma conexão finalizada.

Então pesquisei alguma resposta por aqui, ate que baixei o discador Gnome PPP, configurei-o e nada. Realizava os mesmos passos que antes.

Daí achei uns textos de um rapaz daqui que montou alguns scripts para conexão (esqueci seu nome, peço desculpas, qdo ler isto), baixei num pc e passei para o pc com o ubuntu. Fiz a instalação completa confome o manual, mas agora nem sequer disca. No registro, indica algo como "No Carrier" ou algo do genero.

A versão do script é a 20.

Ainda, segui as observações no final do texto e nada.

Conferi que meu modem estava indicado como um dos suportados pelo script (1039:7013), e ao fazer "lspci" informa que é um Silicon Integrated System AC'97 Modem COntroller (rev a0).

Que eu faço???? Tive que desistir da banda larga, mas parece que terei que voltar a outra distro (usava o Kalango 3.3 e rodava internet discada, antes de usar o Ubuntu 7.04->7.10).

Abs e obrigado!
Gilmar

alarcon

  • Visitante
Re: Não consigo me conectar em "banda discada"
« Resposta #1 Online: 02 de Dezembro de 2007, 19:58 »
Caros,

Eu era usuário de banda larga do Speedy, mas tive que mudar para a conexão discada. Entretanto, o programinha do Ubuntu nao conseguia estabelecer uma conexão. Ele até discava e pelo fone do telefone eu ouvia o barulho caracteristico, mas não havia uma conexão finalizada.

Então pesquisei alguma resposta por aqui, ate que baixei o discador Gnome PPP, configurei-o e nada. Realizava os mesmos passos que antes.

Daí achei uns textos de um rapaz daqui que montou alguns scripts para conexão (esqueci seu nome, peço desculpas, qdo ler isto), baixei num pc e passei para o pc com o ubuntu. Fiz a instalação completa confome o manual, mas agora nem sequer disca. No registro, indica algo como "No Carrier" ou algo do genero.

A versão do script é a 20.

Ainda, segui as observações no final do texto e nada.

Conferi que meu modem estava indicado como um dos suportados pelo script (1039:7013), e ao fazer "lspci" informa que é um Silicon Integrated System AC'97 Modem COntroller (rev a0).

Que eu faço???? Tive que desistir da banda larga, mas parece que terei que voltar a outra distro (usava o Kalango 3.3 e rodava internet discada, antes de usar o Ubuntu 7.04->7.10).

Abs e obrigado!
Gilmar

Por uma acaso este rapaz sou eu.

Se você pegou o pacote correto e fez tudo de forma correta, por isso recomendo ler com atenção o guia_instalação.pdf completamente, por que no seu final tem a solução para os erros mais comumente encontrados.

Este modem funciona com o pacote, mas é um dos mais problemáticos.

Veja que no meu guia falo que para estes usuários antes de usar o discador gnome-ppp, tem de abrir um terminal e digitar:

sudo /etc/init.d/sl-modem-daemon restart

e só então usar o dicador gnome-ppp. Deixe também a opção verificar portadora desmarcada e também tem o caso de para alguns usuários usarem outro Init2 do que o padrão. Outra coisa é usar o nome de acesso do provedor completo  com @provedor.com.br e não só o nome.

Explico tudo isso por lá, tem também o caso de prestar bastante atenção as perguntas que o script de instalação faz a você por que se responder algo errado, a instalação vai falhar. Por exemplo quando pergunto pelo nome do usuário no processo de instalação é o seu nome que você digita para entrar no Ubuntu e não o nome de acesso do provedor, escreva exatamente o mesmo, mas isso chamo atenção do gui de instalação, basta ler tudo com calma e detalhadamente.

modem-arquivos-v20.tar.gz = Ubuntu 7.04 Feisty

modem-arquivos-v21.tar.gz = Ubuntu 7.10 Gutsy

para o Ubuntu o script de instalação é o que tem o nome Gnome no seu nome, pois o que tem o nome KDE no seu nome é para o Kubuntu.

Releia o guia_instalação.pdf veja se não está respondendo nada de forma errada ou esquecendo de alguma coisa, tipo deixar o LiveCd no driver (ou bandeja) durante o processo de instalação ou usar um CD remasterizado que não contenha o que vou baixa dele e etc. Principalmente no final do guia onde fala sobre solucionando problemas.
« Última modificação: 02 de Dezembro de 2007, 20:07 por alarcon »

Offline Gimar23br

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re: Não consigo me conectar em "banda discada"
« Resposta #2 Online: 02 de Dezembro de 2007, 20:18 »
O rapaz é vc msm!

Então, quanto aos pontos, irei respondendo:

1. Li o seu guia pdf, com as devidas atualizações (tornar o arquivo executavel outro que nao o que nao consta no pacote...)

2. Usei o codigo para reiniciar o modem, mas nao deu certo

3. Init2 vc diz aquelas opções de codigos da instalação passo a passo, ne? utilizei o padrão e alternate 3... acabei nao usando os do meio mais por "réiva" msm.

4. @provedor sempre coloco

5. usei o nome de usuario no lugar correto e o login do provedor no respectivo local, sem erro nisso.

Agora estou baixando a vers;ao 21, ja que fiz a atualizaão do ubuntu da 04 para 10. o problema maior é que nao tenho o cd da 10.

Há alguma chance de ser aqueles que vc relata no tutorial que vc montou?

Ainda, durante a instalação, apareceram varias dependencias que nao foram localizadas, mesmo com o cd do 04 no drive.. é normal?

abs

alarcon

  • Visitante
Re: Não consigo me conectar em "banda discada"
« Resposta #3 Online: 02 de Dezembro de 2007, 21:37 »
O rapaz é vc msm!

Então, quanto aos pontos, irei respondendo:

1. Li o seu guia pdf, com as devidas atualizações (tornar o arquivo executavel outro que nao o que nao consta no pacote...)

2. Usei o codigo para reiniciar o modem, mas nao deu certo

3. Init2 vc diz aquelas opções de codigos da instalação passo a passo, ne? utilizei o padrão e alternate 3... acabei nao usando os do meio mais por "réiva" msm.

4. @provedor sempre coloco

5. usei o nome de usuario no lugar correto e o login do provedor no respectivo local, sem erro nisso.

Agora estou baixando a vers;ao 21, ja que fiz a atualizaão do ubuntu da 04 para 10. o problema maior é que nao tenho o cd da 10.

Há alguma chance de ser aqueles que vc relata no tutorial que vc montou?

Ainda, durante a instalação, apareceram varias dependencias que nao foram localizadas, mesmo com o cd do 04 no drive.. é normal?

abs

Este pacote que fiz é ideal para se usar logo após a instalação do sistema e antes de instalar qualquer coisa da internet, por que alguns pacotes ele vai instalar do próprio pacote modem-arquivos-v2?.tar.gz e outros ele vai pegar do LiveCD, mais se você já tinha atualizado ou usado um CD remasterizado as versões não irão bater e aí complica.

Lembre-se que para o caso do HSP56 MR (SiS) antes de usar o discador tem sempre que  abrir o terminal antes e digitar:

sudo /etc/init.d/sl-modem-daemon restart

não sei por qual motivo, mas pare esse modem o discador só funciona assim, ou seja, digita este comando no terminal e só depois usa o gnome-ppp.

Outra coisa para alguns modems na configuração do gnome-ppp na aba Opções a opção verificar portadora tem de ficar desmarcada e ela por padrão está marcada, então veja se não é o seu caso.

Veja também , coo root, se nos arquivos chap-secrets e pap-secrets que se encontram em /etc/ppp/ no final de cada um exite a seguinte informação:

"usuario@provedor.com.br" * "senha1234"

obviamente que as informações sobre duas aspas  (" ") serão seu nome de acesso do provedor e sua senha de acesso do mesmo.

« Última modificação: 02 de Dezembro de 2007, 21:49 por alarcon »

Offline Gimar23br

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re: Não consigo me conectar em "banda discada"
« Resposta #4 Online: 03 de Dezembro de 2007, 09:05 »
Eae!

Ja baixei a versão 21. Qdo chegar em casa, farei esse restart e instalarei o seu plugin.

Já com relação aos arquivos e a adição do meu nome de login completo e senha, eu verifiquei os arquivos e já continham essa informação.

O verificar portadora também ja havia des-setado ele.

Então, à noite testarei e amanha, logo cedo, posto para avisar se deu certo ou não.. embaçado msm será a questão do livecd do 7.10, pq nao o tenho, só o 7.04.

abs

alarcon

  • Visitante
Re: Não consigo me conectar em "banda discada"
« Resposta #5 Online: 03 de Dezembro de 2007, 10:42 »
Eae!

Ja baixei a versão 21. Qdo chegar em casa, farei esse restart e instalarei o seu plugin.

Já com relação aos arquivos e a adição do meu nome de login completo e senha, eu verifiquei os arquivos e já continham essa informação.

O verificar portadora também ja havia des-setado ele.

Então, à noite testarei e amanha, logo cedo, posto para avisar se deu certo ou não.. embaçado msm será a questão do livecd do 7.10, pq nao o tenho, só o 7.04.

abs

É o seguinte antes de usar o meu pacote você tem de ter instalados estes pacotes .deb aqui:

- make
- gcc
- build-essential
- linux-headers-VERSÃO_KERNEL (para saber qual versão, no terminal digite: uname -r)

e o meu instalador busca do LiveCD, mas como você não tem o liveCD  você terá de pegar da iternet. O grande problema é que às vezes um pacote deste tem como dependência um outro e este outro pode ter como dependência um ou vários outros gerando uma reação em cadeia, por isso pode ser tornar complicado a procura manual dos pacotes e usnado o meu script que usa o apt-get já resolve este problema de dependência, se tiver, de forma automática.

Acho que o make e o gcc já estão instalados por padrão os outros dois é que não e o resto esta no meu pacote (libasound2, libasound2-dev e gnome-ppp).

Querendo baixar manualmente procure neste endereço:
http://packages.ubuntu.com/gutsy/allpackages

Lá contem todos os pacotes .deb para o Gutsy então você procura pelos listados e vê quais são os pacotes de dependência deles e faz uma busca no seu sistema (via synaptic) para saber se estão instalados, caso não então também terá de baixar as dependências. É trabalhoso desta forma se tiver algum do arquivos necessário com muitas dependências.

Offline Gimar23br

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re: Não consigo me conectar em "banda discada"
« Resposta #6 Online: 03 de Dezembro de 2007, 21:47 »
Que marabilha! Usando a vertsão 21 funciou aqui no meu!

Muito obrigado msm!

Agora só umas duvidas:

1. desde que fiquei tentando instalar a net discada aqui agora o Gerenciador de Atualizações dá mensagem de erro informando que "a índex de software está quebrado (sic)". Se eu fizer a atualização pelo caminho que indica (sudo apt-get install -f) volta ao normal eu eu consegui dar pau de vez nele?

2.  Na janela Connection Log (Registro na janela de conexão) apareceram erros naqueles arquivos que vc indicou para adicionar "seu login@provedor" * "senha", com relação à permissão. É melhor mudar a permissão deles ou deixar dessa forma, já que eu consegui me conectar normal?

abs e mais uma vez, muito obrigado!

Gilmar