Autor Tópico: Configurando o teclado num Toshiba Satellite  (Lida 51098 vezes)

Offline daniellfeijo

  • Usuário Ubuntu
  • *
  • Mensagens: 46
    • Ver perfil
    • Daniel Feijó | Engenheiro de Software
Configurando o teclado num Toshiba Satellite
« Resposta #15 Online: 12 de Abril de 2006, 12:53 »
Já fiz isso, mas sempre que eu mudo alguma coisa na configuração do teclado... da um erro lá. Queria tentar fazer isso via terminal para ver se dava certo. Vc sabe como? Eu colocar layout de portugal via terminal?

Abraço...
Daniel Feijó
www.danielfeijo.net

Offline daniellfeijo

  • Usuário Ubuntu
  • *
  • Mensagens: 46
    • Ver perfil
    • Daniel Feijó | Engenheiro de Software
Configurando o teclado num Toshiba Satellite
« Resposta #16 Online: 12 de Abril de 2006, 13:22 »
Cara,
Decobri. Por algum motivo as alterações do teclado pelo Gnome não estão sendo efetuadas. Dei o boot pelo Live CD e coloquei padrão de Portugal no teclado e ficou PERFEITO! Fica aí a dica valeu.... se alguem tiver um notebook Toshiba com um teclado meio diferente tenta o padrão de Portugal.

Abraço......
Daniel Feijó
www.danielfeijo.net

Offline engdoug

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
    • http://www.douglas.lasthope.com.br
Re: Configurando o teclado num Toshiba Satellite
« Resposta #17 Online: 08 de Janeiro de 2007, 19:35 »
Instalei o Ubuntu (já algum tempo) e tenho esse Laptop (Toshiba A70-S125) , comigo essa dica não funcionou então resolvi dar uma procurada e dei um jeitinho :)

- Abra o terminal

1. sudo gedit (ou o editor que você preferir) /etc/X11/xorg.conf

- E procura as configurações do teclado (keyboard), deve ser algo assim:
Código: [Selecionar]
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
Option "XkbVariant"    "alt-intl"

2. Adiciona a linha Option "XkbVariant" "alt-intl"

- Agora os acentos vão funcionar, porém o cedilha vai sair assim ć, o jeito de fazer o cedilha aparecer normal é por uma tecla de atalho no caso o alt+vírgula (ç). Se você for programador vai ter uma dor de cabeça com as aspas duplas/simples porque elas não aparecem direito (¨ - ") para usar elas use essa tecla de atalho alt+shift+aspas (aspas duplas) e alt+aspas (aspas simples).

Ae  Galera o jeito mais facil de resolver isso é muito simples, tbm tenho um Toshiba Satellite M115-S3094 e tive o mesmo problema

Utilizem o vi ou qualquer outro editor pra alterar o arquivo
/etc/gtk2.0/gtk.immodules

na linha
"cedilla" "Cedilla" "gtk+" "/usr/share/locale" "az:ca:co:fr:gv:oc:pt:sq:tr:wa"

acresente um :en
vai ficar -> "cedilla" "Cedilla" "gtk+" "/usr/share/locale" "az:ca:co:fr:gv:oc:pt:sq:tr:wa:en"

pronto agora pra modelos de layout en voce tem o ç e nao o 'c haha

Espero ter ajudado, funcionou aqui, quem conseguir com essa dica, deixa um post ae!

vlw!
Douglas Campos
Atlhon 64 300+
MB- Abit Av8
HD SATA 80 Seagate
1GB ddr400 - Kingston
NVidia Gforce 2 - 64 MB ;(

//--------------------
Notebook Toshiba M115-S3094
14.1"
80GB
Intel Core Duo 1.6
1GB DDR2 533