Autor Tópico: Problema drivers ATI HD2400  (Lida 2583 vezes)

Offline joao_mourico

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Problema drivers ATI HD2400
« Online: 01 de Novembro de 2007, 17:42 »
Boas!

Recentemente comprei um portátil Toshiba Satellite A200-1c3, o qual trás com SO o Windows Vista.
Como queria mudar para o mundo Linux, decidi fazer download do Ubuntu 7.10 e instalar no portátil.
Instalei o Ubuntu 7.10, fiz download dos drivers da ATi, instalei e agora não inicia o Ubuntu, ou seja, aparece-me sempre o ecran preto e não inicia.
Já instalei o ubuntu umas 7 vezes, e voltei a instalar os drivers, e nada..

Gostava que me ajudassem a instalar e a meter a funcionar a 100%.

Cumprimentos

Offline Eduardo André Viana

  • Usuário Ubuntu
  • *
  • Mensagens: 71
    • Ver perfil
Re: Problema drivers ATI HD2400
« Resposta #1 Online: 01 de Novembro de 2007, 21:03 »
se vc fez backup do seu xorg.conf antes de instalar o driver para a placa ATI, pode voltar à configuração inicial e tentar instalar novamente o driver, mas não o que está nos repositórios do Ubuntu. Existe um script chamado envy (procure no google que você vai achar o site e poderá seguir as instruções de instalação, que são muito fáceis, já que o envy é disponibilizado em pacotes .deb. basta clicar e instalar) que automatiza todo o processo de instalação de drivers para placas ATI e nvídia. Basicamente, o script baixa o driver mais recente do site do fabricante, instala dependências necessárias, pacotes adicionais para compilação e "constrói" um pacote especial, adaptado ao seu sistema e ao seu hardware, portanto, terá mais possibilidades de funcionar corretamente (embora isso não seja 100% certo). Primeiro, se vc fez backup da configuração anterior do seu xorg, basta iniciar seu sistema com a opção recovery mode na tela de inicialização (se a tela não aparecer, tecle esc logo no início do processo). Quando sistema tiver terminado de iniciar no modo texto, faça seu login (digite sudo login), entre com nome de usuário e senha. Depois, dê o seguinte comando: sudo cp /etc/X11/xorg.conf-backup /etc/X11/xorg.conf. Agora, se vc não tiver feito a cópia de segurança, terá que reinstalar tudo, ou tentar acessar o arquivo citado com um live CD, como o do Ubuntu e então copiar o xorg.conf do CD na sua partição em que está instalado o sistema.
Bom, depois de recuperado seu servidor gráfico, abra o synaptic e desinstale o driver ATI e prováveis dependências. Após, baixe o script do envy e siga as instruções, que são todas em modo gráfico e muito fáceis de usar. Boa sorte!

Offline joao_mourico

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re: Problema drivers ATI HD2400
« Resposta #2 Online: 02 de Novembro de 2007, 05:16 »
Desde já agradeço a ajuda.

Vou ter que o instalar outra vez, pois não fiz beckup.
Eu já experimentei esse programa e fez a mesma coisa, ou seja, não inicia na mesma.

Cumprimentos

Offline prct

  • Usuário Ubuntu
  • *
  • Mensagens: 84
  • Ubuntu 8.04 LTS
    • Ver perfil
Re: Problema drivers ATI HD2400
« Resposta #3 Online: 03 de Novembro de 2007, 11:18 »
A melhor forma é como eu fiz.

Deixar tudo como após a instalação e fazer o seguinte :

Menu:

Sistema -> Administração -> Gestor de Controladores Restritos

ATI accelerated graphics driver -> Enable [Click Enable when prompted]

Linha de comandos (Consola):
(Nota: convem fazer uma copias antes : sudo cp /etc/X11/xorg.conf  /etc/X11/xorg.conf.001)

sudo gedit /etc/X11/xorg.conf

Alterar de  "0" para "1"

Citar
Section "Extensions"
   Option      "Composite"   "1"
EndSection

Instalar drivers

Linha de comandos (consola):

sudo apt-get install xserver-xgl

Reiniciar o X (ctrl+alt+backspace)

Activar os efeitos

Menus:

Sistema -> Preferencias -> Aparencia -> Efeitos Visuais -> Extra

Podes também instalar o : Compiz Config Manager

Linha de comandos(Consola):

sudo apt-get install compizconfig-settings-manager

Menus:

Sistema -> Preferencias -> CompizConfigManager

Asus T3 Intel 2Duo Core Quad 2.4, 2Gb Ram, 2x 160Gb HDD SataII, Asus EAH2600PRO 512Mb Ram