Autor Tópico: apt-get update quebra ao baixar lista de pacotes em distro em chroot.  (Lida 2237 vezes)

Offline crixtiano

  • Usuário Ubuntu
  • *
  • Mensagens: 339
    • Ver perfil
Eu tenho uma distro ubuntu dentro de um chroot,

ao mudar o /etc/apt/sources.list de feisty para gutsy, tentei atualizar a lista de pacotes, mas dá erro, veja:

Citar
cris@pardal:~$ sudo apt-get update
Obtendo:1 http://archive.ubuntu.com gutsy Release.gpg [191B]
Atingido http://archive.ubuntu.com gutsy/main Translation-pt_BR
Obtendo:2 http://security.ubuntu.com gutsy-security Release.gpg [191B]
Ign http://security.ubuntu.com gutsy-security/main Translation-pt_BR
Atingido http://archive.ubuntu.com gutsy/restricted Translation-pt_BR
Atingido http://archive.ubuntu.com gutsy/main Translation-pt_BR
Atingido http://archive.ubuntu.com gutsy/universe Translation-pt_BR
Atingido http://archive.ubuntu.com gutsy/main Translation-pt_BR
Atingido http://archive.ubuntu.com gutsy/multiverse Translation-pt_BR
Obtendo:3 http://archive.ubuntu.com gutsy-updates Release.gpg [191B]
Ign http://archive.ubuntu.com gutsy-updates/main Translation-pt_BR
Ign http://archive.ubuntu.com gutsy-updates/restricted Translation-pt_BR
Ign http://security.ubuntu.com gutsy-security/restricted Translation-pt_BR
Ign http://security.ubuntu.com gutsy-security/main Translation-pt_BR
Ign http://security.ubuntu.com gutsy-security/universe Translation-pt_BR
Ign http://security.ubuntu.com gutsy-security/main Translation-pt_BR
Ign http://security.ubuntu.com gutsy-security/multiverse Translation-pt_BR
Atingido http://archive.ubuntu.com gutsy Release             
Atingido http://archive.ubuntu.com gutsy-updates Release     
Atingido http://security.ubuntu.com gutsy-security Release                       
Atingido http://archive.ubuntu.com gutsy/main Packages       
Obtendo:4 http://security.ubuntu.com gutsy-security/main Packages [51,6kB]
Atingido http://archive.ubuntu.com gutsy/restricted Packages
Atingido http://archive.ubuntu.com gutsy/main Packages     
Atingido http://archive.ubuntu.com gutsy/universe Packages 
Atingido http://archive.ubuntu.com gutsy/main Packages     
Atingido http://archive.ubuntu.com gutsy/multiverse Packages
Atingido http://archive.ubuntu.com gutsy-updates/main Packages
Atingido http://archive.ubuntu.com gutsy-updates/restricted Packages
Atingido http://security.ubuntu.com gutsy-security/restricted Packages
Obtendo:5 http://security.ubuntu.com gutsy-security/main Packages [51,6kB]
Atingido http://security.ubuntu.com gutsy-security/universe Packages
99% [5 Packages bzip2 0] [Aguardando por cabeçalhos]bzip2: (stdin) is not a bzip2 file.
Err http://security.ubuntu.com gutsy-security/main Packages
  Sub-processo bzip2 retornou um código de erro (2)
Obtendo:6 http://security.ubuntu.com gutsy-security/main Packages [51,6kB]
Atingido http://security.ubuntu.com gutsy-security/multiverse Packages
99% [6 Packages bzip2 0]bzip2: (stdin) is not a bzip2 file.
Err http://security.ubuntu.com gutsy-security/main Packages
  Sub-processo bzip2 retornou um código de erro (2)
Baixados 51,6kB em 4s (11,8kB/s)
Falha ao baixar http://security.ubuntu.com/ubuntu/dists/gutsy-security/main/binary-i386/Packages.bz2  Sub-processo bzip2 retornou um código de erro (2)
Falha ao baixar http://security.ubuntu.com/ubuntu/dists/gutsy-security/main/binary-i386/Packages.bz2  Sub-processo bzip2 retornou um código de erro (2)
Lendo Lista de Pacotes... Pronto
W: Duplicate sources.list entry http://archive.ubuntu.com gutsy/main Packages (/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_gutsy_main_binary-i386_Packages)
W: Duplicate sources.list entry http://archive.ubuntu.com gutsy/main Translation-pt_BR (/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_gutsy_main_i18n_Translation-pt%5fBR)
W: Duplicate sources.list entry http://archive.ubuntu.com gutsy/main Packages (/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_gutsy_main_binary-i386_Packages)
W: Duplicate sources.list entry http://archive.ubuntu.com gutsy/main Translation-pt_BR (/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_gutsy_main_i18n_Translation-pt%5fBR)
W: Duplicate sources.list entry http://security.ubuntu.com gutsy-security/main Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_gutsy-security_main_binary-i386_Packages)
W: Duplicate sources.list entry http://security.ubuntu.com gutsy-security/main Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_gutsy-security_main_binary-i386_Packages)
W: Você terá que executar apt-get update para corrigir esses arquivos faltosos
E: Alguns arquivos de índice falharam no download, eles foram ignorados ou os antigos foram usados em seu lugar.

O apt pede para eu realizar o comando "apt-get update" novamente. Mas sempre que eu realizo o comando dá o mesmo erro.

Alguém poderia me ajudar?