Autor Tópico: Navegadores não mostram "códigos"...  (Lida 2879 vezes)

Offline GDA

  • Usuário Ubuntu
  • *
  • Mensagens: 92
    • Ver perfil
Navegadores não mostram "códigos"...
« Online: 21 de Dezembro de 2005, 12:51 »
Galera,

tem um problema muito doido acontecendo aqui... Há uma semana *todos* os meus navegadores se recusam a exibir trechos de html que contenham códigos (como por exemplo os códigos aqui do fórum). Por serem todos eles, eu suponho que o problema estaja em alguma coisa no Gnome, algo ligado às fontes, talvez... Mas o que??? O engraçado é que muitos dos códigos "proibidos" são escritos em vários tipos de tags html diferentes... e mais, os "quotes" são exibidos normalmente.

É tão estranho que fica difícil até de explicar, por isso estou colocando uns screenshots pra vcs verem.

Abração!
http://devos.br22.net/images/Screenshot.png
http://devos.br22.net/images/Screenshot-1.png
jabber: droopalong@jabber.org - Ubuntu'ser:
Interessado em aprender mais sobre o Ubuntu em português? Comece aqui

Offline GDA

  • Usuário Ubuntu
  • *
  • Mensagens: 92
    • Ver perfil
Aceito palpites...
« Resposta #1 Online: 26 de Dezembro de 2005, 14:52 »
Olá,

Ainda estou batendo cabeça com esse problema, e não consegui absolutamente nada. Do jeito que estão as coisas, não precisa nem saber a solução, e até palpites eu aceito.

Abração!
jabber: droopalong@jabber.org - Ubuntu'ser:
Interessado em aprender mais sobre o Ubuntu em português? Comece aqui

Offline agente100gelo

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.367
  • @Ceará
    • Ver perfil
Navegadores não mostram "códigos"...
« Resposta #2 Online: 26 de Dezembro de 2005, 18:23 »
Nas fontes deste fórum (primeiro screenshot) nos CODEs (e só) utiliza a fonte de espaçamento fixo. No site do PHP é a mesma coisa, o teu problema é no tipo de fonte Courier.

Neste fórum utiliza estas fontes em sequência:

font-family: Courier, 'Courier New', sans-serif;

Tenta ver se tem a Courier instalada. Se tiver tenta reinstalar a fonte, ou mesmo só retirar.
Advogado e analista de sistema cearense.
Twitter: @glaydson

Offline LaSSarD

  • Usuário Ubuntu
  • *
  • Mensagens: 1.144
    • Ver perfil
Navegadores não mostram "códigos"...
« Resposta #3 Online: 26 de Dezembro de 2005, 20:21 »
A Courier vem junto com o pacote msttcorefonts mas a Monospace toma lugar dela quando ela não existe, até onde sei... Ao menos não lembro de ter deixado de ver algum conteúdo por não ter o msttcorefonts instalado :shock:
desculpem as mensagens não respondidas, mas eu tô afastado há mais de ano...
um dia eu volto ;)

Offline agente100gelo

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.367
  • @Ceará
    • Ver perfil
Navegadores não mostram "códigos"...
« Resposta #4 Online: 26 de Dezembro de 2005, 20:46 »
O correto seria procurar Courier, Courier New e depois usar a sans-serif padrão do sistema.

Eu nunca vi isso, é como se não tivesse encontrando nenhuma sans-serif :)
Advogado e analista de sistema cearense.
Twitter: @glaydson

Offline GDA

  • Usuário Ubuntu
  • *
  • Mensagens: 92
    • Ver perfil
Resolvido...
« Resposta #5 Online: 27 de Dezembro de 2005, 19:43 »
Bom, é isso mesmo.

O problema era com a fonte Courirer... Não a falta dela, mas por ela estar (de algum modo) corrompida. Se ela simplesmente não existisse, a segunda opção do CSS seria utilizada, mas como ela existia, a troca não era feita e nada era usado em seu lugar (origem de toda a minha confusão).

Valeu pelos palpites.

Abração!
jabber: droopalong@jabber.org - Ubuntu'ser:
Interessado em aprender mais sobre o Ubuntu em português? Comece aqui