Autor Tópico: Instalar Compiz-Fusion + Fusion-icon  (Lida 255778 vezes)

kErNeL_sCrIpT

  • Visitante
Re: Instalar Compiz-Fusion (O novo Compiz+Beryl) + Fusion-icon *Update .deb*
« Resposta #285 Online: 29 de Dezembro de 2007, 02:14 »
vinicius_aleao, isso aconteceu comigo algumas vezes, acho que o servidor onde está o pacote DEB do Fusion Icon fica fora do ar ou algo assim, mas depois é só tentar novamente que funciona denovo, agora mesmo testei e tava funfando beleza :)


Abraço e até mais.

Offline vinicius_aleao

  • Usuário Ubuntu
  • *
  • Mensagens: 1.275
    • Ver perfil
Re: Instalar Compiz-Fusion (O novo Compiz+Beryl) + Fusion-icon *Update .deb*
« Resposta #286 Online: 29 de Dezembro de 2007, 11:55 »
Fiz pesquisa antes com o nome do pacote, mas não encontrei nada. Então lá fui eu: compilar. E como se o fato de eu não gostar disso pudesse influenciar nos resultados, não deu outra: instalou beleza, mas as barras de título das janelas não apareceram com o compiz, o que nunca aconteceu com a instalação pelo pacote pronto. Segui as instruções do tutorial pra resolver o problema das barras, especialmente uma que falava na modificação do xorg.conf. Fiz certinho o que tava lá, e quando reiniciei o X... perdi o modo gráfico, só logava por linha de comando! Lá vou eu, LiveCD, editar o xorg pra tudo voltar ao normal... Voltou, mas, claro, sem barra de título nas janelas... Decidi voltar pro metacity pelo fusion-icon e desligar o PC.

Isso tudo foi ontem. Liguei hoje o PC e decidi tentar de novo. Ativei o compiz pelo fusion-icon e... as barras de título apareceram! Bom, o decorador era o GTK, mas servia... Decidi testar o emerald e... funcionou também! Oxe, que danado é isso?! Eu não fiz nada de ontem pra hoje! Vai entender...

Bom, o importante é que tá belezinha aqui. Mas eu ainda vou ver se o kernel_script tem razão, talvez o site lá esteja fora do ar, depois eu vejo se o download do pacote pega. Eu gosto de ter os pacotes guardadinhos...

Bom, brigadão pela ajuda cicampos.

Abraços!
« Última modificação: 29 de Dezembro de 2007, 11:57 por vinicius_aleao »

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Instalar Compiz-Fusion (O novo Compiz+Beryl) + Fusion-icon *Update .deb*
« Resposta #287 Online: 29 de Dezembro de 2007, 18:58 »
Pô Vinicius comecei a ler sua mensagem e fiquei preocupado... Pensei logo: "Putz mandei o cara compilar e ferrou tudo!"

Mas que bom que resolveu! Cuidado ao instalar o pacote porque o compilado é mais novo (pelo que li na mensagem lá do início) e pode trazer é problemas.

[]'s e feliz ano novo!

Cristiano
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline vinicius_aleao

  • Usuário Ubuntu
  • *
  • Mensagens: 1.275
    • Ver perfil
Re: Instalar Compiz-Fusion (O novo Compiz+Beryl) + Fusion-icon *Update .deb*
« Resposta #288 Online: 29 de Dezembro de 2007, 20:36 »
Preocupa não, que tá tudo funcionando beleza. Muitíssimo obrigado pela ajuda, cicampos. Eu nunca contei, mas tenho certeza de que você foi a pessoa que mais me ajudou aqui no fórum com o Ubuntu. Brigadão por tudo, cara.

Abração e feliz ano novo pra você também.

Offline pinduvoz

  • Usuário Ubuntu
  • *
  • Mensagens: 2.494
    • Ver perfil
Re: Instalar Compiz-Fusion (O novo Compiz+Beryl) + Fusion-icon *Update .deb*
« Resposta #289 Online: 02 de Janeiro de 2008, 04:26 »
Estou fazendo um test-drive no Fedora 8 e notei que o xorg.conf dele é diferente e, o que importa, o CF está rodando bem melhor.

Assim, já que o servidor X é o mesmo (1.3.0), quem quiser tentar usá-lo no Gutsy fique à vontade (mas não se esqueça de fazer backup).

Segue o arquivo, lembrando que serve apenas para quem tem o driver proprietário da Nvidia instalado:

Código: [Selecionar]
# Xorg configuration created by livna-config-display

Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        ModulePath   "/usr/lib/xorg/modules/extensions/nvidia"
        ModulePath   "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
        Option      "AIGLX" "on"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "abnt2"
        Option      "XkbLayout" "br"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "nvidia"
        Option      "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

Section "Extensions"
        Option      "Composite" "Enable"
EndSection

« Última modificação: 02 de Janeiro de 2008, 04:28 por pinduvoz »
:: Linux Registered User nº 439378 ::

Offline Nossile

  • Usuário Ubuntu
  • *
  • Mensagens: 807
  • Loading...
    • Ver perfil
Re: Instalar Compiz-Fusion (O novo Compiz+Beryl) + Fusion-icon *Update .deb*
« Resposta #290 Online: 02 de Janeiro de 2008, 21:20 »
Estou usando o Xorg.conf postado pelo pinduvoz e o sistema esta estável. o CF já rodava bem antes, então não posso afirmar se há melhora de performance.

Alterações que eu percebi foram apenas a tela com o logo da Nvidia na inicialização e as fontes do menu contexto do Opera que ficaram bem grandes.

O que importa é que realmente funciona e por ser mais simples que o xorg.conf padrão deve funcionar melhor mesmo.
sudo aptitude remove terno-e-gravata && sudo aptitude install bermuda chinelo -y

Offline luiss

  • Usuário Ubuntu
  • *
  • Mensagens: 38
    • Ver perfil
Re: Instalar Compiz-Fusion (O novo Compiz+Beryl) + Fusion-icon
« Resposta #291 Online: 15 de Janeiro de 2008, 19:51 »
Aqui também, tenho um gforce fx5200...
ae quando eu instalei as janelas perderam os botoes maximizar, minimizar e fechar e o terminal vira uma janela toda branca.... digitei o que foi indicado...  'sudo nvidia-xconfig --add-argb-glx-visuals'
obtive essa saída no terminal:

Using X configuration file: "/etc/X11/xorg.conf".
Option "AddARGBGLXVisuals" "True" added to Screen "Default Screen".
Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'

mas quando eu ativo de novo o compiz nada acontece....
alguém poderia me ajudar??

Estou com esse mesmo problema. Já rodei o 'sudo nvidia-xconfig --add-argb-glx-visuals', reiniciei X, kernel e nada.
Uso o Ubuntu 7.10 e tava tudo normal. Só que estava achando um pouco lentos os efeitos de minimizar e maximizar. Entao resolvi instalar o driver nativo da nvidia. Triste fim. Fiz isso pelo Envy. Desinstalei por lá o driver que já vem no 7.10 e depois instalei o nativo. Ai que esse problema do terminal todo branco começou.
Minha placa é uma GeForce 8400M GT.

Alguma ajuda?

EDIT: Depois de descansar um pouco e voltar a tentar consertar o problema, testei o xorg.conf do Fedora postado pelo pinduvoz. E problema resolvido. E talvez seja até impressao minha soh, mas acho que agora tá melhor que antes, como eu esperava.
« Última modificação: 15 de Janeiro de 2008, 23:35 por luiss »
"Quem tem um porquê, enfrenta qualquer como." (Victor Frankl)

Offline pinduvoz

  • Usuário Ubuntu
  • *
  • Mensagens: 2.494
    • Ver perfil
Re: Instalar Compiz-Fusion (O novo Compiz+Beryl) + Fusion-icon *Update .deb*
« Resposta #292 Online: 17 de Janeiro de 2008, 21:41 »
Legal o xorg.conf do Fedora ter ajudado.
:: Linux Registered User nº 439378 ::

Offline akaihen

  • Usuário Ubuntu
  • *
  • Mensagens: 194
    • Ver perfil
    • Quase-Crônicas
Re: Instalar Compiz-Fusion (O novo Compiz+Beryl) + Fusion-icon *Update .deb*
« Resposta #293 Online: 21 de Janeiro de 2008, 01:19 »
Cara, vou dizer todos os meus problemas....... não consigo aumentar minha resolução além de 800x600, não consigo manter como padrão meu monitor e minha placa de video, sempre reconfiguro. nao consigo entra no ccsm para configurar meu compiz. Já vi todos os tópicos e tentei quase tudo mas nada1 ???
Kubuntu 10.04
Athlon 64 XP2 2.6+ Geforce 9600 GT
150 gb MAxtor +40 gb samsung +2 gb ram

Offline JPiR

  • Usuário Ubuntu
  • *
  • Mensagens: 34
  • Liga dos Dinos
    • Ver perfil
Re: Instalar Compiz-Fusion (O novo Compiz+Beryl) + Fusion-icon *Update .deb*
« Resposta #294 Online: 21 de Janeiro de 2008, 19:13 »
Cara, vou dizer todos os meus problemas....... não consigo aumentar minha resolução além de 800x600, não consigo manter como padrão meu monitor e minha placa de video, sempre reconfiguro. nao consigo entra no ccsm para configurar meu compiz. Já vi todos os tópicos e tentei quase tudo mas nada1 ???

Qual a configuração do seu equipamento, amigo?
Talvez assim, possamos ajudá-lo...
« Última modificação: 21 de Janeiro de 2008, 19:15 por JPiR »

    Usuário Ubuntu 17331 /  Usuário Linux 442069

Offline akaihen

  • Usuário Ubuntu
  • *
  • Mensagens: 194
    • Ver perfil
    • Quase-Crônicas
Re: Instalar Compiz-Fusion (O novo Compiz+Beryl) + Fusion-icon *Update .deb*
« Resposta #295 Online: 22 de Janeiro de 2008, 22:09 »
Ta!

Athlon 64 x2 4000+, geforce 8400 gs, 160 hd e monitor samsung syncmaster 551v....
Kubuntu 10.04
Athlon 64 XP2 2.6+ Geforce 9600 GT
150 gb MAxtor +40 gb samsung +2 gb ram

Offline rdlf0512

  • Usuário Ubuntu
  • *
  • Mensagens: 41
    • Ver perfil
Re: Instalar Compiz-Fusion (O novo Compiz+Beryl) + Fusion-icon *Update .deb*
« Resposta #296 Online: 27 de Janeiro de 2008, 15:25 »
Não sei porque mas as pessoas do canal #ubuntu dizem que o envy e o automatix são danosos ao Ubuntu. De qualquer maneira, eu tento instalar os drivers de vídeo manualmente e quanto aos restricted-extras eu tbm prefiro a instalação manual ao invés de simplesmente instalar o automatix e achar que seus problemas acabaram, quando na verdade estão apenas começando...

Offline Nossile

  • Usuário Ubuntu
  • *
  • Mensagens: 807
  • Loading...
    • Ver perfil
Re: Instalar Compiz-Fusion (O novo Compiz+Beryl) + Fusion-icon *Update .deb*
« Resposta #297 Online: 27 de Janeiro de 2008, 21:11 »
Bem, sempre usei o Automatix e nunca enfrentei problemas, o Envy usei somentecom o 7.10 e até agora tudo certo.
sudo aptitude remove terno-e-gravata && sudo aptitude install bermuda chinelo -y

Offline pinduvoz

  • Usuário Ubuntu
  • *
  • Mensagens: 2.494
    • Ver perfil
Re: Instalar Compiz-Fusion (O novo Compiz+Beryl) + Fusion-icon *Update .deb*
« Resposta #298 Online: 27 de Janeiro de 2008, 23:54 »
O Automatix, por conta das "fofocas" (nunca tive problemas com ele, então penso que são "fofocas"), deixou de acrescentar repositórios estranhos, inclusive o tradicional "Medibuntu". Agora, são usados apenas aqueles que são considerados "padrão" (o "Universe" e o "Multiverse" estão nesta categoria") e os pacotes que não estão disponíveis, como o libdvdcss e o w32codecs, são baixados e instalados localmente.
:: Linux Registered User nº 439378 ::

Offline rdlf0512

  • Usuário Ubuntu
  • *
  • Mensagens: 41
    • Ver perfil
Re: Instalar Compiz-Fusion (O novo Compiz+Beryl) + Fusion-icon *Update .deb*
« Resposta #299 Online: 03 de Fevereiro de 2008, 08:36 »
Citar
Fusion-Icon

Vou agora indicar como instalar o Fusion-icon. É um icon no SysTray onde é possivel activar e configurar o Compiz-Fusion.

Pacote debian do fusion-icon criado por mim :  http://www.guiaubuntupt.org/files/debs/fusion_1.0-1_i386.deb

Preciso dizer que a sua dica resulta em um bug em nobos com placa de vídeo da intel.
Segui a dica ao pé da letra e cheguei a conclusão de que foi exatamente isso a única e principal causa do terminal retornar isso:

Código: [Selecionar]
direct rendering: No (LIBGL_ALWAYS_INDIRECT set)
quando dou o comando glxinfo.
E independente de que nobo eu esteja, uma coisa é certa: isso vale tanto pro i810, i915, i945 (ainda não tive a oportunidade de testar com o i965GMA/960GML, mas assim que puder, vou fazê-lo e postar isso aqui).

E por um acaso, alguém sabe como fazer pra que eu REMOVA TOTALMENTE o compizfusion-icon do sistema? preciso remover com as configurações que ele instalou na minha máquina, pois já segui diversos tutoriais e não tive sucesso. (ele foi instalado a partir desse arquivo .deb que está no post que eu citei).

EDIT: Confirmado. Testei com vários modelos de nobo, dell latitude 120L e positivo V3, ambos com o video da intel.
As versões com i810, i915, i945 e i965 têm esse "problema". Ou seria problema com o aplicativo que vc criou?
Enfim, a reação das placas de vídeo ANTES de instalar o CFicon é

Código: [Selecionar]
direct rendering: Yes
e isso muda depois que o seu aplicativo é instalado. Vou verificar se o cenário é o mesmo com placas de vídeo da intel, dessa vez, em desktops. Enquanto isso, eu espero por uma resposta de como fazer pra remover toda a configuração do compizfusion-icon, afim de voltar toda a configuração do sistema ao normal.

######
Estou editando este post porque em primeiro lugar o bug mencionado, na verdade, não tem nada a ver com o aplicativo em si.
Tem a ver somente com o Compiz. Eu cheguei à essa conclusão quando testei com os mesmo três notebooks a instalação do CF através do comando (pelo terminal) depois de ter formatado os três e (re)instalado o Ubuntu 7.10. Também comentei sobre esse erro com vários técnicos do xorg@lists.freedesktop.org, com o técnico Zhenyu, com um desenvolvedor de driver open source da intellinux e postei sobre o erro do direct rendering no fórum do compiz fusion (Que foi resolvido - então se vc tem um nobo com placa de vídeo i915, visite esse site: http://forum.compiz-fusion.org/showthread.php?t=6921 )
E pra deixar claro que nas máquinas com o compiz fusion instalado, não ocorre nenhum erro, o problema mesmo é com o compiz fusion e com a variável de ambiente. (ainda estou procurando uma placa de vídeo da ATi até o X1800 com AiGLX pra ver se ocorre o mesmo problema e até lá postarei isso aqui, assim que tiver mais informações).
« Última modificação: 05 de Fevereiro de 2008, 03:49 por rdlf0512 »