Autor Tópico: O novo Compiz  (Lida 48786 vezes)

ginho

  • Visitante
Re: O novo Compiz
« Resposta #30 Online: 26 de Junho de 2007, 08:25 »
Citar
Não aconteceu nada, tudo na mesma. É como se as janelas não tivessem borda nem título. Ou seja, não consigo movê-las... Muito estranho isso... Já alterei um monte configurações no Compiz e nada....
Tente assim, desde que não esteja inicializando junto com a sessão:
No terminal:
compiz --replace
fica sem as bordas das janelas aí faz
emerald --replace

Não sei por que mas com o comando compiz --replace -c emerald eu não consegui fazer subir o emerald.
Se não der é melhor ver a instalação da placa nvidia.

Eu entendi que o tema do gnome que ele usa é metacity, se estiver com gtk acontece isso, só que não tenho certeza da ordem metacity gtk, mas é por aí.

Citar
Na primeira página eu escrevi que minha primeira impressão com o Compiz Fusion não foi das melhores, lento e travando muito. Depois de ler tanta gente falando que gostou, resolvi instalar e passar uns dias usando ele, pra ter uma segunda impressão.
Sinceramente, continuo não gostando nem um pouco. Trava o tempo inteiro, tem momentos que os efeitos vão quadro a quadro. Como compartilho o PC com mais um usuário, ele fica ainda mais lento e travado quando as duas sessões estão ativas, coisa que também não acontecia com o Beryl.
Meu PC não é de assustar ninguém, mas não é uma máquina ruim: Athlon 64 3200, 1GB de ram e uma GeForce 6600 com 256MB. Então, lhes pergunto, tem alguma configuração em especial que vocês estão utilizando? Estou muito disposto a voltar pro Beryl, apesar de ter gostado de alguns efeitos do Fusion, como o cubo com reflexo, o alternador de aplicativos em anel, muito mais bonito. De resto, estou achando uma desgraça essa fusão.

Isso é uma daquelas coisas, todos os comentários que eu escuto é da leveza do compiz-fusion em relação ao beryl, vai entender. Inclusive aqui, ficou sobrando. o benchmark passa de 70 frames por segundo e o
consumo de memória aumentou entre 50 e 100 mb.

Offline Glauco Hass

  • Usuário Ubuntu
  • *
  • Mensagens: 416
    • Ver perfil
Re: O novo Compiz
« Resposta #31 Online: 26 de Junho de 2007, 09:27 »
Meu, meu PC é inferior ao teu. Um Athlon XP 2000+ com 1G de RAM e placa NVIDIA igual a sua. Com o Compiz-Fusion ele ficou bem mais rápido. Nem estou usando o Emerald.
Putz, acho que encontrei o problema. À noite eu realmente uso o PC e confirmo.

Offline Cláudio Novais

  • Usuário Ubuntu
  • *
  • Mensagens: 501
  • I'm ubuntued
    • Ver perfil
    • UBUNTUED.info
Re: O novo Compiz
« Resposta #32 Online: 26 de Junho de 2007, 09:39 »
Na primeira página eu escrevi que minha primeira impressão com o Compiz Fusion não foi das melhores, lento e travando muito. Depois de ler tanta gente falando que gostou, resolvi instalar e passar uns dias usando ele, pra ter uma segunda impressão.
Sinceramente, continuo não gostando nem um pouco. Trava o tempo inteiro, tem momentos que os efeitos vão quadro a quadro. Como compartilho o PC com mais um usuário, ele fica ainda mais lento e travado quando as duas sessões estão ativas, coisa que também não acontecia com o Beryl.
Meu PC não é de assustar ninguém, mas não é uma máquina ruim: Athlon 64 3200, 1GB de ram e uma GeForce 6600 com 256MB. Então, lhes pergunto, tem alguma configuração em especial que vocês estão utilizando? Estou muito disposto a voltar pro Beryl, apesar de ter gostado de alguns efeitos do Fusion, como o cubo com reflexo, o alternador de aplicativos em anel, muito mais bonito. De resto, estou achando uma desgraça essa fusão.

provavelmente não tens os drivers da gráfica bem instalados, por isso faz-me um favor, vai ao terminal e escreve
Código: [Selecionar]
glxgears se as roldanas andarem devagar não tens isso bem instalado. caso o movimento seja fluido, aí deve ser mesmo um bug do compiz fusion

Offline Glauco Hass

  • Usuário Ubuntu
  • *
  • Mensagens: 416
    • Ver perfil
Re: O novo Compiz
« Resposta #33 Online: 26 de Junho de 2007, 21:20 »
Valeu pela tentativa, mas não sei se são os drivers. Eu uso os que vieram com o Ubuntu 7.04 e o FPS do glxgears fica acima de 2200. Com o Beryl ficava perto dos 4000, mas havia testado no 6.10, com os drivers instalados manualmente. Porém, mesmo com os drivers nativos do Feisty Fawn, o desempenho do Beryl é muito superior ao do Compiz Fusion.
Bom, fico no aguardo, se alguém tiver alguma idéia sobre o que pode ser essa queda de desempenho, tentarei. Vou continuar me batendo com o Compiz mais um pouco, pra ver se descubro alguma coisa. Mas que tá chato, tá.

Offline Cláudio Novais

  • Usuário Ubuntu
  • *
  • Mensagens: 501
  • I'm ubuntued
    • Ver perfil
    • UBUNTUED.info
Re: O novo Compiz
« Resposta #34 Online: 26 de Junho de 2007, 22:59 »
estando o glxgears a funcionar como dizes, conclui-se que o problema não é dos drivers...

Offline Cláudio Novais

  • Usuário Ubuntu
  • *
  • Mensagens: 501
  • I'm ubuntued
    • Ver perfil
    • UBUNTUED.info
Re: O novo Compiz
« Resposta #35 Online: 27 de Junho de 2007, 10:09 »
Quanto ao java fiz isso:
http://pabner.wordpress.com/2007/01/12/programas-java-em-aiglx-beryl/

como fizeste? aqui não está a funcionar, mas eu pus no etc/profile, porque penso que seria nesse sitio, mas, na verdade, o mercury não está a dar.. :(

ginho

  • Visitante
Re: O novo Compiz
« Resposta #36 Online: 27 de Junho de 2007, 11:13 »
No /etc/profile, esta assim:
Citar
# /etc/profile: system-wide .profile file for the Bourne shell (sh(1))
# and Bourne compatible shells (bash(1), ksh(1), ash(1), ...).

if [ "$PS1" ]; then
  if [ "$BASH" ]; then
    PS1='\u@\h:\w\$ '
    if [ -f /etc/bash.bashrc ]; then
   . /etc/bash.bashrc
    fi
  else
    if [ "`id -u`" -eq 0 ]; then
      PS1='# '
    else
      PS1='$ '
    fi
  fi
fi

umask 022
export AWT_TOOLKIT=MToolkit

e na pasta do meu usuário tem um link para /usr/lib/jvm/java-6-sun-1.6.0.00/jre/plugin/i386/ns7/libjavaplugin_oji.so
esse não sei se tem a ver.

ginho

  • Visitante
Re: O novo Compiz
« Resposta #37 Online: 27 de Junho de 2007, 11:39 »
É assim que tem que ficar?

Eu não tinha ele instalado, baixei agora. Já havia testado antes com o 6.10, sem sucesso, agora parece que deu.

Offline Cláudio Novais

  • Usuário Ubuntu
  • *
  • Mensagens: 501
  • I'm ubuntued
    • Ver perfil
    • UBUNTUED.info
Re: O novo Compiz
« Resposta #38 Online: 27 de Junho de 2007, 12:25 »
que estranho isto não dar. mas, explica melhor isso do atalho, não percebi, obrigado

EDIT:

já está resolvido. realmente no teu caso, mercury 1.8, a solução é essa, mas para quem está a usar o mercury 1.9 beta o problema não se resolve dessa maneira. fiz consoante este tópico explica e resolvi o problema. de denotar que resolve o problema de qualquer aplicação java, pelo menos da versão 6.
o site é este:
http://forum.mercury.to/index.php?showtopic=16630
« Última modificação: 27 de Junho de 2007, 13:06 por unrater »

ginho

  • Visitante
Re: O novo Compiz
« Resposta #39 Online: 27 de Junho de 2007, 12:48 »
Eu estava tentando lembrar, mas não consegui, não sei mais da onde tirei, o atalho criou quando da colocação do java 1.6 como padrão, o comando usado
 sudo ln -s /usr/lib/jvm/java-6-sun-1.6.0.00/jre/plugin/i386/ns7/libjavaplugin_oji.so
achei no terminal, parece ser este, certeza não tenho.
Acho que tem que fazer o sistema entender que é pra usar o 1.6.
Aproveitando, o mercury esta em Inglês, onde consigo o xml para pt-br?
Cada vez fico mais impressionado com este SO, estes dias copiei um DVD do meu filho como iso para o PC e ele tocou direto no VLC, agora o mercury, uma pasta zipada, só extraí no meu home e executei o startup, rodou direto para o wizard de configuração e saiu para a área de logim, o googleearth só next, next, mesma coisa com o acroread......

Offline Cláudio Novais

  • Usuário Ubuntu
  • *
  • Mensagens: 501
  • I'm ubuntued
    • Ver perfil
    • UBUNTUED.info
Re: O novo Compiz
« Resposta #40 Online: 27 de Junho de 2007, 13:11 »

ginho

  • Visitante
Re: O novo Compiz
« Resposta #41 Online: 27 de Junho de 2007, 14:19 »
Acabei de pegar o arquivo em pt_BR, assim: baixei um rpm converti com o alien, abri com o compactador de arquivos, localizei o arquivo e extraí somente ele, copiei na pasta lang, e esta em Português do Brasil.

Offline Deus Ex Machina

  • Usuário Ubuntu
  • *
  • Mensagens: 102
    • Ver perfil
Re: O novo Compiz
« Resposta #42 Online: 27 de Junho de 2007, 23:52 »
Alguém sabe se essa beleza está tendo problemas com ATI + XGL, que é o que sou obrigado a usar aqui em casa, graças a má-vontade da AMD em fazer drivers decentes...

Abraços!
Notebook Asus A7Jc; Core Duo 1,66 GHz; ATI Mobility Radeon X1600 256 MB; 2GB DDR2.
Hardy Heron funcionando (quase) perfeitamente!

Offline rjbgbo

  • Usuário Ubuntu
  • *
  • Mensagens: 3.889
  • Xubuntu 18.04LTS
    • Ver perfil
    • Twitter
Re: O novo Compiz
« Resposta #43 Online: 28 de Junho de 2007, 00:22 »
Alguém sabe se essa beleza está tendo problemas com ATI + XGL, que é o que sou obrigado a usar aqui em casa, graças a má-vontade da AMD em fazer drivers decentes...

Abraços!

também tenho a mesma dúvida do amigo, pois minha placa de vídeo é uma ATI Radeon X300SE (único hardware que ñ funciona legal no Linux, mas que em breve pretendo trocar por uma NVidia GeForce 6600LE!)

A muito custo consegui fazer funcionar o beryl através do http://www.howtoforge.com/ubuntu_feisty_beryl_ati_radeon dica me passada aqui nesse fórum
Roda até bem, mas se eu deixo o Beryl na inicialização do Ubuntu, complica as coisas.

No blog http://hamacker.wordpress.com/2007/06/21/compiz-fusion-no-ubuntu-feisty/#comments vi um conselho sobre placas ATI usar os drives proprietários ATI

Citar
Placas ATI sao problematicas, o melhor caminho é esse: http://wiki.cchtml.com/index.php/Ubuntu_Feisty_Installation_Guide

Pelo que sei, ñ dá p/ se usar drive proprietário ATI p/ Compiz ou Beryl. Já testei a instalação dos drives proprietários s/ fazer as configurações do xorg.conf conforme o indicado em: http://wiki.cchtml.com/index.php/Ubuntu_Feisty_Installation_Guide

Tô c/ vontade de arriscar.

Dei uma pesquisada no assunto e achei no site da ATI/AMD -  http://ati.amd.com/support/drivers/linux/linux-radeon.html a resposta abaixo p/ minha placa de vídeo

ATI Driver Installer     51.8MB     8.38.6     June 25 , 2007     Automated installer and Display Drivers for XFree86 4.3 and X.Org 6.7, 6.8, 6.9, 7.0, 7.1
Linux User #440843 | Ubuntu User #11469

Offline Cláudio Novais

  • Usuário Ubuntu
  • *
  • Mensagens: 501
  • I'm ubuntued
    • Ver perfil
    • UBUNTUED.info
Re: O novo Compiz
« Resposta #44 Online: 28 de Junho de 2007, 07:17 »
Sabem, desculpem o off-topic, mas eu nunca mais comprava hardware da ATI, á muito tempo que o pessoal se queixa da ATI e eles nunca se preocuparam, eu acho que nem que daqui a um mês eles tivessem o melhor driver de sempre, nunca compraria NADA deles.
eu sou adepto de nunca mais comprar nada nessas empresas. se toda a gente fizesse isso, as outras empresas perceberiam isso, mas infelizmente há muito pessoal, que prefer aventurar-se em caminhos obscuros, mas ok.


agora quanto ao tópico, como se põe temas do beryl no fusion? acho que são temas emerald, mas não sei muito disto, nunca me importei com este software.. :D

obrigado