Autor Tópico: Nao toca mais de um som ao msmo tempo (ALSA CS4281)  (Lida 8613 vezes)

Offline Mythus

  • Usuário Ubuntu
  • *
  • Mensagens: 264
  • Liga dos Dinos
    • Ver perfil
    • http://www.protopage.com/skopein
Re: Nao toca mais de um som ao msmo tempo
« Resposta #15 Online: 27 de Junho de 2007, 13:01 »
Mas não rola nenhuma msg, no terminal executando aqueles comandos =/
:o
Cara! Temos que debugar isso! Xô Desânimo! Você vai usar o modprobe em verbose e vais ligar a chave do syslog adcionando -v e -s aos comandos. Tem que aparecer alguma coisa desse jeito nem que seja na saída do dmesg.

Se nada disso der certo, como medida de desespero temos que analisar o config do modprobe. Para gerar o arquivo digite modprobe -c > arquivo_do_modprobe.
Abraços,
_________________
Não é programador, não é hacker. Formado em Direito pela UFPb. Usuário de Linux em tempo integral: Linux User Number: 174012.

Offline Strokes

  • Usuário Ubuntu
  • *
  • Mensagens: 75
    • Ver perfil
Re: Nao toca mais de um som ao msmo tempo
« Resposta #16 Online: 28 de Junho de 2007, 23:08 »
Mas não rola nenhuma msg, no terminal executando aqueles comandos =/
:o
Cara! Temos que debugar isso! Xô Desânimo! Você vai usar o modprobe em verbose e vais ligar a chave do syslog adcionando -v e -s aos comandos. Tem que aparecer alguma coisa desse jeito nem que seja na saída do dmesg.

Se nada disso der certo, como medida de desespero temos que analisar o config do modprobe. Para gerar o arquivo digite modprobe -c > arquivo_do_modprobe.
Bah velho, me da uma luz, eu so meio nb ainda no linux, eu tava sem pc ate hj pq deu derma na minha fonte e nao tava conseguindo constatar oque era, e demorei para axar o problema.
Eu teria que ir no terminal e dar "modprob syslog -v -s" no terminal é isso?!
Valeu pela grande força que tu esta me dando!

Offline Mythus

  • Usuário Ubuntu
  • *
  • Mensagens: 264
  • Liga dos Dinos
    • Ver perfil
    • http://www.protopage.com/skopein
Re: Nao toca mais de um som ao msmo tempo
« Resposta #17 Online: 29 de Junho de 2007, 09:20 »
Não, não. O que eu disse foi que, nos comandos que usam modprobe você inia adcionar -v e -s, para que o programa force aparecer mensagens na tela e no syslog. Daí, esperançosamente, você veria o que está acontecendo com o teu sistema, seja na tela, seja usando o dmesg. Para dar exemplo:
Código: [Selecionar]
sudo modprobe -v -s snd-cs4281
Sucesso!
Abraços,
_________________
Não é programador, não é hacker. Formado em Direito pela UFPb. Usuário de Linux em tempo integral: Linux User Number: 174012.

Offline Strokes

  • Usuário Ubuntu
  • *
  • Mensagens: 75
    • Ver perfil
Re: Nao toca mais de um som ao msmo tempo
« Resposta #18 Online: 29 de Junho de 2007, 13:57 »
T_T não apareceu nenhuma msg, ta soda

Offline Mythus

  • Usuário Ubuntu
  • *
  • Mensagens: 264
  • Liga dos Dinos
    • Ver perfil
    • http://www.protopage.com/skopein
Re: Nao toca mais de um som ao msmo tempo
« Resposta #19 Online: 30 de Junho de 2007, 02:22 »
o dmesg continua o mesmo?

Olhe de onde eu tirer os parâmetros:

Do man modprobe
Citar
OPTIONS
       -v --verbose
              Print messages about what the program is doing.  Usually modprobe only prints messages if something  goes
              wrong.

              This  option  is  passed  through  install  or  remove  commands  to  other modprobe commands in the MOD-
              PROBE_OPTIONS environment variable.
(...)
       -c --showconfig
              Dump out the configuration file and exit.
(...)
       -s --syslog
              This option causes any error messages to go through  the  syslog  mechanism  (as  LOG_DAEMON  with  level
              LOG_NOTICE)  rather  than  to standard error.  This is also automatically enabled when stderr is unavail-
              able.

              This option is passed through install  or  remove  commands  to  other  modprobe  commands  in  the  MOD-
              PROBE_OPTIONS environment variable.
Abraços,
_________________
Não é programador, não é hacker. Formado em Direito pela UFPb. Usuário de Linux em tempo integral: Linux User Number: 174012.

Offline Strokes

  • Usuário Ubuntu
  • *
  • Mensagens: 75
    • Ver perfil
Re: Nao toca mais de um som ao msmo tempo
« Resposta #20 Online: 30 de Junho de 2007, 14:01 »
o dmesg continua o mesmo?

Olhe de onde eu tirer os parâmetros:

Do man modprobe
Citar
OPTIONS
       -v --verbose
              Print messages about what the program is doing.  Usually modprobe only prints messages if something  goes
              wrong.

              This  option  is  passed  through  install  or  remove  commands  to  other modprobe commands in the MOD-
              PROBE_OPTIONS environment variable.
(...)
       -c --showconfig
              Dump out the configuration file and exit.
(...)
       -s --syslog
              This option causes any error messages to go through  the  syslog  mechanism  (as  LOG_DAEMON  with  level
              LOG_NOTICE)  rather  than  to standard error.  This is also automatically enabled when stderr is unavail-
              able.

              This option is passed through install  or  remove  commands  to  other  modprobe  commands  in  the  MOD-
              PROBE_OPTIONS environment variable.
Sim, o dmseg ta o manual lá e talz, msa tipo
Citar
sudo modprobe -v -s snd-cs4281
assim como alguns outros comandos que tu me passou antes n funfa, nao aparece msg nenhuma no terminal.

Offline Mythus

  • Usuário Ubuntu
  • *
  • Mensagens: 264
  • Liga dos Dinos
    • Ver perfil
    • http://www.protopage.com/skopein
Re: Nao toca mais de um som ao msmo tempo
« Resposta #21 Online: 01 de Julho de 2007, 17:06 »
vamos por outra frente então:

Execute um som
Execute também:
Código: [Selecionar]
dmesg |grep tail -n 20 > 1som
Execute um mp3 e durante a execução, abra um filme, seriado ou wave
Execute logo a seguir:
Código: [Selecionar]
dmesg |grep tail -n 20 > 2sons
Já tentou ver se algum controle da sua placa está desligado? Abra o alsamixer e tente ver o que está "mute" (para desmarcar o "mute" tecle M e para sair do alsamixer, basta teclar duas vezes em esc).

Você continua escutando um só som, não?

Abra no gedit os arquivos 1som e 2sons e veja se aparece neles algum motivo para isso continar sem funcionar. Poste aqui se não achar nada.
Abraços,
_________________
Não é programador, não é hacker. Formado em Direito pela UFPb. Usuário de Linux em tempo integral: Linux User Number: 174012.

Offline Strokes

  • Usuário Ubuntu
  • *
  • Mensagens: 75
    • Ver perfil
Re: Nao toca mais de um som ao msmo tempo
« Resposta #22 Online: 02 de Julho de 2007, 12:46 »
Citar
matheus@matheus-desktop:~$ dmesg |grep tail -n 20 > 1som
grep: 20: Arquivo ou diretório inexistente
matheus@matheus-desktop:~$ dmesg |grep tail -n 20 > 2sons
grep: 20: Arquivo ou diretório inexistente

ERRR X_X
Ainda, so consigo escutar um audio por vez

Offline Mythus

  • Usuário Ubuntu
  • *
  • Mensagens: 264
  • Liga dos Dinos
    • Ver perfil
    • http://www.protopage.com/skopein
Re: Nao toca mais de um som ao msmo tempo
« Resposta #23 Online: 02 de Julho de 2007, 17:41 »
Citar
matheus@matheus-desktop:~$ dmesg |grep tail -n 20 > 1som
grep: 20: Arquivo ou diretório inexistente
matheus@matheus-desktop:~$ dmesg |grep tail -n 20 > 2sons
grep: 20: Arquivo ou diretório inexistente

ERRR X_X
Ainda, so consigo escutar um audio por vez

Ops! hehehe Costume de colocar um grep sempre atrás de um pipe  ;D
Código: [Selecionar]
dmesg | tail -n 20 > 1som
Abraços,
_________________
Não é programador, não é hacker. Formado em Direito pela UFPb. Usuário de Linux em tempo integral: Linux User Number: 174012.

Offline Strokes

  • Usuário Ubuntu
  • *
  • Mensagens: 75
    • Ver perfil
Re: Nao toca mais de um som ao msmo tempo
« Resposta #24 Online: 02 de Julho de 2007, 21:41 »
1som
Código: [Selecionar]
[   43.360000] Using specific hotkey driver
[   43.644000] pcc_acpi: loading...
[   45.712000] eth1: no IPv6 routers present
[   48.916000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   49.752000] agpgart: Found an AGP 1.0 compliant device at 0000:00:00.0.
[   49.752000] agpgart: Putting AGP V2 device at 0000:00:00.0 into 2x mode
[   49.752000] agpgart: Putting AGP V2 device at 0000:01:00.0 into 2x mode
[   50.592000] ppdev: user-space parallel port driver
[   52.968000] apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16ac)
[   52.968000] apm: overridden by ACPI.
[   54.092000] Bluetooth: Core ver 2.11
[   54.092000] NET: Registered protocol family 31
[   54.092000] Bluetooth: HCI device and connection manager initialized
[   54.092000] Bluetooth: HCI socket layer initialized
[   54.252000] Bluetooth: L2CAP ver 2.8
[   54.252000] Bluetooth: L2CAP socket layer initialized
[   54.272000] Bluetooth: RFCOMM socket layer initialized
[   54.272000] Bluetooth: RFCOMM TTY layer initialized
[   54.272000] Bluetooth: RFCOMM ver 1.8
[   63.816000] eth1: no IPv6 routers present

2sons
Código: [Selecionar]
[   43.360000] Using specific hotkey driver
[   43.644000] pcc_acpi: loading...
[   45.712000] eth1: no IPv6 routers present
[   48.916000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   49.752000] agpgart: Found an AGP 1.0 compliant device at 0000:00:00.0.
[   49.752000] agpgart: Putting AGP V2 device at 0000:00:00.0 into 2x mode
[   49.752000] agpgart: Putting AGP V2 device at 0000:01:00.0 into 2x mode
[   50.592000] ppdev: user-space parallel port driver
[   52.968000] apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16ac)
[   52.968000] apm: overridden by ACPI.
[   54.092000] Bluetooth: Core ver 2.11
[   54.092000] NET: Registered protocol family 31
[   54.092000] Bluetooth: HCI device and connection manager initialized
[   54.092000] Bluetooth: HCI socket layer initialized
[   54.252000] Bluetooth: L2CAP ver 2.8
[   54.252000] Bluetooth: L2CAP socket layer initialized
[   54.272000] Bluetooth: RFCOMM socket layer initialized
[   54.272000] Bluetooth: RFCOMM TTY layer initialized
[   54.272000] Bluetooth: RFCOMM ver 1.8
[   63.816000] eth1: no IPv6 routers present

Offline Mythus

  • Usuário Ubuntu
  • *
  • Mensagens: 264
  • Liga dos Dinos
    • Ver perfil
    • http://www.protopage.com/skopein
Re: Nao toca mais de um som ao msmo tempo
« Resposta #25 Online: 03 de Julho de 2007, 00:25 »
Isso aí foi exatamente depois de escutar os dois sons ao mesmo tempo? Caracas! Os arquivos estão iguais, parece que não aconteceu nada de errado.

E no alsamixer? Viu se tem algum controle desligado?

Só pra constar: quando você usa o ALSA não aparece mais a mensagem: "audiotestsrc wave since=512 ! audioconvert ! audiosample ! gconfaudiosink profile=music: recurso ocupado ou não disponivel" Não, né?

E você está de fato usando o ALSA, né? Andei catando no google e encontrei dois links e um encaminhava a outro:
http://forum.ubuntu-fr.org/viewtopic.php?id=130444
http://www.linuxquestions.org/questions/showthread.php?t=522137

Talvez seja interessante como o Ricardisimo tentou, mas uma solução possível foi esta: http://www.linuxquestions.org/questions/showthread.php?p=2791142#post2791142

Leia lá! Ele diz que executou o comando asoundconf reset-default-card e criou um alsa.conf com um conteúdo minimalístic. E ainda indica a fonte: http://gentoo-wiki.com/HOWTO_Dolby_Digital_Out_(AC3,_SPDIF)

O mais interessante é que no fórum o Ricardisimo ele começa dizendo que "não aparece nenhuma mensagem de erro". Exatamente como nós aqui.
Abraços,
_________________
Não é programador, não é hacker. Formado em Direito pela UFPb. Usuário de Linux em tempo integral: Linux User Number: 174012.

Offline Strokes

  • Usuário Ubuntu
  • *
  • Mensagens: 75
    • Ver perfil
Re: Nao toca mais de um som ao msmo tempo
« Resposta #26 Online: 03 de Julho de 2007, 01:45 »
No alsamixer ta tudo on
e akele erro da lah no sitema > preferencia > sons
e quando fui executar o passo 2 o mplayer deu um erro dizendo [gl] could not aquire buffer for dr Expect a _major_speed penalty

vo dar uma olhada nos links
vlw

Offline Strokes

  • Usuário Ubuntu
  • *
  • Mensagens: 75
    • Ver perfil
Re: Nao toca mais de um som ao msmo tempo
« Resposta #27 Online: 12 de Julho de 2007, 13:41 »
Isso aí foi exatamente depois de escutar os dois sons ao mesmo tempo? Caracas! Os arquivos estão iguais, parece que não aconteceu nada de errado.

E no alsamixer? Viu se tem algum controle desligado?

Só pra constar: quando você usa o ALSA não aparece mais a mensagem: "audiotestsrc wave since=512 ! audioconvert ! audiosample ! gconfaudiosink profile=music: recurso ocupado ou não disponivel" Não, né?

E você está de fato usando o ALSA, né? Andei catando no google e encontrei dois links e um encaminhava a outro:
http://forum.ubuntu-fr.org/viewtopic.php?id=130444
http://www.linuxquestions.org/questions/showthread.php?t=522137

Talvez seja interessante como o Ricardisimo tentou, mas uma solução possível foi esta: http://www.linuxquestions.org/questions/showthread.php?p=2791142#post2791142

Leia lá! Ele diz que executou o comando asoundconf reset-default-card e criou um alsa.conf com um conteúdo minimalístic. E ainda indica a fonte: http://gentoo-wiki.com/HOWTO_Dolby_Digital_Out_(AC3,_SPDIF)

O mais interessante é que no fórum o Ricardisimo ele começa dizendo que "não aparece nenhuma mensagem de erro". Exatamente como nós aqui.

Tentei fazer todos mas nada pareceu ter resultado, digo "todos" o do linux questions por que o gentoo nao consegui acessar!!!
Mais uma vez obrigado pela ajuda!!!


Acabei de ter a seguinte msg no terminal...

Código: [Selecionar]
matheus@matheus-desktop:~$ sudo asoundconf
Usage:
asoundconf is-active
asoundconf get|delete PARAMETER
asoundconf set PARAMETER VALUE
asoundconf list

Convenience macro functions:
asoundconf set-default-card CARD
asoundconf reset-default-card
asoundconf set-pulseaudio
asoundconf unset-pulseaudio

matheus@matheus-desktop:~$ asoundconf reset-default-card
matheus@matheus-desktop:~$ sudo gedit /etc/alsa.conf
- using device default
- using device default
ALSA lib pcm_dmix.c:864:(snd_pcm_dmix_open) unable to open slave
- using device default
- using device default
ALSA lib pcm_dmix.c:864:(snd_pcm_dmix_open) unable to open slave
- using device default
- using device default
ALSA lib pcm_dmix.c:864:(snd_pcm_dmix_open) unable to open slave
- using device default
- using device default
ALSA lib pcm_dmix.c:864:(snd_pcm_dmix_open) unable to open slave
- using device default
- using device default
ALSA lib pcm_dmix.c:864:(snd_pcm_dmix_open) unable to open slave
- using device default
- using device default
ALSA lib pcm_dmix.c:864:(snd_pcm_dmix_open) unable to open slave
- using device default
- using device default
ALSA lib pcm_dmix.c:864:(snd_pcm_dmix_open) unable to open slave
matheus@matheus-desktop:~$ sudo gedit /etc/alsa.conf
- using device default
- using device default
ALSA lib pcm_dmix.c:864:(snd_pcm_dmix_open) unable to open slave
- using device default
- using device default
ALSA lib pcm_dmix.c:864:(snd_pcm_dmix_open) unable to open slave
- using device default
- using device default
ALSA lib pcm_dmix.c:864:(snd_pcm_dmix_open) unable to open slave
« Última modificação: 12 de Julho de 2007, 13:44 por Strokes »

Offline Strokes

  • Usuário Ubuntu
  • *
  • Mensagens: 75
    • Ver perfil
Re: Nao toca mais de um som ao msmo tempo (ALSA CS4281)
« Resposta #28 Online: 12 de Julho de 2007, 16:25 »
Cara, sei lá como foram as coisas, mas eu botei o padrao do sistema como ESD, e no xmms eSound, e agora uma BOA parte dos programas esta tocando os sons todos ao mesmo tempo :o

Offline Mythus

  • Usuário Ubuntu
  • *
  • Mensagens: 264
  • Liga dos Dinos
    • Ver perfil
    • http://www.protopage.com/skopein
Re: Nao toca mais de um som ao msmo tempo (ALSA CS4281)
« Resposta #29 Online: 13 de Julho de 2007, 01:34 »
Pareceu Xicó: "não sei, só sei que foi assim"

Ao menos fico feliz que tenhas resolvido de uma forma ou outra. :)
Abraços,
_________________
Não é programador, não é hacker. Formado em Direito pela UFPb. Usuário de Linux em tempo integral: Linux User Number: 174012.