Autor Tópico: Erro no mplayer ????  (Lida 2590 vezes)

Offline arilsonramone

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Erro no mplayer ????
« Online: 21 de Junho de 2007, 01:55 »
ola galera o mplayer aqui da o seguinte erro:

error opening/initializing the selected video_out(-vo) device


alguem sabe como resolver isso ?????

vlw galera.

Offline RC2006

  • Usuário Ubuntu
  • *
  • Mensagens: 820
  • Ubuntu 10.10
    • Ver perfil
Re: Erro no mplayer ????
« Resposta #1 Online: 21 de Junho de 2007, 08:39 »
HP All-in-one 4GB HD760 - windows7 home premium - Netbook Asus 1005PEB - Windows 7 - Ubuntu 11.04
Macbook branco 13.3" 2gb 160HD - Mac OS X 10.6 - Tablet Asus Eee Pad Transformer com dock - Android 3.2

Offline Mythus

  • Usuário Ubuntu
  • *
  • Mensagens: 264
  • Liga dos Dinos
    • Ver perfil
    • http://www.protopage.com/skopein
Re: Erro no mplayer ????
« Resposta #2 Online: 22 de Junho de 2007, 02:20 »
error opening/initializing the selected video_out(-vo) device

O video_out padrão está configurado num dispositivo que você não tem instalado no seu computador ou a sua placa de vídeo não suporta.

Se você entende inglês, digite no terminal man mplayer e procure "VIDEO OUTPUT DRIVERS (MPLAYER ONLY)" que tem uma extensa explicação sobre cada driver.

Tente rodar o arquivo de vídeo pelo terminal colocando diferentes -vo's
xv
x11
sdl
vesa
svga
gl
gl2
a
caca

Ex.: mplayer -vo xv video.avi

Depois que você achou melhor driver, escolha-o como padrão:
gedit ~/.mplayer/config

Abaixo segue um exemplo:

# Escolha suas opções ou comente-as com um #
vo = x11
fs = yes
ao = alsa
zoom = yes
# fontconfig = yes
subfont-autoscale = 1
# subfont-osd-scale = 6
# subfont-text-scale = 6
Abraços,
_________________
Não é programador, não é hacker. Formado em Direito pela UFPb. Usuário de Linux em tempo integral: Linux User Number: 174012.