Autor Tópico: HD morto???  (Lida 7443 vezes)

Offline LedStyle

  • Usuário Ubuntu
  • *
  • Mensagens: 1.345
    • Ver perfil
    • http://www.tuxresources.org
HD morto???
« Online: 28 de Novembro de 2005, 04:20 »
Pessoal, peguei um HD aqui que ao iniciar o Ubuntu aparecem vááárias mensagens assim:

[xxxxxxx,xxxxxxx] Buffer I/O error on device hdb, logical block xxxxxxxx


Esses "xxxx" são números, creio que dos blocos com problemas.

O HD eu sei que é vfat mas não consigo nem ver o que tem dentro. Tenho que salvar uns arquivos dele.

Tentei dar um fdisk e um cfdisk nele e nada. Não da pa montar tbm não sei como salvar os dados.


Alguém ai pode me ajudar?

Vlw!

Wesley F

  • Visitante
HD morto???
« Resposta #1 Online: 28 de Novembro de 2005, 08:14 »
Putz ja aconteceu mais ou menos isso no meu outro HD maxtor slim 40GB 7200rpm um dia fui inciar meu linux e deu uns negocios de block ae fiquei sabendo que era bad block(no meu caso), isso pode ser não posso afirmar que seje Bad Block, e eu navegava no meu linux ae travava ae tive que trocar de HD. Mas não sei se eh seu caso so to falando isso q vc comentou esse lance de blocks, tenta passar um fsck nele e ver no que da.

Abraços

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.684
    • Ver perfil
HD morto???
« Resposta #2 Online: 28 de Novembro de 2005, 08:38 »
Led, coloca ele no Freezer ou congelador por uma hora mais ou menos. Mas antes coloca ele dentro daqueles sacos plásticos para congelados (ZipLock alguma coisa assim, ou filme de PVC mesmo). Depois você tira ele do Freezer e tenta salvar o que puder antes dele dar Pau de novo.  Muitas vezes funciona.


Tenta aí e depois diz o que deu.
BigLinux no Notebook  / Várias Distros Virtualizadas no PC.

Offline FaBMak

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 722
    • Ver perfil
    • fabmak://website
HD morto???
« Resposta #3 Online: 28 de Novembro de 2005, 12:16 »
Já fiz o que Galactus disse, colocar o HD no freezer, e já me salvou um vez.

FaBMak
"Não creias impossível o que apenas improvável parece". (Shakespeare)
fabmak://website | http://twitter.com/fabmak

Offline eggx.geo

  • Usuário Ubuntu
  • *
  • Mensagens: 222
    • Ver perfil
HD morto???
« Resposta #4 Online: 28 de Novembro de 2005, 12:38 »
é sério este negócio do Freezer? sempre pensei que era lenda isso.

Sabe que ah algum tempo atras tive um problema parecido, com um HD de note.
Depois de diversas tentativas eu consegui montar esse HD. Acho que consegui copiar a metade dos arquivos e daí ele morreu de vez. Não montou nunca mais.

Talvez se tivesse posto no freezer.....
Egg

Offline LedStyle

  • Usuário Ubuntu
  • *
  • Mensagens: 1.345
    • Ver perfil
    • http://www.tuxresources.org
HD morto???
« Resposta #5 Online: 28 de Novembro de 2005, 14:47 »
Alguém sabe me dizer onde consigo um saco desses? Não pode ser um saquinho normal???

E outra... num tem um comando ou programa pra isolar os bad blocks??? Pesquisando me falaram do comando "badblocks" mas parece que não é pra vfat. Ocorre que eu tentei ontem abrir o Partition Magic pelo meu disquete de boot aqui e ele nem detectou que tem outro HD espetado na máquina. Os programas nem detectam  que ele está la :'(

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.684
    • Ver perfil
HD morto???
« Resposta #6 Online: 28 de Novembro de 2005, 17:26 »
Você pode usar outro saco plástico sim, o que importa é que ele fique bem vedado para não acumular gelo no HD, só por fora. Para na hora em que você tirar do Freezer não molhar e dar curto.

Vixi, ele não estar sendo nem detectado é um péssimo sinal mesmo.
BigLinux no Notebook  / Várias Distros Virtualizadas no PC.

Offline FaBMak

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 722
    • Ver perfil
    • fabmak://website
HD morto???
« Resposta #7 Online: 28 de Novembro de 2005, 19:29 »
Para tarefas de recuperação eu uso o dd_rescue: http://www.dicas-l.com.br/dicas-l/20050801.php

FaBMak
"Não creias impossível o que apenas improvável parece". (Shakespeare)
fabmak://website | http://twitter.com/fabmak

Offline LedStyle

  • Usuário Ubuntu
  • *
  • Mensagens: 1.345
    • Ver perfil
    • http://www.tuxresources.org
HD morto???
« Resposta #8 Online: 28 de Novembro de 2005, 22:48 »
Galera... em congelado o bixo detectou. No boot do Linux varios erros mesmo. Acho que ja era :'(

Offline FaBMak

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 722
    • Ver perfil
    • fabmak://website
HD morto???
« Resposta #9 Online: 29 de Novembro de 2005, 12:04 »
Sim, normalmente isto ocorre, o que eu faço é colocar HD "bixado" como slave e uso o dd_rescue para criar uma imagem do no outro HD, depois eu monto a imagem e copio os dados.

FaBMak.
"Não creias impossível o que apenas improvável parece". (Shakespeare)
fabmak://website | http://twitter.com/fabmak