Autor Tópico: [Tutorial] Modem HSP56MR - Smartlink no 7.04  (Lida 56128 vezes)

Offline Law

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #60 Online: 20 de Outubro de 2007, 17:11 »
Caro Alarcon

Fiz como vc aconselhou e esperei o modem dar pau novamente. Não demorou muito. Ontem não consegui conectar e resolvi usar seu pacote. Mas não desinstalei o driver antigo. Simplesmente cliquei no arquivo pro gnome e segui os passos como recomendado. Depois que terminou eu tentei conectar e nada. Aí reiniciei e tentei de novo. Depois de alguns "NO CARRIER" conectou beleza.

Mas ainda tem que restartar o slmodemd-daemon toda vez que ligo o pc. Como já disse isso não é problema.

Me corrija se eu estiver errado, mas acho que a navegação tá mais rápida agora. Eu ficava reclamando comigo mesmo pois no windows a navegação era um pouco mais rápida, mas agora tá até melhor no ubuntu. Download continua o mesmo, mas as páginas estão abrindo bem rápido.

Você realmente merece os parabéns. Primeiro por colocar tudo que precisa em um pacote e depois por melhorara as coisas.

A cada dia que passa eu uso menos o Windows. Só no trampo mesmo mas já estou usando o Kurumin lá também.

Só tenho a agradescer a vocês!

Valeu mesmo!

alarcon

  • Visitante
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #61 Online: 20 de Outubro de 2007, 17:27 »
Caro Alarcon

Fiz como vc aconselhou e esperei o modem dar pau novamente. Não demorou muito. Ontem não consegui conectar e resolvi usar seu pacote. Mas não desinstalei o driver antigo. Simplesmente cliquei no arquivo pro gnome e segui os passos como recomendado. Depois que terminou eu tentei conectar e nada. Aí reiniciei e tentei de novo. Depois de alguns "NO CARRIER" conectou beleza.

Mas ainda tem que restartar o slmodemd-daemon toda vez que ligo o pc. Como já disse isso não é problema.

Me corrija se eu estiver errado, mas acho que a navegação tá mais rápida agora. Eu ficava reclamando comigo mesmo pois no windows a navegação era um pouco mais rápida, mas agora tá até melhor no ubuntu. Download continua o mesmo, mas as páginas estão abrindo bem rápido.

Você realmente merece os parabéns. Primeiro por colocar tudo que precisa em um pacote e depois por melhorara as coisas.

A cada dia que passa eu uso menos o Windows. Só no trampo mesmo mas já estou usando o Kurumin lá também.

Só tenho a agradescer a vocês!

Valeu mesmo!

O seu e o  HSP56 MR da SiS?

Se for, não sei por qual motivo mais para alguns usuários é preciso sempre estar executando novamente o script de ativação do modem (sl-modem-daemon) quando você reinicia o sistema (sudo /etc/init.d/sl-modem-daemon restart).

Realmente alguns usuários relataram uma melhor velocidade e estabilidade, creio que é mérito do novo driver smartlink adicionado neste pacote. ;D
« Última modificação: 20 de Outubro de 2007, 21:49 por alarcon »

Offline Law

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #62 Online: 20 de Outubro de 2007, 21:47 »
Mesmo assim!

Quando instalei o driver antigo tive que baixar um monte de pacotes!

Você, acredito, colocou tudo num lugar só!

Não entendo muito bem ainda do sistema em si, mas acredito que não seja fácil esse tipo de conhecimento. Espero um dia realmente contribuir para a comunidade Linux.

Valeu!

alarcon

  • Visitante
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #63 Online: 20 de Outubro de 2007, 21:50 »
Mesmo assim!

Quando instalei o driver antigo tive que baixar um monte de pacotes!

Você, acredito, colocou tudo num lugar só!

Não entendo muito bem ainda do sistema em si, mas acredito que não seja fácil esse tipo de conhecimento. Espero um dia realmente contribuir para a comunidade Linux.

Valeu!

Exato coloquei tudo em um pacote para poder facilitar as coisas para os iniciantes, pois  com a internet ativa podemos pesquisar melhor via google ou neste forum por exemplo.
« Última modificação: 20 de Outubro de 2007, 21:53 por alarcon »

Offline Shakmatton

  • Usuário Ubuntu
  • *
  • Mensagens: 213
    • Ver perfil
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #64 Online: 23 de Outubro de 2007, 00:29 »
Aqui vai o máximo que consegui de uma conexão (0.1 segundos e cai.) Queria saber se isso tem a ver com o discador Yahoo, já que o Oi parece que tá querendo conectar... falta pouco, mas... o que falta fazer ?

Não foi reconhecido automaticamente pelo 7.10 o winmodem, instalei sem erros o teu pacote, e pelo visto até funcionou, eu acho que justamente o problema é nesta "sintonia fina" que falta fazer...
vi que muitos por aqui tiveram problema parecido, mas alguns de cara conseguiram resolver...
E agora ?


Segue sobre o modem :

Comportamento após a instalação do pacote do Alarcon e após digitar no terminal apenas sudo pppconfig, e fazer o que recomenda o seguinte texto, do Viva O Linux :

Oi galera, já são 23:41 e estou muito satisfeito, pois depois de um mês tentando consegui transformar meu winmodem em um linmodem graças a uma matéria que eu achei em um site hoje. Logo que consegui me conectar pensei direto em mandar a dica para todos que como eu não estavam conseguindo conectar.

Aí vai, só peço desculpas pois é meu primeira dica e espero que seja aprovada, pois é de grande ajuda. As matérias que vou passar foram conseguidas em:
http://www.dicas-l.com.br/dicas-l/20070509.php

E no site do Ubuntu Brasil, uma completou a outra.

Modem Motorola SM56 - device id 1057:3052

Colaboração: Fábio Augusto Bitencourt Ranquetat

Gostaria de compartilhar um pequeno howto que fiz para quem tem a plaquinha SM56, winmodem da Motorola.

Como fazer LinModem Motorola SM56 - device id 1057:3052

Testei no Ubuntu 7.04 Feisty Fawn

Instalar os pacotes de desenvolvimento:

$ sudo aptitude update
$ sudo aptitude install build-essential sl-modem-daemon

Baixar os seguintes arquivos (o driver da smartlink já está patcheado para reconhecer o modem da motorola):

$ wget -c http://linmodems.technion.ac.il/packages/smartlink/slmodem-2.9.11-20070430.tar.gz
$ wget -c http://linmodems.technion.ac.il/packages/smartlink/ungrab-winmodem-20070430.tar.gz

Descompactar os arquivos acima:

$ tar -xzvf slmodem-2.9.11-20070430.tar.gz
$ tar -xzvf ungrab-winmodem-20070430.tar.gz

Entrar na pasta criada na descompactação do primeiro arquivo e emitir os seguintes comandos:

$ make
$ sudo make install

Entrar na pasta criada na descompactação do segundo arquivo (como root) e emitir os seguintes comandos:

$ make
$ make install

Iniciar o serviço do sl-modem-daemon:

$ sudo /etc/init.d/sl-modem-daemon start

Testar se o driver está ativo:

$ sudo /etc/init.d/sl-modem-daemon status

Se disser que está "running" tudo beleza!

No gnome-ppp mandar detectar o modem, o device é /dev/ttySL0.

Testar a conexão!

Ele detecta o modem da motorola como slamr: probe 1057:3052 SL1900 card... um cara da lista linmodemns falou que ele conecta a 33600, tem que testar pra ver...

Trocar o grupo do device /dev/ttySL0 para dialout.

$ sudo chgrp dialout /dev/ttySL0
$ sudo chgrp dialout /dev/modem

Fiquem a vontade para divulgar e melhorar esse tutorial. Informações obtidas no site:
http://linmodems.technion.ac.il/

Depois vamos ao discador.

Você precisará:
O número de telefone de seu provedor;
Seu nome de usuário e senha em seu provedor;
O nome do dispositivo de modem (/dev/...).

Eu tenho um modem serial externo (se você tiver informações sobre como lidar com outros tipos de modems, por favor comente).

Se seu modem conecta à porta serial, ou é um modem interno (não-Win) e você sabe a porta COM, o nome do dispositivo é /dev/ttySx, onde x é o número da porta COM menos 1. Por exemplo, se seu modem está na COM2, o dispositivo é /dev/ttyS1, ou se seu modem está na COM1, o dispositivo é /dev/ttyS0.

Configurando PPP:

Abra um terminal (Aplicações > Ferramentas do Sistema > Terminal). Digite:

$ sudo pppconfig

Você estará no menu principal. Escolha 'Criar uma conexão'.

Deixe o nome como 'provedor', aperte 'Ok'.

Selecione 'Dinâmico Usar DNS dinâmico', aperte 'Ok'.

Selecionar 'PAP Peer Authentication Protocol', aperte 'Ok'.

Insira seu nome de usuário para o provedor, aperte 'Ok'.

Insira sua senha para o provedor, aperte 'Ok'.

Deixe a velocidade de 115200 como recomendado, aperte 'Ok'.

Escolha discagem de Tom ou Pulso, aperte 'Ok'.

Insira o número do telefone de seu provedor (use apenas números), aperte 'Ok'.

Você pode tentar ter seu modem detectado automaticamente, mas não funcionou para mim, mesmo em meu facilmente detectável modem externo.

Se o modem não for detectado, ele perguntará em qual porta seu modem está. Insira o nome do dispositivo para seu modem, aperte 'Ok'.

Uma tela de finalização aparecerá e lhe dará a oportunidade de fazer mudanças se necessário. Estamos quase acabando esta parte. Os próximos passos permitirão que sua conta de usuário conecte e desconecte sem precisar de sudo (de forma que você não precisará inserir a senha para conectar). Escolha 'Opções Avançadas'.

Escolha 'Adicionar-Usuário Adicionar um usuário ppp'.

Remova quaisquer caracteres indesejados da caixa de entrada pressionando Backspace (se necessário), então digite seu nome de usuário no Ubuntu, aperte 'Ok'.

Escolha 'Anterior Retorne para o menu anterior' na tela de Configurações Avançadas.

Escolha 'Finished Write files and return to main menu.'.

Escolha 'Sair deste utilitário'.

Saia da janela do terminal, digite:

$ exit

Reinicie seu computador (para as alterações de grupo terem efeito). Alternativamente, você pode testar sua conexão agora mesmo:

$ sudo pon

Para desconectar, digite:

$ sudo poff

Após a reinicialização, bastará digitar 'pon' ou 'poff'.

É isso aí pessoal eu espero que seja publicado o mais rápido possível.

Instalei no Ubuntu 7.04 com o kernel 2.6.20-15-generic e deu tudo certo, espero que com vocês de também, boa noite.






 WvDial: Internet dialer version 1.56
WvModem<*1>: Cannot get information for serial port.
WvDial<*1>: Initializing modem.
WvDial<*1>: Sending: ATZ
WvDial Modem<*1>: ATZ
WvDial Modem<*1>: OK
WvDial<*1>: Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
WvDial Modem<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
WvDial Modem<*1>: OK
WvDial<*1>: Modem initialized.
WvDial<*1>: Sending: ATM1L1DT17003131
WvDial<*1>: Waiting for carrier.
WvDial Modem<*1>: ATM1L1DT17003131
WvDial Modem<*1>: CONNECT 46667
WvDial<*1>: Carrier detected.  Starting PPP immediately.
WvDial<Notice>: Starting pppd at Sun Oct 21 23:58:45 2007
WvDial<Err>: Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
WvDial<Err>: --> PAP (Password Authentication Protocol) may be flaky.
WvDial<Err>: Warning: Could not modify /etc/ppp/chap-secrets: Permission denied
WvDial<Err>: --> CHAP (Challenge Handshake) may be flaky.
WvDial<Notice>: Pid of pppd: 5862
WvDial<*1>: Using interface ppp0
WvDial<*1>: local  IP address 201.5.218.32
WvDial<*1>: remote IP address 200.216.95.41
WvDial<*1>: primary   DNS address 200.222.0.34
WvDial<*1>: secondary DNS address 200.202.193.75



Após desfazer o que fiz seguindo a dica do Viva O Linux, continuou da mesma forma.

Por enquanto eu só consigo obter isso com o número de discador da Oi, mas o da Yahoo que sempre uso no windows só da o erro No Carrier...

alarcon

  • Visitante
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #65 Online: 23 de Outubro de 2007, 10:50 »
Olha só usando o meu pacote, na teoria, não é necessário fazer mais nada por que ele pretende usar tudo que for possível para fazer seu modem funcionar.

Aconselho primeiro você usar o pacote que fiz e se não funcionar, voltar aqui para fazermos os ajustes possíveis até que não se encontre nenhuma alternativa e só então você tentaria algo diferente. Misturando as coisas você pode é estar atrapalhando mais as coisas do que ajudando a resolver.

No pacote que fiz tem um arquivo de texto chamado guia_instalação.pdf que não só explica como usar o pacote que fiz com tem no seu final umaseção falando sobre os problemas mais comuns com este driver e a instalação do pacote, ou seja, são algumas dicas sobre após a instalação e não funcionar. Por exemplo, modems HSP56 MR SiS, não sei por qual motivo, antes de usar o gnome-pp tem de abrir um terminal e digitar sudo /etc/init.d/sl-modem-daemon start. Outro exemplo, alguns modems tem de ter a opção verificar portadoran as configurações do gnome-ppp na aba opções, desmarcada e etc.

Tudo isso você saberia pelo guia_instalação.

Por isso aqui:

WvDial: Internet dialer version 1.56
WvModem<*1>: Cannot get information for serial port.
WvDial<*1>: Initializing modem.
WvDial<*1>: Sending: ATZ
WvDial Modem<*1>: ATZ
WvDial Modem<*1>: OK
WvDial<*1>: Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
WvDial Modem<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
WvDial Modem<*1>: OK
WvDial<*1>: Modem initialized.
WvDial<*1>: Sending: ATM1L1DT17003131
WvDial<*1>: Waiting for carrier.
WvDial Modem<*1>: ATM1L1DT17003131
WvDial Modem<*1>: CONNECT 46667
WvDial<*1>: Carrier detected.  Starting PPP immediately.
WvDial<Notice>: Starting pppd at Sun Oct 21 23:58:45 2007
WvDial<Err>: Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
WvDial<Err>: --> PAP (Password Authentication Protocol) may be flaky.
WvDial<Err>: Warning: Could not modify /etc/ppp/chap-secrets: Permission denied
WvDial<Err>: --> CHAP (Challenge Handshake) may be flaky.
WvDial<Notice>: Pid of pppd: 5862
WvDial<*1>: Using interface ppp0
WvDial<*1>: local  IP address 201.5.218.32
WvDial<*1>: remote IP address 200.216.95.41
WvDial<*1>: primary   DNS address 200.222.0.34
WvDial<*1>: secondary DNS address 200.202.193.75

está parecendo que nos arquivos pap-secrets e chap-secrets que se encontram ambos em /etc/ppp/ no final de cad um deles não existe esta informação que é vital:
"uuario@provedor.com.br" * "senha1234". Logicamente que os valores são sue nome de acesso completo do provedor e sua senha de acesso.

O meu pacote já se encarregaria de colocar estas informações aí.

Offline Shakmatton

  • Usuário Ubuntu
  • *
  • Mensagens: 213
    • Ver perfil
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #66 Online: 23 de Outubro de 2007, 11:02 »
so lembrando que o modeem é motorola sm56.

vejo isso dos arquivos quan chegarem casa.

obrigado

Offline Shakmatton

  • Usuário Ubuntu
  • *
  • Mensagens: 213
    • Ver perfil
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #67 Online: 23 de Outubro de 2007, 17:02 »
Ei Alarcon...

Eu estive vendo melhor aquele meu "problema" e observei que ainda não tinha testado nada com um navegador de internet.
Achei que teria que ouvir um barulhinho de modem conectando, ou uma mensagem gigantesca que acabasse em uma linha com algo do tipo Connection estabilished e a respectiva velocidade... então hoje fui de bobeira verificar isso...

Fiquei surpreso ao perceber que por algum motivo Deus sabe qual, a internet FUNCIONOU ! Mas é estranho, porque se funcionou pro meu discador Oi, deveria funcionar pro discador Yahoo também... e eu quero ver se consigo navegar com o InteligWeb (que é meu objetivo), mas só de conseguir postar esta mensagem pelo Ubuntu já valeu a pena...Só não sei se é assim mesmo, aqui uma hora a taxa de recebimento de dados cai à alguns bytes, depois sobe à uns 8KB/s, depois vai pra 2, depois 4, oscila muito, testei alguns sites e o único que demorou um pouco de abrir foi o do Yahoo (que no windows também demorava), fopra isso os googles da vida funcionam bem...

Meu problema parece ter se resolvido (espero que não dê nenhum erro bizarro como outros já relataram aqui neste fórum)...
Só estou perdidaço pra baixar as atualizações (não sei exatamente aonde configurar o tal do cubo 3d compiz, nem como baixar os plug-ins pra ouvir meus mp3, mas imagino que fuçando mais por aqui eu ache a resposta).

Muito obrigado mesmo.

alarcon

  • Visitante
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #68 Online: 23 de Outubro de 2007, 17:33 »
Ei Alarcon...

Eu estive vendo melhor aquele meu "problema" e observei que ainda não tinha testado nada com um navegador de internet.
Achei que teria que ouvir um barulhinho de modem conectando, ou uma mensagem gigantesca que acabasse em uma linha com algo do tipo Connection estabilished e a respectiva velocidade... então hoje fui de bobeira verificar isso...

Fiquei surpreso ao perceber que por algum motivo Deus sabe qual, a internet FUNCIONOU ! Mas é estranho, porque se funcionou pro meu discador Oi, deveria funcionar pro discador Yahoo também... e eu quero ver se consigo navegar com o InteligWeb (que é meu objetivo), mas só de conseguir postar esta mensagem pelo Ubuntu já valeu a pena...Só não sei se é assim mesmo, aqui uma hora a taxa de recebimento de dados cai à alguns bytes, depois sobe à uns 8KB/s, depois vai pra 2, depois 4, oscila muito, testei alguns sites e o único que demorou um pouco de abrir foi o do Yahoo (que no windows também demorava), fopra isso os googles da vida funcionam bem...

Meu problema parece ter se resolvido (espero que não dê nenhum erro bizarro como outros já relataram aqui neste fórum)...
Só estou perdidaço pra baixar as atualizações (não sei exatamente aonde configurar o tal do cubo 3d compiz, nem como baixar os plug-ins pra ouvir meus mp3, mas imagino que fuçando mais por aqui eu ache a resposta).

Muito obrigado mesmo.

Alguns modems que utilizam o driver Smartlink fazem os sons de discagem outros não.

Com relação ao yahoo pode ser uma das coisas:

Primeira dela é que talvez os DNS primaŕio e secundário não seja obtidos de forma automática e sim manualmente, ou seja, você teria de fornecê-los aos discador gnome-ppp.

Segunda possibilidade é que nos arquivos chap-secrets e pap-secrets que se encontram em /etc/ppp/ devem ter sempre as informações de suas contas dos provedores que você usa no final destes arquivos assim:

"usuario1@provedor1.com.br" * "senha1234"
"usuario2@provedor2.com.br" * "1234senha"

O meu pacote só faz a configuração do gnome-ppp e destes arquivos falados para uma conta e levendo em consideração que os DNS são obtidos de forma automática que é o padrão e mais comumente usados pelos provedores.

para editar os arquivos abra um terminal ( Menu Aplicações > Acessórios > Terminal) e digite:

sudo gedit /etc/ppp/pap-secrets

e coloque a informação sobre o yahoo nome completo de acesso e senha de acesso nesta formatação já explicada logo acima.

repita novamente para o outro arquivo:

sudo gedit /etc/ppp/chap-secrets

e coloque no final desta a mesma informação que o anterior.


Depois no gnome-ppp é só mudar o nome de acesso completo e a senha de acesso e o Nº do telefone do novo provedor.
« Última modificação: 23 de Outubro de 2007, 17:40 por alarcon »

Offline daniel.netti

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #69 Online: 02 de Novembro de 2007, 18:46 »
Eaeee alarcon ....puxa caraq ainda mexendo com isso!!!! Legal sua ajuda é sempre muito boa...

Cara aqui em casa sempre apareceu essa mensagem mas sempre conectou......a unica coisa que me deixa meio cabreiro é que as vezes (quase sempre) a conexão cai e o modem trava...dae vem aquela maldita mensagem de o modem está ocupado ou algo do genero quando vou reconectar, e o pior é que demora pra exibir que a conexão caiu, veja a mensagem de conexão:

-> Ignoring malformed input line: ";Do NOT edit this file by hand!"
--> WvDial: Internet dialer version 1.56
--> Cannot open /dev/ttySL0: Device or resource busy
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATM1L1DT30097900
--> Waiting for carrier.
ATM1L1DT30097900
CONNECT 50667
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Fri Nov  2 18:29:46 2007
--> Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
--> --> PAP (Password Authentication Protocol) may be flaky.
--> Warning: Could not modify /etc/ppp/chap-secrets: Permission denied
--> --> CHAP (Challenge Handshake) may be flaky.
--> Pid of pppd: 9000
--> Using interface ppp0
--> local  IP address 200.234.107.42
--> remote IP address 200.205.111.199
--> primary   DNS address 200.225.159.124
--> secondary DNS address 200.225.159.126



e agora meus arquivos pap e chap com a senha trocada para 1234 é claro =)   (postei só o final do arquivo PAP) :

# OUTBOUND connections

# Here you should add your userid password to connect to your providers via
# PAP. The * means that the password is to be used for ANY host you connect
# to. Thus you do not have to worry about the foreign machine name. Just
# replace password with your password.
# If you have different providers with different passwords then you better
# remove the following line.

#       *       password


"danieldeamparo@ig.com.br" * "1234"
danieldeamparo\@ig\.com\.br     *       1234
daniel\.netti\@inteligweb\.com\.br      *       1234
daniel\.netti\@ig\.com\.br      *       1234
UU\/ppp139378   *       aQ\&J\+Yev
"daniel.netti@orolix.com.br" * "1234"
daniel\.netti\@orolix\.com\.br  *       1234
"danieldeamparo@ig.com.br" * "1234"



(CHAP) :


# Secrets for authentication using CHAP
# client        server  secret                  IP addresses


"danieldeamparo@ig.com.br" * "1234"
danieldeamparo\@ig\.com\.br     *       1234
daniel\.netti\@inteligweb\.com\.br      *       1234
daniel\.netti\@ig\.com\.br      *       1234
UU\/ppp139378   *       aQ\&J\+Yev
"daniel.netti@orolix.com.br" * "1234"
daniel\.netti\@orolix\.com\.br  *       1234
"danieldeamparo@ig.com.br" * "1234"




Me dá uma forçinha ae cara......=)
Be free.... 
...be Linux!!!

alarcon

  • Visitante
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #70 Online: 02 de Novembro de 2007, 19:23 »
Não entendi estes seus arquivos pap-secrets e chap-secrets nas partes que destaquei em vermelho logo abaixo:

(PAP) :

Citar
"danieldeamparo@ig.com.br" * "1234"
danieldeamparo\@ig\.com\.br     *       1234
daniel\.netti\@inteligweb\.com\.br      *       1234
daniel\.netti\@ig\.com\.br      *       1234
UU\/ppp139378   *       aQ\&J\+Yev

"daniel.netti@orolix.com.br" * "1234"
daniel\.netti\@orolix\.com\.br  *       1234
"danieldeamparo@ig.com.br" * "1234"


(CHAP) :

Citar
"danieldeamparo@ig.com.br" * "1234"
danieldeamparo\@ig\.com\.br     *       1234
daniel\.netti\@inteligweb\.com\.br      *       1234
daniel\.netti\@ig\.com\.br      *       1234
UU\/ppp139378   *       aQ\&J\+Yev

"daniel.netti@orolix.com.br" * "1234"
daniel\.netti\@orolix\.com\.br  *       1234
"danieldeamparo@ig.com.br" * "1234"


Pode ser que estas informações estejam atrapalhando algo, pois a formatação é como já disse, ou seja, para cada provedor que você usar deve ter uma entrada exatamente assim nestes arquivos:

"nome_de_acesso@provedor.com.br" * "senha_de_acesso_1234"

Retire as informações repetidas também.

Vejo que sua conexão é ótima (CONNECT 50667), quando funciona, para os padrões de conexão discada.
« Última modificação: 02 de Novembro de 2007, 19:43 por alarcon »

Offline daniel.netti

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #71 Online: 02 de Novembro de 2007, 19:34 »
vou retirar o que você colocou em vermelho e voltarei a conectar....volto a postar assim que estiver pronto pra  falar se muda o log de conexão ok.
Quanto a conexão é realmente show de bola....faço downloads com velocidade bem acima donormal....meu modem é o netodragon (só pra esclarecer) valeu pela resposta rapida.
Be free.... 
...be Linux!!!

alarcon

  • Visitante
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #72 Online: 02 de Novembro de 2007, 19:41 »
vou retirar o que você colocou em vermelho e voltarei a conectar....volto a postar assim que estiver pronto pra  falar se muda o log de conexão ok.
Quanto a conexão é realmente show de bola....faço downloads com velocidade bem acima donormal....meu modem é o netodragon (só pra esclarecer) valeu pela resposta rapida.


Outra coisa você pode abrir um terminal e digitar:

gedit .wvdial.conf

e alterar a linha:

Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0

para:

Init2 = ATQ0 V1 E1 S0=0 X3 &C1 &D2 +FCLASS=0

ou

Init2 = ATQ0 V1 E1 S0=0 X3 &C1 &D2 +MS=34

ou

Init2 = ATQ0 V1 E1 S0=0 X3 &C1 &D2  +MS=90

para ver qual é o melhor para você. Também pode desmarcar a opção verificar portadora, se estiver marcada, nas configurações do gnome-ppp.

Offline daniel.netti

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #73 Online: 02 de Novembro de 2007, 19:53 »
Retirei as linhas em que vc colocou em vermelho, deixei apenas os nomes de provedores e senha que estavam entre aspas.....do mesmo jeito não funcionou....como a mesnsagem era de "Permission denied" entrei no terminal e alterei a permissão com:

sudo chmod 777 /etc/ppp/pap-secrets
sudo chmod 777 /etc/ppp/chap-secrets

funcionou e alem disso almentou minha velocidade de conexão para 52000 =) veja :

--> Ignoring malformed input line: ";Do NOT edit this file by hand!"
--> WvDial: Internet dialer version 1.56
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATM1L1DT30097900
--> Waiting for carrier.
ATM1L1DT30097900
CONNECT 52000
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Fri Nov  2 19:46:57 2007
--> Pid of pppd: 11286
--> Using interface ppp0
--> local  IP address 200.234.34.199
--> remote IP address 200.205.111.104
--> primary   DNS address 200.225.159.124
--> secondary DNS address 200.225.159.126


O problema é que qualquer pessoa que acessar minha maquina poderá ver a minha senha da internet...não sei se existe outra solução pra isso...mas por enquanto vou deixar assim.....
Be free.... 
...be Linux!!!

alarcon

  • Visitante
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #74 Online: 02 de Novembro de 2007, 20:00 »
olha só pelo que entendo ele tenta colocar nos arquivos chap-secrets e pap-secrets as informações que já coloquei e como não tem permissão ele falha, mas isso não é preciso mais fazer por que já fiz manualmente. Acho que não é legal alterar as permissões destes arquivos.

Eu coloquei estas informações nestes arquivos por que percebi que sem elas a conexão não efetivava e o prórpio discador não era capaz de fazer isso, então para evitar alterar as permissões eu faço isso manualmente pelo meu script.

A conexão ficou maior talvez só pelo acaso, pois às vezes quando desligamos e conectamos logo em seguida a conexão pode ser maior como também pode ser menor.