Autor Tópico: [Tutorial] Modem HSP56MR - Smartlink no 7.04  (Lida 54979 vezes)

Offline canha

  • Usuário Ubuntu
  • *
  • Mensagens: 54
    • Ver perfil
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #30 Online: 17 de Maio de 2007, 21:02 »
 Daniel Obrigado pela ajuda por enquanto e aqui segui o log:

root@canha-desktop:/home/canha/Modem4# cd /usr/bin
root@canha-desktop:/usr/bin# sudo gnome-ppp
WVCONF: /root/.wvdial.conf
GNOME PPP: Conectando...
GNOME PPP: STDERR: --> Ignoring malformed input line: ";Do NOT edit this file by hand!"
GNOME PPP: STDERR: --> WvDial: Internet dialer version 1.56
GNOME PPP: STDERR: --> Cannot get information for serial port.
GNOME PPP: STDERR: --> Initializing modem.
GNOME PPP: STDERR: --> Sending: ATZ
GNOME PPP: STDERR: ATZ
GNOME PPP: STDERR: OK
GNOME PPP: STDERR: --> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
GNOME PPP: STDERR: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
GNOME PPP: STDERR: OK
GNOME PPP: STDERR: --> Modem initialized.
GNOME PPP: STDERR: --> Please enter password (or empty password to stop):

   Ai cliquei novamente em conectar e olha o que deu

GNOME PPP: STDERR: Caught signal 2:  Attempting to exit gracefully...
GNOME PPP: Conectando...
GNOME PPP: STDERR: --> Ignoring malformed input line: ";Do NOT edit this file by hand!"
GNOME PPP: STDERR: --> WvDial: Internet dialer version 1.56
GNOME PPP: STDERR: --> Cannot open /dev/modem: Device or resource busy
GNOME PPP: STDERR: --> Cannot open /dev/modem: Device or resource busy
GNOME PPP: STDERR: --> Cannot open /dev/modem: Device or resource busy

 Agora eu estou achando que estamos tentando instalar o drive errado porque no BIGLinux3 na hora em que vai desligar o Micro mostra assim Smartlink 2.9.9e Pre1 , ai procurei no Google tem ,mas é em tar.gz o que vai pedir um monte de compiladores se estiver em DEB como o seus pacotes acho que vai funcionar , e mais o meu modem compartilha com o som no caso seria como no post meu acima é AC 97, agora o Ubuntu ficou 10 no meu micro , rapido e reconhendo to o Hardware pena que o modem não está dando certo.
 Mas sem internet fica complicado .
 Valeu.
BIGLINUX 4
SIDUX 2008.03 OUREA
UBUNTU ULTIMATE EDITION 1.8

Offline daniel.netti

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #31 Online: 18 de Maio de 2007, 10:17 »
Ao invés de clicar em conectar de novo, vai no terminal e digita ctrl+c(control c) e depois
sudo /etc/init.d/sl-modem-daemon restart
coloca o resultado aqui pra gente dar uma olhada.
Tenha paciencia que vamos resolver isso. :)
Be free.... 
...be Linux!!!

Offline canha

  • Usuário Ubuntu
  • *
  • Mensagens: 54
    • Ver perfil
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #32 Online: 20 de Maio de 2007, 14:59 »
 Daniel boas noticias , fiz o seguinte instalei um outro modem ,PCI MODEM BRAVIEW  este modem ele tem o Chipset Smartlink 2800 ,apenas inspetei ,não desabilitei o que já tenho ou seja tenho agora dois modem segui o tutorial com todos os comandos , só que conecta ,faz o barulho de conexão e nem dava tempo de abrir o Firefox que desconetava , ai fiquei racicionando o que poderia ser , ai que tive a seguinte ideia de uma olhada no log acima meu ele para paresse que pedindo alguma senha , pois bem ai como eu já tinha fuçado em alguns lugares fui no item rede e lá se encontra a placa de rede e o modem na parte de configurações lá não tinha a senha apenas o email , veja bem não estou falando das configurações do Gnome-PPP e sim no item rede como o Gnome é novo para mim e eu conheço melhor o KDE .
 Resultado estou conseguindo me conectar com o Ubuntu porem não acabou ai vai mais algumas duvidas:
 1º Como configurar mais um provedor , eu estou usando o Uol e quero configurar o IG ?
 2º Agora o problema maior é o seguinte a conexão está lenta já alterei a velocidade do modem mas não adiantou ?
 3º Tendo em vista a falta de colocar a Senha na parte de rede fiquei pensando será que se eu tirar o modem Braview que eu coloquei e deixar o anterior será que vai conectar  vou fazer esta experiencia  ?
 
 Valeu.
 
BIGLINUX 4
SIDUX 2008.03 OUREA
UBUNTU ULTIMATE EDITION 1.8

Offline canha

  • Usuário Ubuntu
  • *
  • Mensagens: 54
    • Ver perfil
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #33 Online: 22 de Maio de 2007, 22:16 »
 Alguem mais poderia me esclarecer nas minhas duvidas acima.
 Valeu.
BIGLINUX 4
SIDUX 2008.03 OUREA
UBUNTU ULTIMATE EDITION 1.8

Offline daniel.netti

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #34 Online: 25 de Maio de 2007, 09:04 »
caro canha,
Desculpe a demora pra responder, andei meio atolado de trabalho esses dias, tanto no trabalho quanto na faculdade, ta fo** , mas vamos ao que interessa:

Quanto a seu log, é exatamente isso cara, faltava a senha e vc pensava que tinha caido, tente fazer de novo via linha de comando pra pegar o log da conexão, quem sabe melhoramos a velocidade.

1- Nas configurações do gnome-ppp tem um espaço que dá pra colocar mais telefones, é só inserir o do ig, na tela principal digite seu email e senha e depois é só conectar.

2- Quanto a velocidade tem que ver se o modem é apropriado pra uma velocidade maior.

3- Não entendi muito bem, vc espetou o modem novo, mas continuou usando o antigo???Onde esta colocado o cabo do telefone? No novo ou no antigo? experimente retirar 1 e deixar só o outro pra ver o que acontece....faça testes....se conectou 1 vez sinal que conectara de novo, nem que tenha que reconfigurar.

Abraço.
« Última modificação: 25 de Maio de 2007, 09:09 por daniel.netti »
Be free.... 
...be Linux!!!

Offline canha

  • Usuário Ubuntu
  • *
  • Mensagens: 54
    • Ver perfil
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #35 Online: 25 de Maio de 2007, 20:01 »
  É o seguinte ,seguindo o seu tutorial não estava tendo exito, com o modem onboard que se conecta a 52.000 no Biglinux , ai fiz o seguinte eu tinha um modem PCI da Braview que usa o Chipset 2800 da Smartlink espetei e iniciei o Ubuntu naquela barrinha logo no inicio travou , dei reset e foi numa boa em seguida , não desinstalei os pacotes porque um dependia do outro e assim por diante , pois bem reinstalei os pacotes seguindo a risca o tuto e está funcionado o modem novo da Braview.
  Só que a velocidade neste modem é de apenas 45.666  , ou seja  a momentos em que dá 2.2 , 3.6 , as vezes 5.0Kbs.

  Então fiquei assim: O Biglinux reconheceu o modem novo porem ele usa o modem Onboard , o Ubuntu não funciona com o modem Onboard ,mas funciona com o novo que alias ate o som do modem faz, agora o mais curioso ficou por conta do Kurumin que antes funcionava com o Onboard e agora só funciona com o novo  então quando eu estiver no Ubuntu e no Kurumin eu tenho que mudar a conexão atrás do micro e vice-versa.
 Quanto ao log vou verificar e te mando para ver se dá para melhorar a velocidade.
 Agora eu não entendo muito bem , mas acho que estes pacotes que voce preparou não são para modem Onboard.
 Lembrando que no meu micro o modem Onboard é aquele que usa o sript do Big e do Kurumin Pctel AMR onboard........ não sei se voce conhece este script de uma olhada por curiosidade ?!!
 Outra duvida é em relação ao Link criado no Big é   /dev/modem e no Ubuntu é /dev/ttySL0
 
 Valeu e volto postar mais duvidas e com o log para melhorar a conexão.
 Obrigado
 
BIGLINUX 4
SIDUX 2008.03 OUREA
UBUNTU ULTIMATE EDITION 1.8

Offline Kamei Hyoga

  • Usuário Ubuntu
  • *
  • Mensagens: 1.095
  • Ubuntu 11.04
    • Ver perfil
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #36 Online: 25 de Maio de 2007, 20:27 »
To com saudades do meu Lucent... com ele eu baixava a 5 kb/s. Com esse num passa de 3 kb/s...

Offline gaucho.online

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #37 Online: 27 de Maio de 2007, 12:54 »
Citar
Sem Graça Consegui, demorou (ser iniciante é uma *****),mas consegui:
Ainda não é a melhor solução mas já ajuda bastante, leia até o fim antes de fazer qualquer alteração no seu sistema.
lembrando que isso resolve apenas o problema da restart do modulo, pra executar, precisa estar com os pacotes do topico instalados.

baixe e salve em seu /tmp o arquivo gnome-ppp que está aqui:http://gnome-ppp.4shared.com/, (é um pequeno script, portanto é pequeno mesmo)

Agora vamos começar as alterações:

Abra o terminal e execute:

Código:

su

senha pra virar root
Código:

cd /usr/bin/


Código:

mv gnome-ppp gnome-ppp.bin


Código:

cp /tmp/gnome-ppp /usr/bin/


Agora vamos inserir duas novas linhas no arquivo sudoers
Código:

sudo gedit /etc/sudoers

Onde estava:

# /etc/sudoers
#
# This file MUST be edited with the 'visudo' command as root.
#
# See the man page for details on how to write a sudoers file.
# Host alias specification

# User alias specification

# Cmnd alias specification

# Defaults

Defaults        !lecture,tty_tickets,!fqdn

# User privilege specification

root   ALL=(ALL) ALL


Agora vai ficar assim:

# /etc/sudoers
#
# This file MUST be edited with the 'visudo' command as root.
#
# See the man page for details on how to write a sudoers file.
# Host alias specification

# User alias specification

# Cmnd alias specification
Cmnd_Alias INTERNET=/usr/bin/gnome-ppp
# Defaults

Defaults        !lecture,tty_tickets,!fqdn

# User privilege specification
root    ALL=(ALL) NOPASSWD:INTERNET, PASSWD: ALL
#root   ALL=(ALL) ALL


Vejam que a ultima linha foi comentada, não se esqueçam disso,onde está em negrito são as linhas a serem incluidas.

Salve e feche o arquivo.
Agora entre normalmente no gnome-ppp (Arquivo>>internet>>gnome-ppp) e veja se funciona.
Se não funcionar, tente sair e entrar novamente na seção.
Espero ter ajudado, agora quando quiser reconectar, bastará fechar e abiri o gnome-ppp, como eu disse resolve apenas em partes.




O link ta quebrado, tens musicas lá no seu scripit.


Essas informações você deixa em todos os sites que visita.

Offline AlexCamargo

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #38 Online: 27 de Maio de 2007, 20:05 »
Daniel.netti, segui o seu tutorial e deu certo de primeira!
Muito obrigado pela ajuda que vocês dão para nós novatos!
Um abraço!

Offline daniel.netti

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #39 Online: 28 de Maio de 2007, 00:19 »

 Agora eu não entendo muito bem , mas acho que estes pacotes que voce preparou não são para modem Onboard.
 
 Outra duvida é em relação ao Link criado no Big é   /dev/modem e no Ubuntu é /dev/ttySL0
 
 Valeu e volto postar mais duvidas e com o log para melhorar a conexão.
 Obrigado
 

Exatamente isso canha, o tuto é para o pessoal com modem que tenham chipset da smartlink, na verdade acho que vc foiaté longe demais com o seu onboard....rsrsrsrsrsr

Olink na verdade é o mesmo, só que no big /dev/modem é um link para /dev/ttySL0, experimente ir manualmente no big linux, acho que é kppp não? e troque /dev/modem por /dev/ttySL0, com certeza vai continuar funcionando.....quanto a velocidade cara....aqui em casa não é muito diferente não....fica nessa faixa de 3 a 5 Kbps, mas não podemos esperar muito da telefonica, aliás, falando em conexão, em setembro teremos conexão pela tomada de energia das nossas casas, vcs ja estão sabendo disso? ;D
Abraço a todos e aproveitem o tuto. ;D
Be free.... 
...be Linux!!!

Offline daniel.netti

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #40 Online: 28 de Maio de 2007, 00:32 »

O link ta quebrado, tens musicas lá no seu scripit.

Ja arrumei o link, me desculpem....
Be free.... 
...be Linux!!!

alarcon

  • Visitante
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #41 Online: 02 de Junho de 2007, 18:53 »
Para quem tentou todas as dicas deste tópico aqui e ainda não obteve sucesso vejam este link aqui e veja se para o seu caso funciona:

http://ubuntuforum-pt.org/index.php/topic,4204.msg113490.html#msg113490


Lembrando que o melhor seria reinstalar o Ubuntu Linux 7.04 Feisty Fawn antes de testar o pacote deste link para que as tentativas anteriores não atrapalhem, isto, é claro, para quem puder reinstalar o sistema.

Offline vampire_thunder

  • Usuário Ubuntu
  • *
  • Mensagens: 735
    • Ver perfil
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04 (editado em 16/05/2007)
« Resposta #42 Online: 20 de Junho de 2007, 23:53 »
Bom amigos, fiz um apanhado de vários posts e criei um tuto (pelo menos aqui funcionou assim).
A várias distros atrás que venho lutando com meu modem (inclusive instalando scripts) pra conseguir conectar, essa é a melhor distro em que já instalei o netodragon (e olhe que já instalei ele em várias distros)
Ficou um pouco longo, mas é porque eu quis deixar bem fácil de entender até para os leigos no assunto
Taylon me desculpe cara, mas peguei uma boa parte do seu tuto nesta mesma pagina. :-[

Bom, vamos lá:

Baixe o pacote Pacote_install_modem.tar.gz no link: http://sl-modem.4shared.com/ (que postei pra o sossego de todos, pois sei que é uma desgraça usar o janelas pra ficar baixando as dependências  ;D).

(...)

Por favor, poderia fazer um novo upload desse pacote? Não tem mais nada no link e eu o perdi. Só consegui instalar o modem no Ubuntu através desta dica.

gabriel.goc

  • Visitante
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #43 Online: 21 de Junho de 2007, 16:02 »
vampire_thunder, tente instalar o modem de acordo com este tópico:

http://ubuntuforum-br.org/index.php/topic,20826.0.html

Acabei de atualizá-lo, agora está descrito como instalá-lo de acordo com a versão do kernel.

Dê uma olhada no tópico só.

Flws

Offline vampire_thunder

  • Usuário Ubuntu
  • *
  • Mensagens: 735
    • Ver perfil
Re: [Tutorial] Modem HSP56MR - Smartlink no 7.04
« Resposta #44 Online: 22 de Junho de 2007, 17:30 »
vampire_thunder, tente instalar o modem de acordo com este tópico:

http://ubuntuforum-br.org/index.php/topic,20826.0.html

Acabei de atualizá-lo, agora está descrito como instalá-lo de acordo com a versão do kernel.

Dê uma olhada no tópico só.

Flws

Obrigado, amigo. Eu baixei e tudo, mas perdi meu modem Braview Smartlink. Estou com um Lucent Agere Winmodem agora, e um USRobotics. Sei que o USR não roda no Linux, mas acho que o Lucent tem jeito. Você saberia me indicar qual?