Autor Tópico: Problema com o comando init 3 (resolvido)  (Lida 5962 vezes)

Offline Biasi

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Problema com o comando init 3 (resolvido)
« Online: 06 de MAR?O de 2007, 11:54 »
Olá!!

Estou com problema para executar o comando init 3 para sair do modo gráfico e entrar em modo de texto, X.
Já tentei de tudo qualquer jeito como root, sem ser root. Já verifiquei em vários posts, foruns, lugares e nada pôde me ajudar.

Acontece sempre o seguinte ao digitar o comando init 3:
bash: init: command not found

Achei em um dos foruns que dando o camando ctrl+alt+F2 seria o mesmo que init 3. Esse comando sai do modo gráfico entrando em modo texto, mas não desabilita o modo gráfico.

Em qualquer fórum de qualquer comunidade, distribuição, diz para usar o tal comando, init 3, para sair do modo gráfico para executar a instalação do driver da placa de vídeo, que no meu caso é da Nvidia, Geforce4 MX440.

Apenas gostaria que alguém pudesse me ajudar de como eu posso fazer para habilitar o comando init 3 ou se tem outra forma de desativar o modo gráfico.

grato!
« Última modificação: 06 de MAR?O de 2007, 22:59 por Biasi »

arlei

  • Visitante
Re: Problema com o comando init 3
« Resposta #1 Online: 06 de MAR?O de 2007, 12:15 »
Olha amigo,

acredito que vc possa executar os procedimentos necessários para configuração da sua placa gráfica pelo terminal mesmo e depois de terminado simplesmente reiniciar o servidor gráfico (X) teclando Ctrl+Alt+Backspace.
Mais de qualquer forma se isso for realmente necessário, para executar o init 3 vc deve estar em um console, então no seu ambiente gráfico tecla Ctrl+Alt+F1, logue-se e no console digite sudo init 3. Entre então com a senha do seu usuário para ter poderes administrativos de root e execute os procedimentos necessários. Depois execute sudo init 2 para retornar ao modo gráfico.

T+
Arlei


Offline eduferr

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: Problema com o comando init 3
« Resposta #2 Online: 06 de MAR?O de 2007, 14:08 »
Pressione "Ctrl+Alt+Backspace" e então digite "ps -ax" como root, localize o processo responsavel pelo servidor de video e mate o processo "killall gdm" logo após digite "rmmod nvidia" (para remover o driver).

Para voltar ao modo gráfico (init 5) digite "modprobe" nvidia e logo após "gdm"

Níveis de Execução.
 
init 0 --> desligar o sistema
 
init 1 --> modo monousuário, também chamado de modo single
 
init 2 --> modo multiusuário, texto
 
init 3 --> modo multiusuário, texto, com serviços
 
init 4 --> não utilizado
 
init 5 --> modo gráfico (X11)
 
init 6 --> reinicializar o sistema


 


arlei

  • Visitante
Re: Problema com o comando init 3
« Resposta #3 Online: 06 de MAR?O de 2007, 14:20 »
Pressione "Ctrl+Alt+Backspace" e então digite "ps -ax" como root, localize o processo responsavel pelo servidor de video e mate o processo "killall gdm" logo após digite "rmmod nvidia" (para remover o driver).

Para voltar ao modo gráfico (init 5) digite "modprobe" nvidia e logo após "gdm"

Níveis de Execução.
 
init 0 --> desligar o sistema
 
init 1 --> modo monousuário, também chamado de modo single
 
init 2 --> modo multiusuário, texto
 
init 3 --> modo multiusuário, texto, com serviços
 
init 4 --> não utilizado
 
init 5 --> modo gráfico (X11)
 
init 6 --> reinicializar o sistema


eduferr,

vc esta enganado amigo, no Ubuntu o modo gráfico é carregado no nivel de execução 2 (init 2), para ver isso estando vc logado normalmente (modo gráfico) em seu sistema executar em um terminal o comando runlevel, que ira lhe retornar a saída "2".
A grande maioria das distribuições usa o runlevel 5 como modo gráfico, mais isso não é uma regra. Para saber melhor como seu sistema processa os diferentes níveis de execução consulte seu arquivo /etc/inittab.

T+
Arlei
« Última modificação: 06 de MAR?O de 2007, 14:23 por arlei »

Offline eduferr

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: Problema com o comando init 3
« Resposta #4 Online: 06 de MAR?O de 2007, 14:39 »
Vc concorda que neste caso isso não vem muito ao caso!!!

Em todo caso no Ubuntu os inits 2 a 5 são chamados Runs levels Multi-user, o 1 é Halt, 2 Single-user e o 6 reboot.

arlei

  • Visitante
Re: Problema com o comando init 3
« Resposta #5 Online: 06 de MAR?O de 2007, 14:57 »
Vc concorda que neste caso isso não vem muito ao caso!!!

Em todo caso no Ubuntu os inits 2 a 5 são chamados Runs levels Multi-user, o 1 é Halt, 2 Single-user e o 6 reboot.

Na questão em si, concordo com vc, talvez não seja relevante. Mais acho importante sempre nos corrigirmos para que as informações possam chegar aos outros membros que delas usufruem da forma mais correta possível.
E isso vale para todos, pois só não espero, como faço questão que qualquer equivoco de minha parte seja também alertado e corrigido.

T+
Arlei

Offline Biasi

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: Problema com o comando init 3 (resolvido)
« Resposta #6 Online: 06 de MAR?O de 2007, 22:58 »
Obrigado pela força pessoal. Consegui, com a ajuda de vcs, resolver meu problema.

até mais!