Autor Tópico: GTA 3 - Unhandled Exception!  (Lida 9464 vezes)

Offline tnq13

  • Usuário Ubuntu
  • *
  • Mensagens: 63
    • Ver perfil
GTA 3 - Unhandled Exception!
« Online: 30 de Outubro de 2005, 18:39 »
Eu estou tentando jogar só que não vai!!!

Eu instalei primeiro pelo cd. normalmente, agora tentei usando o isntalador do loki installers, e nenhum deles funcionaram!!!

Segue o que aparece quando eu tentei pelo terminal digitando cedega gta3.exe

primeiro aparece:
Unhandled exception: c000000005
At adress: 005ac3bb

E um monte de coisas escritas:

Código: [Selecionar]
wine: Unhandled exception, starting debugger...
WineDbg starting on pid 1
No debug information in ELF '/usr/lib/transgaming_cedega//winex/bin/wine' (0x00000000)
Breakpoint 1 at 0x4000ba41
No debug information in ELF '/usr/lib/transgaming_cedega//winex/pthread_lib/libntdll.so' (0x40018000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/pthread_lib/libwine.so' (0x4011c000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwine_unicode.so' (0x40131000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwine_port.so' (0x401f9000)
No debug information in ELF '/lib/tls/i686/cmov/libm.so.6' (0x40208000)
No debug information in ELF '/lib/tls/i686/cmov/libc.so.6' (0x4022a000)
No debug information in ELF '/lib/tls/i686/cmov/libpthread.so.0' (0x40358000)
No debug information in ELF '/lib/tls/i686/cmov/libdl.so.2' (0x4036a000)
No debug information in ELF '/lib/ld-linux.so.2' (0x40000000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libadvapi32.so' (0x407f3000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libkernel32.so' (0x4081a000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libddraw.so' (0x4089b000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libuser32.so' (0x408e0000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libgdi32.so' (0x40a08000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwine_tsx11.so' (0x40a7f000)
No debug information in ELF '/usr/lib/libSM.so.6' (0x40a9d000)
No debug information in ELF '/usr/lib/libICE.so.6' (0x40aa4000)
No debug information in ELF '/usr/lib/libGL.so.1' (0x40abd000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libGLU.so.1' (0x40b23000)
No debug information in ELF '/usr/lib/libXext.so.6' (0x40bde000)
No debug information in ELF '/usr/lib/libX11.so.6' (0x40beb000)
No debug information in ELF '/usr/lib/libXxf86vm.so.1' (0x40cab000)
No debug information in ELF '/usr/lib/libdrm.so.1' (0x40cb0000)
No debug information in ELF '/usr/lib/libXau.so.6' (0x40cb7000)
No debug information in ELF '/usr/lib/libXdmcp.so.6' (0x40cba000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libdinput8.so' (0x40cbe000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libdinput.so' (0x40cc3000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwinmm.so' (0x40ce7000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwsock32.so' (0x40d3d000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libws2_32.so' (0x40d4a000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libiphlpapi.so' (0x40d62000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libd3d8.so' (0x40d71000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libole32.so' (0x40d98000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/librpcrt4.so' (0x40dfd000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwineserver.so' (0x40e43000)
No debug information in ELF '/usr/lib/libfreetype.so.6' (0x40e9d000)
No debug information in ELF '/usr/lib/libz.so.1' (0x40f07000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libx11drv.so' (0x40f27000)
No debug information in ELF '/usr/lib/X11/locale/common/xlcUTF8Load.so.2' (0x40fa7000)
No debug information in ELF '/usr/lib/X11/locale/common/ximcp.so.2' (0x40fa9000)No debug information in ELF '/usr/lib/libXcursor.so.1' (0x40fd1000)
No debug information in ELF '/usr/lib/libXrender.so.1' (0x40fda000)
No debug information in ELF '/usr/lib/libXfixes.so.3' (0x40fe2000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libd3dgl.so' (0x41270000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwinealsa.drv.so' (0x412b8000)
No debug information in ELF '/usr/lib/libasound.so.2' (0x412e8000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libmsacm.drv.so' (0x4139b000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libmsacm32.so' (0x413a3000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libmidimap.drv.so' (0x414d0000)
No debug information in 32bit DLL 'D:\TransGaming_Drive\Program Files\Rockstar Games\GTAIII\gta3.exe' (0x00400000)
No debug information in 32bit DLL 'NTDLL.DLL' (0x40056000)
No debug information in 32bit DLL 'KERNEL32.DLL' (0x4084d000)
No debug information in 32bit DLL 'ADVAPI32.DLL' (0x40805000)
No debug information in 32bit DLL 'GDI32.DLL' (0x40a27000)
No debug information in 32bit DLL 'USER32.DLL' (0x40917000)
No debug information in 32bit DLL 'DDRAW.DLL' (0x408b1000)
No debug information in 32bit DLL 'WINMM.DLL' (0x40cf5000)
No debug information in 32bit DLL 'DINPUT.DLL' (0x40cd0000)
No debug information in 32bit DLL 'DINPUT8.DLL' (0x40cc0000)
No debug information in 32bit DLL 'IPHLPAPI.DLL' (0x40d69000)
No debug information in 32bit DLL 'WS2_32.DLL' (0x40d52000)
No debug information in 32bit DLL 'WSOCK32.DLL' (0x40d41000)
No debug information in 32bit DLL 'D3D8.DLL' (0x40d80000)
No debug information in 32bit DLL 'D:\TRANSGAMING_DRIVE\PROGRAM FILES\ROCKSTAR GAMES\GTAIII\MSS32.DLL' (0x21100000)
No debug information in 32bit DLL 'RPCRT4.DLL' (0x40e20000)
No debug information in 32bit DLL 'OLE32.DLL' (0x40db7000)
No debug information in 32bit DLL 'X11DRV.DLL' (0x40f46000)
No debug information in 32bit DLL 'D3DGL.DLL' (0x41281000)
No debug information in 32bit DLL 'WINEALSA.DRV' (0x412c7000)
No debug information in 32bit DLL 'MSACM32.DLL' (0x413a8000)
No debug information in 32bit DLL 'MSACM.DRV' (0x4139e000)
No debug information in 32bit DLL 'MIDIMAP.DRV' (0x414d2000)
Unhandled exception: page fault on read access to 0x00000004 in 32-bit code (0x005ac3bb).
In 32-bit mode.
Register dump:
 CS:0073 SS:007b DS:007b ES:007b FS:003b GS:0033
 EIP:005ac3bb ESP:407e1ff4 EBP:00000000 EFLAGS:00010246(  R- 00  I  Z- -P1 )
 EAX:00000000 EBX:00000000 ECX:00000064 EDX:006ee274
 ESI:00000000 EDI:00000000
Stack dump:
0x407e1ff4 (NTDLL.DLL.memcpy+0x54c7d4):  00000000 00000000 006ee270 005ac4b2
0x407e2004 (NTDLL.DLL.memcpy+0x54c7e4):  00000000 00000064 00000000 00000000
0x407e2014 (NTDLL.DLL.memcpy+0x54c7f4):  00000000 004791a6 00000000 00000064
0x407e2024 (NTDLL.DLL.memcpy+0x54c804):  00000000 00000000 00000000 00000000
0x407e2034 (NTDLL.DLL.memcpy+0x54c814):  0048bafa 00000000 00000064 00000000
0x407e2044 (NTDLL.DLL.memcpy+0x54c824):  bfebf120 00000001 403ac400 403b8f94
0x407e2054 (NTDLL.DLL.memcpy+0x54c834):

Backtrace:
=>0 0x005ac3bb (gta3.exe..text+0x1ab3bb in D:\TransGaming_Drive\Program Files\Rockstar Games\GTAIII\gta3.exe) (ebp=00000000)

0x005ac3bb (gta3.exe..text+0x1ab3bb in D:\TransGaming_Drive\Program Files\Rockstar Games\GTAIII\gta3.exe): movw 0x4(%esi),%dx
Modules:
Address                 Module  Name
0x00400000-00982000     (PE)    D:\TransGaming_Drive\Program Files\Rockstar Games\GTAIII\gta3.exe
0x21100000-2115b800     (PE)    D:\TRANSGAMING_DRIVE\PROGRAM FILES\ROCKSTAR GAMES\GTAIII\MSS32.DLL
0x40056000-40058000     (PE)    NTDLL.DLL
0x40805000-40807000     (PE)    ADVAPI32.DLL
0x4084d000-4084f000     (PE)    KERNEL32.DLL
0x408b1000-408b3000     (PE)    DDRAW.DLL
0x40917000-40919000     (PE)    USER32.DLL
0x40a27000-40a29000     (PE)    GDI32.DLL
0x40cc0000-40cc2000     (PE)    DINPUT8.DLL
0x40cd0000-40cd2000     (PE)    DINPUT.DLL
0x40cf5000-40cf7000     (PE)    WINMM.DLL
0x40d41000-40d43000     (PE)    WSOCK32.DLL
0x40d52000-40d54000     (PE)    WS2_32.DLL
0x40d69000-40d6b000     (PE)    IPHLPAPI.DLL
0x40d80000-40d82000     (PE)    D3D8.DLL
0x40db7000-40db9000     (PE)    OLE32.DLL
0x40e20000-40e22000     (PE)    RPCRT4.DLL
0x40f46000-40f48000     (PE)    X11DRV.DLL
0x41281000-41283000     (PE)    D3DGL.DLL
0x412c7000-412c9000     (PE)    WINEALSA.DRV
0x4139e000-413a0000     (PE)    MSACM.DRV
0x413a8000-413aa000     (PE)    MSACM32.DLL
0x414d2000-414d4000     (PE)    MIDIMAP.DRV
Threads:
process  tid      prio
00000001 (D) D:\TransGaming_Drive\Program Files\Rockstar Games\GTAIII\gta3.exe
        00000003   -1
        00000002    0 <==
WineDbg terminated on pid 1
wine client perror:3: write/writev: Bad file descriptor


Alguém sabe como resolver??

PS: ubuntu breezy, cedega 4.4 com as fontes e o controles activex do mozilla instalados.. No kurumin 5 funcionou de primeira!

Offline davis aguiar

  • Usuário Ubuntu
  • *
  • Mensagens: 28
    • Ver perfil
comigo a mesma coisa
« Resposta #1 Online: 31 de Outubro de 2005, 22:44 »
estou com o mesmo problema :(

sou novato no ubuntu (ver 5.10) vindo do kurumin. Também estou usando a versao 4.4 do cedega. Consigo jogar Warcraft III sem problemas mas no caso do GTA 3 (que no kurumin rodava blz) estou tendo o mesmo problema!

E aí galera, o que fazer?
Cante Hare Krishna Hare Krishna Krishna Krishna Hare Hare - Hare Rama Hare Rama Rama Rama Hare Hare e seja feliz!!

Offline tnq13

  • Usuário Ubuntu
  • *
  • Mensagens: 63
    • Ver perfil
GTA 3 - Unhandled Exception!
« Resposta #2 Online: 31 de Outubro de 2005, 23:01 »
Cara, sinceramente? Volta pro Kurumin, até o Ubuntu amadurecer... eu no começo gostei pra caramba, mas em uma semana de uso SÓ TIVE PROBLEMAS!!!

1- apanhei pra instalar o driver; no kurumin era só ir no ícone mágico
2- ainda não consegui rodar o gta bem; no kurumin foi de prima...
3- fui instalar o mercury, instalei; só que agora dá erro na inicialização, no kurumin rodava tranquilo
4- TODA vez que eu ligo o computador, entro no ubuntu, tenho que reconfigurar a conexão com a internet; no kurumin era ligar o computador e estar conectado
5- O ubuntu demora mais de 2 minutos para carregar; no kurumin não levava mais do que 1 minuto e meio...

Porém no ubuntu tem o Gnome, no Kurumin eu apanhei, apanhei e não consegui instalá-lo....

Ahhh.. antes que eu me esqueça, me parece que o Ubuntu 5.1 que ficou uma verdadeira M* E* R* D* A*, recheado de bugs, o 4. alguma coisa parece que era muiiiiiiiiiiiiiiiiiiiiii (...)iiiiiiiito melhor...

Offline davis aguiar

  • Usuário Ubuntu
  • *
  • Mensagens: 28
    • Ver perfil
obrigado mas...
« Resposta #3 Online: 01 de Novembro de 2005, 12:50 »
cara, acho que não é bem por aí.

Concordo plenamente com você sobre a maturidade do Kurumin (nota 10 com estrelinha), mas  não acho que o ubuntu 5.10 seja um sistema problemático.

Realmente para nós que estamos vindo do Kurumin, os "ícones mágicos" fazem uma grande falta, mas eu confesso que as vezes sentia que a coisa tava fácil de mais (tudo de mão beijada!). Não que isso seja algo negativo, mas acho que nós como usuários também devemos procurar amadurecer nossa relação com o LINUX, sendo independentes de facilidades como os  "ícones mágicos" que são voltadas para o usuário 100% neófito.

Com relação aos problemas que voce citou, consegui resolver quase todos eles sem muito esforço (uma única pesquisa neste fórum foi suficiente):

1- apanhei pra instalar o driver; no kurumin era só ir no ícone mágico (supondo que seja o driver da NVIDIA)
R: http://ubuntuforum-pt.org/index.php?topic=1294&highlight=instalar+driver+nvidia
http://www.formatds.org/ubuntu/#installnvidiadriver

2- ainda não consegui rodar o gta bem; no kurumin foi de prima...

este ainda não resolvi (por isso escrevi neste tópico), mas tem um detalhe que esqueci de dizer: no KURUMIN o jogo só rodava no KDE! Quando tentava pelo Gnome dava exatamente o mesmo erro que no Ubuntu :(

3- fui instalar o mercury, instalei; só que agora dá erro na inicialização, no kurumin rodava tranquilo

ainda não instalei o mercury mas assim  que tiver ele instalado posto os resultados
 
4- TODA vez que eu ligo o computador, entro no ubuntu, tenho que reconfigurar a conexão com a internet; no kurumin era ligar o computador e estar conectado
R:
http://ubuntuforum-pt.org/index.php?topic=898&highlight=kanotix

5- O ubuntu demora mais de 2 minutos para carregar; no kurumin não levava mais do que 1 minuto e meio...
R:
voce pode diminuir o tempo do boot retirando serviços que voce não usa. Dá uma olhada no forum do Kurumin que tem uns artigos bem legais sobre isso :)

E quanto ao Gnome no Kurumin dava pra instalar sem problemas desde que voce  não instalasse antes algumas outras aplicações. De preferencia instale o Gnome antes de qualquer outra aplicação. Vai funfar com certeza :)

E pra finalizar uma dica: atualize o seu ubuntu 5.10 para a versão final. Ela ta bem mais enxuta. A proposito, no Ubuntu contamos com esse baita recurso de atualização, coisa que o Kurumin ainda não tem.

Qualquer coisa estamos aí,

Abraços,

Seu servo,
Davis
Cante Hare Krishna Hare Krishna Krishna Krishna Hare Hare - Hare Rama Hare Rama Rama Rama Hare Hare e seja feliz!!

Offline tnq13

  • Usuário Ubuntu
  • *
  • Mensagens: 63
    • Ver perfil
GTA 3 - Unhandled Exception!
« Resposta #4 Online: 01 de Novembro de 2005, 15:00 »
Eu consegui fazer o GTA rodar, vide item 2, eu consegui no domingo e ainda não tive tempo de postar...

1- não é tão facil assim quanto no ubuntu guide, eu tive que fazer muito mais coisa, inclusive postei um tutorial de como eu fiz, mas foi BEEEEEEEEEEEEEEEEM mais trabalhoso

2- eu baixei o instalador do loki installer, depois que ele instalar, é só ir na pasta que foi instalado e abrir o GTA3.sh, porém, o GTA ficou LERDISSIMO, além do mouse ficar travado no centro da tela

3- eu reinstalei o mercury e funcionou :S

4- eu tinha consultado esse tópico, tinha outra dica, ue tinha seguido e não tinha funcionado, vou tentar o que postaram de novo...

5- Eu baixei do site do ubuntu a imagem, como eu faço para atualizá-lo para a versão final?? (Embora eu acho que já tenho a essa...)

O problema nem é a falta de ícones mágicos, mas é que as coisas que me falam pra fazer não funcionam, sempre tem algum errinho...

Offline davis aguiar

  • Usuário Ubuntu
  • *
  • Mensagens: 28
    • Ver perfil
Funcionou!
« Resposta #5 Online: 02 de Novembro de 2005, 01:41 »
Aí galera,

To rodando o GTA3 perfeitamente (mesmo!) no Ubuntu 5.10. Só que o método que usei foi meio "híbrido". Digo que o método foi "híbrido" porque o jogo só rodou depois que eu instalei no Win XP. Daí foi so acessar a partição Windows onde o jogo foi instalado e chamar o comando "cedega gta3.exe". Na verdade, no Kurumin também só tinha conseguido jogar desse jeito (tinha esquecido deste detalhe).

Espero que isto possa ajudar voces. No meu caso o jogo ta normal, sem lentidão nem travamento nenhum. :D

Abraços,

Seu servo,
Davis
Cante Hare Krishna Hare Krishna Krishna Krishna Hare Hare - Hare Rama Hare Rama Rama Rama Hare Hare e seja feliz!!

Offline tnq13

  • Usuário Ubuntu
  • *
  • Mensagens: 63
    • Ver perfil
GTA 3 - Unhandled Exception!
« Resposta #6 Online: 02 de Novembro de 2005, 02:28 »
o problema aqui eu descobri só agora há pouco.. é o driver que está com problemas...

ele instala normal, aparece a imagem da nvidia antes de carregar o X, porém quando eu uso o comando glxinfo, ele diz:

$ glxinfo | grep render
direct rendering: No
OpenGL renderer string: RIVA TNT2/AGP/SSE

Offline LaSSarD

  • Usuário Ubuntu
  • *
  • Mensagens: 1.144
    • Ver perfil
GTA 3 - Unhandled Exception!
« Resposta #7 Online: 02 de Novembro de 2005, 15:54 »
No arquivo /etc/X11/xorg.conf procure a Section "Module" e substitua toda ela por isso:
Código: [Selecionar]
Section "Module"
# Load "GLcore"
Load "i2c"
Load "bitmap"
Load "ddc"
# Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection
desculpem as mensagens não respondidas, mas eu tô afastado há mais de ano...
um dia eu volto ;)

Offline tnq13

  • Usuário Ubuntu
  • *
  • Mensagens: 63
    • Ver perfil
GTA 3 - Unhandled Exception!
« Resposta #8 Online: 03 de Novembro de 2005, 02:16 »
aee.. cara, valeu pela ajuda, mãããããs.... eu resolvi o problema...

fui no ubutun internacional e me mandaram para o nvnews, e lá um cara da Nvidia mandou eu reinstalar o driver e... FUNCIONOU!

Ainda não entendi direito o que mudou, já que era para ter sido instalado logo de cara..

só que o GTA está rodando com os graficos meio ruins, mas é até melhor! assim fica mais rápido  :P  Eu sempre procurei saber como 'piorar' os graficos para tentar ganhar performance...

Offline LaSSarD

  • Usuário Ubuntu
  • *
  • Mensagens: 1.144
    • Ver perfil
GTA 3 - Unhandled Exception!
« Resposta #9 Online: 03 de Novembro de 2005, 20:05 »
Citação de: "tnq13"
só que o GTA está rodando com os graficos meio ruins, mas é até melhor! assim fica mais rápido  :P  Eu sempre procurei saber como 'piorar' os graficos para tentar ganhar performance...


viu até nisso o linux é melhor, adivinha seus pensamentos :mrgreen:
:lol:
desculpem as mensagens não respondidas, mas eu tô afastado há mais de ano...
um dia eu volto ;)