Autor Tópico: Problemas de dependência ao executar o comando sudo apt-get dist-upgrade  (Lida 1302 vezes)

Offline cthulhu13

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Ao executar o comando sudo apt-get dist-upgrade para atualizar o meu sistema obtive a seguinte saída:

Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto       
Calculando atualização... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
 gnome-control-center : Depende: libwacom2 (>= 1.1) mas não será instalado
 gnome-settings-daemon : Depende: libwacom2 (>= 1.1) mas não será instalado
 gnome-shell : Depende: gir1.2-mutter-6 (>= 3.36.0) mas não será instalado
               Depende: libmutter-6-0 (>= 3.36.0) mas não será instalado
 mutter : Depende: libmutter-6-0 (>= 3.29.4) mas não será instalado
 python3-samba : Depende: python3-crypto mas não será instalado
 ubuntu-desktop : Depende: gnome-shell-extension-desktop-icons mas não será instalado
                  Depende: gvfs-bin mas não será instalado
                  Recomenda: remmina mas não será instalado
 ubuntu-desktop-minimal : Depende: gnome-shell-extension-desktop-icons mas não será instalado
                          Depende: gvfs-bin mas não será instalado
E: Pacotes quebrados

Algum membro poderia me ajudar? Agradeço antecipadamente.

Offline nomade

  • O negócio não tem alma
  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.192
  • O negócio não tem alma
    • Ver perfil
Re:Problemas de dependência ao executar o comando sudo apt-get dist-upgrade
« Resposta #1 Online: 10 de Fevereiro de 2024, 10:36 »
Tente os comandos:

sudo apt update

depois:

sudo apt full-upgrade -y

Veja se continua dando o mesmo problema com dependências

diferença entre usar apt-get e apenas apt:

Desde 2014 o apt substituiu o apt-get como padrão no gerenciamento de pacotes das distros Debian like.

Tanto o apt quanto o apt-get lidam com a resolução de dependências. No entanto, o apt determina cadeias de dependência complexas, instala pacotes sempre na ordem correta e recomenda pacotes sugeridos para instalação evitando conflitos.

Por padrão, o comando apt upgrade remove versões antigas de pacotes instalados ou atualizáveis no sistema que não são mais necessários durante a atualização.

O comando apt-get upgrade não.

Resumindo, vários conflitos de dependências que tenho visto se devem ao fato dos usuários insistirem em usar apt-get em vez do apt, achando que é a mesma coisa e não é. O empacotamento desde 2014 é feito para funcionar com as funcionalidades extras do apt. Muitas vezes não precisa usar e o usuário não vê problemas acontecerem, mas quando precisa acaba dando erro. Desde quando o apt surgiu eu nunca mais tive conflitos de dependências como acontecia antes com o apt-get.

Outra possibilidade é você estar usando alguma PPA que cause isso, mas ainda assim muito provável ter sido pelo uso do apt-get em vez de apt.
« Última modificação: 10 de Fevereiro de 2024, 10:46 por nomade »
Ubuntu Studio 22.04 LTS